Homebridge Keine Antwort Home App und Zubehör taucht nie in der Home App auf

  • Hallo zusammen,


    ich habe das Problem, dass die Homebridge nur 12h über die Home App erreichbar war und seither keine Antwort mehr leistet.

    Ebenso habe ich es bis jetzt nicht geschafft, dass das accessory in der Home App erscheint.


    Die Config ist laut JSONlint in Ordnung und es taucht unter


    sudo systemctl restart homebridge; sudo journalctl -fau homebridge


    nur der Fehler homebridge.service: Main process exited, code=exited, status=143/n/a auf, welcher wohl nicht relevant sei?!


    Kann mir einer von Euch weiterhelfen? Ich bin dazu noch total Laie was das betrifft ;)

  • nur der Fehler homebridge.service: Main process exited, code=exited, status=143/n/a auf, welcher wohl nicht relevant sei?!


    Kann mir einer von Euch weiterhelfen? Ich bin dazu noch total Laie was das betrifft ;)

    Die Meldung taucht im Log immer dann auf, wenn Homebridge beendet wird. Aber vgnsxe hat Recht, um was ordentliches zu sagen, müsste man mehr vom Log sehen.


    Stefan

  • Installiert habe ich es nach der Anleitung hier auf smartapfel.



    Der komplette Log sieht folgt aus:


    -- Logs begin at Thu 2016-11-03 18:16:42 CET. --

    Jun 10 18:24:53 raspberrypi homebridge[2784]: [2019-6-10 6:24:53 PM] [Lg tv] webOS - sound output changed

    Jun 10 18:24:53 raspberrypi homebridge[2784]: [2019-6-10 6:24:53 PM] [Lg tv] webOS - current sound output: external_speaker

    Jun 10 18:25:00 raspberrypi homebridge[2784]: [2019-6-10 6:25:00 PM] [Config] Console v4.4.5 is listening on :: port 8080

    Jun 10 18:53:00 raspberrypi homebridge[2784]: [2019-6-10 6:53:00 PM] Got SIGTERM, shutting down Homebridge...

    Jun 10 18:53:00 raspberrypi systemd[1]: Stopping Node.js HomeKit Server...

    Jun 10 18:53:06 raspberrypi systemd[1]: homebridge.service: Main process exited, code=exited, status=143/n/a

    Jun 10 18:53:06 raspberrypi systemd[1]: Stopped Node.js HomeKit Server.

    Jun 10 18:53:06 raspberrypi systemd[1]: homebridge.service: Unit entered failed state.

    Jun 10 18:53:06 raspberrypi systemd[1]: homebridge.service: Failed with result 'exit-code'.

    Jun 10 18:53:06 raspberrypi systemd[1]: Started Node.js HomeKit Server.

    Jun 10 18:53:08 raspberrypi homebridge[3121]: [2019-6-10 6:53:08 PM] Loaded config.json with 1 accessories and 1 platforms.

    Jun 10 18:53:08 raspberrypi homebridge[3121]: [2019-6-10 6:53:08 PM] ---

    Jun 10 18:53:08 raspberrypi homebridge[3121]: [2019-6-10 6:53:08 PM] Loaded plugin: homebridge-config-ui-x

    Jun 10 18:53:08 raspberrypi homebridge[3121]: [2019-6-10 6:53:08 PM] Registering platform 'homebridge-config-ui-x.config'

    Jun 10 18:53:08 raspberrypi homebridge[3121]: [2019-6-10 6:53:08 PM] ---

    Jun 10 18:53:08 raspberrypi homebridge[3121]: [2019-6-10 6:53:08 PM] Loaded plugin: homebridge-vsx

    Jun 10 18:53:08 raspberrypi homebridge[3121]: [2019-6-10 6:53:08 PM] Registering accessory 'homebridge-vsx.VSX'

    Jun 10 18:53:08 raspberrypi homebridge[3121]: [2019-6-10 6:53:08 PM] ---

    Jun 10 18:53:08 raspberrypi homebridge[3121]: [2019-6-10 6:53:08 PM] Loaded plugin: homebridge-webos-tv

    Jun 10 18:53:08 raspberrypi homebridge[3121]: [2019-6-10 6:53:08 PM] Registering accessory 'homebridge-webos-tv.webostv'

    Jun 10 18:53:08 raspberrypi homebridge[3121]: [2019-6-10 6:53:08 PM] ---

    Jun 10 18:53:08 raspberrypi homebridge[3121]: [2019-6-10 6:53:08 PM] Loading 1 platforms...

    Jun 10 18:53:08 raspberrypi homebridge[3121]: [2019-6-10 6:53:08 PM] [Config] Initializing config platform...

    Jun 10 18:53:08 raspberrypi homebridge[3121]: [2019-6-10 6:53:08 PM] [Config] Spawning homebridge-config-ui-x with PID 3149

    Jun 10 18:53:08 raspberrypi homebridge[3121]: [2019-6-10 6:53:08 PM] Loading 1 accessories...

    Jun 10 18:53:08 raspberrypi homebridge[3121]: [2019-6-10 6:53:08 PM] [Lg tv] Initializing webostv accessory...

    Jun 10 18:53:08 raspberrypi homebridge[3121]: Setup Payload:

    Jun 10 18:53:08 raspberrypi homebridge[3121]: X-HM://0023R2ECGPA6D

    Jun 10 18:53:08 raspberrypi homebridge[3121]: Scan this code with your HomeKit app on your iOS device to pair with Homebridge:

    Jun 10 18:53:08 raspberrypi homebridge[3121]:

    Jun 10 18:53:08 raspberrypi homebridge[3121]:

    Jun 10 18:53:08 raspberrypi homebridge[3121]:

    Jun 10 18:53:08 raspberrypi homebridge[3121]:

    Jun 10 18:53:08 raspberrypi homebridge[3121]:

    Jun 10 18:53:08 raspberrypi homebridge[3121]:

    Jun 10 18:53:08 raspberrypi homebridge[3121]:

    Jun 10 18:53:08 raspberrypi homebridge[3121]:

    Jun 10 18:53:08 raspberrypi homebridge[3121]:

    Jun 10 18:53:08 raspberrypi homebridge[3121]:

    Jun 10 18:53:08 raspberrypi homebridge[3121]:

    Jun 10 18:53:08 raspberrypi homebridge[3121]:

    Jun 10 18:53:08 raspberrypi homebridge[3121]:

    Jun 10 18:53:08 raspberrypi homebridge[3121]:

    Jun 10 18:53:08 raspberrypi homebridge[3121]:

    Jun 10 18:53:08 raspberrypi homebridge[3121]:

    Jun 10 18:53:08 raspberrypi homebridge[3121]:

    Jun 10 18:53:08 raspberrypi homebridge[3121]:

    Jun 10 18:53:08 raspberrypi homebridge[3121]:

    Jun 10 18:53:08 raspberrypi homebridge[3121]:

    Jun 10 18:53:08 raspberrypi homebridge[3121]:

    Jun 10 18:53:08 raspberrypi homebridge[3121]:

    Jun 10 18:53:08 raspberrypi homebridge[3121]:

    Jun 10 18:53:08 raspberrypi homebridge[3121]:

    Jun 10 18:53:08 raspberrypi homebridge[3121]:

    Jun 10 18:53:08 raspberrypi homebridge[3121]:

    Jun 10 18:53:08 raspberrypi homebridge[3121]:

    Jun 10 18:53:08 raspberrypi homebridge[3121]: Or enter this code with your HomeKit app on your iOS device to pair with Homebridge:

    Jun 10 18:53:08 raspberrypi homebridge[3121]:

    Jun 10 18:53:08 raspberrypi homebridge[3121]: ┌────────────┐

    Jun 10 18:53:08 raspberrypi homebridge[3121]: │ ***-**-*** │

    Jun 10 18:53:08 raspberrypi homebridge[3121]: └────────────┘

    Jun 10 18:53:08 raspberrypi homebridge[3121]:

    Jun 10 18:53:08 raspberrypi homebridge[3121]: [2019-6-10 6:53:08 PM] Homebridge is running on port 51826.

    Jun 10 18:53:09 raspberrypi homebridge[3121]: [2019-6-10 6:53:09 PM] [Lg tv] webOS - connected to TV

    Jun 10 18:53:09 raspberrypi homebridge[3121]: [2019-6-10 6:53:09 PM] [Lg tv] webOS - app launched, current appId: com.webos.app.hdmi2

    Jun 10 18:53:09 raspberrypi homebridge[3121]: [2019-6-10 6:53:09 PM] [Lg tv] webOS - audio status changed

    Jun 10 18:53:09 raspberrypi homebridge[3121]: [2019-6-10 6:53:09 PM] [Lg tv] webOS - current volume: 0

    Jun 10 18:53:09 raspberrypi homebridge[3121]: [2019-6-10 6:53:09 PM] [Lg tv] webOS - muted: No

    Jun 10 18:53:09 raspberrypi homebridge[3121]: [2019-6-10 6:53:09 PM] [Lg tv] webOS - current channel status changed

    Jun 10 18:53:09 raspberrypi homebridge[3121]: [2019-6-10 6:53:09 PM] [Lg tv] webOS - current channel: undefined, undefined

    Jun 10 18:53:09 raspberrypi homebridge[3121]: [2019-6-10 6:53:09 PM] [Lg tv] webOS - sound output changed

    Jun 10 18:53:09 raspberrypi homebridge[3121]: [2019-6-10 6:53:09 PM] [Lg tv] webOS - current sound output: external_speaker

    Jun 10 18:53:14 raspberrypi homebridge[3121]: [2019-6-10 6:53:14 PM] [Config] Console v4.4.5 is listening on :: port 8080

  • Sieht doch gut aus. Homebridge läuft.

  • Jun 10 18:53:00 raspberrypi homebridge[2784]: [2019-6-10 6:53:00 PM] Got SIGTERM, shutting down Homebridge...

    Das hier sagt aus, dass homebridge bewusst ueber einen Befehl beendet wurde. Wenn du das nicht initiiert hast, dann scheint es irgendwo einen Befehl zu geben, welcher das fuer dich macht, unbewusst.


    Wie sschuste schon meinte, laeuft die HB ja nach dem automatischen restart komplett ohne Fehler durch. Heißt wir koennen und jetzt darum kuemmern warum es nicht in HomeKit erscheint.


    Hast du mal versucht den QR Code den dir das Terminal ausspuckt mit dem iPhone zu scannen und damit automatisch hinzuzufuegen?

    Oder alternativ in der Home App oben rechts auf + klicken, Geraet hinzufuegen, Code fehlt, bzw. kann nicht gescannt werden? Erscheint dort deine Homebridge?


    PS: Wenn du sagst keine Antwort, wie kann dann nix zu sehen sein? Wo siehst du denn dann keine Antwort? ;-) Ansonsten versuche mal die homebridge zu entfernen und in der config.json aendere bei usernamen die letzte Zahl, speicher ab, lass homebridge neu starten und fuege es wieder zu HomeKit hinzu!

  • Hallo vgnsxe


    ja ich habe den QR Code eingescannt und erfolgreich hinzugefügt. Die HomeBridge war gestern nach der Installation auch erreichbar. Aber seit heute morgen steht Keine Antwort.

    Was gestern aber auch nie der Fall war, ist dass das Zubehör auch nicht in der Home App auftauchte.

  • MCT


    Was nutzt du als Steuerzentrale?

  • Ok das passt ja schon mal. Hast schon viele Automationen oder insgesamt viele Geräte drin?


    Als letzte Möglichkeit würde sich noch anbieten, den user um ein Zähler in der config zu erhöhen, homebridge neu starten und dann die homebridge neu hinzuzufügen.


    Allerdings sind dann bestehende Automationen und Geräte in der Home App neu und müssen neu konfiguriert werden.