Welche Versionen passen momentan zusammen? HomeBridge, Node, HUE- und HomeMatic-Plugin

  • Hallo,


    Knapp zwei Jahre lief meine Installation mit 2 Raspis (RaspberryMatic und Homebridge recht zuverlässig). Ich habe in der Zeit nichts upgedatet, nur 2 Mal die RaspberryMatic.


    Ich konnte alle Geräte im Haushalt über HOME und Siri steuern.


    Nun habe ich meine RaspberryMatic zur aktuellen OCCU upgegraded und nichts lief mehr.

    Ich habe mich entschlossen, die HomeBridge völlig neu aktuell aufzusetzen und zunächst die HomeBridge App von Herrn Weihen ausprobiert. Sehr schnell hatte ich ohne komplexe Eingriffe ein vermeintlich lauffähiges System und auf Anhieb war das neue Gerät „HomeBridge“ in meiner HOME App im Standardraum mit zwei Testanwendungen (Raspi-Temperatur und Test PC) ebenfalls angelegt.

    Allerdings waren weder das von mir angelegte HomeMatic Gewerk mit diversen HomeMatic - Schaltaktoren und Sensoren, noch irgendein HUE Gerät verfügbar.

    Das Error Log zeigte a, dass die Node-Version nicht kompatibel mit der Version des HUE PlugIns war.

    Zum HomeMatic PlugIn gab es keine Fehlerhinweise.

    Das dritte, von mir installierte PlugIn für SONOS funktionierte auf Anhieb.


    Im Update Center der HomeBridge App ist es leider nicht möglich, auf eine bestimmte, im Error-Log geforderte Version, upzugraden, sondern nur auf eine vorgegebene oder die allerneueste. Beide werden aber beim Start der HomeBridge im Error-Log als inkompatibel benannt.


    Somit blieb mir nichts anderes übrig, als die ganze Installation neu manuell aufzusetzen ohne die „tolle“ HomeBridge App.


    Kann mir jemand aus eigener Erfahrung schreiben, welche Paket-, bzw. PlugIn Versionen jetzt gerade für

    HomeBridge

    HomeMatic

    HUE

    SONOS


    zu einander passen und wie ich dauerhaft die HUE Lib korrekt einbinden kann?


    Ganz toll wäre ein Link oder der Code einer lauffähigen Config.json, die die obigen PlugIns korrekt einbinden.


    Herzlichen Dank für die Unterstützung!


    Claus aus dem Schwarzwald

  • Ich empfehle die node lts version, also 10.16.0.


    Die aktuelle [email protected]


    Das hue-plugin sowie lib-plugin setzen immer die aktuellste node lts voraus......


    Ich habe zwar kein homematic oder sonos, du kannst jedoch bei github unter package.json unter „engines“ immer die mindestversion von node und homebridge nachschauen.....

  • Gruß aus dem Süden Baden-Württemberg 😜

  • Das Error Log zeigte a, dass die Node-Version nicht kompatibel mit der Version des HUE PlugIns war.

    Kein ERROR. Nur ein Hinweis.