Homebridge-Tweaks

  • Moin zusammen,


    super Anleitung.


    Ich hoffe es ist noch erlaubt, auf diesen Thread zu antworten, auch wenn die letzte Antwort schon etwas her ist...


    Ich hake gerade bei dem Punkt SSL - Das Zertifikat installieren. Wenn ich den ersten der drei Befehle eingebe, erhalte ich die Fehlermeldung dass das Verzeichnis /var/homebridge nicht existiert.

    https://i.imgur.com/PuQ3YkQ.png


    Daher habe ich mich via VNC auf den Pi eingeloggt und versucht den entsprechenden Ordner zu erstellen. Da bekomme ich die Fehlermeldung dass ich als "pi" User nicht die Berechtigung habe.


    Wie komme ich nun hier weiter?

    Gibt es einen Terminal Befehl um das Verzeichnis zu erstellen?

  • Den Ordner brauchst du nicht erstellen, da er bereits existiert. Du schaust nur an der falschen Stelle.


    Je nachdem welche Installationsanleitung du für deine Homebridge verwendet hast ist der Pfad zu deinem Homebridge-Verzeichnis anders. Es kann /var/lib/homebridge sein, oder zur Zeit als die Anleitung von Sschuste erstellt wurde (ca. 2 Jahre her) und es noch die "alte" Smartapfel-Installationsanleitung gab, dann ist es /var/homebridge. Oder eben ganz ein anderer Pfad. Sehen kannst du das z.B. mit in der Weboberfläche des Config-UI-X Plugins links unten.


  • Super danke, eine Installationsanleitung habe ich nicht genutzt. Sondern direkt das Homebridge Image von der Raspberry Seite gezogen.

    Aber var/lib/homebridge war es.


    Danke für den Tipp.

    Aber ich hänge direkt bei dem zweiten Befehl fest.

    Code
    sudo chown -R homebridge:homebridge /var/lib/homebridge

    Da wird von einem User Homebridge gesprochen, den ich nicht habe. Muss ich den erstellen? Wenn ja, wie?


    Sorry, bin noch ein kompletter Laie. Letzten Mittwoch den Homepod Mini bekommen, seit Samstag die Homebridge und fuchse mich momentan mit den verschiedensten Anleitungen durch.

  • Also, hier zunächst mal der Link zur damaligen Installationsanleitung (PDF-Datei): Homebridge Installationsanleitungen


    Dort wird auf Seite 17 auch erklärt, wie der User "Homebridge" angelegt wird. Ob das alles noch so kompatibel ist zu deiner Installation über das offizielle Homebridge-Image (welches inzwischen auch die neue Smartapfel-Anleitung empfiehlt) kann ich nicht sagen. Wie gesagt, diese Anleitung hier ist nicht mehr aktuell (Bzw. war stets "Work in Progress") und wurde noch für die alte Installationsanleitung (ebenfalls nicht mehr aktuell) geschrieben.


    Welcher User steht denn bei dir in der config-UI-X Plugin links unten? Vermutlich Pi. Evtl. geht es auch damit, aber vllt. kann das sschuste sicherheitshalber verifizieren.

    Einmal editiert, zuletzt von Patrick_ ()

  • Patrick_ Nochmals vielen Dank für deine geniale Hilfe. Es hat nun alles geklappt.


    Ich hake gerade bei dem nächsten Schritt, dass es unter Plugins, das Plugin

    Configuration UI plugin for Homebridge nicht existiert. Sondern nur das normale Homebridge UI, was halt per Default installiert ist.

    Wenn ich dort in den Einstellungen gehe, befindet sich auch kein Unterpunkt mit SSL.

    https://i.imgur.com/XUJOkHB.png


    Nun bin ich gerade total lost und habe keine Ahnung, wie ich das gerade erstellte Zertifikat einbinden soll. :|


    Habe gerade noch die Forums suche mit "Zertifikat" bemüht, aber bin nicht wirklich weitergekommen.


    Edit: Ich habe mir nun über das github wiki eine Anleitung rausgesucht, wie man das über die Konfiguration macht, erhalte da aber immer eine Fehlermeldung das ich einen Syntax Fehler in der JSON habe.

    siehe: https://i.imgur.com/9FetVxJ.png


    Vielleicht kann sschuste mir hier weiterhelfen?

    Einmal editiert, zuletzt von Levtos ()

  • Das ist das selbe Plugin. Die Einstellung zu SSL gibt es wohl nicht mehr in der Benutzeroberfläche sondern gehen nur noch über die config.json


    Edit: Ich habe mir nun über das github wiki eine Anleitung rausgesucht, wie man das über die Konfiguration macht, erhalte da aber immer eine Fehlermeldung das ich einen Syntax Fehler in der JSON habe.

    Wenn du in der Config.json händisch was einfügst, musst du vor dem letzten Parameter auch ein Komma setzen.


    heißt aus

    Code
    "platform": "config"

    muss ein

    Code
    "platform": "config",

    werden. Danach den SSL Teil.

  • siehe: https://i.imgur.com/9FetVxJ.png


    Vielleicht kann sschuste mir hier weiterhelfen?

    Nein. Kann ich vielleicht, will ich aber nicht. Dazu müsste ich deine Konfiguration von deinem Screenshot abschreiben. Das bereitet mir nicht die größte Freude und daher mache ich es nicht.


    Warum muss ich die abschreiben? Das liegt schon mal daran, dass ich offenbar nicht so scharfe Augen habe wie Patrick_ . Den Kommafehler habe ich mehrfach übersehen, obwohl ich genau danach gesucht habe. Damit ich mir nicht selbst die Augen blöde suche, verwende ich Computer, die das für mich tun. Ich würde eine fehlerhafte Konfiguration immer kopieren und bei https://jsonlint.com einfügen. Das geht aber nur mit Text und nicht mit einem Screenshot.


    Es gibt bestimmt irgendwelche Gründe, Screenshots zu machen. Beispielsweise möchte man vielleicht gerne ein 16x16-Pixel-Quadrat von der linken Seite des Screens aufheben, nur so als Erinnerung. Es ist völlig legitim, von allem einen Screenshot zu machen. Aber Logs und Konfigurationen: nee. Da kannst du auch gleich deinen Raspi von außen fotografieren. Außer du willst die Konfiguration vielleicht zu Weihnachten verschenken, dann geht natürlich auch ein Screenshot.


    Und wenn wir schon dabei sind: ich bevorzuge die gesamte Konfiguration, von ganz oben bis nach ganz unten. Als Text.

  • sschuste Tut mir leid, mit den Screenshots.

    Die waren nur quasi als "Beweis".

    Verbuchen wir dies unter Anfängerfehler. Kommt nicht wieder vor. ;(

    Ich habe den Code nun wie folgt ergänzt und erhalte beim Speichern ein Pop-Up mit der Fehlermeldung "Fehler, Speichern der Konfiguration fehlgeschlagen"

    Danach habe ich die komplette Config auf der besagten Seite eingefügt und da kam "Valid JSON" raus.


    Die Homebridge habe ich bereits neu gestartet und mich nochmals aus- und eingeloggt. Ich kriege die Config nicht gespeichert.


    Hat da jemand eine Idee, woran es nun hakt?


    Anbei den kompletten Code.

    (Einige Sachen habe ich mit X versehen, um Passwörter und ähnliches nicht öffentlich bekannt zu machen - ich hoffe das dies ok ist.)


  • Anbei den kompletten Code.

    (Einige Sachen habe ich mit X versehen, um Passwörter und ähnliches nicht öffentlich bekannt zu machen - ich hoffe das dies ok ist.)

    Perfekt formatiert - das macht's ja noch einfacher. Und die Daten auszu-X-en, ist natürlich völlig richtig und ok so.


    Deine Konfiguration ist richtig und funktioniert auch so. Ich habe nämlich das, was du da oben hin kopiert hast, einfach in meine Homebridge kopiert und ich bekomme deinen Fehler nicht. Also jsonlint sagt, dass das ok ist und meine Homebridge ebenfalls.


    Es kam hier im Forum gelegentlich vor, dass die Konfiguration nicht gespeichert werden konnte, obwohl alles korrekt ist. So wie bei dir jetzt. Da hat immer Abhilfe geschaffen, die eigene Konfiguration von dieser Webseite erneut zu kopieren und dann in den Konfig-Editor einzufügen. Die vorhandene Konfiguration wird dabei überschrieben oder man löscht sie vorher).


    Natürlich musst du vorher deine ge-X-ten Usernames und Keys irgendwo zwischenspeichern, damit die nicht verloren gehen.

  • Das hat geklappt. Nochmals vielen Dank für eure Hilfe.


    Allerdings befürchte ich, das ich Mist gebaut habe.

    Nachdem die Konfiguration gespeichert wurde, habe ich die Bridge neugestartet.

    Seitdem (circa 20 Minuten) hänge ich im Startbildschirm fest.

    https://i.imgur.com/wOkTOto.png (Sorry für den Screenshot, aber da es nichts Code relevantes ist, denke ich sollte dies in Ordnung gehen)

    Wie Ihr in der URL seht, spreche ich nun die Bridge via https an, das klappt schon mal.


    Danach habe ich mich im Terminal eingeloggt und wie auf dem Startbildschirm beschrieben die Logs angezeigt.

    Die Bridge läuft, nur komme ich nicht in die Weboberfläche rein.


    Anbei einen Auszug vom Log


    Wie kann ich das nun beheben?


    Edit: Man sollte sich natürlich auch die Anleitung bis zum Ende durchlesen. Alles funktioniert nun. Und bedanke mich nochmals für eure Hilfe.

    Einmal editiert, zuletzt von Levtos ()