WLAN abschalten

  • Gib ein:

    sudo rfkill block wifi


    Schließe das LAN-Kabel an.

    Gib ein:

    sudo reboot


    Änderungen an Homebridge sind wahrscheinlich nicht notwendig.

  • Das nenn ich jetzt mal Zufall. Ich zerbrech mir gerade den Kopf darüber, weshalb ich mich seit Buster immer mal wieder nicht mehr auf meinen RasPi per ssh einloggen kann.


    Habe bemerkt, dass ich sowohl LAN dran hab und WLAN aktiviert ist.


    Könnte sich dies in die Quere kommen?

  • Habe bemerkt, dass ich sowohl LAN dran hab und WLAN aktiviert ist.


    Könnte sich dies in die Quere kommen?

    Eigentlich nicht. Die WLAN-Netzwerkkarte und die LAN-Netzwerkkarte haben ja unterschiedliche IP-Adressen. Ich würde es trotzdem nicht empfehlen.

  • Das dachte ich mir, dass es nicht unbedingt empfehlenswert ist. Dann werde ich die Tage mal den Befehl oben eingeben und neu starten 😜

  • hat wunderbar funktioniert 👍 Merci!

  • Jetzt wollte ich mich mit dem terminal übern mac auf den RasPi schalten und erhalte folgende Ausgabe:


    @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@

    @ WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED! @

    @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@

    IT IS POSSIBLE THAT SOMEONE IS DOING SOMETHING NASTY!

    Someone could be eavesdropping on you right now (man-in-the-middle attack)!

    It is also possible that a host key has just been changed.

    The fingerprint for the ECDSA key sent by the remote host is

    SHA256:KSWbuNpsyhMZ8+JJFkGq/uck5kPuexX85r7QKQr7yMk.

    Please contact your system administrator.

    Add correct host key in /Users/manuelkohler/.ssh/known_hosts to get rid of this message.

    Offending ECDSA key in /Users/manuelkohler/.ssh/known_hosts:1

    ECDSA host key for 192.168.178.28 has changed and you have requested strict checking.

    Host key verification failed.

    Manuels-Mini:~ manuelkohler$



    Was muss ich tun, um mich wieder auf dem RasPi anzumelden?


    Dies ist die IIP, welche zuvor am RasPi per LAN vergeben war, als auf dem RasPi noch Jessi lief. Jetzt bin ich ja auf Buster....



    Kurz selbst gegoogelt und mit folgendem Befehl konnte ich den Server löschen:


    ssh-keygen -f "/Users/meinAnmeldename/.ssh/known_hosts" -R 192.168.178.28



    Im Anschluss konnte ich mich wie gewohnt anmelden.

  • Was muss ich tun, um mich wieder auf dem RasPi anzumelden?

    Nichts. Das war's. Du bist raus. Dir bleibt nur noch, deine Smarthome-Geräte zu verkaufen und die alten Lichtschalter wieder einzubauen :D

  • Hallo zusammen,


    ich bekommen meine neuen Raps einfach nicht ins WLAN.

    Per LAN hängt er drin und Homebridge läuft, aber WLAN will einfach nicht und ich weiß nicht weiter.

    Ich ab schon einiges probiert, bin aber Raspi Noobie komme aber grundsätzlich mit IT Themen klar

    Der Lüfter st so laut, dass ich den Raspi dringend weg vom Router haben möchte.

    Wer weiß hier ggf. weiter?


    Grüße

    Dirk

  • Ich ab schon einiges probiert

    Also schamanische Schreitänze. Und was noch?

  • Eigentlich brauchst du nur die Datei /etc/wpa_supplicant/wpa_supplicant.conf tz erstellen und dann den Raspi neu zu booten:


    sudo nano /etc/wpa_supplicant/wpa_supplicant.conf

    Und dort drin steht dann so was wie:


    ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev

    update_config=1

    country=DE


    network={

    ssid="MEIN_WLAN"

    psk="MEIN_WLAN_PASSWORT"

    key_mgmt=WPA-PSK

    }


    Natürlich musst du MEIN_WLAN und MEIN_WLAN_PASSWORT durch was Brauchbares ersetzen.

  • Das hab ich tatsächlich div. Male versucht....ohne Erfolg

    Da steht nun dies!


    Erste Netzwerk läuft über mein Time Capsule

    Das zwote übe den normalen Router. Das ist normalerweise ausgeschaltet. Hatte ich jetzt nur mal aktiviert weil ich nicht ins normale Netz komme!


    ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev

    update_config=1

    country=NL


    network={

    ssid="Dirks WLAN-Netzwerk"

    psk="12345"

    }


    network={

    ssid="VFNL-0AB5B25G"

    psk="12345"

    }

  • Das fliegt bei ifconifig raus


    th0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500

    inet 192.168.1.126 netmask 255.255.255.0 broadcast 192.168.1.255

    inet6 fe80::7b50:bfd9:b994:3c47 prefixlen 64 scopeid 0x20<link>

    ether dc:a6:32:6c:0b:f1 txqueuelen 1000 (Ethernet)

    RX packets 318 bytes 86802 (84.7 KiB)

    RX errors 0 dropped 0 overruns 0 frame 0

    TX packets 173 bytes 53450 (52.1 KiB)

    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0


    lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536

    inet 127.0.0.1 netmask 255.0.0.0

    inet6 ::1 prefixlen 128 scopeid 0x10<host>

    loop txqueuelen 1000 (Local Loopback)

    RX packets 60 bytes 60367 (58.9 KiB)

    RX errors 0 dropped 0 overruns 0 frame 0

    TX packets 60 bytes 60367 (58.9 KiB)

    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0


    wlan0: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500

    ether dc:a6:32:6c:0b:f3 txqueuelen 1000 (Ethernet)

    RX packets 0 bytes 0 (0.0 B)

    RX errors 0 dropped 0 overruns 0 frame 0

    TX packets 0 bytes 0 (0.0 B)

    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0