IP-Camera ffmpeg

  • Hi all,


    Ich beschäftige mich erst seit ein paar Tagen mit der Homebridge (Raspberry Pi 3).

    Mir ist es gelungen meine Axis IP Kamera mit dem Plugin "Camera-ffmpeg" zum Laufen zu bringen.

    Was ich habe nicht verstehe ist folgendes:


    Nachdem ich den Befehl: >homebridge setze, passiert folgendes: (über den Terminal (ssh))


    [2018-9-18 18:55:33] Homebridge is running on port 51826.

    [2018-9-18 18:55:33] Axis is running on port 35937.

    [2018-9-18 18:55:59] [Camera-ffmpeg] Snapshot from Axis at 480x270

    [2018-9-18 18:56:10] [Camera-ffmpeg] Snapshot from Axis at 480x270


    Das ist auch alles ok, ich sehe im HomeKit das Live Bild, nur wenn ich jetzt absichtlich die Pi neu starte wird das Live Bild nicht mehr übertragen.

    Wie oder was muss eingestellt werden, damit der RTSP Stream immer aktiv bleibt?


    Vielen Dank im Voraus!


    LG Dino


    EDIT: Verwende zusätzlich noch Philips Hue und Fritz!Box Plugin.

    Ist das ein Ressourcen Thema von der Raspberry oder sollte das die Hardware schaffen?

  • Hallo zusammen,


    ich bin neu hier in der Community.


    Seit drei Tagen versuche ich vergeblich meine INSTAR Kamera an Laufen zu bekommen.


    Meine Config sie so aus:

    {

    "name": "Kamera1",

    "videoConfig": {

    "source": "-re -i rtsp://admin:[email protected]:/11/",

    "stillImageSource": "-i http://admin:[email protected]/tmpfs/snap.jpg",

    "maxStreams": 2,

    "maxWidth": 1280,

    "maxHeight": 720,

    "maxFPS": 24

    }

    }


    Aber ich bekomme weder das Livebild noch ein Standbild.


    Muss ich noch irgendwas beachten?


    Irgendwas ausser das Plugin installieren? Oder muss ich auf dem Webinterface der Kamera noch was einstellen?


    Über VLC bzw. den Browser kann ich beides erreichen.


    Auch wüsste ich gerne was die Softwareschalter "-i, -re" etc vor der Stream URL bedeuten.


    Vielen Dank vorab.

  • Hallo,


    ffmpeg musst du zusätzlich installieren.


    https://www.jeffreythompson.or…-ffmpeg-for-raspberry-pi/

  • Config ist richtig, laut npm musst du ffmpeg installieren auf deinem Raspi:



    Installation


    1. Install ffmpeg on your Raspberry PI3
    2. Install this plugin using: npm install -g homebridge-ip-camera
    3. Edit config.json and add the camera
    4. Run Homebridge
    5. Add extra camera accessories in Home app. The setup code is the same as homebridge.

  • Sooo... Es läuft alles. Vielen Dank für die Hilfe.


    Allerdings habe ich noch das Problem das ich jedes mal wenn ich was an der config ändere einen neuen Namen vergeben muss.... wenn ich

    unter /root/.homebridge/accessories die cachedaccesseries lösche hilft das komischerweise nicht....


    LG

  • Moin!


    Ich versuche gerade eine billige Kamera (https://amzn.to/2NMeLDz nahezu baugleich mit https://amzn.to/2SayUqm) zu homebridge hinzuzufügen. Ich bekomme auch ein Standbild in der Home-App oder in der Eve-App zustande. Aber es wird leider nicht gestreamt. Da steht das er anfängt und dann wird es einfach gestoppt.


    Ich habe ffmpeg installiert und das homebridge-camera-ffmpeg plugin.


    Das hier habe ich konfiguriert:

    {

    "platform": "Camera-ffmpeg",

    "cameras": [

    {

    "name": "Kamera",

    "videoConfig": {

    "source": "-re -i rtsp://192.168.178.61:554/onvif2",

    "vcodec": "h264_omx",

    "maxFPS": 15,

    "maxHeight": 240,

    "maxStreams": 4,

    "maxWidth": 320,

    "debug": true

    }

    }

    ]

    },


    Mit "rtsp://192.168.178.61:554/onvif2" bekomme ich mit VLC auf dem Mac ein gestreamtes 320x240 großes Video hin. Bei onvif1 bekomme ich nur ein Standbild aber dann in 1280x720.


    Dies hier erscheint mit Debug in der Logdatei:


    Kann mir zufällig hier jemand sagen, was dort schiefläuft. Ich stehe da wie der Ochs vorm Berg.


    Eben hat es ziemlich ruckelnd (ca. alle 5s ein Bild) doch einmal funktioniert, nachdem ich bei der Konfiguration alle Angaben außer "source" und "debug" gelöscht habe:



    Kann es sein das der Pi Zero W damit überfordert ist? Mit der Pi-Kamera funktionierte das eigentlich ohne dieses starke Ruckeln.


    Danke!

  • Ich nutze die Logitech C270, eine relativ günstige USB-Webcam am Pi 3 und die OMX Erweiterung. Leider funktioniert das Live-Bild noch nicht zuverlässig. Gibt es hier Tipps, auf was zu achten ist, z.B. kleinere Bildgröße oder FPS?. Aktuelle nutze ich native Kameraauflösung und 30FPS, wahrscheinlich zu viel, oder?


    FYI: Meine bisherigen Erfahrungen mit dem Plugin habe ich auch in einen Blogeintrag gegossen.

  • [quote='carsten_h','https://forum.smartapfel.de/forum/thread/55-ip-camera-ffmpeg/?postID=42248#post42248']

    Moin!


    Ich versuche gerade eine billige Kamera (https://amzn.to/2NMeLDz nahezu baugleich mit https://amzn.to/2SayUqm) zu homebridge hinzuzufügen. Ich bekomme auch ein Standbild in der Home-App oder in der Eve-App zustande. Aber es wird leider nicht gestreamt. Da steht das er anfängt und dann wird es einfach gestoppt.


    Ich habe ffmpeg installiert und das homebridge-camera-ffmpeg plugin.


    Das hier habe ich konfiguriert:

    {

    "platform": "Camera-ffmpeg",

    "cameras": [

    {

    "name": "Kamera",

    "videoConfig": {

    "source": "-re -i rtsp://192.168.178.61:554/onvif2",

    "vcodec": "h264_omx",

    "maxFPS": 15,

    "maxHeight": 240,

    "maxStreams": 4,

    "maxWidth": 320,

    "debug": true

    }

    }

    ]

    },


    Mit "rtsp://192.168.178.61:554/onvif2" bekomme ich mit VLC auf dem Mac ein gestreamtes 320x240 großes Video hin. Bei onvif1 bekomme ich nur ein Standbild aber dann in 1280x720.


    Dies hier erscheint mit Debug in der Logdatei:


    Kann mir zufällig hier jemand sagen, was dort schiefläuft. Ich stehe da wie der Ochs vorm Berg.


    Eben hat es ziemlich ruckelnd (ca. alle 5s ein Bild) doch einmal funktioniert, nachdem ich bei der Konfiguration alle Angaben außer "source" und "debug" gelöscht habe:



    Kann es sein das der Pi Zero W damit überfordert ist? Mit der Pi-Kamera funktionierte das eigentlich ohne dieses starke Ruckeln.


    Danke!

    [/quote]

    Probier das mal



    Sent from my iPhone using Community

  • Hallo,


    Also habe ich richtig gelesen, dass ich mit einem Raspberry, ffmpeg und homebridge eine Instar (z.B. 9008) in Homekit einbinden kann ?


    Mir ist es wichtig dass ich die Live Übertragung meiner beiden Kameras (Instar) in der Homekit App sehe.

    lg, Gassi


  • Probier das mal

    Jetzt sehe ich erst, daß das die Antwort zu meinem war, ich dachte das wäre nur eine Kopie.


    Sobald ich das eintrage, erscheint gar kein Video mehr. Ich habe inzwischen sämtliche Parameter mit sinnvollen Werten ausprobiert ,aber ich bekomme es nur hin, daß ein Vorschaubild erscheint und wenn man auf das Video geht ein ziemlich abgehackter Film erscheint, der schon mit ca. 1 Minute im Rückstand anfängt und dann entsprechend langsam hinterherläuft. Der Abstand wird immer länger (oben links wird ja Datum/Uhrzeit eingeblendet).

    Auch die Parameter, die das ganze per Hardware funktionieren lassen sollten (h264_omx) funktionieren nicht.


    Daher ja meine Frage: "Ist eine Pi Zero W zu langsam für das Video?"