[Anleitung] Installation von Home Assistant auf einem Pi4B mit einer über USB angeschlossenen SSD (ohne SD-Card!)

  • Moin!


    Ich habe noch einmal ergänzt, daß man die Datei "ssh" auf dem boot-Volume anlegen muß, damit man später auch mit dem Terminal auf den Pi4B zugreifen kann

    Seltsam, daß darauf noch niemand gestoßen ist. :-)

  • Gibt es für die Stinkendfaulen ein bereits fix und fertiges Raspbee?


    ConBee 2 | Echo | Fritz!Box | Philips Hue Bridge V2 |

    Home Assistant Supervised (Debian) auf ollem Netbook |

    Amazon Alexa | Eve | Home Assistant | Home | Hue | Hue Essentials |



    „2 Stunden Ausprobieren können 10 Minuten Handbuchlesen ersetzen.“

  • ein bereits fix und fertiges Raspbee?

    Ja, das kannst Du bei Dresden Electronic kaufen. Das ist ein Stück Hardware, das man auf den Pi steckt.

    Aber was hat das jetzt mit Home Assistant zu tun?

  • Nö, ich meinte inkl. Software.


    ConBee 2 | Echo | Fritz!Box | Philips Hue Bridge V2 |

    Home Assistant Supervised (Debian) auf ollem Netbook |

    Amazon Alexa | Eve | Home Assistant | Home | Hue | Hue Essentials |



    „2 Stunden Ausprobieren können 10 Minuten Handbuchlesen ersetzen.“

  • Nö, ich meinte inkl. Software.

    Du meinst also Home Assistant inklusive Deconz als Image für einen Pi?

    Dazu geht man einfach bei installiertem Home Assistant auf Supervisor/Add-On store und wählt deconz zum Installieren aus. Das sollte es dann gewesen sein. Simpler geht es doch schon fast nicht.

  • Ich meine einen Raspberry Pi, auf dem der ganze Krempel schon drauf ist, die Schritte 1 - 4 also mehr oder weniger entfallen.


    ConBee 2 | Echo | Fritz!Box | Philips Hue Bridge V2 |

    Home Assistant Supervised (Debian) auf ollem Netbook |

    Amazon Alexa | Eve | Home Assistant | Home | Hue | Hue Essentials |



    „2 Stunden Ausprobieren können 10 Minuten Handbuchlesen ersetzen.“

  • auf dem der ganze Krempel schon drauf ist

    Wenn Du einen Pi4B mit neuem Bootloader hast, brauchst Du nur eine SSD mit dem Image von Home Assistant zu flashen und an den Pi anzuschließen. Fertig.

  • Moin!


    Ich habe die Anleitung stark verkürzt, weil inzwischen der offizielle bootloader mit USB Support als Image herunterladbar ist. Das macht die Sache um einiges einfacher.

  • Hervorragende Anleitung. Hat alles reibungslos geklappt. Inklusive Reload eines zuvor erstellten kompletten Snapshots. Ich bin dabei wie folgt vorgegangen:


    HINWEIS: Wenn der RasPi4 vorher schon mit eine HomeAssistant-Konfiguration lief und dies anschließend auch wieder tun soll, müsst ihr, bevor ihr der Anleitung von carsten_h folgt, UNBEDINGT einen kompletten Snapshot von eurem System machen und diesen extern speichern!

    1. Ich habe beim ersten Start des RasPi 4 mit der neuen SSD-Festplatte bewusst nichts weiter an dem RasPi 4 eingestöpselt (Deconz-Stick oder ähnliches).
    2. Als dann das System nach dem Hinweis, dass es gerade installiert wird, (siehe Anleitung von carsten_h Punkt 4) das erste Mal "nackt" zur Verfügung stand, habe ich nur einen User angelegt.
    3. Danach habe ich nur "SAMBA share" über den Addon-Store installiert, damit ich die Möglichkeit hatte, vom Mac auf die SSD-Platte zuzugreifen. Dafür muss in der SAMBA share Config Username und ein Kennwort eingegeben werden. Dann das Addon starten. Kurz warten, bis das Addon gestartet ist (lässt sich im Logfile kontrollieren.
    4. Im Mac-Finder im Menüpunkt "Gehe zu" auf "mit Server verbinden klicken"
    5. Dann in der Befehlszeile smb://<IP des RasPi4>/backup eingeben und auf "Verbinden" klicken.
    6. Benutzernamen und Kennwort aus der SAMBA share Config in dem aufpoppenden Login-Fenster eintragen.
    7. Nun nur noch den zuvor extern gespeicherten Snapshot in das Backup-Verzeichnis kopieren.
    8. Anschließend ist der Snapshot dann im HomeAssistant Supervisor unter Snapshot zu finden und kann zum Wiederherstellen verwendet werden.
  • Hervorragende Anleitung.

    Das Kompliment kann ich an Dich weitergeben. Zu dem Vorgehen hatte ich noch keine Lust etwas zu beschreiben.


    Sind dann eigentlich alle Integrationen inklusive HACS etc. wieder vorhanden wenn man aus einem Snapshot wiederherstellt?

  • Ja, bislang habe ich weder etwas gefunden, das fehlt noch etwas, das nicht funktioniert. Ganz im Gegenteil, bislang läuft das ganze System mega schnell. Überall sehr kurze Reaktionszeiten.


    Sogar Deconz läuft bislang fehlerfrei und da hatte ich bislang allergrößte Probleme, weil die Devices in sehr kurzen Abständen den Status "unavailable" hatten und deshalb auch nur sehr verzögert oder gar nicht reagierten. Das hatte ich bislang noch gar nicht wieder. Ist aber auch erst ein paar Stunden her, dass ich den Wechsel auf die SSD-Festplatte gewagt habe. Da warte ich lieber noch etwas ab, bevor ich sage, dass Deconz stabil läuft.


    Was aber auf jeden Fall sehr auffällig ist, ist, dass ich in "Glances" überhaupt keine IOWAIT-Fehlermeldungen mehr habe. Das war vorher ein Dauerzustand bei mir. Selbst die CPU-Auslastung ist merklich nach unten gegangen.


    Bislang bin ich sehr zufrieden. :S:thumbup:

  • Überall sehr kurze Reaktionszeiten.

    Ich schätze, daß ich davon leider nicht so viel merken werde, da ich bisher schon eine Lösung mit Boot-SD-Karte und Daten-SSD laufen habe. Aber ich möchte den Umstieg eigentlich bei Erscheinen der 5.3 machen.


    Sogar Deconz läuft bislang fehlerfrei

    Das habe ich ausgelagert auf einem Pi Zero laufen, wo es völlig problemlos läuft.

  • DJay

    Hat das Thema geschlossen