Umzug bzw. Parallel-Betrieb Home Assistant - Wie bekomme ich meine Geräte eingepflegt

  • Hallo zusammen ...


    nun bin ich doch auf HA gestossen, damit sich meine Waschmaschine per Push meldet, wenn die Wäsche fertig ist (TP-Link HS110).

    Und ein paar meiner Geräte wurden nun schon direkt erkannt ... aber wie bekomme ich den "Rest" auch auf HA rüber?

    Ich habe die "Schreibweise" der "configuration.yaml" noch nicht so recht verstanden, also habe ich noch nicht einmal den AVM NetMonitor eingerichtet bekommen ... naja, wird schon noch werden. Aller Anfang ist schwer ;)


    Aber wie sieht es mit diesen PlugIns aus, kann ich die auch bei HA einbinden?


    ├── [email protected]

    Den Broadlink hat HA erkannt, aber wie kann ich nun meine Funk-Steckdosen etc. damit steuern?


    ├── [email protected]

    Ich habe ein paar Xiaofang Kameras mit RSTP-Stream die auch im HomeKit hängen, wie bekomme ich diese in HA?


    ├── [email protected]

    Den Harmony-Hub hat HA erkannt, aber ich habe keine Möglichkeit gefunden, die/eine Fernbedienung in HA zu bekommen.


    ├── [email protected]

    Ein ESP8266 steuert meine Markise über einen http-Aufruf, kann ich sowas auch in HA machen?


    ├── [email protected]

    Ich habe diverse ESP8266 mit einem Temp-Fühler ausgestattet und diese werden per MQTT bzw. über eine Webseite des ESP8266 ausgelesen,

    wie kann ich diese in HA importieren?

    Das hier kommt beim Aufruf der IP-Adresse:

    Und dann habe ich noch ein paar Kooges Tür-/Fenster-Sensoren im Betrieb, diese sind aber eh schon nativ HK-fähig ...


    Hoffe das sind nicht zu viele Fragen auf einmal ;) Aber vielen Dank schonmal für etwas Hilfe.

    Gruß Kai ...

  • Hallo Kai, Glückwunsch!


    Zunächst: Welche Instanz hast du installiert? Vollversion, Supervised, Core?


    Nutzt du Stores? HACS etc.?


    Hast du dir Einstellungen - Integrationen angeschaut?

    Taucht dort bereits die Broadlink Integration auf? (Manchmal) hilfreich sind auch die Manuals, hier:

    Broadlink


    Für mqtt gibt es ebenfalls eine eigene Anbindung/addon.


    Für esp siehe als Erstes: ESP8266


    Benutzt du die Homekit Integration oder Homekit Controller?


    Hilfreich wäre auch, deine configuration.yaml zu posten.


    Vergessen: Für die Harmony gibt es die

    - platform: harmony


    ConBee 2 | Echo | Fritz!Box | Philips Hue Bridge V2 |

    Home Assistant Supervised (Debian) auf ollem Netbook |

    Amazon Alexa | Eve | Home Assistant | Home | Hue | Hue Essentials |



    „2 Stunden Ausprobieren können 10 Minuten Handbuchlesen ersetzen.“

  • Hi ...


    danke ;) Dann werde ich mal schauen, wo ich die Infos finde.

    - Operating system HassOS 4.13

    - Supervisor - Version 247

    - den Add-On-Store kann ich auch nutzen


    Ja, habe erstmal mit dem Broadlink gestartet ... und auch schon einen Schalter anlegen können,

    aber der schaltet nix ... habe versucht den RF-Code in einen base64 code umzuwandeln, aber auch

    damit geht es nicht :(


    Ich nutze zur Zeit HA neben meiner HB und werde ma sehen, ob HA die HB komplett ablösen kann/wird.

    Habe es erstmal nur wegen der TP-Link Steckdosen versucht, damit ich eine Meldung bekomme, wenn die Wäsche oder mein 3D-Drucker fertig ist ;) Das habe ich mit Apple-Home und der Homebridge nicht hinbekommen.


    Die MQTT-Ereiterung habe ich auch schon installiert, bekomme da aber auch noch keine Daten drüber.

    Denke das meine Temp-Sensoren kein mqtt machen ... die erstellen eine WebSeite, habe diese hierüber installiert.

    https://github.com/NorthernMan…cuiot/tree/master/nodemcu


    Mein Kameras machen aber MQTT für Motion etc. aber da weiß ich auch noch nicht, wie ich ein Bild in HA bekommen soll ... ist erstmal ganz schön viel zu lesen.


    Meinen Harmony-Hub hat HA erkannt, ich habe aber keine "Schalter" oder keine "Fernbedienung" im HA,

    da muss ich bestimmt auch wieder was in der Config-Datei ändern ...


    Gar nicht so easy am Anfang ... aber das wird schon, hoffe ich.


    CU und Danke ... Kai


    Das ist meine aktuelle Config.

  • Puh, bissken schlecht zu lesen so unformatiert.

    Ist das nur ein Auszug aus deiner configuration.yaml oder hast du den homeassistant-Teil bewusst rausgeschmissen?


    Ich würde auf jeden Fall

    Code
    discovery:

    reinnehmen.


    Zu Broadlink:

    Zitat

    The following devices are supported:

    • Power Strips: MP1-1K3S2U and MP1-1K4S
    • Sensors: e-Sensor
    • Smart Plugs: SP mini, SP mini+, SP mini 3, SP1, SP2, SP2-CL, SP2-UK/BR/IN, SP3, SP3-EU, SP3S-EU and SP3S-US
    • Universal Remotes: RM mini, RM mini 3, RM pro, RM pro+, RM plus, RM4 mini, RM4 pro and RM4C mini
    • Wi-Fi Controlled Switches: SC1

    Configuration

    To set up a Broadlink device, click Configuration in the sidebar and click Integrations. If you see your device there, click Configure. If not, click the + icon in the lower right, enter the hostname or IP address of the device and follow the instructions to complete the setup.

    Das passt soweit??


    Harmony fehlt in der config. Da müsste sowas in der Art stehen:


    Code
    remote:
    - platform: harmony
    name: # vergebener Name des Hubs #
    host: # IP-Adresse des Hubs; wenn leer, #
    # sollte autom. Erkennung greifen #


    mqtt:


    Da würde ich noch mal die Konfiguration im Addon selbst (Superviser Store) kontrollieren.


    Generell gilt: HA will jedes Mal neugeladen werden, wenn man direkt mit der configuration.yaml arbeitet und Änderungen vorgenommen hat. Und die Log-Datei ist oftmals ein wahrer Informationsquell, wenns mal nicht so läuft.


    Die Lernkurve war für mich steil. Aber wenn man den Dreh erst maln bisschen raushat, macht es richtig Spaß.


    ConBee 2 | Echo | Fritz!Box | Philips Hue Bridge V2 |

    Home Assistant Supervised (Debian) auf ollem Netbook |

    Amazon Alexa | Eve | Home Assistant | Home | Hue | Hue Essentials |



    „2 Stunden Ausprobieren können 10 Minuten Handbuchlesen ersetzen.“

  • Hi ...


    ich habe nix aus der config gelöscht, da stand nur nicht viel drin zu Anfang ...

    Was macht denn die Option "discovery"?


    Ich habe den Broadlink RM Pro + und der wird auch erkannt ... aber ich schaffe es eben nicht

    meine diversen RF-Steckdosen und Rollo-Schalter anzusteuern ... die Codes die ich damals mit

    HB ausgelesen habe, funktionieren leider nicht.

    "remote.broadlink_rmpro_remote"


    Auch den HarmonyHub erkennt HA, aber ich habe keine Schalter die ich in das Webinterface integrieren kann.

    Das hier finde man in den Tiefen der Geräte:

    - current activity - Fernsehen

    - activity list
    Apple TV, Fernsehen, PS3, Sonos Küche, Sonos Wohnzimmer, Surround

    - devices list
    Wohnzimmer, Vu+ DVR, Denon AVR, Apple TV, Main Zone, Küche Sonos (PLAY:1), Apple TV (2), LG-Fernseher, Sony PS3, AppleTV, Wohnzimmer Sonos (PLAY:1)

    - last activity - Fernsehen


    Hm ... wobei die anderen Geräte auch erkannt werden, aber nix in der Config steht.

  • discovery ist Autoerkennung von neuen Geräten.


    Für die Harmony musst du wie gesagt erst die oben erwähnte platform in die config einbauen, danach kannst du den Schalter einfügen. Dazu einfach die gewünschte Karte auf deinem Dashboard auswählen.


    Meine configuration.yaml beginnt wie folgt:



    ConBee 2 | Echo | Fritz!Box | Philips Hue Bridge V2 |

    Home Assistant Supervised (Debian) auf ollem Netbook |

    Amazon Alexa | Eve | Home Assistant | Home | Hue | Hue Essentials |



    „2 Stunden Ausprobieren können 10 Minuten Handbuchlesen ersetzen.“

    Einmal editiert, zuletzt von Rup ()

  • Hab die Broadlink Schalter nun zum Großteil eingebunden ;)

    Hab nen Code-Converter im Netz gefunden, damit werden die "alten" Codes in die 64er Version umgewandelt und schon gehts.


    Das Discovery habe ich auch drin, aber irgendwie nur noch in der Config-Datei ...


    Werde mich dann mal an dein Einbindung vom Harmony Hub machen, wenn ich die letzen Broadlink Codes

    für meine Rollos eingebaut habe ...

    Gibt es auch ne Option, das der Schalter von allein wieder auf "off" schalten? Bei der HB habe ich das bei

    meinen Rollos so gemacht "Rollo 1 hoch" und nach 3 Sekunden ging der Schalter wieder aus.

    Genau so bei "Rollo 1 stop" und bei "Rollo 1 runter"


    CU Kai