homebridge-camera-ui

  • neomorph


    Probier es mal mit folgendem config


    https://pastebin.com/hm33raNm



    Wenn "videoanalysis" aktiv ist brauch man kein smtp/mqtt/ftp/http weil dann camera.ui nativ den stream analysiert und bewegungsmeldungen rausschickt :)

    Einmal editiert, zuletzt von SeydX () aus folgendem Grund: Ein Beitrag von SeydX mit diesem Beitrag zusammengefügt.



  • Wenn "videoanalysis" aktiv ist brauch man kein smtp/mqtt/ftp/http weil dann camera.ui nativ den stream analysiert und bewegungsmeldungen rausschickt :)

    War mir gar nicht bewußt! Welcher Voraussetzungen sind Kameraseitig notwenig damit die Videoanalyse funktioniert?


    Es ist gar nicht mehr so einfach die ganzen Funktionen des Plugins zu verstehen und richtig zu kombinieren. Ich greife mir gerade an die eigene 👃

  • War mir gar nicht bewußt! Welcher Voraussetzungen sind Kameraseitig notwenig damit die Videoanalyse funktioniert?


    Es ist gar nicht mehr so einfach die ganzen Funktionen des Plugins zu verstehen und richtig zu kombinieren. Ich greife mir gerade an die eigene 👃

    Eigtl ist nicht so viel dran 😄


    Die verschiedenen Funktionen erkennt man im config.json daran das sie ihren eigenen „block“ haben


    Und diese sind meist optional. Zb mqtt,smtp,http,ftp oder options


    Bleiben nurnoch die Kameras übrig. Und via homebridge-config-ui-x oder direkt über das Interface, siehst du ja zu allen parametern eine Beschreibung 😄


    Bzgl videoanalysis: Dieser gehört auch zu Bewegungserkennung, befindet sich jedoch im block der Kameras weil diese Kameraspezifisch ist, der eine will es zb nur für eine bestimmte Kamera aktiv haben, ein anderer für alle.


    Mqtt, smtp, http oder ftp hingegen bauen einen „server“ auf und sind, wenn aktiviert, direkt beim Start von camera.ui aufgebaut und sie differenzieren nicht zwischen den Kameras

  • SeydX: Heute Nacht unter 5.0.7 haben sich ganz viele ffmpeg-Prozesse nicht geschlossen. Der Mac mini war echt am Schwitzen. Ein Homebridge Stop hat die Prozesse nicht geschlossen, aber die Last zurückgenommen. Ich habe dann den Mac mini neu gebootet.


    Ich habe gerade 5.0.8 installiert. Außerdem habe ich den ftp-Server ausgeschaltet, weil ich ja zuvor gelernt habe, dass die Videoanalyse auch Bewegungen erkennt (das war klar) und HSV bzw. CameraUI-Aufzeichnungen triggert (das war mir nicht klar).


    Edit: Ohne ftp-trigger werden bei mir Bewegungen nicht erkannt. Ist mir aber auch egal. Habs wieder eingeschaltet, weil es eigentlich sehr gut lief.

    Homebridge-Neuling seit 02/2021, alter HomeKit-Hase fast von Anfang an

    Einmal editiert, zuletzt von iPhoneast ()

  • Hey und einen schönen Sonntag,

    DANKE SeydX , mit Deiner config laufen nun auch die Aufnahmen in HSV. Super, ich freue mich.


    Die lokalen Aufnahmen funzen nun auch, allerdings bekomme ich immer "invalid date" beim Zeitstempel:


    Woran könnte das liegen?
    Viele Grüße

    neo

    Raspberry 4b, Homebridge v.1.4.0-beta4 im Docker mit Portainer, fhem, Camera-UI V.5.0.8

    Einmal editiert, zuletzt von neomorph ()

  • SeydX: Heute Nacht unter 5.0.7 haben sich ganz viele ffmpeg-Prozesse nicht geschlossen. Der Mac mini war echt am Schwitzen. Ein Homebridge Stop hat die Prozesse nicht geschlossen, aber die Last zurückgenommen. Ich habe dann den Mac mini neu gebootet.


    Ich habe gerade 5.0.8 installiert. Außerdem habe ich den ftp-Server ausgeschaltet, weil ich ja zuvor gelernt habe, dass die Videoanalyse auch Bewegungen erkennt (das war klar) und HSV bzw. CameraUI-Aufzeichnungen triggert (das war mir nicht klar).


    Edit: Ohne ftp-trigger werden bei mir Bewegungen nicht erkannt. Ist mir aber auch egal. Habs wieder eingeschaltet, weil es eigentlich sehr gut lief.


    Oh interessant. Wichtig wäre gewesen um welche ffmpeg Prozesse sich hierbei gehandelt hat :/ ich nehme aber an es waren die für HSV


    Kannst du das weiterhin beobachten bitte und mir am besten dann ein Screenshot von den Prozessen schicken die sich aufhängen (falls es wieder passieren sollte)


    Und bzgl Bewegungserkennen mit Video Analyze. Über das Interface (Einstellungen > Kameras > Video Analyze) kannst du die Sensitivität einstellen und es fein justieren damit die camera.ui besser Bewegung erkennt


    Aber wenn es über FTP sowieso geklappt hat dann würde ich das lassen :)


    Lg


    Wunderbar. Hmm das ist in der tat komisch. Sehe ich auch zum ersten Mal. Zeitstempel wird vom Dateinamen ausgelesen, kannst du mir mal den Dateinamen von irgendeiner Aufnahme schicken bitte wo „invalid date“ steht

    Einmal editiert, zuletzt von SeydX () aus folgendem Grund: Ein Beitrag von SeydX mit diesem Beitrag zusammengefügt.

  • Hey SeydX ,

    die Aufnahme heißt: sleep-cam-4793ab39fc-1642332546_c_CUI.mp4 und das ist das Bild dazu:


    Im Dateinamen ist in der Tat auch kein Timestamp zu sehen.


    LG

    neo

    Raspberry 4b, Homebridge v.1.4.0-beta4 im Docker mit Portainer, fhem, Camera-UI V.5.0.8

  • Ne da ist alles gut soweit, Zeitstempel ist dieser Wert im Namen "1642332546" hmm seltsam, auch ein Neuladen der Seite behebt das Problem nicht? Irgendein Fehler in der Browser Konsole zu erkennen?

  • Ne da ist alles gut soweit, Zeitstempel ist dieser Wert im Namen "1642332546" hmm seltsam, auch ein Neuladen der Seite behebt das Problem nicht? Irgendein Fehler in der Browser Konsole zu erkennen?

    Hey SeydX ,


    neuladen hilft nix. Auf der Konsole finde ich folgendes:

    Raspberry 4b, Homebridge v.1.4.0-beta4 im Docker mit Portainer, fhem, Camera-UI V.5.0.8

  • Hallo zusammen,


    ich brauche mal eure Hilfe. Ich habe eine Kamera in Camera.ui hinzugefügt. In Camera.ui kann ich das live Bild auch sehen. So gut so schön. In Homekit kann ich die Kamera aber nicht hinzufügen. Der Frag immer nach den Konfigurationscode. Bisher war ich es gewohnt das alles über Hombridge sofort in Homekit auftauchte. Mach ich da etwas falsch?

  • Geb doch einfach den Code ein 😂

    Cameras werden als separate Bridge eingebunden, daher muss der Code der Homebridge eingegeben werden.

    Gleiches Prinzip wie bei einer Child-Bridge

  • Geb doch einfach den Code ein 😂

    Cameras werden als separate Bridge eingebunden, daher muss der Code der Homebridge eingegeben werden.

    Gleiches Prinzip wie bei einer Child-Bridge

    Woher soll ich den den Haben wenn die Kamera nicht für Home Kit gemacht wurde? Wie gesagt über Homebridge und Camera.ui will ich die einbinden.

  • Code der Homebridge

  • SeydX: Heute Nacht unter 5.0.7 haben sich ganz viele ffmpeg-Prozesse nicht geschlossen. Der Mac mini war echt am Schwitzen. Ein Homebridge Stop hat die Prozesse nicht geschlossen, aber die Last zurückgenommen. Ich habe dann den Mac mini neu gebootet.


    Ich habe gerade 5.0.8 installiert. Außerdem habe ich den ftp-Server ausgeschaltet, weil ich ja zuvor gelernt habe, dass die Videoanalyse auch Bewegungen erkennt (das war klar) und HSV bzw. CameraUI-Aufzeichnungen triggert (das war mir nicht klar).


    Edit: Ohne ftp-trigger werden bei mir Bewegungen nicht erkannt. Ist mir aber auch egal. Habs wieder eingeschaltet, weil es eigentlich sehr gut lief.

    Denke das gleiche Problem habe ich auch. Habe Videos die nun knappe 75 Minuten aufgezeichnet wurde.

    Das steht im Log


    Im Weiteren wird von meiner Kamera mit HSV keine Aufnahme in camerau-ui abgelegt. Im Log steht aber nicht warum.

  • Ich habe heute wieder zwei ffmpeg-Prozesse.

    Da steht auch irgendwas von 1077 Fehler





    Die Aktivitätsanzeige des Macs erlaubt mir eine Analyse, die vielleicht hilft? Die ganze Analyse ist leider zu lang für hier. Ich habe das Kapitel "binary images" weggelassen.


    Sag einfach, was du brauchst.


    Homebridge-Neuling seit 02/2021, alter HomeKit-Hase fast von Anfang an

  • Denke das gleiche Problem habe ich auch. Habe Videos die nun knappe 75 Minuten aufgezeichnet wurde.

    Das steht im Log


    Im Weiteren wird von meiner Kamera mit HSV keine Aufnahme in camerau-ui abgelegt. Im Log steht aber nicht warum.


    Hm, könntest du im Log mal nachschauen ob bei einer HSV Aufnahme was so lange geht im Log der Eintrag "Motion OFF" auftaucht? Falls nämlich ja, ist das auf ein Fehler von Homebridge zurückzuführen, falls nicht stimmt etwas im Code nicht


    Und welche Version von homebridge-camera-ui ?



    Leider kann ich dadurch nicht den ffmpeg command sehen, es gibt ein super tool namens "htop" was super die laufenden Prozesse anzeigt inkl Zeit etc und dem command dazu


    https://www.cyberciti.biz/faq/…ktop-running-macbook-pro/

    2 Mal editiert, zuletzt von SeydX () aus folgendem Grund: Ein Beitrag von SeydX mit diesem Beitrag zusammengefügt.

  • iPhoneast  Ubee


    v5.0.10-beta.3 ist online


    lg

    Ich habe die aktuelle Homebridge Beta als auch deine aktuelle Beta installiert. Leider laufen Streams nicht mehr die vorher liefen.


    Meinen PSEye Cam Stream kann ich in Home als auch Camerau-Ui nicht mehr öffnen.

    Error ist

    Code
    PSEye: FFmpeg exited with code: 1 and signal: null - [fatal] Option rtsp_transport not found.

    Den Stream meiner HSV Kamera kann ich auch nicht mehr öffnen in Camera-UI

    Error ist


    Code
    Request failed with status code 500
    Cars: Stream exited with error! (null) - Option stimeout not found.

    Wenn ich den Stream meiner Yi Cams in der Home App öffnen möchte klappt das auch nicht mehr.

    Im Log steht nur


    Code
    [1/18/2022, 9:45:40 AM] [CameraUI] Heizung: Starting video stream: native
    [1/18/2022, 9:45:40 AM] [CameraUI] Heizung: Stopped video stream.

    Kommt aber kein Stream. In Camera-UI kann ich den Stream öffnen


    Mit welchem Problem wollen wir zuerst anfangen? :)