Homebridge lässt sich nicht aktualisieren

  • Hallo zusammen,


    ich hab das Problem das meine Homebridge sich nicht mehr updaten lässt und das immer mit einem Fehler endet.


    PI ist auf dem neusten stand

    node ist auf 14.16.0

    npm auf 7.7.6


    ich hoffe mir kann jemand helfen. Der Fehler log vom pi ist nur der Anfang wenn nötig kann ich den Rest mit reinstellen.


    Danke schonmal im Voraus.

  • Versuchs mit

    Code
    sudo hb-service update-node 15.13.0

    in der Konsole/Terminal .


    LG

  • Nein, kein Node-Update.


    Versuche es im Terminal mit

    sudo npm uninstall -g --unsafe-perm homebridge-config-ui-x

    sudo npm install -g --unsafe-perm homebridge-config-ui-x


    Wenn das nicht geht, dann versuche ein:

    sudo rm -rf /usr/local/lib/node_modules/homebridge-config-ui-x

    sudo npm install -g --unsafe-perm homebridge-config-ui-x


    Auf jeden Fall versuchst du das nächste mal, auf Screenshots deiner Logs zu verzichten, damit ich hier nicht alles abschreiben muss.

  • Also das nächste mal kopieren und einfügen?

    Ja, bitte.

  • Abend.


    so nachdem der erste weg nicht geklappt hat, hab ich einfach mit dem zweiten weiterversucht. Siehe da es hat geklappt und alles geht wieder wie gehabt :)


    ich danke für euere Hilfe und einen schönen Abend noch sowie schöne Ostern morgen

  • Immer wenn ich das UI Update über das WebIF ausführen will, bekomme ich folgenden Fehler:

    Jemand ne Ahnung, was ich tun muss? (Linux DAU hier ;-) )

  • Vielen Dank!! Mal wieder!

    Lief durch, lediglich ein paar Warnungen :-) Irgendwas Beunruhigendes?

    Code
    [email protected]:~ $ sudo npm install -g --unsafe-perm homebridge-config-ui-x
    npm WARN deprecated [email protected]: Debug versions >=3.2.0 <3.2.7 || >=4 <4.3.1 hav e a low-severity ReDos regression when used in a Node.js environment. It is reco mmended you upgrade to 3.2.7 or 4.3.1. (https://github.com/visionmedia/debug/iss ues/797)
    npm WARN deprecated [email protected]: Debug versions >=3.2.0 <3.2.7 || >=4 <4.3.1 hav e a low-severity ReDos regression when used in a Node.js environment. It is reco mmended you upgrade to 3.2.7 or 4.3.1. (https://github.com/visionmedia/debug/iss ues/797)
    npm WARN deprecated [email protected]: Debug versions >=3.2.0 <3.2.7 || >=4 <4.3.1 hav e a low-severity ReDos regression when used in a Node.js environment. It is reco mmended you upgrade to 3.2.7 or 4.3.1. (https://github.com/visionmedia/debug/iss ues/797)
    npm WARN deprecated [email protected]: Debug versions >=3.2.0 <3.2.7 || >=4 <4.3.1 hav e a low-severity ReDos regression when used in a Node.js environment. It is reco mmended you upgrade to 3.2.7 or 4.3.1. (https://github.com/visionmedia/debug/iss ues/797)
    npm WARN deprecated [email protected]: This release contains a breaking change from 0.3.1 but otherwise functions properly. Please read the changelog on Github to learn more.
    added 378 packages, and audited 379 packages in 2m
  • Irgendwas Beunruhigendes?

    Wer weiß? Diese Warnungen richten sich eher an den Entwickler des Plugins. Der muss zusehen, dass er neuere Versionen von debug und class-transformer verwendet. Ich habe keine Ahnung, wozu debug und class-transformer benötigt werden, aber es eigentlich auch egal - solange es nur Warnungen sind: ignorieren. Irgendein Update wird es irgendwann richten.

  • Für eine Anleitung wäre ich sehr dankbar!

    das hier hat bei mir doe 7.x hochgezogen


    sudo npm i -g npm-upgrade

    //.ichael

    -----------------------------------


  • Hi, bei meiner Homebridge gibts das Update für ui-x-Plugin, aber wenn ich es updaten will wirft er mir immer Errors entgegen, die ich nicht wirklich deuten kann.

    Kann mir von euch jemand weiterhelfen?

    Ich bedanke mich schon einmal.


    Code
    npm ERR! code ENOTEMPTY
    npm ERR! syscall rename
    npm ERR! path /usr/local/lib/node_modules/homebridge-config-ui-x
    npm ERR! dest /usr/local/lib/node_modules/.homebridge-config-ui-x-3gtnOIj4
    npm ERR! errno -39
    npm ERR! ENOTEMPTY: directory not empty, rename '/usr/local/lib/node_modules/homebridge-config-ui-x' -> '/usr/local/lib/node_modules/.homebridge-config-ui-x-3gtnOIj4'
    npm ERR! A complete log of this run can be found in:
    npm ERR! /home/homebridge/.npm/_logs/2021-04-28T20_06_14_007Z-debug.log
  • Hatten wir hier schon mal. Siehe hier: RE: Homebridge lässt sich nicht aktualisieren

  • Leider haben die Befehle


    Hallo scschuste,


    leider haben die Befehle bei mir das Problem nicht lösen können.Kannst du mir helfen ?


    USER: pi

    DIR: /usr/local

    CMD: sudo -E -n npm install -g [email protected]


    TypeError: Class extends value undefined is not a constructor or null

    at Object.<anonymous> (/usr/local/lib/node_modules/npm/node_modules/socks-proxy-agent/dist/agent.js:114:44)

    at Module._compile (node:internal/modules/cjs/loader:1101:14)

    at Object.Module._extensions..js (node:internal/modules/cjs/loader:1153:10)

    at Module.load (node:internal/modules/cjs/loader:981:32)

    at Function.Module._load (node:internal/modules/cjs/loader:822:12)

    at Module.require (node:internal/modules/cjs/loader:1005:19)

    at require (node:internal/modules/cjs/helpers:102:18)

    at Object.<anonymous> (/usr/local/lib/node_modules/npm/node_modules/socks-proxy-agent/dist/index.js:5:33)

    at Module._compile (node:internal/modules/cjs/loader:1101:14)

    at Object.Module._extensions..js (node:internal/modules/cjs/loader:1153:10)

    at Module.load (node:internal/modules/cjs/loader:981:32)

    at Function.Module._load (node:internal/modules/cjs/loader:822:12)

    at Module.require (node:internal/modules/cjs/loader:1005:19)

    at require (node:internal/modules/cjs/helpers:102:18)

    at Object.<anonymous> (/usr/local/lib/node_modules/npm/node_modules/make-fetch-happen/lib/agent.js:161:25)

    at Module._compile (node:internal/modules/cjs/loader:1101:14)


    Command failed. Please review log for details.



    Aus dem Protokoll


    [11/20/2021, 9:04:57 PM] [Homebridge UI] Running Command: sudo -E -n npm install -g [email protected]

    [11/20/2021, 9:05:01 PM] [Homebridge UI] Command failed. Please review log for details.

  • Einmal editiert, zuletzt von Patrick_ ()