Homebridge Backup auf NAS (Synology) automatisch sichern

  • Ja, steht ja oben. Denn


    Code
    "scheduledBackupPath": "/mnt/backup/"


    Ist kein gültiger Befehl für die Konsole sondern gehört wie geschrieben in die config.json

    Wenn ich das einfach so einfüge, kommt eine rote Fehlermeldung, ich denke, dass das nicht ganz richtig war :|

    Kannst du mir bitte genauer erklären, wie ich das in die config.json schreibe, kenn mich nicht so damit aus, obwohl ich schon lange hier im Forum bin, sorry, dafür bin ich zu blöd.

  • Wenn ich das einfach so einfüge, kommt eine rote Fehlermeldung, ich denke, dass das nicht ganz richtig war :|

    Stimmt, bei mir auch.

    Wenn ich aber ein bischen nachdenke und es da eintrage wo es hingehört funktioniert es doch:/;)

    Code
    {
    "platform": "config",
    "name": "Config",
    "port": 8581,
    "auth": "none",
    "theme": "dark-mode",
    "tempUnits": "c",
    "lang": "de",
    "sessionTimeout": 1296000,
    "scheduledBackupPath": "/mnt/backup/"
  • Stimmt, bei mir auch.

    Wenn ich aber ein bischen nachdenke und es da eintrage wo es hingehört funktioniert es doch:/;)

    Das ist ja mein Problem, ich weiss ja nicht wo es hin soll, kenne mich mit Linux nicht aus

    Ich habe es jetzt so gemacht, kommt auch ne rote Meldung

  • Klar fehlt ja auch ein Komma!


    Du müsstest Dich schon ein bischen bemühen die Zusammenhänge zu verstehen. Ständig darauf zu hoffen und so lange zu fragen, bis Dir jemand die Lösung auf dem Silbertablett serviert wird sicher nicht immer klappen!

  • Beitrag von Vollerpla ()

    Dieser Beitrag wurde vom Autor gelöscht ().
  • Nach deinem "platform": "config". Jeder Parameter in deiner Config wird mit einem Komma beendet und in der Zeile darauf folgt der nächste Parameter. nur beim letzten Parameter braucht es dann kein Komma mehr, hier wird nämlich die geschweifte Klammer geschlossen in der Zeile darunter.


    So "ließt" ein Computer deine config.json, er weiß, nach jedem Komma fängt ein neuer Parameter an, solange, bis er bei der geschweiften Klammer ankommt.

    Einmal editiert, zuletzt von Patrick_ ()

  • Aha, ok :/, nimm ich mal so hin, das heisst dann nach "platform": "config" muss ein Komma also so, "platform": "config",

    Habe es bei den vorherigen Zeilen gesehen, dass da ein Komma als letztes war.

    Hhabe ich auch gerade probiert, hat geklappt, HB neu gestartet und jetzt muss wahrscheinlich bis morgen warten, dass dann eine Datei auf meinem Zielordner auf meinem NAS ist.


    Danke für die Hilfe.


    Guten Morgen allerseits.

    Ich habe jetzt zwei Tage gewartet und habe gerade mal in HB unter Backups > geplante Backups geschaut, da wird mir folgendes angezeigt

    Code
    Fehler
    Custom instance backup path is not writable / readable by service: EACCES: permission denied, access '/mnt/backup/'

    Ich habe die schritte auch nochmal wiederholt, doch beim aufrufen von

    Code
    sudo nano /etc/fstab

    ist mir aufgefallen, dass das Feld leer ist, der Eintag den ich gemacht, der ist weg.

    Ich wiederhole nochmal die Schritte, vielleicht, da wird bestimmt noch ein Fehler sein.


    Also es öffnet sich dieses Fenster, da trage ich als letzte Zeile folgendes ein

    Code
    192.168.XXX.XXX:5000/DS218plus/backup /mnt/backup/ nfs defaults,local_lock=all 0 0

    Dann verwende ich folgenden Tasten auf meiner Tastatur um das Fenster zu schließen

    control x

    bestätige dann mit Y dass es gespeichert werden soll, es kommt auch ne Meldung

    File Name to Write: /etc/ fstab

    und was mache ich dann ?? Wie komme ich aus dem Fenster wieder raus ??

    Ich habe bisher oben auf "Status" geklickt, ist das richtig ??


    Habe danach die weiteren Schritte, aber das scheint ja nichts zu bringen

    Einmal editiert, zuletzt von Spy () aus folgendem Grund: Ein Beitrag von Vollerpla mit diesem Beitrag zusammengefügt.