Harmony Hub Plugin auf Synology NAS 418 Play wird nicht erkannt

  • Hallo Zusammen,


    ich bin ein absoluter Neuling was das Thema Homebridge angeht.

    Ich habe auf meinem Synology NAS 418 play über Docker den Container oznu/Homebridge:latest installiert.

    Homebridge wird auch auf meinem iPhone erkannt und ich hab es mit dem dazugehörigen Code gekoppelt.


    forum.smartapfel.de/attachment/6644/

    Im Anschluss habe ich die beiden Plugins über den Terminal mit dem sn Befehl installiert:



    1. Install Homebridge using: npm install -g homebridge
    2. Install this plugin using: npm install -g homebridge-harmony

    Danach habe ich die config.json abgeändert auf:


    {

    "bridge": {

    "name": "Homebridge",

    "username": "CC:22:3D:E3:CE:30",

    "port": 51826,

    "pin": "031-45-154"

    },


    "description": "This is an example configuration file. You can use this as a template for creating your own configuration file containing devices you actually own.",


    "accessories": [

    ],


    "platforms": [

    {

    "platform": "HarmonyHub",

    "name": "Harmony Hub"

    }

    ]

    Dies führt dazu, das die Bridge auf meinem iPhone nicht mehr erkannt wird.

    Ich habe schon alle möglichen Variationen ausprobiert auch mit: JSONLINT -Validator


    Leider alles ohne Erfolg.


    Hier die Fehlermeldung:



    Ich bin mit meinem Latein am Ende und brauche Hilfe von einem Experten.


    Schon mal vielen Dank im Voraus.


    VG GoodGrooves

  • Wenn du die oben gezeigte Config wirklich so 1:1 verwedest, dann fehlt eine Klammer am Schluss }


  • Hi maNu,


    danke für deine schnelle Hilfe.


    leider ohne Erfolg.


    Homebridge am iPhone down und diese Fehlermeldung im Terminal:


    [8/12/2019, 4:00:33 PM] Loaded plugin: homebridge-harmony

    [8/12/2019, 4:00:33 PM] Registering platform 'homebridge-harmonyHub.HarmonyHubWe

    bSocket'

    [8/12/2019, 4:00:33 PM] ---

    [8/12/2019, 4:00:33 PM] Loading 1 platforms...

    [8/12/2019, 4:00:33 PM] Error: The requested platform 'HarmonyHub' was not regis

    tered by any plugin.

    at API.platform (/usr/local/lib/node_modules/homebridge/lib/api.js:134:13)

    at Server._loadPlatforms (/usr/local/lib/node_modules/homebridge/lib/server.

    js:327:45)

    at Server.run (/usr/local/lib/node_modules/homebridge/lib/server.js:90:36)

    at module.exports (/usr/local/lib/node_modules/homebridge/lib/cli.js:59:10)

    at Object.<anonymous> (/usr/local/lib/node_modules/homebridge/bin/homebridge

    :17:22)

    at Module._compile (internal/modules/cjs/loader.js:778:30)

    at Object.Module._extensions..js (internal/modules/cjs/loader.js:789:10)

    at Module.load (internal/modules/cjs/loader.js:653:32)

    at tryModuleLoad (internal/modules/cjs/loader.js:593:12)

    at Function.Module._load (internal/modules/cjs/loader.js:585:3)

    at Function.Module.runMain (internal/modules/cjs/loader.js:831:12)

    at startup (internal/bootstrap/node.js:283:19)

    at bootstrapNodeJSCore (internal/bootstrap/node.js:622:3)

    [8/12/2019, 4:00:33 PM] Got SIGTERM, shutting down Homebridge...

    -U /homebridge -P /homebridge/node_modules -C

    [8/12/2019, 4:00:41 PM] Loaded config.json with 0 accessories and 1 platforms.


    Noch ne Idee?

    VG

  • Hi, habe gerade noch ne andere config probiert und siehe da, es hat geklappt.



    "bridge": {

    "name": "Homebridge",

    "username": "CC:22:3D:E3:CE:30",

    "port": 51826,

    "pin": "031-45-154"

    },

    "description": "This is an example configuration file. You can use this as a template for creating your own configuration file containing devices you actually own.",

    "accessories": [],

    "platforms": [{

    "platform": "HarmonyHubWebSocket",

    "name": "HarmoyHub",

    "hubIP": "192.168.0.186",

    "showTurnOffActivity": true,

    "skipedIfSameStateActivities": ["PowerOff", "La musique"],

    "publishActivitiesAsIndividualAccessories": false

    }]

    }


    Vielen Dank nochmal für die hilfe.

  • Okay damit du den anderen Fehler auch nachvollziehen kannst, welcher vorher auch noch da war.


    Es gibt fuer den Harmony Hub mehrere plugins und demnach auch unterschiedliche Formen, welche du in die config.json eintragen musst.


    Hierbei wuerde ich dir empfehlen, die Plugins direkt ueber das config-ui-x zu installieren. Nachdem sie installiert sind in der Plugin Seite rechts auf so eine Art Teilen Symbol zu klicken unter dem Entwicklernamen. Damit gelangst du direkt auf die github Seite mit den config.json samples fuer das jeweilige Plugin. So kommst du nicht durcheinander wenn es mehrere Plugins fuer die selbe hardware gibt und du demnach unterschiedliche config.json Szenarien kreierst!

  • Hab die Hue Bridge am laufen mit den Hue Leuchtmittel, habe aber auch 10 Osram Plugs die über die Hue Bride in HomeKit nicht angezeigt werden.
    Werde mir das Plugin morgen installieren.
    Welche Version soll ich nehmen. Habe gelesen das die letzte mit den Plugs Probleme macht.



    Sent from my iPhone using Community

  • Das ist normal, dass die Fremdgeräte die mit der Hue Bridge verbunden sind, nicht in HomeKit angezeigt werden. Dafür gibt es ja das Plugin (homebridge-hue).


    Von Problemen weiß ich nix, einzige was ist das die Plugs als Leuchtmittel angezeigt werden in HomeKit. Um das zu ändern gibt es aber eben diesen ph xxxxx Befehl. Wie das genau zu machen ist, steht hier im entsprechenden Thema dann.

  • Hi maNu,


    hab seit heute das Problem das das Hue Plugin hängen bleibt.


    Fehlermeldung:


    [8/27/2019, 6:22:13 PM] [Hue] Initializing platform accessory 'XFDani[7]sn:state

    '...

    [8/27/2019, 6:22:13 PM] [Hue] Initializing platform accessory 'XFDani[6]sn:state

    '...

    [8/27/2019, 6:22:13 PM] [Hue] Initializing platform accessory 'XFDani[6][2]sn:st

    ep'...

    [8/27/2019, 6:22:13 PM] [Hue] Initializing platform accessory 'XFDani[7][2]sn:st

    ep'...

    [8/27/2019, 6:22:13 PM] [Hue] Initializing platform accessory 'XFDani[7][3]sn:st

    ep'...

    [8/27/2019, 6:22:13 PM] [Hue] Initializing platform accessory 'XFDani[1][3]sn:st

    ep'...

    [8/27/2019, 6:22:13 PM] [Hue] Initializing platform accessory 'XFDani[6][3]sn:st

    ep'...

    [8/27/2019, 6:22:13 PM] [Hue] Initializing platform accessory 'XFDani[4]sn:state

    '...

    [8/27/2019, 6:22:13 PM] [Hue] Initializing platform accessory 'TV Leuchte'...

    [8/27/2019, 6:22:13 PM] [Hue] Initializing platform accessory 'XFDani[4][4]sn:st

    ep'...

    [8/27/2019, 6:22:13 PM] [Hue] Initializing platform accessory 'XFDani[4][1]sn:st

    ep'...

    [8/27/2019, 6:22:13 PM] [Hue] Initializing platform accessory 'XFDani[6][1]sn:st

    ep'...

    ^[c


    Hatte gestern einen Stromausfall und seit dem Tag bekomme ich es nicht mehr an laufen.


    Ne Idee?


    VG GoodGrooves