Node.js auf Raspi Zero W aktualisieren

  • Hi,

    mein Raspi fährt gerade auf Node.js 11.15, ein Homebridge-Plugin erfordert aber minimum 12.17.

    Leider muss man das Update ja manuell starten. Aktuell ist 14.3 verfügbar (http://nodejs.org/dist/latest/). Eigentlich würde ich armv6l nehmen, aber die gibt es nicht. Welche Version ist denn da die richtige für den Raspi ZW mit ARM 6?


    Danke für die Hilfe.

  • Latest ist nicht die stable bzw. LTS. installier wenn dann die LTS version und wenn dein Zero keine neuere mehr unterstuetzt, dann entweder das update versuchen und hoffen, es ist nur ne Warnung und alles laeuft, oder wenn nicht, wieder die aeltere Version installieren...

  • Welche Version ist denn da die richtige für den Raspi ZW mit ARM 6?

    Such dich tot oder lass das den Rechner machen. Installiere den Node-Paketmanager n mit sudo npm install -g --unsafe-perm n. Danach dann ein herzhaftes sudo n lts. Das installiert dir die letzte Long Time Support-Version für deinen Pi.


    Ein sudo n latest installiert die neueste Node-Version für deinen Pi. Falls es keine mehr gibt für ARM6, dann hilft nur noch https://amzn.to/39Wo7Ld