Beiträge von DUKE

    Danke Stefan für Deine Antwort. Bin ein großes Stück weiter. Konnte jetzt einen USER für die HueBridge durch Tastendruck erzeugen. Leider wird bei jedem Reboot diese Aufforderung den Button zu drücken wiederholt. Also muss man dann wohl jedesmal die „config.json“ in der entsprechenden Zeile aktualisieren?!


    Leider bekomme ich im UI der Homebridge immer nur eine „gestoppte Homebridge" angezeigt?! Wie starte ich die?


    Ach ja, da gibt es noch eine Fehlermeldung in der Log.


    Zitat

    [6/16/2019, 4:50:31 PM] [Config] Failed load accessories from Homebridge: Error: connect ECONNREFUSED 127.0.0.1:51826


    Hier meine config.json, jetzt ist Dein Code-Stippet (natürlich mit meinen Daten) enthalten. Config.json lässt sich auch speichern (grüne Bestätigung).


    Guten Morgen die Herren des gepflegten Configuratons-Wahnsinns. ;)

    Habe nun den ruhigen Sonntagvormittag seit 7 Uhr dazu genutzt für:

    1. Umsetzung der Hilfestellung von den Champs vgnsxe und sschuste. Danke Euch dafür sehr!!!

    2. Account angelegt bei myHue

    2. Dank des Thomas Krampe Blogartikels, die (eine) USER ID meiner Hue Bridge ermittelt.

    3. Wieder intensives Lesen mehrer Threads hier, bei GitHub und sonstwo.

    Mir schwirren wieder die Augen. :-( Und wie vor stecke ich fest, beim Einbinden der OSRAM Smart+ Plugs in HomeKit via Homebridge. Wie erwähnt. In der Hue App (OSX) ist der Osram Plug bereits erfolgreich eingebunden. Somit ergeben sich weitere Fragen.

    1. Benötige ich in Homebridge noch dieses Plugin?

    homebridge-hue-utils


    2. Wird bei Abfrage der Hue-Bridge User ID über den „Clip API Debugger“ und dem Drücken auf den Hue Bridge Button möglicherweise jedesmal eine neue User ID ausgegeben?


    3. Mit dem Befehl ph -H <IP.HueBridge> -u <USER-ID> outlet -V

    Kommt folgende Info raus. ph outlet: /resourcelinks/34879: 1 outlets

    Was stelle ich mit der der Info an?


    4. Die Nr. 34879. Was ist das? Die ID eines HUE-Divice?


    5. Bisher habe ich meine „config.json“ noch nicht für die HUE Bridge erweitert. Muss ich das noch? Deswegen blöd gefragt, weil ja alle HUE-Lampen bei mir in HomeKit auftauchen und natürlich somit bedienbar sind – bis auf die Osram Smart+ Steckdose.


    Auf der einen Seite freue ich mich, dass ich nun wieder etwas lernen kann, z.B. bin ich jetzt beim Bedienen von Terminal mit einigen Linux Befehlen schon DAU-mässig weit gekommen. Obwohl ich Mac User seit über 20 Jahren bin, habe ich aber Terminal nie wirklich benötigt. Somit auch nie verwendet.

    Dann natürlich der Einsatz von unterschiedlichen Hersteller-Hardware, wie meine Fritz-Steckdose, jetzt die HUE-Geräte und die Osram Steckdose ... aber es ist schon verdammt komplex die ganze Materie. Aber mit jedem verheiztem Sonntag wird man auch wieder ein kleines Stück erfahrener ... ganz kleines Stück! ;)


    Danke wie immer! Ihr seit sehr hilfreich. Selten so ein freundliches Forum entdeckt.

    Gruss


    DUKE

    Ich kenne den langen Thread Osram Smart+ Plug an Hue-Bridge. Logisch, bin ja bemüht hier erst nach der Lösung zu suchen ... leider hilft mir die von Dir verlinkte 4. Seite nicht weiter. Entweder ich bin zu doof oder die Angaben sind für solche Anfänger wie mich, einfach zu kryptisch oder beinhalten nicht genug Detailinfos. Ist halt leider sehr komplex für Nicht-Coder, so eine schöne Raspberry Pi Installation, mit Homebridge-Installation, den ganzen PlugIns, den Linux-Befehlen, die HUE Bridge usw. Bin echt motiviert mich einzuarbeiten, auch Dank der zahlreichen Foreninfos soweit alleine zu kommen, wie es geht. Aber manchmal sieht man, auch mangels Erfahrung, den Wald vor lauter Bäumen nicht. Da kommt schnell „weißes Rauschen“ auf, bei mir im Hirnkastl. ;-)


    Du schreibst auf Seite 4 im oben verlinkten Thread:

    Zitat

    Füg also einfach mehre Steckdosen zur Bridge hinzu, Stoppe die Homebridge dann, führe den Befehl aus und anschließend die Homebridge wieder starten. Dann kannst du wieder bei allen neuen Steckdosen den Typ ändern.


    Bei „Stoppe die Homebridge“ hab ich bereits gezuckt. Da musste ich erstmal gucken, wo/wie das geht. Aja, der Befehl im GUI hinter den 3 Punkten = „Runterfahren“. Das wird schon richtig sein. Denke dass meinst Du mit „Stoppe die Homebridge“?

    Nur wie kann ich anschließend Deinen Befehl einfügen, der die Osram-Steckdose als „Pseudo-Lampe“ für Homebridge finden soll? Wohl über Terminal via SSH, nur da geht dann bei mir nix!?


    Terminal melde sich nach dem „stoppen“ von Homebridge und nach der Eingabe des von Dir genannten Befehl mit:

    Zitat

    $ sudo shutdown -h now

    Connection to 192.168.178.nn closed by remote host.

    Connection to 192.168.178.nn closed.

    ph -H 192.168.178.nn -u xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx outlet -v

    -bash: ph: command not found

    Anmerkung: nn – da steht natürlich die notwendige Nr.

    Auf deutsch und kurz. Ich hänge fest. :-(
    Wie kann ich der Homebridge Deinen Befehl aufs Auge pressen, wenn die doch gar nicht läuft?!

    Hier für die Vollständigkeit meine Installation (JUN 19):


    Homebridge

    v0.4.50


    node.js

    v11.2.0


    Configuration UI plugin for Homebridge

    homebridge-config-ui-x v4.5.1


    Homebridge platform plugin for Fritz!Box

    homebridge-fritz v0.8.0


    Homebridge plugin for Philips Hue and deCONZ

    homebridge-hue v0.11.28


    Library for homebridge plug-ins

    homebridge-lib v4.2.8


    npm

    v6.9.0.

    Guten Abend die Herren,


    nachdem Ihr mir vor ein paar Tagen so erfolgreich bei meinem config.json Problem geholfen habt, hoffe ich erneut auf hilfreiche Tipps.


    Habe jetzt meine Smart-Home Installation aufbohren müssen, nachdem ich gedacht habe, meine neues € 15 Osram Smart+ Plug (ZigBee) kommt ohne weitere Hardware aus, damit ich die Steckdose über HomeKit steuern kann. OK, war ein typischer DAU-Wunsch. Habe mir jetzt das HUE Paket mit der Bridge und den drei WLAN Lampen geleistet.

    Die HUE Bridge und die Lampen habe ich recht schnell zum Laufen gebracht. Zuerst über die HUE App, dann aber auch dank Homebridge über HomeKit. Soweit so gut.

    Leider funktioniert der Osram Smart+ Plug aber nur über die HUE iOS App. In HomeKit tauchen nur die drei HUE Lampen auf, von der (vierten) Pseudo-Lampe, also dem Smart+ Plug fehlt jede Spur. Ist doch soweit stand der Software-Technik, dass ich die Osram Steckdose eben nur als „Lampe“ ins HUE-System integrieren kann. Nicht das sich was geändert hat.

    In der config.json habe ich den Osram Smart+ Plug jedoch nicht eingefügt. Ging irgendwie nicht und erscheint mir nicht logisch, weil die Steckdose nunmal beim HUE-System als „Lampe“ geführt wird?! Oder doch nicht, bzw. nur bei HomeKit eben nicht.

    Da steckt das Problem. Wie bringe ich die Steckdose (Pseudo-Lampe) ins HomeKit? Denke von den HomeBridge Plugins bin ich auf dem neusten Stand. Da habe mir Eure Beiträge sehr geholfen.


    Homebridge

    v0.4.50


    Configuration UI plugin for Homebridge

    homebridge-config-ui-x v4.5.1


    Homebridge platform plugin for Fritz!Box

    homebridge-fritz v0.8.0


    Homebridge plugin for Philips Hue and deCONZ

    homebridge-hue v0.11.28


    Library for homebridge plug-ins

    homebridge-lib v4.2.8


    npm

    v6.9.0.


    Wie immer – Danke im voraus.


    Gruss

    Guten Morgen,


    bin leider erst jetzt dazu gekommen, den Tip von schuste umzusetzen. Und das war die finale Lösung. Warum jetzt die config.json nicht dort lag, wo sie sein sollte ... keine Ahnung. Jetzt ist mein Homebridge GUI unter OSX-Safari wieder aufrufbar und ... ich versuch nochmal die ZigBee-Steckdose von Osram zu integrieren. :/

    Auf alle Fälle möchte ich allen danken, die sich meinem DAU Problem angenommen haben. Super Forum-Community hier. Aber das habe ich vor 7 Monaten schon mitbekommen, vor allen Dingen das Engagement und Wissen von schuste hat mir schon sehr geholfen.

    :thumbup::thumbup::thumbup:

    So, jetzt bin ich mit den gefundenen Kommandozeilen-Befehlen etwas tiefer eingedrungen. Sieht so aus, dass ich mittlerweile an drei Stellen eine „config.json“ liegen habe?!


    [email protected]:/# find -name "config.json"

    ./var/homebridge/config.json

    ./home/pi/.homebridge/config.json

    ./usr/local/lib/node_modules/homebridge-fritz/config.json

    [email protected]:/#


    Komme ich dem Problem näher? Einmal „config.json“ sollte doch genügen?!

    Hey vgnsxe,


    der Gedanke ist mir auch gekommen. Aber nachdem meine SSH/Linux/RaspiOS (was auch immer) Befehle-Skills gegen Null gehen, weiß ich aktuell nicht, wie ich nach der „config.json“ suchen kann. Aber ich mach mich jetzt via G schlau und werde berichten.

    Und wenn ich schon dabei bin. Hier die Verzeichnisstruktur:


    drwxr-xr-x 5 pi pi 4096 Jun 10 09:30 .

    drwxr-xr-x 4 root root 4096 Nov 25 2018 ..

    -rw------- 1 pi pi 1610 Jun 10 12:11 .bash_history

    -rw-r--r-- 1 pi pi 220 Nov 13 2018 .bash_logout

    -rw-r--r-- 1 pi pi 3523 Nov 13 2018 .bashrc

    drwx------ 3 pi pi 4096 Jun 9 19:30 .config

    drwxr-xr-x 4 pi pi 4096 Jun 10 10:01 .homebridge

    drwxr-xr-x 6 pi pi 4096 Nov 15 2018 node-v11.2.0-linux-armv7l

    -rw-r--r-- 1 pi pi 17669881 Nov 15 2018 node-v11.2.0-linux-armv7l.tar.gz

    -rw-r--r-- 1 pi pi 675 Nov 13 2018 .profile

    Hier wie gewünscht die Config.json:


    {

    "bridge": {

    "name": "Homebridge",

    "username": "CC:22:3D:E3:CE:30",

    "port": 51826,

    "pin": "031-45-154"

    },

    "description": "Home Smart Home",

    "platforms": [

    {

    "platform": "config",

    "name": "Config",

    "port": 8080,

    "auth": "form",

    "theme": "red",

    "restart": "sudo -n systemctl restart homebridge",

    "temp": "/sys/class/thermal/thermal_zone0/temp",

    "sudo": true,

    "log": {

    "method": "systemd",

    "service": "homebridge"

    }

    },

    {

    "platform": "Fritz!Box",

    "name": "My FritzBox",

    "username": "XXX",

    "password": "XXX",

    "url": "http://fritz.box",

    "interval": 60,

    "hide": [

    "wifi",

    "<ain>"

    ],

    "concurrent": false,

    "wifiName": "Guest WLAN",

    "options": {

    "strictSSL": false

    }

    }

    ],

    "accessories": []

    }

    Danke für Deine schnelle Reaktion: Also ... hatte ja meine gesicherte (Backup) config.json zurückgespielt, weil meine Anpassungen wegen der geplanten ZigBee Erweiterung eben einen Fehler ausgegeben hat.


    D.h. meine gesicherte config.json war so 6 Monate im Einsatz. Habe trotzdem gerade jsonlint.com zur Verifizierung des Codes verwendet und das Ergebnis lautet „Valid Json“?!


    Dank Deines Hinweises sehe ich aber in der Fehlermeldung nun einen Pfad Aufruf, den ich so nicht verstehe. Ich habe drei Ordern auf dem Raspberry. 1. PI 2. Homebridge 3.Config. Was bedeutet nur der Pfad in der Fehlermeldung:

    usr/local/lib/node_modules/homebridge/lib/server.js:218?!

    Aktuell hänge ich total fest. Wie ärgerlich. Der Raspi hat die letzten 6 Monate so schön funktioniert, bis ich dieses ZigBee Plugin installiert habe. Darum auch meine Änderung an der config.json, die ich aber nun wieder rückgängig gemacht habe, durchs zurückspielen des BackUp. :-(


    Nachdem mein Raspberry 3 als Homebridge-Server seit über 6 Monaten sauber und brav lief, habe ich nun eine ZigBee Steckdose in die config.json integrieren wollen. Konkret das entsprechende ZigBee Plugin wie bei GitHub verfügbar. Leider hat das so gar nicht funktioniert. Aktuell kann ich meine Raspberry nur über Shell/SSH erreichen. Habe es nun wieder geschafft, mein config.json Backup zurückzuspielen. Via SSH und dem Editor. Soweit so gut. Leider kommt es nach dem Neustart zu einer Fehlermeldung. Siehe Anhang. Wer kann die Fehlermeldung deuten, dass klar wird was ich falsch gemacht habe?

    Wie immer – vielen Dank für Eure Unterstützung! :thumbup:

    So, jetzt habe ich auf meinem iPhone dank der Homebridge Installation auf meinem nieselnagelneuen Raspi 3+ auch die iOS HomeApp am Laufen. Soweit dort alles klar. Sogar die Meisterklasse erreicht und das Hintergrundbild ausgetauscht ... yeahhhh. :D

    Nun denn, der nächste Schritt war das Einladen eines Mitbewohners. Hat geklappt, nachdem einige Details auf seinem iPhone geklärt werden mussten. Jetzt kann er aber die Fritz!Dect 200 in seiner HomeApp nicht hinzufügen, weil kein HomeKit-Code vorhanden ist. Bei meiner HomeApp ist die Steckdose bereits installiert und flutscht. Was mache ich (wir) falsch? Den Barcode in der Homebridge Webapps will sein iPhone auch nicht akzeptieren, weil es halt schon "vorhanden" ist (genaue Wortlaut fällt mir nicht ein).


    Auf dem Raspi habe ich eines der vier bekannten Fritz!Box PlugIns installiert. Und zwar dieses hier: Homebridge platform plugin for Fritz!Box v0.7.3

    Benötige ich noch eines der anderen drei Plugins und wenn ja, welches?


    – Homebridge-fritz-platform v2.7.1

    – Homebridge platform plugin for Fritz!Box (eve) v0.7.5

    – Hombridge plugin for Fritz!Box v0.1.22


    Hatte eben das gleiche Problem. Lösung war, das in der iCloud der Schlüsselbund aktiv sein muss, also bei einem selbst wohl sowieso, aber dito bei der Person, die man einladen will. Außerdem muss der Kontakt über seine iMessage Adresse ausgewählt werden. Also in der HomeKit App kann man ja eben eine Person aus der Kontakte-Adressliste auswählen. Die meisten Personen dürfte dort keinen farbigen Eintrag in der Auswahladressliste besitzen. Nur die mit farbigen Eintrag (bei mir war der jetzt orange) lassen sich auch erfolgreich einladen. Vielleicht hilft euch ja der Hinweis.

    Hallo Stefan,


    danke das Du Dich dem Problem als Champ annimmst. Das mein Screenshot verloren gegangen ist, ist natürlich nicht hilfreich, wenn man auf eine Antwort wartet. ;) Mein Fehler, hab den angeschobenen Upload nicht auf Ausführung geprüft. Nun denn, wie auch immer. Jetzt wollte ich den Fehler reproduzieren, nur plötzlich ist der berühmte Hund in der Pfanne mal wieder verrückt geworden. Will heißen ... jetzt hat es genau so geflutscht, wie im Teil 3 Deiner Anleitung beschrieben. Frag mich bitte nicht warum. Deine Anleitung ist ja sehr, sehr detailliert und explizit auf Newbies wie mich perfekt ausgerichtet. Teil 1 und 2 haben geflutscht, nur bei Teil 3 ging gestern nichts weiter. Über Nacht den Raspi ins Aus geschickt und jetzt, nach dem Neustart ... ?! Frag mich nicht. Konnte mich abschließend in das Webinterface von Homebridge einloggen. Super! Danke für Deine tolle Anleitung und auch für dieses Forum hier!!!


    Gruss


    DUKE

    Hallo Zusammen,


    bin neu hier. Gestern kam der Raspi 3+, alles easy-peasy zusammengesetzt ... und mich dann gleich auf Eure Anleitung gestürzt. Supercool und verständlich erklärt, so waren Schritt 1 und 2 auch kein Hindernis, außer halt langsam machen und das dauert halt ein wenig, beim erste Mal. ;)


    Leider bin ich dann beim Schritt 3 gleich gescheitert. Weiß nicht warum. Denn es steht ja „Zunächst installierst du das Plugin. Dabei kann erstmal nichts passieren.“ Den Befehl kopiert und eingefügt ... aber da passiert leider so gar nix. Siehe Screenshot. Keine Ahnung was falsch läuft. Habe auch den Raspi neu gestartet. Beim Herunterlaufen der Meldung habe ich sogar war von HOMEKIT gelesen. War wohl die Aktivität von Homebridge. Warum die PlugIn-Installation nicht flutsch ... ???