Beiträge von det
-
-
-
Woran kann es liegen das ist zwei Dienste nicht starten kann?
Ohne Auszug aus der LOG Datei, kann man nur raten.
logwatch.service loaded inactive dead logwatch.service
es sollte nur einen logwach.timer geben ebenso wie fritzbox-reboot.timer
? reporter.service loaded failed failed reporter.service
geht nur mit Auszug aus dem Log

-
WiFi_Check.sh
Hallo,
gelegentlich habe ich das Problem, das der RaspBerry sich nicht automatisch mit dem WLAN wieder verbindet, wenn dieses mal unterbrochen war.
Das Script prüft ob der Gateway erreichbar ist, wenn nicht wird das WLAN interface neu gestartet.
Der Test nach dem Gateway erfolgt aller 5 min, ist aber anpassbar.
Das Script ist in meinem Tool-Pack „hbridge_install.tar.gz“ enthalten.
DownloadLink in:
Homebridge-Tool zum aktualisieren, sichern, neu aufsetzen.....
Nach dem ersten Start:
wird ein Systemlink angelegt, danach ist ein Start durch
Eingabe von:
möglich.
Damit sich der Raspberry automatisch mit dem WLAN, nach dessen Ausfall neu verbindet.
Prüft das Script ob der Gateway erreichbar ist. Wenn dieser nicht nicht erreichbar ist, wird das Interface neu gestartet.
Einstellbar mit Variable: max_Reset=9 # after 9 WLAN-Reset -> Raspberry reboot
Wenn das Interface 9 mal resetet wurde wird der Raspberry neu gestartet.
Dazu muss das Script im cron von user root laufen
(s.u. Instructions).
Das Script ermittelt automatisch:
- das benutzte Interface
- den Gateway
- den Installationsort
Hinnweis!!
Ab v.0.17 sollte das Script auch mit einem LAN Interface funktionieren und es wurden einige Bugs behoben.
Anzeige aller Parameter:
WiFi_Check.sh -?
Wenn die autom. Erkennung fehl schlägt, können diese im Script gesetzt werden.
Das einrichten im cron ist im Script beschrieben.
Code
Alles anzeigen# max_Reset=9 # after 9 WLAN-Reset -> Raspberry reboot # Purpose: # # The script checks, in WiFi the default gateway is reachable # and if not WiFi will be restarted # # Uses a lock file which prevents the script from running more # than one at a time. If lockfile is old, it removes it # # If auto-detection returns incorrect values then manually set # remove the Route (#) and adjust variable, # interface = "wlan0" monitors interface wlan0 # ToolDir = "" folder where this script resides # #Interface="wlan0" #ToolDir="$HOME/hbridge_install/files" #Gateway="192.168.23.1" # # Parameters: # -h/? shows the help and displays the automatically determined variables (exit -1) # -r removes the system link (exit 1) # -kill kill the Process while it is still running (exit 3) # # Instructions: # o Add to crontab from user root # o sudo su # o crontab -e # # Run Every 5 mins - Seems like ever min is over kill unless # this is a very common problem. If once a min change */5 to * # once every 2 mins */5 to */2 ... # # */5 * * * * /usr/local/bin/WiFi_Check.sh 2>&1 | /usr/bin/logger -t WiFi_check #So sieht der Logeintrag aus, wenn alles in Ordnung ist:
WiFi_Check.sh
hier ein Logauszug:
Installation in crontab von User root eintragen:
sudo -i
diese Zeile am Ende einfügen:
*/5... prüft aller 5 Minuten ob eine WLAN Verbindung besteht.
*/2... prüft aller 2 Minuten ob eine WLAN Verbindung besteht.
beenden und speichern, das war es schon.
Jetzt sollte aller 5 min im syslog erscheinen:
Version v.0.17 angehangen

-
Code
Alles anzeigen{ "bridge": { "name": "Homebridge", "username": "CC:22:3D:E3:CE:30", "port": 51826, "pin": "031-45-154" }, "platforms": [{ "platform": "NukiBridge", "name": "Nuki", "api_token": "xxxxxx", "bridge_url": "192.168.xxxx:8080", "webhook_port": "51827", "lock_state_mode": "1", "webhook_server_ip_or_name": "192.168.178.60", "locks": [{ "id": "xxxxxxx", "usesDoorLatch": "true", "name": "Hausstür", "priority": "1" }] }], "accessories": [{ "accessory": "DelaySwitch", "name": "DelaySwitch", "disableSensor": false, "delay": 5000 }] }so sollte die config passen.

-
Wenn ich die timer eingetragen habe, mit welchem Befehl werden die in Service übertragen?
welche Timer, von was/wem redest Du?
Sorry kann gerade nicht folgen.

-
-
-
HINWEIS: Sep 01 20:28:10 raspberrypi systemd-hostnamed[2051]: Warning: nss-myhostname is not installed. Changing the local hostname might make it unresolveable. Please install nss-myhostname!
diese Meldung sollte mit:
verschwinden.
HINWEIS: Sep 01 20:28:46 raspberrypi org.gtk.Private.UDisks2VolumeMonitor[2683]: index_parse.c:190: indx_parse(): error opening /media/pi/BACKUPPI/BDMV/index.bdmv
Zitat:
Code
Alles anzeigenRe: Fehler beim Öffnen von BDMV? Zitat Mo 31.07.2017 12:12 Uhr Hallo alle zusammen. Ich lese hier https://bbs.archlinux.org/viewtopic.php?pid=1383084 dass das Problem mit gvfs zu tun hat. Ich habe verstanden, dass das gvfs-Paket ohne Bluray-Unterstützung gebaut werden sollte, um den Fehler loszuwerden Einfaches Erzwingen des Entfernens von libbluray kann dazu führen, dass ein anderes Paket beschädigt oder instabil wird. Weiß jemand, ob bereits ein Fehler vorliegt oder ob es Neuigkeiten gibt?evtl- dem Link mal folgen
HINWEIS: Sep 01 20:29:05 raspberrypi kernel: random: 7 urandom warning(s) missed due to ratelimiting
hie muss nach den eigentlichen Fehlermeldungen gesucht werden.

-
Meiner ist nun unterwegs, per UPS.
-
wenn Du einfach den Ordner /var/homebridge anlegst, sollte es funktionieren.
Wenn dieser Ordner existiert, wird alles was mit homebridge* anfängt gesichert.

-
-
das sollte genau Dein Modell sein.
Habe den Verkäufer vorher gefragt ob es das Modell von Dir ist ( finde im Portal gerade den Kontakt und die Antwort nicht)
gerade gefunden:
Na schaun wir mal.
Bin bloß gespannt wo UPS das Paket abgibt wenn ich nicht da bin.
Naja werde ich ja sehen.

-
Das da der Akku stand nich im HomeKit angezeigt wird, ist auch doof.

So ist Bestellt, auch per UPS.
Bin mal gespannt.

-
mit UPS aus den Niederlanden geliefert
Ich vermute dadurch am Zoll vorbei.
-
Hallo Leute,
weis jemand von euch ob dieser
mit dem HK-Plugin funktioniert?
würde mir den gerne bestellen (für die näh. Hitzewelle)
Danke schonmal.

-
Ich habe gerade noch mal mit einer Backup cfg Datei getestet.
Da ist ein Bug drinn Sorry, fals diese Meldung kommt:
dann ist der schnelle Fix, die Zeile 1399 in hbridge_new.sh auskommentieren (werde es in der nä. Version korrigieren)
danach sollte es so durchlaufen:
//Edit
Erxitcode 2 bedeutet: "tar" hat Datei oder Ordner nicht gefunden

-
Ja habe 2 Instanzen und den reporter
Siehe dir meinen PrintScreen (#213) an.
Ich benutze keine Backupdatei, das ist die Standart Sicherung, wenn er einen Homebridge Daten Ordner findet
(einlesen kann).
Wenn das geht, kann man weiter machen.
Komme irgendwie nicht weiter
Das ist schlecht, aber wo?

-
-
Geprüft wird auf
/var/homebridge
Damit wird zb homebridge und homebridge-Fritz gesichert
Wie sind die Rechte auf /var/homebridge ?