Fake-Switch in Eve-Regeln

  • Hallo zusammen,

    ich bräuchte mal Eure Hilfe denn irgendwie will ich es grad nicht kapieren…

    Also folgendes Setup:

    Raspberry Pi 3B+

    deConz-RaspBe

    Philips Hue-Lampen

    Apple TV 4k als Steuerungszentrale

    Alle OS auf aktuellem Stand

    Ein Hue-Bewegungsmelder im Außenebreich sorgt dafür das die Hue-Lampen im Hof bei Bewegungserkennung geschaltet werden sollen. Das alles soll natürlich nur in der Dunkelheit ausgeführt werden. Soweit läuft das auch sauber durch.


    Ich würde jetzt gerne dieser Automation hinzufügen dass zw. 21-04 Uhr keine Lichtschaltung getätigt werden soll. Realisieren wollte ich das über einen Fake-Switch der Abends um 21 Uhr angeschaltet und um 4 Uhr morgen ausgeschaltet wird.


    In der Eve-App (aktuelle Version – konnte die vorherige leider nicht testen) habe ich unter Bedingungen diesen Schalter hinzugefügt, sprich, Wenn Bewegung -> Nach + Vor Sonnenauf/untergang und Fake-Switch = Aus dann schalte Licht Hof.

    Problem: Fake-Switch aus –> es ist dunkel = keine Lichtschaltung!

    Mach ich da einen Denkfehler? Muss die Regel anders aussehen? Liegt es an einem Fehler in der Eve-App? Denn sobald ich diesen Fake-Switch aus den Bedingungen nehme läuft alles wieder sauber durch.


    Habt ihr eine Idee dazu wie ich die Lichtschaltung effektiv zu bestimmten Zeit ‚abschalten‘ kann

  • Moin redbull2906


    Deine Automation ist prinzipiell goldrichtig angelegt. Nach diesem Prinzip reguliere ich meine gesamte Behausung.


    Fehlermöglichkeiten gibt es Mehrere. Angefangen beim Fake-Switch per Homebridge-Plugin. Am besten testest du diesen mal in einer einfachen Testautomation mit einem Schalter und einer Lichtquelle (damit du nicht immer bis zum Sonnenuntergang warten musst). Fehler in der Eve-App ist nicht ganz auszuschließen, aber eher unwahrscheinlich. Du könntest einmal in der Home App nachsehen, ob die Bedingung dort aufgelistet wird und, falls du eine alternative HomeKit App hast (bspw. Controller App), alternativ mit dieser die Automation neu anlegen. HomeKit selbst birgt mitunter diverse Tücken, insbesondere bei neu angelegten Automationen, die eine gewisse Zeit brauchen können, bis sie im System verankert sind. Hier hilft zumeist ein einfacher Neustart der Steuerzentrale/n, nachdem man eine oder mehrere Automationen angelegt hat.

  • Gerne :)


    Na, dann scheidet der Switch doch schonmal als Fehlerquelle aus.


    Was die "Übermittlung" an HomeKit betrifft, so kann es passieren, dass Automationen erst verzögert im System ausgeführt werden. Das KANN wohlgemerkt passieren, muss aber nicht. Dank der undurchsichtigen iCloud-Synchronisation seitens Apple ist hierzu auch leider keine verlässliche Aussage über das Warum, Wieso, Weshalb zu machen. In meinen Automationserarbeitungen hat sich bei Nicht-Funktion zu 90% der Steuerzentralen-Neustart bewährt. Vermutlich wird dadurch nochmal explizit abgefragt, was es alles so Neues in HomeKit gibt ;)


    Wenn also deine Testautomation schonmal funktioniert hat, würde ich persönlich nun als Nächstes einen Test mit Bewegunsgmelder statt Schalter machen. Dies ebenfalls in einfacher Form, also ohne zeitabhängige Bedingungen.

  • Auf ein Eve-Update zur Behebung des Problems würde ich nicht hoffen. Wenn dein besagter Test mit dem Fake-Switch positiv verlaufen ist, liegt das Problem sehr wahrscheinlich weder an Eve noch am Homebridge-Plugin. Hast du keine andere HomeKit-App, mit der du die Automation alternativ erstellen könntest?


    Werden die Außenleuchten noch anderweitig über weitere Automationen geschaltet?


    Um das Problem besser nachvollziehen zu können, müsstest du ein wenig mehr Details preisgeben. Screenshots könnten helfen.