Beiträge von Kohle_81

    ...absolut keine dumme Idee! Das heißt, du verwendest die Temperatur an einer anderen Stelle um daraus abzuleiten, wie heftig die Sonne in dein Wohnzimmer scheint, korrekt?

    Ja genau, bzw. ist meine Logik die, wenn um 12.30 die Temperatur nicht schon über Wert x ist, dann ist es nicht notwendig für den Nachmittag, zu beschatten.


    Nur über die Wetter-Apps ist zu ungenau und nur über Helligkeit ist dann relativ oft abzufragen, ob sich was verändert hat, was bei bewölktem Himmel doch oft vorkommen kann.


    Mir ist die Variante der Temperatur am angenehmsten, da die Automation ganzjährig funktioniert. Auch im Winter bei der größten Helligkeit muss nicht beschattet werden, da Außentemperatur kalt 🥶 😜

    Ich löse meine Beschattungs-automation mittels Temperatur zu einer bestimmten Uhrzeit.


    Ich habe mir z.B. auf der Terrasse nen Philips Outdoor Sensor, der um 12.30 Uhr noch keine direkte Sonneneinstrahlung abbekommt. Wenn um 12.30 Uhr dann die Temperatur den Wert X überschreitet, dann werden die Rolläden runtergefahren. Die Automation wird um 14.30 Uhr nochmals ausgeführt.


    Mit dieser Einstellung fahre ich jetzt schon 2 Sommer gut damit. Ich habe sie auch nie deaktiviert, da im Herbst/Winter die Grenze nie überschritten wird.

    Ich bin jetzt aufgrund wochenlanger Abstürze immer noch skeptisch, ob die Ursache nun behoben ist. Seit heute Nachmittag bei anfänglich freiem Arbeitsspeicher mit 3,24 GB sind jetzt 5 Stunden später nur noch 3 GB frei....


    Wenn dies so weiter ginge ist ein Absturz ja auch wieder vorprogrammiert....


    Oder wie verhält sich euer RasPi bzgl. des Arbeitsspeichers?

    Nastra


    Vielen Dank für den Tipp!!!


    Karte in RasPi 4 eingelegt und läuft erst mal alles einwandfrei 👍👍



    Ich hatte irgendwie ein Brett vor dem Kopf bzw. dachte ich, ich müsste es wie beim letzten Mal machen wie beim homebridge umziehen. Aber da bin ich natürlich von Debian auf Buster umgezogen, deshalb war ein Neuaufsetzen notwendig 😄😄

    Vielen Dank sschuste für die Bestätigung und deine ausführliche und nachvollziehbare Diagnose.


    Ich denke, ich werde - wenn ich nun schon auf den neuen RasPi 4 umziehen werde - mir gleich die neue Logik der homebridge installieren und dann mit den child bridges arbeiten.


    Es ist dann einfach „zukunftssicherer“, als wenn ich jetzt nur jede einzelne Instanz 1:1 umziehen würde......


    sschuste


    Wenn mir hierzu noch eine Frage vergönnt sei:


    Um wenig Automationen in Homekit zu verlieren würde ich im ersten Schritt alle Instanzen stoppen und dann wie in dieser Anleitung beschrieben die Ordnerstruktur sichern und mit der Einrichtung der neuen homebridge beginnen.


    Nachdem ich die child bridges drin hab, müsste ich noch schauen, wo hier genau einzelne Dateien wie config und Co. gespeichert wurden und im besten Fall kopiere ich die gespeicherten Daten an die neue Stelle. Zumindest mit der config.json dürfte dies machbar sein.


    Dann neu starten und schauen was passiert und dann erst die alten homebridge-Instanzen aus Homekit löschen. Oder übersehe ich etwas?


    Edit:


    Denkfehler, das Ziel sollte ja sein, homebridge und neue child bridges so zu konfigurieren, dass Homekit die Änderung gar nicht mitbekommt.


    Bedeutet, ich sollte die Instanzen über hb-service mit der gleichen Bezeichnung und Ports anlegen.....


    Wobei ich mir jetzt gerade während des Schreibens nicht viel Hoffnung mache, dass dies so funktionieren wird 😂😂


    Im schlimmsten Fall muss ich halt die eine oder andere Automation wieder ergänzen oder neu einrichten 🙈

    RAM weder gekauft noch sonst was dran rum gemacht 😜


    Es löuft nur homebridge auf dem RasPi, allerdings inzwischen mit 12 Instanzen......


    Probleme tauchten auf, seit dem homebridge Update auf 1.3x


    Hier mal die Ausgabe von ps aux:


    Nachdem ich den RasPi direkt per LAN am Router hängen hatte, tauchte das Problem erneut nach ca. 5 Tagen auf.


    Betreibe nun den RasPi seit 6 Tagen am WLAN, bisher keinen Ausfall.


    Was mir jedoch Sorge bereitet, ist der täglich abnehmende „freie Arbeitsspeicher“. Beginnend mit anfänglich 0,30 bis 0,35 GB freiem Arbeitsspeicher nach dem reboot laut Anzeige mit config-ui, so wird jetzt nach 6 Tagen noch 0,05 GB freier Arbeitsspeicher angezeigt.


    Habe nun die Befürchtung, dass mein RasPi morgen irgendwann wieder „hängen“ bleibt.


    Habe inzwischen auch gegoogelt, könnte es mit dem Swap Speicher zusammenhängen?


    Code
    free -h
    total used free shared buff/cache available
    Mem: 926Mi 827Mi 31Mi 16Mi 66Mi 35Mi
    Swap: 99Mi 99Mi 0B
    [email protected]:~ $

    Ich danke euch allen zunächst für die breite Meinungsbildung.


    Gerade auch „kritische“ Anmerkungen oder das generelle Hinterfragen gefällt mir sehr gut.


    Je mehr ich drüber nachdenke und abwäge, es mal umzusetzen, komme ich zum Entschluss, mir zuvor ein neues Auto mit integriertem Carplay zu kaufen 😂😂😂


    Bzw. ansonsten tatsächlich wie von Marco Schmidt vorgeschlagen, das iPhone als Display zu verwenden und dann mal schauen, was mit Klinken-/Bluetoothadapter evtl. noch dazu möglich ist......

    Ich habe gerade gesehen, dass es zu der Parallelnutzung bereits diesen thread gibt, ich habe bereits im Plugin-Thread etwas dazu geschrieben, wobei es hier besser passt.


    In der verlinkten Anleitung wird geschrieben, dass es nach dem Auslesen des tokens möglich sei, anschließend die Roborock App nutzen zu können 🤷🏻🤷🏻🤷🏻



    https://www.simon42.com/roborock-homekit-token-einfach/



    __________________________________


    Rückmeldung vom Entwickler, geht leider doch nicht:


    @Kohle81 Sorry for any confusion this might have caused, unfortunately this is impossible.

    → Once registered in another App where an additional pairing is needed, the token will get invalid and a new one will be created.

    I re-wrote the part in the guide and wanted to thank you for the heads-up and your question!“

    Dann hast du den Sinn hinter CarPlay nicht verstanden ;)


    CarPlay erlaubt es verschiedene Apps vom iPhone auf dem Autoradio zu nutzen, z.B. Google Maps statt dem eingebauten Navi etc.

    Wobei der Einwurf von Marco Schmidt hinsichtlich des DIY Projekts ja nicht den Sinn von CarPlay in Frage stellt, sondern den Umweg mit TouchScreen...


    Oder würdest du Patrick_ die Umsetzung empfehlen statt das iPhone als quasi Display zu nutzen, wenn im PKW überhaupt kein Screen und kein bluetooth besteht?


    Bin da völlig offen und entspannt für ehrliche Anregungen?

    Ich verstehe den Sinn dahinter nicht. Dann soll er das Handy doch gleich per Bluetooth mit dem Radio koppeln.

    Eigentlich auch keine blöde Idee 💡🤪🤪


    Ich hab mich noch überhaupt nicht mit CarPlay beschäftigt.....


    Ist CarPlay dann nicht mehr, als die Grundfunktionen des iOS auf den Bildschirm im PKW anzuzeigen??

    Hallo zusammen,


    ich ben gerade auf dieses Projekt gestoßen. Mein aktuelles Gefährt ist leider noch nicht mit CarPlay ausgestattet und ich überlege mir, ob dieses Projekt tatsächlich so umsetzbar wäre, mittels dem Touch Screen und dem RasPi CarPlay zu erhalten.....


    Bis auf den Touch und den USB Dongle hätt ich sonst eigentlich alles schon daheim liegen.....


    Hört sich zu schön an, wie seht ihr es? Realistisch, dass es gut und zufriedenstellend läuft?


    Der RasPi muss bei jedem Autostart ja neu booten, oder? Muss ich dann während der Fahrt noch koppeln oder kann man nach kurzer boot Zeit dann per Siri besuftragen?


    Hier mal der Link zum Projekt:


    Hallo zusammen,


    ich nutze seit der ersten Stunde die Koogeek Mehrfachsteckdosen und per Homekit laufen diese wunderbar.


    Der Alexa Skill hat bis Anfang 2021 immer Probleme gemacht, inden letzten Monaten lief der Skill jedoch ebenfalls einwandfrei.


    Ich hatte den Skill mal kurzzeitig abgemeldet und nun finde ich diesen in der Skill-Übersicht gar nicht mehr.


    Kann dies auch noch jemand bei sich feststellen?