Beiträge von Sheldon

    Warum sollten Geräte die nur 2,4 GHz unterstützen ein Problem mit dem 5 GHz Netz haben, diese sehen das Netz theoretisch ja nicht.

    Hatte ich schon. Ich hab ein Mesh, das auf beiden Frequenzen läuft und dann entscheidet, welches Gerät was bekommt. Mein iRobot Staubsauger wollte sich damit nicht verbinden. Ich musste das 5 GHz temporär abschalten, um den iRobot einmal anzumelden. Jetzt stört ihn das nicht mehr.

    Wie gehe ich denn genau vor, wenn ich die index.js mit deinem code ändern will?

    Also erstmal die Datei lokalisieren. Die liegt bei mir unter:

    /usr/lib/node_modules/homebridge-zway/index.js


    Dann solltest Du Dir unbedingt eine Sicherungskopie machen. Wenn Du beim Editieren was falsch machst, wir die Homebridge nicht mehr starten...

    sudo cp /usr/lib/node_modules/homebridge-zway/index.js /home/index.js

    Kopiert die Datei nach /home/ (check zur Sicherheit, ob sie auch da ist)


    Dann erstmal die Homebridge stoppen:

    sudo systemctl stop homebridge


    Dann den Editor starten:

    sudo nano /usr/lib/node_modules/homebridge-zway/index.js


    Dann suchst Du (sollte Zeile 1186 sein) den Beginn der TargetPosition Abfrage:

    if(cx instanceof Characteristic.TargetPosition)...


    Dann den kompletten Block löschen (endet in Zeile 1266 mit "return cx;") incl. des letzen } (danach kommt "if(cx instanceof Characteristic.HoldPosition)"). An der Stelle fügst Du dann meinen Codeblock ein und speicherst.


    Dann die Homebridge wieder starten:

    sudo systemctl start homebridge


    Sollte die Homebridge nicht mehr laufen, die index.js wieder zurück kopieren und nochmal versuchen.

    Also was die 0% betrifft, keine Ahnung, hab ich noch nie gehabt. Mit der Steuerung von außerhalb HomeKit kann ich Dir vielleicht helfen. Ich hab das Homebridge-Zway Plugin leicht modifiziert. Grob gesagt ist das Problem folgendes:

    Es gibt 2 maßgebliche Werte, CurrentPosition und TargetPosition, also aktuelle und Zielposition. Wenn die beiden sich unterscheiden, zeigt HomeKit den Kreis. Wenn Du außerhalb von HomeKit steuerst ist das Problem, dass "TargetPosition" nicht geupdatet wird. Hier im letzten Beitrag wurde ein Workaround dafür beschrieben, der so aussieht, dass einfach TargetPosition=CurrentPosition gesetzt wird. Der funktioniert aber seit IOS 12.2 nicht mehr.


    Ich hab das so gelöst, dass ich eine Variable eingebaut habe, die speichert, ob das Gerät über HomeKit geschaltet wurde. Wenn ja, gibt die Funktion den von HomeKit gesetzten Wert zurück, ansonsten die CurrentPosition.

    Ich kann zwar grundsätzlich programmieren, hab aber von Javascript keinen Plan :). Läuft aber bei mir. Mach Dir aber vorher auf jeden Fall eine Kopie der index.js vom Homebridge-Zway Plugin. Dann kannst Du mal probieren die Abfrage "if(cx instanceof Characteristic.TargetPosition)" (ab Zeile 1186) durch folgenden Code zu ersetzen:

    Zitat

    Ich finde sowohl für Zigbee als auch für Z-Wave beide Lösungen - da der PI aber nur eine GPIO-SSt hat, muss ich mich ja entscheiden - gerade wenn es Performance-Unterschiede zwischen GPIO und USB bei den Modulen gibt.

    Ob es da Unterschiede gibt kann ich Dir nicht beantworten, da ich nur Erfahrungen mit dem Razberry GPIO Modul habe. Im worst case könntest Du natürlich auch 2 Pis betreiben, für jeden Funkstandard einen.


    Zitat

    Das nächste was mich interessieren würde, ist das Thema mit dem „anlernen von Tasterfunktionen“ - also z.B. von meinem o.a. Wandtaster (Bitron / 4-fach)

    Geht sowas dann immer über die „Serverdienste“ (z.b z-Wave-Server)?

    Genau, das geht über den entsprechenden Server. Auch da gibt's verschiedene Optionen. Ich nutze z-way, da ist die Software direkt von der z-wave alliance, das geht aber soweit ich weiß auch direkt mit anderen SmartHome Lösungen, wie Openhab oder Home Assistant.

    Irgendwelche Paramter konfigurieren geht mit HomeKit sowieso nicht. Ich habe ein Fibaro Relais, das nativ unterstützt, das musste ich über eine separate Fibaro App konfigurieren.


    Zitat


    Wie ist das mit der remote-Steuerung? muss mein RasPi dann via dyndns im Internet sein oder geht alles dann über einen meiner AppleTVs als Remote-Hub? Das ist nicht so ganz klar geworden - oder ich habs überlesen :)

    Das geht über das Apple TV, der RasPi muss über Internet nicht erreichbar sein.


    Zitat

    Ach - und ich habe das doch korrekt verstanden, dass sowohl Zigbee als auch Z-Wave Geräte sich zu einem Mesh-Netzwerk verbinden und somit das Reichweiten-Thema beseitigen, oder?


    Korrekt. Die Geräte müssen halt nur so verteilt sein, dass das Mesh ausreichend dicht ist.

    Läuft bei mir stabil. Am Anfang hat sich der Pi ab und zu mal aufgehängt. Keine Ahnung wieso. Ich lasse ihn jetzt einfach einmal nachts durchstarten. Seitdem keine Probleme mehr. Zur Sicherheit wollte ich mir aber auch nochmal einen HomeKit Stecker kaufen, dann könnte ich ihn im Fall der Fälle auch Remote stromlos machen und neu booten.


    Die angebundenen Devices (Rolladen und Lichtschalter, bisher 1 Sensor, alles Z-Wave) laufen alle stabil, lassen sich aber ja alle auch noch mit den normalen Schaltern schalten, sodass die Funktion selbst wenn der Pi mal abrauchen sollte noch gegeben ist.


    Meine Frau nutzt ausschließlich HomeKit und hat mit dem Pi nichts zu tun.

    Ich wollte ursprünglich auch ein "Plug & Play" System und bin dann letztendlich doch beim Raspberry mit Homebridge gelandet, da es einfach die größte Flexibilität bietet und wenn mal z.B. in der Community von hom.ee etwas mitliest, dann ist das m.E. von Vorteil, wenn man die Möglichkeit hat Probleme selber zu beheben und nicht auf einen Hersteller angewiesen ist.


    Ich bin zwar IT-ler, hatte aber bisher auch keine Linux Kenntnisse. Mit der Anleitung hier aus dem Forum war die Homebridge aber schnell aufgesetzt und auch die Einrichtung von Z-Wave auf dem Raspberry ging problemlos. Das Finetuning hat noch etwas länger gedauert, aber ich musste weitaus wendiger Zeit aufbringen als befürchtet.


    Daher solltest Du darüber doch einmal nachdenken. Für Z-Wave gibt es diverse Aktoren und Sensoren und durch das Mesh System solltest Du damit auch die ganze Wohnung abdecken können. Eine andere Möglichkeit wären die Shelly Relais, die mit WLAN funken und außerdem sehr preiswert sind. Über Homebridge kriegst Du die ebenfalls in Homekit integriert.

    Hmm, also vorab, ich bin weder Elektriker, noch kenne ich das Relais. Daher alles ohne Gewähr.


    Wenn ich mir das von Dir oben verlinkte Relais angucke, dann müsstest Du 1 und 2 an Klemme 5 und 6 anschließen und den Schalter für das Relais an A1 und A2...

    Ja, korrekt. Die Qubinos laufen über das Razberry Modul mit z-wave-me und sind über Homebridge in Homekit eingebunden. Mit den entsprechenden Einstellungen (also "Plain Association" und den o.a. Parameter werden) läuft das alles problemlos und Schalten geht sowohl per Homekit, als auch am physischen Schalter.

    Der rotierende Kreis in Homekit kommt nur wenn der Soll-Zustand in Homekit nicht mit dem Ist-Zustand in z-wave-me übereinstimmt. Das passiert sehr selten einmal, wenn aus irgendeinem Grund mal der Status im z-wave-me nicht upgedatet wird.

    Was ich mich aber Frage ist, da der Anschluss für die Lichtschranke nur 24V ausgibt, könnte ich den Switch und das Relaise welche für 110-230/240V gedacht ist wohl gar nicht mit Strom versorgen oder?

    Korrekt. Die 240V müsstest Du Dir dann von woanders holen. Direkt an der Platine der Torsteuerung anschließen geht dann nicht. Frage ist auch, ob die Bluetooth Reichweite von Deiner Homekit Zentrale bis zur Garage reicht?


    Hast Du mal einen Tipp wie das genau geht? Ich steige da nicht durch...

    Du hast den Shutter doch kalibriert. Dazu musstest du doch auch den Parameter 78 auf 1 setzen. Genau so setzt du auch die anderen Parameter.


    Geh in der z-wave-me Oberfläche auf Geräte -> Verwalten. Da bei dem entsprechenden Gerät auf Konfiguration -> Hardwarekonfiguration. Dort kannst Du dann über den Set Button die entsprechenden Parameter setzen:



    Die Größe (hier ein 1 byte) so wählen, wir im Handbuch vom Shutter angegeben.

    Meine Rolladen schalten auch selbständig ab, trotzdem waren die o.a. wichtig für eine korrekte Funktion.


    Ich hab bisher nur die automatische Kalibrierung gemacht. Manuell geht auch über entsprechende Parameter, am besten auf der Qubino Webseite das entsprechende Handbuch runterladen. Die mitgelieferte Anleitung ist eher knapp gehalten.

    Ja, sowohl hoch runter, als auch genaue Positionierung über % Werte geht und genau, du brauchst den https://amzn.to/2VqQhmZ.


    Die Rückmeldung funktioniert in geschätzt 95% der Fälle korrekt. Ab und bleibt der Status auch hängen. Das liegt aber m.E. an Z-way wo die Rückmeldung scheinbar nicht richtig ankommt. Wenn ich in Z-Way manuell auf "aktualisieren" klicke hat er sofort den richtigen Status.


    Noch ein Tipp, falls die Steuerung nicht auf Anhieb funktioniert: Ich musste bei mir den Parameter 76 (Motor Betriebsmodus Erkennung) auf 50 setzen und den 85 (Leistungsaufnahme maximale Verzögerungszeit) auf 30. Den Tipp hab ich ein einem anderen Forum gefunden. Damit laufen meine 14 Rolladen alle problemlos. Kann natürlich bei anderen Rolladenmotoren anders sein, aber damit würde ich erst einmal starten.

    Der Roller Shutter 3 hat ein Problem mit der Firmware. Ich hab ihn bei mir (auch Z-Way) nicht vernünftig zum Laufen gekriegt. Das war im Januar, inzwischen gab es wohl schon Updates der Firmware, aber ich weiß nicht, ob wirklich alle Probleme behoben wurden. Leider kannst du die Firmware selber auch nur updaten wenn Du ein Fibaro Home Center hast.

    Wenn du keine Lösung findest, schick ihn zurück solange du noch kannst und tausche ihn gegen einen Qubino Roller Shutter. Die laufen bei mir problemlos und zuverlässig (nur die richtigen Einstellungen für die Parameter zu finden war etwas tricky).

    Hi Wildwolve,


    du benötigst für das Z-Wave Modul noch eine Controller Software, z.B. Zway. Darüber bindest du dann auch die Z-wave Geräte ein. Für die Homebridge gibt es dann ein entsprechendes Plugin.


    Falls du die Fibaro Shutter noch nicht gekauft hast, würde ich dir eher zu den Qubino Shuttern raten. Die Roller Shutter 3 machen diverse Probleme (einfach mal googeln). Mit der ersten Firmware waren die überhaupt nicht nutzbar. Ich hatte zunächst selber einen, den ich wieder zurück schicken musste. Ich weiß nicht, ob inzwischen alle Probleme behoben wurden. Abgesehen davon sind die Qubinos m.E. qualitativ hochwertiger.

    Ich denke auch es macht SInn Homekit nicht zu überfrachten, damit es auch für Nicht-Nerds einfach bedienbar bleibt. Trotzdem kann es nicht der Weisheit letzter Schluss sein, dass ich mir z.B. für meinen Fibaro SIngle Switch in der HK Version extra die Fibaro App installieren muss, um dem Switch mitzuteilen, dass er an einem Schalter und nicht an einem Taster hängt.