Beiträge von iPhoneast

    Dir fehlt die Angabe, was Homebridge als Standbild an HomeKit weiterpetzen soll.


    Der Eintrag sollte in etwa so aussehen.


    "stillImageSource": "-i http://xxx@[email protected]:80/snap.jpg",


    Ich habe gerade im Internet gefunden. Du solltest es mit diesem Pfad probieren.


    "stillImageSource": "-i http://yyyyyy/snapshot.cgi?user=XXXX&pwd=X",


    Ist zwar für eine andere Cam von Aldi, aber vom selben Hersteller und die Wahrscheinlichkeit ist vorhanden, dass es funktioniert.


    Ich habe heute wieder zwei ffmpeg-Prozesse.

    Da steht auch irgendwas von 1077 Fehler





    Die Aktivitätsanzeige des Macs erlaubt mir eine Analyse, die vielleicht hilft? Die ganze Analyse ist leider zu lang für hier. Ich habe das Kapitel "binary images" weggelassen.


    Sag einfach, was du brauchst.


    SeydX: Heute Nacht unter 5.0.7 haben sich ganz viele ffmpeg-Prozesse nicht geschlossen. Der Mac mini war echt am Schwitzen. Ein Homebridge Stop hat die Prozesse nicht geschlossen, aber die Last zurückgenommen. Ich habe dann den Mac mini neu gebootet.


    Ich habe gerade 5.0.8 installiert. Außerdem habe ich den ftp-Server ausgeschaltet, weil ich ja zuvor gelernt habe, dass die Videoanalyse auch Bewegungen erkennt (das war klar) und HSV bzw. CameraUI-Aufzeichnungen triggert (das war mir nicht klar).


    Edit: Ohne ftp-trigger werden bei mir Bewegungen nicht erkannt. Ist mir aber auch egal. Habs wieder eingeschaltet, weil es eigentlich sehr gut lief.

    neomorph. M.E. fehlt ein Eintrag


    motion: true,


    und die Art, wie deine Kamera die erfasste Bewegung an Camera UI bzw. an HomeKit meldet.


    Das kann er mqtt, http, smtp, ftp erfolgen. Da muss ein Eintrag sein.


    Aber ich bin nicht der Oberspezialist.


    Schau mal in deinen Kameras nach, was die so liefern können, wenn sie eine Bewegung erfassen: mqtt, http, smtp oder ftp. Bei mir hat es mit ftp geklappt. Und dann musst du der Kamera sagen, dass sie bei Bewegungserkennung an die Homebridge meldet.



    Auf dem iPhone ins Kontrollzentrum wechseln (iPhones mit FaceID von oben wischen, iPhones mit TouchID von unten wischen), dann oben rechts in das Feld klicken, das deine Wiedergabe darstellt, dort auf das Airplay-Symbol klicken, dann beide HomePods mini auswählen, wobei sich das iPhone bzw. die AirPods von alleine abwählen sollten.

    Ich habe gerade die v1.3.0 veröffentlicht, bei dem die Chip ID als Seriennummer verwendet wird. Ansonsten gab es nur kleinere (hauptsächlich interne) Änderungen, siehe Changelog.

    Wunderbar. Controller for HomeKit ist jetzt auch zufrieden und meckert nicht mehr wegen zwei gleichen Seriennummern. Vielen Dank.


    Ich werde mir mal die Ideen von Seite 10/11 durchlesen und dann eine geeignete Variante testweise umsetzen.

    Anregung für einen Schalter, Sensor oder sonst irgendwas für das Auslösen einer HomeKit-Automation.


    Bei mir ist die Klingel direkt an der Fritzbox angeschlossen und dort als Klingel registriert. Wenn man den internen Anruf der Klingel als Schalter, Sensor oder sonst irgendwie in Homebridge/HomeKit darstellen könnte, wäre das prima. Dann kann man im Fall der Abwesenheit über die HomePods Hundegebell abspielen und/oder bei Nacht das Licht im Gang einschalten, wenn jemand klingelt. Da bieten sich viele Möglichkeiten. Wer will, kann dann auch im Wohnzimmer den Staubsauger starten oder alle Lichter im ganzen Haus ausschalten und per HomePod rausbrüllen, dass man nix kauft.


    Ein Umweg über eine externe Rufnummer als Ziel der Klingel hat bei mir nie so richtig geklappt.

    Ich stelle mir gerade folgende Frage: Wenn ich eine Aufzeichnung aufgerufen habe (und das geht jetzt wirklich sehr schnell), die Aufzeichnung abgelaufen ist und ich die nächste Aufzeichnung in der Zukunft sehen will, klicke ich in deinem Interface intuitiv auf den Pfeil rechts, weil auf einem Zeitstrahl die Zukunft auch rechts ist. Du benutzt aber die japanische Art und Weise, dass die Zukunft links ist. Oder bin ich falsch gewickelt? Links ist trotzdem für mich zurück, auch in zeitlicher Hinsicht.


    Das steht nicht im Widerspruch dazu, dass bei umgekehrter Sortierung deiner Aufnahmen in der Übersicht die Zukunft links liegt. Das liegt an der Sortierung, die anhand der Vorschauen sofort als "Neueste zuerst" zu erkennen ist. Wenn ich aber blind vor einem Bildschirm sitze, ist für mich die Zukunft rechts, die Vergangenheit links. Das ist nur meine Meinung und keine Kritik. Ist mir auch nicht so wichtig, ich weiß ja jetzt, wohin ich klicken muss.


    Und noch ein kleiner Vorschlag: Wenn man ganz ganz ganz viele Aufzeichnungen hat und nach ganz unten scrollen will, dauert das eine Ewigkeit, weil ich immer warten muss, bis die Vorschauen einer Bildschirmseite geladen sind, bevor ich weitersollen kann. Ein Direktsprung an die unterste Zeile mit der ersten Aufzeichnung oder ähnlich würde dem ansonsten wirklich tollen Camera UI gut tun.


    Übrigens: Sehr süß ist die Analoguhr, die man bei Aufruf des Camera UI auf dem iPhone in den Widgets sieht, wenn man das iPhone ins Querformat dreht.

    Kurzer Zwischenbericht:


    Homebridge 1.4.0.beta.4 in Verbindung mit Camera UI 5.0.4 läuft und läuft und läuft. Alles fehlerfrei und stabil. Echt alltagstauglich. Und ein echter Wumms an Features. Echte klasse Leistung!!


    Besonders hervorheben möchte ich: Wenn in Camera UI ein paar mehr Aufzeichnungen aufgezeichnet waren, wurde es beim Anschauen der Aufzeichnungen zäh, sehr zäh. Auch das ist nicht mehr! Auch kleinere Fehler bei der Darstellung der Aufzeichnung, alles behoben.


    Außerdem finde ich toll, dass man aus dem Homebridge UI direkt über "Plugin" "Einstellungen" auf das Webinterface Camera UI zugreifen kann. Sehr bequem und uferfreundlich.


    Ich habe sicher noch viele Zuckerl übersehen.


    Ein großes Lob an Seydx, ein sehr sehr großes Lob.

    Den bzw. einen ähnlichen Fehler hatte ich auch mal:



    Gelöst mit dem Abschalten von SSL durch "ssl":false



    Es funktioniert, sehr schön



    Ich habe gerade alle Camera UI Aufzeichnungen gelöscht und dann den Ort der Aufzeichnung von einer externen Festplatte auf die interne Festplatte gewechselt. Jetzt meckert's im Homebridge.log


    [1/9/2022, 7:01:24 PM] Please add [Einfahrt D82C] manually in Home app. Setup Code: 830-45-963

    [1/9/2022, 7:05:10 PM] [CameraUI] Einfahrt: Starting video stream: nativexnative, native fps, ??? kbps

    [1/9/2022, 7:05:15 PM] [CameraUI] Einfahrt: Stopped video stream.

    [1/9/2022, 7:10:09 PM] [Bad] irgendwas anderes (kein Fehler)

    [1/9/2022, 7:10:09 PM] [Bad] irgendwas anderes (kein Fehler)

    Error: ENOENT: no such file or directory, stat '/Users/rainer/Pictures/CameraUI/[email protected]'

    Error: ENOENT: no such file or directory, stat '/Users/rainer/Pictures/CameraUI/[email protected]'

    Error: ENOENT: no such file or directory, stat '/Users/rainer/Pictures/CameraUI/[email protected]'

    Error: ENOENT: no such file or directory, stat '/Users/rainer/Pictures/CameraUI/[email protected]'

    [1/9/2022, 7:17:43 PM] [CameraUI] Einfahrt: Starting video stream: nativexnative, native fps, ??? kbps

    [1/9/2022, 7:17:47 PM] [CameraUI] Einfahrt: Stopped video stream.

    [1/9/20



    Das hatte ich neulich schon mal, nachdem ich die Aufzeichnungen gelöscht hatte (und keinen Speicherort gewechselt habe).


    Noch ein kleiner "Fehler", der sich schon seit beta.58 eingeschlichen hatte:

    Wenn ich im Camera UI auf eine Aufnahme klicke und dann per Play-Knopf abspiele, öffnet sich der Player auf dem Mac im Safari, aber die Laufzeitleiste ist unten fast außerhalb des Bildrands. Wenn ich dann die Aufnahmen als Mosaic rechts einblende und dort eine Aufnahme aufrufe und per Play-Click abspiele, ist die Laufzeitleiste ganz normal sichtbar.


    Screenshot: Unter 01 des Datums ist der Laufbalken. Der Screenshot geht bis ganz runter.


    Wenn ich rechts das Mosaic eingeblendet habe, dann ist der Laufzeitbalken wieder normal


    Gerade fällt mir noch was auf: gelöscht, war mein Fehler.

    beta.58 up and running. Keine Codec-Umwandlung, keine Bewegung erfasst, kein Force-Prebuffer. normales Prebuffer wie vorher auf 7 Sekunden. Prozessorlast jetzt durchschnittlich auf 23%, vorher unter beta.55 auf 2 bis 2%.


    Update:


    mds_stores steigt bis auf über 80% und liegt immer mindestens bei

    Außerdem kommt node auch ab und zu auf 30% oder mehr



    Keine Ahnung, ob dir das hilft. Mac mini ist frisch gebootet und es läuft nur ein Backupserver (aber gerade kein Backup).


    Update 2: md_worker und Konsortien gehören zu Spotlight. Camera UI ist unschuldig.

    Ich habe noch eine Idee für Laundrify, die ich mal los werden wollte.


    Die meisten Maschinen und Trockner haben ja einen Knitterschutz. Sie haben aber auch einen Ausschalter. Bisher meldet Laundrify bzw. das Homebridge Plugin schön brav, wenn die Maschine bzw. der Trockner „fertig“ ist. Dann geht man zu dem Gerät, entleert es und stellt es üblicherweise auf „aus“.


    Wenn Laundrify dieses „aus“ auch noch erkennen könnte, wäre das Klasse. Man könnte dann bei Maschine bzw. Trockner „fertig“ eine Lampe anknipsen, die dann bei Maschine bzw. Trockner „aus“ wieder ausgeknipst wird.


    Das wäre ein weiteres Alleinstellungsmerkmal.

    Habe jetzt dieselben Einstellungen wie bei deinem Screenshot gewählt. Und zack, es zeichnet auf. Du bis der Held.


    Probier jetzt gleich die beta.55

    Mit der beta.53 kann ich nicht gleichzeitig HSV laufen lassen und per Camera UI aufzeichnen



    Ich installiere jetzt mal beta.54.


    Update1: Die beta.54 leidet unter demselben Problem. Kein HSV und lokale Aufnahmen


    Tolle Sache hier, wie sich Seydx da reinhängt.


    Bananajoe86: Die homebridge 1.4.0-beta.4 hat schon alle Modifikationen und ist quasi nativ homekitfähig.


    Update2: Kleiner Fehler in der beta.54. Wenn ich die geführte Konfiguration aufrufe, erscheint bei Prebuffer length erst mal keine Zahl für die Sekunden:


    Erst wenn ich den Regler verschiebe, taucht in der Folgezeile eine Zahl für die Sekunden auf.


    Du kannst die Cloud-Videos nur für bestimmte Bewegungen aufzeichnen lassen, aber lokal als Rohdaten für alle Bewegungen. HSV funktioniert im Bewegungserkennungsmodus nicht perfekt. Die lokalen Daten haben alles, wenn man es mal braucht. Und dank Camera Ui können diese lokalen Daten nach der voreingestellten Zeit automatisiert gelöscht werden.


    Außerdem gibt es viele Cams, die nicht HSV-kompatibel sind. Mit Camera Ui hast du sie in Home. Von dort kannst du dann z. B. den Bewegungssensor als Trigger dafür hernehmen,dass die Gartenbewässerung anspringt, damit der Eindringling schön nass wird (im Sommer).

    Die Homebridge 1.4.0-beta.4 habe ich jetzt mitsamt deinem Camera UI Plugin 5.0.0-beta.53 drauf. Ohne Fehlermeldungen. Nur der Snapshot-Händler hat bisher einmal über zu langsam (5.2 Sekunden) gemeckert. Beim ersten Mal Start der Homebridge 1.4.0-beta.4 war die Prozessorlast auch ziemlich hoch; deshalb habe ich nochmal gestartet. Diesmal normale Prozessorlast und kein Meckern wegen eines langsamen Snapshots.


    Sieht ziemlich nach Goldmaster aus. Camera UI Aufzeichnungen und HSV funktionieren perfekt. Mehr habe ich bis jetzt nicht getestet. Ich lasse jetzt mal 24 Stunden laufen.


    Update: Eine neue Meldung habe ich, wenn ich in Home den Stream anschaue.


    [1/6/2022, 11:24:22 PM] [CameraUI] Einfahrt: Starting video stream: nativexnative, native fps, ??? kbps (AAC-eld)

    [1/6/2022, 11:24:22 PM] [CameraUI] Einfahrt: Replacing audio with a dummy track, audio source not found or timed out during probe stream (stream)

    [1/6/2022, 11:24:27 PM] [CameraUI] Einfahrt: Stopped video stream.


    In der Config.json steht audio auf false.


    "cameras": [
    {
                        "name": "Einfahrt",
                        "hsv": true,
                        "prebuffering": true,
                        "videoConfig": {
                            "stimeout": 10,
                            "readRate": true,
                            "stillImageSource": "-i http://xxx@[email protected]:80/snap.jpg",
                            "maxStreams": 2,
                            "source": "-i rtsp://[email protected][email protected]:554",
                            "rtspTransport": "tcp",
                            "debug": false,
                            "audio": false,
                            "vcodec": "copy"
    },
                        "motion": true,
                        "mqtt": {},
                        "unbridge": true
    }




    In Home steht Audio auf aus



    Ich habe heute mal testweise wieder mein Time Machine Backup Control (Software für macOS, damit ein Mac zum Time Machine Server wird) gestartet. Die Software lastet die CPU des Mac mini zu ungefähr 20% aus, wenn ein anderer Mac sein Time Machine Backup drauflädt.


    Das Webintereface von Camera UI wird dann sehr zäh bis unbrauchbar. Von der Camera UI aufgezeichnete Aufnahmen Ansehen im Webinterface von Camera UI geht praktisch nicht mehr. Wenn ich das Camera UI Browser-Fenster auf einem anderen Computer in den Hintergrund lege und wieder im Vordergrund aufrufe, geht gar nix. Die CPU-Last des Mac mini steigt aber nicht über 20-25%. Ich habe für HSV immer noch den Video Codec Copy drin. Wenn ich mit ssh auf den Mac mini schaue, sind primär ein kernel task und Smid aktiv (die Time Machine Backups gehen auf eine USB 3.0 - Platte).


    HSV-Aufzeichnung scheinen ohne Störung zu laufen. Im Homebridge.log sind auch keine Auffälligkeiten.


    Das Homebridge Web UI läuft ohne Störungen.


    PS: Deaktiviere ich die Camera UI Aufnahmen, läuft das Camera UI Web Interface wieder normal. Update: Es lag wohl primär daran, dass sowohl die Aufnahmen der Camera UI als auch das Time Machine Backup auf einer per USB angesteckten Festplatte gespeichert wurden. Der Flaschenhals ist somit vorprogrammiert gewesen. Mittlerweile geht der Parallelbetrieb, wenn nicht gerade ein gigabyte-großes Backup gefahren wird.


    PPS: Uhrzeit bei CPU-Last etc. stimmt jetzt.


    PPPS: Verständnisfrage: Ich habe noch diverse Eufy Cams, die alle nativ homekitfähig sind. Never change a running system, sie tun ihren Dienst sehr gut, seit 2 Jahren. Es sind Modelle, die drahtlos an eine Eufy Homebase angebunden sind und autark mit Batterie und Solarpanel laufen. Jetzt kam ich auf die Idee, deren rstp-Stream (der sich parallel zu HomeKit einstellen lässt) in Camera UI zu integrieren und dort HSV nicht zu aktivieren. Das hätte den Vorteil, dass neben HomeKit auch noch in Camera UI alle Kameras vereint sind. HSV verpennt doch ab und zu einige Aufnahmesituationen, da wäre ein zweiter Aufnahmepool gut. Den rstp-Stream konnte ich schon abgreifen, aber es kommt zu Fehlermeldungen, weil der rstp-Stream nicht ständig da ist. Ich vermute, dass die Eufy Cams nur bei ausgelöstem Alarm einen Stream bereitstellen. Wenn ich die Camera UI -Erfassung der Bewegung einschalte, bräuchte die UI ja einen konstanten Stream. Das können die autarken drahtlosen Eufy Cams sicher nicht, weil das Akku ohne Ende fressen würde. Habe ich da einen Denkfehler, oder liege ich da richtig?


    PPPPS: Kleiner Fehler in der Camera UI. Wenn ich mit dem roten Kreuz neben einer zu löschenden Kamera im Camera UI Einstellungsinterface eine Kamera lösche, bleibt sie im Homebridge Json drin und wird als fehlerhafte Kamera in Camera UI angezeigt (habe ich dann in der Homebridge json gelöscht). Ein weitere, noch vorhandene Kamera wird aus ihrem in der Camera UI definierten Raum rausgeworfen. Die Widgets von beiden Kameras verschwinden.