Rasperry Pi Zero W

  • Hallo c_hoch_b,


    ich habe es sogar auf einem "aufgemotzten" RasPi Zero laufen - mit Zero4U und einem LAN-Adapter.

    Hab's auch auf dem Zero w getestet - läuft. Man braucht wirklich keinen RasPi 2 oder gar 3 dafür.

    Habe sogar noch einiges mehr darauf laufen - ohne Probs.


    Viel Spaß.

  • Am Anfang hatte ich Homebridge auf einem Pi Zero WH laufen. Dabei bin ich nach der Anleitung von sschuste vorgegangen, die unter Anleitungen zu finden ist. In der damaligen Version war nur ein Problem an einer Stelle das richtige Paket zu holen. Da ist die Anleitung aber schon erweitert.
    Du solltest das „einfach nicht zum laufen“ einmal näher spezifizieren, damit man Dir helfen kann.

  • Würde mich auch interessieren. Ich bekomme Homebridge einfach nicht zum laufen auf dem Raspberry Zero W.

    Mich auch :-D

  • Du solltest das „einfach nicht zum laufen“ einmal näher spezifizieren, damit man Dir helfen kann.

    Danke für deine Hilfe. Ich habe als erstes die Anleitung oben im Menü unter "Homebridge" und "Anleitung" mit Schritt 1,2,3 ausprobiert.


    Die Anleitung hatte zuvor auf meinem Raspberry 3B+ einwandfrei funktioniert. Ich konnte mich dort auch auf die Weboberfläche mit IP:8080 einloggen. Jetzt habe ich mir einen Raspberry Zero W besorgt und dort funktioniert alles bis zu Schritt 2. Wenn ich bei Schritt 3 weiter mache, komme ich bis zum Punkt (https://smartapfel.de/homebridge/plugins-installieren/) "So. Frust oder Freude erfährst du, wenn du die Homebridge neu startest" und dann kommt genau das Fehlerbild bei "Traurig, aber das ewige Schicksal des Homebridgers..."


    Habe dann die Anleitung mit dem vorgefertigten Image unter Homebridge Image mit VNC - Raspbian Stretch Full - Raspberry Pi ausprobiert. Diese Anleitung scheint aber nicht für den PI Zero geiegnet. Denn Node wurde dort für die Prozessorarchitektur armv7l und nicht für arm6l (PI Zero W) installiert. Ist mir aber erst später aufgefallen. Hatte dann Node versucht für armv6 nachzuinstallieren, trotzdem hat die Homebridge nicht funktioniert.


    Als nächstes habe ich versucht die Homebridge mit der Anleitung und dem Script unter Homebridge-Tool's zum aktualisieren, sichern, neu aufsetzen..... auf einen frisch installierten Rasbian Strech Lite (headless Installation) aufzusetzen. Das Script ist durchgelaufen und gab auch keine Fehler die ich beobachtet habe. Aber nach der Installation komme ich auch dort nicht auf die Oberfläche der Homebridge mit IP:8080


    Scheint das am Raspberry Zero W zu liegen und der Prozessorarchitektur, dass irgendwas nicht funktioniert?

  • <p>Ich schrieb doch, daß es bei mir mit der Anleitung einwandfrei funktioniert hat. Ich habe mir die Anleitung eben noch einmal durchgelesen. Es ist in Schritt 2 bei der Installation von node für den Zero WH etwas anders zu machen. Das ist alles. <br>Mir war der Zero WH nur nicht performant genug, da ich auch noch PoHole darauf laufen hatte. Daher habe ich jetzt dort nur noch PiHole laufen und auf einem 3B+ homebridge. Die Installation war aber genau gleich bis auf die andere node Variante.
    <br>
    Du solltest einmal die Ausgaben vom Log hier posten, die im Schritt drei in der Anleitung ja stehen. Dafür das man über den Port 8080 eine Webseite erhält, ist ja das erste installierte Plugin zuständig. Das muß in der config.json richtig konfiguriert sein, sonst geht es nicht.
    Die Fehlermeldungen würden im Log stehen. Ohne die ist es nur Stochern im Nebel.</p>

  • Du solltest einmal die Ausgaben vom Log hier posten, die im Schritt drei in der Anleitung ja stehen. Dafür das man über den Port 8080 eine Webseite erhält, ist ja das erste installierte Plugin zuständig. Das muß in der config.json richtig konfiguriert sein, sonst geht es nicht.Die Fehlermeldungen würden im Log stehen. Ohne die ist es nur Stochern im Nebel.

    Fehleranalyse:


    ###


    [email protected]:~ $ sudo systemctl restart homebridge && sudo journalctl -fau homebridge

    -- Logs begin at Sun 2018-12-23 05:17:01 GMT. --

    Dec 24 12:34:00 raspberrypi homebridge[484]: ??????????????

    Dec 24 12:34:00 raspberrypi homebridge[484]:

    Dec 24 12:34:00 raspberrypi homebridge[484]: [12/24/2018, 12:34:00 PM] Homebridge is running on port 51826.

    Dec 24 14:42:49 raspberrypi homebridge[484]: [12/24/2018, 2:42:49 PM] Got SIGTERM, shutting down Homebridge...

    Dec 24 14:42:49 raspberrypi systemd[1]: Stopping Node.js HomeKit Server...

    Dec 24 14:42:54 raspberrypi systemd[1]: homebridge.service: Main process exited, code=exited, status=143/n/a

    Dec 24 14:42:54 raspberrypi systemd[1]: Stopped Node.js HomeKit Server.

    Dec 24 14:42:54 raspberrypi systemd[1]: homebridge.service: Unit entered failed state.

    Dec 24 14:42:54 raspberrypi systemd[1]: homebridge.service: Failed with result 'exit-code'.

    Dec 24 14:42:54 raspberrypi systemd[1]: Started Node.js HomeKit Server.

    Dec 24 14:43:03 raspberrypi homebridge[5138]: [12/24/2018, 2:43:03 PM] Loaded config.json with 0 accessories and 0 platforms.

    Dec 24 14:43:03 raspberrypi homebridge[5138]: [12/24/2018, 2:43:03 PM] ---

    Dec 24 14:43:04 raspberrypi homebridge[5138]: [12/24/2018, 2:43:04 PM] Loaded plugin: homebridge-accessory-bandwidth-qualit


    Es werden noch viele weitere Plugins geladen, die ich aber hier ausgelassen habe, da es sonst zu lang geworden wäre...


    Dec 24 14:43:47 raspberrypi homebridge[5138]: Setup Payload:

    Dec 24 14:43:47 raspberrypi homebridge[5138]: X-HM://0023ISYWY53G4

    Dec 24 14:43:47 raspberrypi homebridge[5138]: Scan this code with your HomeKit app on your iOS device to pair with Homebridge:

    Dec 24 14:43:48 raspberrypi homebridge[5138]:

    Dec 24 14:43:48 raspberrypi homebridge[5138]:

    Dec 24 14:43:48 raspberrypi homebridge[5138]:

    Dec 24 14:43:48 raspberrypi homebridge[5138]:

    Dec 24 14:43:48 raspberrypi homebridge[5138]:

    Dec 24 14:43:48 raspberrypi homebridge[5138]:

    Dec 24 14:43:48 raspberrypi homebridge[5138]:

    Dec 24 14:43:48 raspberrypi homebridge[5138]:

    Dec 24 14:43:48 raspberrypi homebridge[5138]:

    Dec 24 14:43:48 raspberrypi homebridge[5138]:

    Dec 24 14:43:48 raspberrypi homebridge[5138]:

    Dec 24 14:43:48 raspberrypi homebridge[5138]:

    Dec 24 14:43:48 raspberrypi homebridge[5138]:

    Dec 24 14:43:48 raspberrypi homebridge[5138]:

    Dec 24 14:43:48 raspberrypi homebridge[5138]:

    Dec 24 14:43:48 raspberrypi homebridge[5138]:

    Dec 24 14:43:48 raspberrypi homebridge[5138]:

    Dec 24 14:43:48 raspberrypi homebridge[5138]:

    Dec 24 14:43:48 raspberrypi homebridge[5138]:

    Dec 24 14:43:48 raspberrypi homebridge[5138]:

    Dec 24 14:43:48 raspberrypi homebridge[5138]:

    Dec 24 14:43:48 raspberrypi homebridge[5138]:

    Dec 24 14:43:48 raspberrypi homebridge[5138]:

    Dec 24 14:43:48 raspberrypi homebridge[5138]:

    Dec 24 14:43:48 raspberrypi homebridge[5138]:

    Dec 24 14:43:48 raspberrypi homebridge[5138]:

    Dec 24 14:43:48 raspberrypi homebridge[5138]:

    Dec 24 14:43:48 raspberrypi homebridge[5138]: Or enter this code with your HomeKit app on your iOS device to pair with Homebridge:

    Dec 24 14:43:48 raspberrypi homebridge[5138]:

    Dec 24 14:43:48 raspberrypi homebridge[5138]: ??????????????

    Dec 24 14:43:48 raspberrypi homebridge[5138]: ? 031-45-154 ?

    Dec 24 14:43:48 raspberrypi homebridge[5138]: ??????????????

    Dec 24 14:43:48 raspberrypi homebridge[5138]:

    Dec 24 14:43:48 raspberrypi homebridge[5138]: [12/24/2018, 2:43:48 PM] Homebridge is running on port 51826.


    ###


    Habe jetzt nochmal folgendes ausgeführt:


    [email protected]:~ $ sudo npm install -g --unsafe-perm homebridge-config-ui-x
    /usr/local/bin/homebridge-config-ui-x -> /usr/local/lib/node_modules/homebridge-config-ui-x/dist/bin/standalone.js

    + [email protected]

    updated 1 package in 79.166s


    ###


    Dann nochmal:


    [email protected]:~ $ sudo nano /var/homebridge/config.json


    Hier war das Problem, dass nur eine "example" Konfiguration drin stand. Diese Konfiguration habe ich dann aus der Anleitung im Schritt 3 ersetzt. Problem war außerdem, dass er beim rein kopieren in Nano (ich gehe über Mac Terminal) vor die Konfiguration Zahlen gesetzt hat von 1-30, die ich gelöscht habe, damit nur noch die Konfiguration aus der Anleitung in der config-json drin steht.


    ###


    Dann nochmal:


    [email protected]:~ $ sudo systemctl restart homebridge && sudo journalctl -fau homebridge

    -- Logs begin at Sun 2018-12-23 05:17:01 GMT. --

    Dec 24 14:43:48 raspberrypi homebridge[5138]: ??????????????

    Dec 24 14:43:48 raspberrypi homebridge[5138]:

    Dec 24 14:43:48 raspberrypi homebridge[5138]: [12/24/2018, 2:43:48 PM] Homebridge is running on port 51826.

    Dec 24 15:03:57 raspberrypi homebridge[5138]: [12/24/2018, 3:03:57 PM] Got SIGTERM, shutting down Homebridge...

    Dec 24 15:03:57 raspberrypi systemd[1]: Stopping Node.js HomeKit Server...

    Dec 24 15:04:02 raspberrypi systemd[1]: homebridge.service: Main process exited, code=exited, status=143/n/a

    Dec 24 15:04:02 raspberrypi systemd[1]: Stopped Node.js HomeKit Server.

    Dec 24 15:04:02 raspberrypi systemd[1]: homebridge.service: Unit entered failed state.

    Dec 24 15:04:02 raspberrypi systemd[1]: homebridge.service: Failed with result 'exit-code'.

    Dec 24 15:04:03 raspberrypi systemd[1]: Started Node.js HomeKit Server.

    Dec 24 15:04:12 raspberrypi homebridge[5905]: [12/24/2018, 3:04:12 PM] Loaded config.json with 0 accessories and 1 platforms.


    Hier wird jetzt 1 Platform geladen, was wohl das Problem war, das ich nicht auf die Weboberfläche drauf kam.


    ###


    Jetzt komme ich auf die Weboberfläche. :-)


    Vielen Dank nochmal carsten_h

  • :thumbup:

    Dann steht ja ruhigen Weihnachtstagen nichts mehr im Wege.


    Gruß

  • Hallo!

    Ich bin neu im Forum und versuche gerade einen Raspberry Pi Zero W zum laufen zu bringen. Ich wollte die Wlan / HomeKit Kamera bauen. Allerdings wird die Kamera nicht im Wlan erkannt. Vermutlich bekomme ich das mit der Wlan Configdatei nicht hin ? Ist es vielleicht möglich, dass mir jemand seine Datei schickt?

    Ich würde mich sehr über eine Antwort freuen.

    Liebe Grüße Christoph

  • Schau mal hier rein: https://smartapfel.de/homebridge/


    Da ist so eine Datei abgebildet.

    Stefan

  • Hallo Stefan!

    Erstens: Ich entschuldige mich, dass ich erst jetzt antworte.

    Zweitens: Es hat mit Deiner Anleitung sofort geklappt! Klasse, ich danke Dir vielmals.

    Ich wünsche noch einen schönen Abend und verbleibe


    mit lieben Grüßen

    Christoph