Kann Homebridge nicht mehr hinzufügen "Gerät bereits hinzugefügt"

  • Was heißt genau vorher verbunden ?


    Also... ich bin umgezogen und habe alles abgebaut.
    in der neuen Wohnung die Hue Bridge komplett neu eingerichtet und eingestellt.


    Nun habe ich den Server wieder ausgepackt und wollte dann alles konfigurieren !


    Also die Endgeräte an der Hue sind natürlich schon die, die auch vorher dran waren

  • hab ich schon alles gelöscht... aber das brachte keine Besserung.


    hast du noch eine Idee wie ich das hinbekomme ?

  • nee, gibt leider keinen „factory reset“ in Homebridge. Hast Du sonst noch was auf dem Raspi laufen? Pihole? oder irgendwas? Sonst würde ich wirklich vorschlagen, nach der Anleitung hier komplett neu zu installieren. raspian buster light reicht für homebridge. Das ist dann der „factory reset“


    Damit bist du in einer konzentrierten Stunde durch. Hieran machst du schon länger rum....

  • bubffm

    Ich habe hier noch einen pi...

    nach welcher Anleitung kann ich dann gehen ? Und wie kann ich das jetzige HB komplett deaktivieren ? So das es beim Neustarten des Servers nicht wieder hochgefahren wird ?

  • Genau die hier:

    https://smartapfel.de/homebridge/


    Wenn du die eine SD neu überschreibst (flasht) ist alles andere weg. Du must natürlich schauen das du da nicht auf einem anderen Gerät noch eine homebridge laufen hast. Dort musst Du die HB dann dauerhaft stoppen. Da ich nicht weiss wo deine derzeitige homebridge läuft kann ich nicht sagen wie du das machst.

  • Du hast ja immer noch nicht verraten wo HB derzeit bei dir läuft! Ich nehme an irgendeine Form von Linux Box / NAS?


    Du musst das Startscript anpassen damit sie nicht mehr automatisch startet, aber wie genau, dafür reichen leider meine Linux Kenntnisse nicht. Sorry.

  • Du hast ja immer noch nicht verraten wo HB derzeit bei dir läuft!

    pillemats: genau das ist die Frage. Wie sieht dein Setup aus, und nach welcher Anleitung hast du es aufgesetzt?

  • hatte ich doch bereits mehrfach erwähnt, das es auf einem normalen debian server installiert ist.


    Ich werde jetzt aber meinen PI ausgraben und da alles neu aufsetzen.


    sschuste reicht es wenn ich die configs aus dem "alten HB" lösche, damit es nicht mehr automatisch startet ?

  • hatte ich doch bereits mehrfach erwähnt, das es auf einem normalen debian server installiert ist.

    Sorry, für mich ist ein Raspi auch ein normaler Debian-Server.


    Entweder wird die Homebridge per systemd gestartet oder per init. Beides ist ein Mechanismus des Betriebssystems, um einen Service zu starten oder zu stoppen. Dieser Mechanismus wird auch genutzt, um einen Service beim Booten zu starten. Der systemd ist die moderne Variante, init ist die alte. Ich weiß nicht welche du nutzt.


    Versuchen wir also, einfach beide abzustellen. Da ich nicht weiß, wie dein System aufgesetzt ist, schieße ich hier mal so ins Blaue.


    systemd:

    sudo systemctl stop homebridge

    sudo systemctl disable homebridge


    Vielleicht kommen da Fehlermeldungen, vielleicht nicht.


    init:

    sudo /etc/init.d/homebridge stop

    sudo rm /etc/rc3.d/*homebridge


    Auch hier: entweder gibt's Fehlermeldungen oder nicht.


    Möglicherweise läuft danach die Homebridge nicht mehr und wird auch nicht mehr beim Booten gestartet.


    Stefan

  • Das teste ich nachher mal!
    Ist ja auch Sinn und Zweck das sie nicht mehr geht...


    alle anderen Sachen sind davon ja unangetastet oder ? Zb mein Samba Server der auch mit auf dem debian läuft

  • alle anderen Sachen sind davon ja unangetastet oder ?

    Das würde ich erwarten.

  • das kam als antwort....

    sollte also passen oder ?


    root@Server ~ > sudo systemctl disable homebridge

    Synchronizing state of homebridge.service with SysV service script with /lib/systemd/systemd-sysv-install.

    Executing: /lib/systemd/systemd-sysv-install disable homebridge

    root@Server ~ >

  • Schätze schon. Probier's aus.

  • sschuste hat geklappt, danke !


    Allerdings kotze ich hier gleich ab :D


    Nun habe ich mit meinem pi die HB komplett nach deiner anleitung aufgesetzt.


    Der fehler ist immer noch da


    gibts doch nicht..... was soll ich tun ?


    muss ich eventuell die originale hue bridge auf HK löschen ?


    Dann muss ich ja alles komplett neu einrichten :(



    EDIT; Nun hat es geklappt.... jetzt kommt der fehler nicht mehr... hatte ein fehler in der config... allerdings werden mir keinerleih geräte angezeigt die in der huebridge installiert sind wie zb. die osram steckdosen....


    muss ich die manuell noch hinzufügen ?


    hier mal meine config:


    2 Mal editiert, zuletzt von pillemats ()

  • allerdings werden mir keinerleih geräte angezeigt die in der huebridge installiert sind wie zb. die osram steckdosen....

    Hab keine Osram-Steckdosen.

    "nativeHomeKitLights": true,

    Was passiert, wenn das auf false steht?

  • manchmal sieht man den wald vor lauter bäumen nicht :D


    Das wars....


    kannst du mir vielleicht sagen warum die schalter (hue) extrem verzögert funktionieren ?


    Wenn ich diese über die hue app einrichte gehen die viel schneller

    Einmal editiert, zuletzt von pillemats ()