homebridge-nukiio

  • Joa

    okay danke und das mit dem true und false hab ich auch richtig verstanden


    Zitat von Acemachine Du musst gar nichts, die Frage ist ob du ein zweites Schloss möchtest, welches die Falle anzieht (egal welchen Schließzustand das Schloss hat).

    ja das meinte ich ja true bedeutet in dem Fall das man in der Home App ein zweites Schloss angezeigt bekommt was lediglich für das ziehen der Falle da ist.

  • Zitat von rel Bridge-Url ist 192.168.0.94 und die ID ist 0DF39B59
    Die Zeile "usesDoorLatch" : true, setzen, dann sollte es passen. Homebridge neu starten und in Home schauen, ob du jetzt 2 zusätzliche Kacheln hast.

    woher weißt Du das das meine ID ist?


    Ist in dem Fall das was in dem Screenshot von mir aus der Nuki App stammt.


    Dann kann ich mir die Suche über Web sparen oder?

  • Und, hast du die Config mal entsprechend angepasst? Läuft es?

    konnte ich leider noch nicht machen da ich nicht zuhause bin und ich von extern leider keine Möglichkeit habe dies zu tun sonst würde ich es gerne mal testen.

    Die einzige Sorge die mich noch diesbezüglich beschäftigt die komplette Config in meine Config an der richtigen stelle einzufügen, da tu ich mich immer ein bisschen schwer X/

  • {
    "bridge": {
    "name": "Homebridge",
    "username": "CC:22:3D:E3:CE:31",
    "port": 51826,
    "pin": "031-45-154"
    },
    "accessories": [
    {
    "name": "Xiaomi Mi Robot Vaccum 2st Generation",
    "ip": "192.168.0.179",
    "token": "6b6843524630736748496b386e644237",
    "pause": true,
    "dock": true,
    "accessory": "XiaomiRoborockVacuum"
    }
    ],
    "platforms": [
    {
    "name": "Config",
    "port": 8080,
    "auth": "form",
    "theme": "dark-mode",
    "restart": "sudo -n systemctl restart homebridge",
    "temp": "/sys/class/thermal/thermal_zone0/temp",
    "tempUnits": "c",
    "sudo": true,
    "log": {
    "method": "custom",
    "command": "journalctl -o cat -n 500 -f -u homebridge"
    },
    "platform": "config"
    },
    {
    "platform": "SoundTouchPlatform",
    "name": "SoundTouch",
    "accessories": [
    {
    "name": "Bose Soundtouch Küche",
    "ip": "192.168.0.59",
    "onVolume": 10,
    "unmuteVolume": 30,
    "source": "true",
    "volume": {
    "mode": "lightbulb"
    },
    "presets": [
    {
    "index": 1,
                               
    "name": "Dies&Das"
    },
    {
    "index": 2,
    "name": "SWR 3"
                           
    },
    {
    "index": 3,
    "name": "big fm"
    }
    ]
    }
    ],
    "global": {
    "sources": [
    {
    "source": "QPLAY",
    "enabled": false
    },
    {
    "source": "AUX",
    "enabled": false
    },
    {
    "source": "BLUETOOTH",
                            
    "enabled": false
    }
    ]
    }
    }
    ]
    }




    so sieht meine aktuelle config aus

  • {

    "bridge": {

    "name": "Homebridge",

    "username": "CC:22:3D:E3:CE:31",

    "port": 51826,

    "pin": "031-45-154"

    },

    "accessories": [{

    "name": "Xiaomi Mi Robot Vaccum 2st Generation",

    "ip": "192.168.0.179",

    "token": "6b6843524630736748496b386e644237",

    "pause": true,

    "dock": true,

    "accessory": "XiaomiRoborockVacuum"

    }],

    "platforms": [{

    "name": "Config",

    "port": 8080,

    "auth": "form",

    "theme": "dark-mode",

    "restart": "sudo -n systemctl restart homebridge",

    "temp": "/sys/class/thermal/thermal_zone0/temp",

    "tempUnits": "c",

    "sudo": true,

    "log": {

    "method": "custom",

    "command": "journalctl -o cat -n 500 -f -u homebridge"

    },

    "platform": "config"

    },

    {

    "platform": "NukiBridge",

    "bridge_url": "IP Bridge",

    "api_token": "BRIDGE API TOKEN",

    "cache_directory": "./.node-persist/storage",

    "locks": [{

    "id": "NUKIID SCHLOSS",

    "name": "TÜRNAME",

    "usesDoorLatch": true

    }]

    }, {

    "platform": "SoundTouchPlatform",

    "name": "SoundTouch",

    "accessories": [{

    "name": "Bose Soundtouch Küche",

    "ip": "192.168.0.59",

    "onVolume": 10,

    "unmuteVolume": 30,

    "source": "true",

    "volume": {

    "mode": "lightbulb"

    },

    "presets": [{

    "index": 1,

    "name": "Dies&Das"

    },

    {

    "index": 2,

    "name": "SWR 3"

    },

    {

    "index": 3,

    "name": "big fm"

    }

    ]

    }],

    "global": {

    "sources": [{

    "source": "QPLAY",

    "enabled": false

    },

    {

    "source": "AUX",

    "enabled": false

    },

    {

    "source": "BLUETOOTH",

    "enabled": false

    }

    ]

    }

    }

    ]

    }



    So sollte es funktionieren. Du musst dann nur noch die Nuki Daten eintragen.

  • Im Klartext heißt es immer noch, dass das Plugin versucht Zugriff auf eine Datei zu erhalten auf die es keinen Zugriff hat und du demnach die Zugeiffsrechte der Datei aendern/erweitern musst!


    30Sekunden Google Suche haetten es schon loesen koennen, aber dandu das Forum bevorzugst und dir jemand die Loesung auf dem Silbertablett praesentieren soll, hier:


    Code
    1. sudo chown -R $user:$group /.node-persist

    Wobei der Teil mit User fuer den User steht mit dem du homebridge nutzt und group die Gruppe in der der jeweilige user enthalten ist.

  • Tut mir leid ich hab gesucht aber nichts gefunden was mich weiterbringt da ich leider noch nicht wirklich Kenntnis von der Sache hab und deshalb versuche ich es hier über das Forum ich wäre froh ich hätte soviel Erfahrung wie manch andere hier.
    Das was du als Lösung geschrieben hast versteh ich leider auch nicht aber okay muss ich halt noch ein bisschen suchen



    Gesendet von iPhone mit Community