ConBee Phoscon deCONZ Setup

  • ES LÄUFT.


    Ich habe es nochmals ganz von vorne mit einem Image ausgeführt. Mit sudo apt-get --with-new-pkgs upgrade wurde Deconz installiert. Danach habe ich den Port wieder angepasst und neu gestartet. Vielleicht hilft es, wenn ich die einzelnen Schritte hier nochmals zusammenhängend angebe:


    sudo apt-get upgrade -y

    sudo apt-get upgrade

    sudo apt-get update

    sudo apt-get --with-new-pkgs upgrade

    sudo nano /lib/systemd/system/deconz.service

    (eventuell hier Port innerhalb der deconz.service anpassen:ExecStart=/usr/bin/deCONZ -platform minimal --http-port=80)

    sudo reboot


    Ferdddisch.


    Herzlichen Dank nochmals, Patrick, für Deine Unterstützung.

  • Hallo Community,


    Nachdem ich lange Zeit ein openHAB-User war, bin ich nun dabei auf Homebridge umzustellen. Hierzu habe ich mir über den Raspberry Pi Imager die neue Image von Homebridge geflasht und diese auf meinem Raspberry gestartet.

    Hierbei handelt es sich um eine cleane Installation. Es läuft nichts anderes auf dem Raspberry.


    Nachdem die Homebridge bzw das UI erreichbar ist, möchte ich deConz für meinen Conbee II installieren. Hierzu benutze ich die "hb-config". Nachdem die Installation abgeschlossen ist, ist das Interface auch erreichbar. Aber nun gehen die Probleme los.


    Wenn ich mich Eingeloggt habe, wird das Gateway nicht erkannt. Also es wird keine Firmware angezeigt und auch kein Hersteller. Also ist meiner Meinung nach der Conbee nicht eingebunden.

    Folgendes habe ich schon Probiert:


    - Neustart des Raspberrys (mehrfach)

    - Neuinstallation von Homebridge (mehrfach)

    - über lsusb geschaut ob der Stick erkannt wird (wird er)

    - ls -l /dev/ttyACM* durchgeführt (scheint auch in Ordnung zu sein)

    - Dialout-Rechte neu vergeben

    - Firmware auf dem Conbee aktualisiert


    Es hat alles nicht geholfen. Der Stick wird vom Raspberry erkannt. Er wird jedoch von deConz nicht angenommen.


    Hatte jemand dieses Problem schon?


    MfG

    Elias

  • Such mal hier im Forum nach dem Problem.

    Ich meine in Erinnerung zu haben das du den Port?

    freigeben musst.

    Bei mir hatte es die Firmware auch nicht angezeigt und nach der Portfreigabe hat es dann geklappt.

  • Moin zusammen,


    ich habe am Wochenende die Homebridge neu installieren müssen, aufgrund eines defektes der Speicherkarte. Installation klappte problemlos. Konnte dann alles mit Hilfe des Backups wieder herstellen. Nur den Conbee 2 musste ich neu anlernen. Hatte auch funktioniert. Gestern musste ich den Raspberry neu starten und seit dem bekomme ich keine Verbindung mehr zum Stick. Hab es über die IP Adresse mit passenden Port probiert aber leider alles ohne Erfolg. Habt ihr eine Idee was ich noch machen kann. Alles neu installieren ist eigentlich die letzte alternative.


    Grüße

  • mr_eder hast Du mal die Port-Angabe mittels

    sudo nano /lib/systemd/system/deconz.service

    geprüft?

    Code
    ...
    [Service]
    User=1000
    ExecStart=/usr/bin/deCONZ -platform minimal --http-port=8080
    Restart=on-failure
    RestartSec=30
    ...

    Beim Restart des raspi werden ja Daemon Configs neu geladen und jetzt läuft das ganze nicht mehr unter dem Standard-Port bzw. Deinem angepassten Port?


    Was sagt die Console bei

    sudo systemctl status deconz ?


    Code
    deconz.service - deCONZ: ZigBee gateway -- REST API
         Loaded: loaded (/lib/systemd/system/deconz.service; enabled; preset: enabled)
         Active: active (running) since Mon 2024-04-22 18:05:41 CEST; 2 weeks 0 days ago
       Main PID: 489613 (deCONZ)
          Tasks: 5 (limit: 8739)
            CPU: 2h 13min 25.656s
         CGroup: /system.slice/deconz.service
                 └─489613 /usr/bin/deCONZ -platform minimal --http-port=8080