Shelly 2.5 Rollershutter Modus wird als Schalter in Homekit angezeigt

  • Hallo zusammen,


    ich habe ein kleines Problem:


    Ich habe bereits diverse Shelly 2.5 zur Rolladensteuerung verbaut und das problemlos.

    Heute habe ich dann einen weiteren eingebaut, aber dieser wird mir in der HomeKit App (Home) nicht als Rolladen, sondern als 2 Schalter angezeigt.

    In der Shelly App ist der Modus auf Rollershutter gestellt.


    Übersehe ich etwas? Die letzten Shellys hatte ich vor etwa einem Jahr installiert. Hat sich da etwas geändert?


    DIe Einbindung der Shellys läuft über eine Hoobs Homebridge.

  • Magst du mal nachsehen, ob die Shelly Firmware 1.8.0 ist?

    Plugins:

    homebridge config ui x; homebridge bravia; homebridge delay switch; homebridge fakebulb; homebridge fakeswitch; homebridge hue; homebridge nukiio; homebridge shelly; homebridge sonos; homebridge xiaomi roborock vacuum

    • Hilfreich

    Dann muss dein shelly-Plugin die Version 0.14.0 haben.

    Wenn das auch aktuell ist würde mir nur noch einfallen, dass der Rolladen nicht Kalibriert wurde.

    HomeKit Geräte / Homebridge Geräte:

    Raspberry 4 4GB | 4x Raspberrypi 3 Model B+ | Raspberry Zero | FritzBox 7490| HarmonyHub | Sonoff/Wemos/Tasmota | Danalock | Koogeek | Z-Way | Raspi-Cam | SwitchBot | Shelly| Logitech Circle2 | RavenSystem | DeCONZ



    Homebridge Plugins:

    Homebridge| Fritzbox | People | Callmonitor | Automation-Switches | Magichome-platform | Harmony | OpenHAB | ioBroker | Z-Way | Camera-FFMPEG | Website-to-Camera | video-doorbell-button |

  • Das Plugin Update hat geholfen. Danke!

    Hatte noch 0.12.0 drauf.

    Jup, damit konnte es nicht funktionieren. Aber schön, dass es jetzt wieder läuft. :thumbup:

    Plugins:

    homebridge config ui x; homebridge bravia; homebridge delay switch; homebridge fakebulb; homebridge fakeswitch; homebridge hue; homebridge nukiio; homebridge shelly; homebridge sonos; homebridge xiaomi roborock vacuum

  • Hallo Zusammen


    Ich habe zwei Shellys 2.5 im Einsatz. Beide Kalibriert und aktualisiert.

    Trotzdem wird immer nur einer, und zwar immer der Gleiche, in Homekit angezeigt. Der Andere erscheint nicht.

    Auch ein erneutes Installieren des Plugins hat nicht geholfen.


    Was könnte man noch versuchen?


    Gruss

    Michi

  • Hast du die Admin Seite eingerichtet. Wird dir dein Shelly auf dieser adminseite angezeigt?

    Code
    "admin": {
    "enabled": true,
    "port": 8185
    }

    HomeKit Geräte / Homebridge Geräte:

    Raspberry 4 4GB | 4x Raspberrypi 3 Model B+ | Raspberry Zero | FritzBox 7490| HarmonyHub | Sonoff/Wemos/Tasmota | Danalock | Koogeek | Z-Way | Raspi-Cam | SwitchBot | Shelly| Logitech Circle2 | RavenSystem | DeCONZ



    Homebridge Plugins:

    Homebridge| Fritzbox | People | Callmonitor | Automation-Switches | Magichome-platform | Harmony | OpenHAB | ioBroker | Z-Way | Camera-FFMPEG | Website-to-Camera | video-doorbell-button |

  • Ich habe im Homebridge-Webbrowser über die Einstellungen direkt im Plugin alles Eingestellt. Musste da die Mail und Passwort eingeben.

    Mehr habe ich noch nicht gemacht...


    Kann morgen gerne mal noch den config.jason Eintrag hochladen

  • Mail und Passwort sind erstmal nur notwendig wenn du auf den Geräten selber dieses auch so eingegeben hast. Ansonsten bracht man das erstmal nicht zwingend.

    HomeKit Geräte / Homebridge Geräte:

    Raspberry 4 4GB | 4x Raspberrypi 3 Model B+ | Raspberry Zero | FritzBox 7490| HarmonyHub | Sonoff/Wemos/Tasmota | Danalock | Koogeek | Z-Way | Raspi-Cam | SwitchBot | Shelly| Logitech Circle2 | RavenSystem | DeCONZ



    Homebridge Plugins:

    Homebridge| Fritzbox | People | Callmonitor | Automation-Switches | Magichome-platform | Harmony | OpenHAB | ioBroker | Z-Way | Camera-FFMPEG | Website-to-Camera | video-doorbell-button |

  • Hier meine config.json nochmals versucht bezüglich dem Shelly anzupassen, hat aber immer noch keinen Erfolg gebracht. Es erscheint nach wie vor nur einer von beiden.


    {
        "bridge": {
            "name": "Homebridge",
            "username": "CC:22:3D:E3:CE:40",
            "manufacturer": "homebridge.io",
            "model": "homebridge",
            "port": 51826,
            "pin": "031-45-156"
    },
        "description": "Home Smart Home",
        "platforms": [
    {
                "platform": "config",
                "name": "Config",
                "port": 8080,
                "auth": "form",
                "theme": "red",
                "restart": "sudo -n systemctl restart homebridge",
                "temp": "/sys/class/thermal/thermal_zone0/temp",
                "sudo": true,
                "log": {
                    "method": "custom",
                    "command": "journalctl -o cat -n 500 -f -u homebridge"
    }
    },
    {
                "name": "Hue",
                "anyOn": true,
                "hosts": [
                    "192.168.178.36"
    ],
                "lights": true,
                "nativeHomeKitLights": true,
                "nativeHomeKitSensors": true,
                "nupnp": true,
                "resource": true,
                "platform": "Hue",
                "users": {
                    "ECB5FAFFFE1EF46A": "hH4YBxXwpUoN5gmLEbdZ-opNmqRMX9SVKuYglpIc"
    }
    },
    {
                "name": "Harmony Hub",
                "hubIP": "192.168.178.30",
                "hubName": "Harmony",
                "TVAccessory": false,
                "switchAccessories": true,
                "showTurnOffActivity": "stateless",
                "publishSwitchActivitiesAsIndividualAccessories": false,
                "platform": "HarmonyHubWebSocket"
    },
    {
                "email": "[email protected]",
                "password": "120312mk",
                "platform": "Automower"
    },
    {
                "platform": "Shelly",
                "name": "Shelly",
                "admin": {
                    "enabled": true,
                    "port": 8181
    }
    }
    ],
        "accessories": [
    {
                "name": "Technik-1",
                "switch_address": "192.168.178.24",
                "accessory": "myStrom"
    },
    {
                "name": "Technik-2",
                "switch_address": "192.168.178.33",
                "accessory": "myStrom"
    },
    {
                "name": "Ladestation",
                "switch_address": "192.168.178.191",
                "accessory": "myStrom"
    },
    {
                "name": "Sub",
                "switch_address": "192.168.178.32",
                "accessory": "myStrom"
    },
    {
                "name": "Clockarth",
                "switch_address": "192.168.178.192",
                "accessory": "myStrom"
    },
    {
                "name": "Kino gedimmt",
                "stateful": false,
                "reverse": false,
                "time": 1000,
                "accessory": "DummySwitch"
    }
    ]
    }

  • Und was passiert wenn du die ip deiner HB mit dem Port :8181 eingibst?

    HomeKit Geräte / Homebridge Geräte:

    Raspberry 4 4GB | 4x Raspberrypi 3 Model B+ | Raspberry Zero | FritzBox 7490| HarmonyHub | Sonoff/Wemos/Tasmota | Danalock | Koogeek | Z-Way | Raspi-Cam | SwitchBot | Shelly| Logitech Circle2 | RavenSystem | DeCONZ



    Homebridge Plugins:

    Homebridge| Fritzbox | People | Callmonitor | Automation-Switches | Magichome-platform | Harmony | OpenHAB | ioBroker | Z-Way | Camera-FFMPEG | Website-to-Camera | video-doorbell-button |

  • Wenn du eine URL in einem Rechner eingibst wird davon deine HB eher nicht gestört.

    Wenn du heute die IP deines Raspis eingibst (192.168.x.x:8080) wirst du auf die Config-UI kommen. Und das gleiche sollst du mal mit 192.168.x.x:8181 probieren. Dann sollten dir alle Shelly Geräte angezeigt werden.

    Ein Port kann nicht doppelt belegt werden, d.h. wenn die Config-UI schon auf 8080 läuft darfst du bei Shelly nicht nochmal :8080 eintragen.

    HomeKit Geräte / Homebridge Geräte:

    Raspberry 4 4GB | 4x Raspberrypi 3 Model B+ | Raspberry Zero | FritzBox 7490| HarmonyHub | Sonoff/Wemos/Tasmota | Danalock | Koogeek | Z-Way | Raspi-Cam | SwitchBot | Shelly| Logitech Circle2 | RavenSystem | DeCONZ



    Homebridge Plugins:

    Homebridge| Fritzbox | People | Callmonitor | Automation-Switches | Magichome-platform | Harmony | OpenHAB | ioBroker | Z-Way | Camera-FFMPEG | Website-to-Camera | video-doorbell-button |

  • Ah ok, das wusste ich nicht. Ich werde das heute Abend mal versuchen. Aber du hast gemeint, ich solle mal versuchen den Port von HB auf 8181 statt 8080 zu ändern. 8181 hat aber schon Shelly, das würde ja dann auch nicht gehen?

  • Bananajoe86 so, konnte es gestern versuchen. Wenn ich die IP von HB und den Port 8181 eingebe, dann kommt nur einer der beiden Shellys, nämlich der, welcher auch in Homekit erscheint.

    Den anderen Shelly kann über die IP aufrufen, er ist also im Netz angemeldet und hat auch Verbindung. Kalibriert ist er, das habe ich schon zwei mal gemacht. Man sieht das ja auch daran, dass ich eine 0-100% Angabe habe, in welcher Stellung sich der Rolladen befindet. Firmware ist V1.8.3 8bei beiden Shellys).

    Also ich verstehe das nicht...

  • Wenn es dir langweilig ist, vielleicht den Shelly nochmal komplett zurücksetzen und schauen, ob er dann gefunden wird. Mehr fällt mir sonst auch nicht mehr ein. Bei mir wurden Shelly 1 ; 2.5 und Dimmer immer sofort gefunden.

    HomeKit Geräte / Homebridge Geräte:

    Raspberry 4 4GB | 4x Raspberrypi 3 Model B+ | Raspberry Zero | FritzBox 7490| HarmonyHub | Sonoff/Wemos/Tasmota | Danalock | Koogeek | Z-Way | Raspi-Cam | SwitchBot | Shelly| Logitech Circle2 | RavenSystem | DeCONZ



    Homebridge Plugins:

    Homebridge| Fritzbox | People | Callmonitor | Automation-Switches | Magichome-platform | Harmony | OpenHAB | ioBroker | Z-Way | Camera-FFMPEG | Website-to-Camera | video-doorbell-button |

  • Hätte zwei Fragen zu deinem Setup:


    1. Hast du dem Shelly mal eine feste IP zugewiesen?

    2. Hast du am Shelly 2x Phase (L) angeschlossen? Ich hatte mal ein Verbindungsproblem, als ich nur 1x Phase angeschlossen habe und mich auf die interne Brücke verlassen habe.

    Plugins:

    homebridge config ui x; homebridge bravia; homebridge delay switch; homebridge fakebulb; homebridge fakeswitch; homebridge hue; homebridge nukiio; homebridge shelly; homebridge sonos; homebridge xiaomi roborock vacuum

  • -Feste IP hat er nicht, dass haber ich aber im Router so eingestellt. Kann ich aber mal versuchen.

    -Das mit den 2x Phase muss ich nachschauen, kann ich so aus dem Bürosessel heraus nicht mehr sagen.

    -zurücksetzten werde ich versuchen...ist ja eigentlich nicht so eine grosse Sache


    Mals schauen ob es dann klappt