Raspberry bei apt-get upgrade abgestürzt - bootet nicht mehr

  • Guten Morgen,


    hat jemand bitte einen Rat?


    Ich habe gestern die aktuell node Version updaten wollen. Dabei mache ich immer ein "sudo apt-get update" und "sudo apt-get upgrade". Mitten beim sudo apt-get upgrade ist der Raspberry dann abgestürtzt?!!


    Hatte ich bisher nicht und bin aktuell ziemlich überfordert. Ich blicke gerade auch nicht ganz durch, was jetzt noch geht bzw. nicht. Nach gut einer halben Stunde habe ich den rasberry vom Strom getrennt und danach neu gestartet. Mir fällt auf, das die beiden Lämpchen am LAN Port nur glimmen (sind nicht aus, sind aber auch nicht richtig am leuchten). Ich dachte daher an einen Hardwaredefekt.


    Die SD Karte selber kann ich am Windows rechner (mit Ext2 Volume Manager) noch auslesen. Auch ein Backup funktioniert problemlos.


    Wenn ich den Raspberry ohne SD Karte starte, passiert nichts ungewöhnliches (bis auf den glimmenden LAN Port). Wenn ich diesen mit SD Karte starte, blinkt die gelbe LED (Vorderseite) 7x schnell (7 Mal blinken: kernel.img nicht gefunden?).


    Ich habe jetzt den Raspberry vom ursprünglichen Einbauort entfernt und versuche diesen mit HDMI über einen Monitor zu starten um ggf. Fehlermeldungen zu sehen.


    Bin aber eher ratlos, wie ich jetzt besser vorgehen soll. Hat daher bitte jemand einen Tipp was sinnvoll wäre? Auch wie ich am schnellsten evlt. Hardwareprobleme ausschließen kann.


    Vielen Dank!


    Gruß


    ... hmm. ok. Das überprüfen mit HDMI / Monitor ging schnell :-(


    Ohne SD Karte bleibt der Bildschirm schwarz. Mit SD Karte habe ich ein ziemlich buntes Viereck auf dem Bildschirm. Kein Prompt, keine Fehlermeldung, nichts...


    Update: Ich habe auf einer der beiden Partitionen auf der SD Karte einen Ordner Boot entdeckt. Dieser war leer. Aber es gab noch einen boot.bak Ordner mit Inhalt. Diesen habe ich dann komplett auf die andere Partition (boot) kopiert.


    Nach einem Neustart sehe ich jetzt wieder den Prompt und eine Menge Daten auf dem Monitor. Der Raspberry selber scheint also zu laufen. Auch der LAN Port funktioniert (die Lämpchen sind jetzt regulär am blinken?!).


    Mein Versuch sudo apt-get update zu machen, schlug aber fehl ("temporary failure resolving..."). Auch ein mutiges (verzweifeltes) sudo apt-get upgrade brachte nur die Meldung dpkg was interrupted...


    Ich soll sudo dpkg --configure -a ausführen. Habe ich gemacht und nun eine kurze Fehlerliste. Aber keine Möglichkeit etwas auszuwählen bzw. ist mir nicht klar was ich machen soll. Es gibt scheinbar einen Versionskonflikt. libraspberryi0 =1.20200902 - system 1.20200819


    error processing package libraspberrypi-dev - dependency problems - leaving unconfigured.


    Das Problem scheint sich neben mir ;-) auf nur zwei Dateien zu begrenzen. libraspberrypi-doc und libraspberrypi-dev.


    nach ein wenig google und vielen Dingen die ich leider nicht verstehe, habe ich folgendes gemacht:


    Code
    sudo rm /var/lib/apt/lists/lock
    sudo rm /var/cache/apt/archives/lock
    cd /var/lib/dpkg/updates
    sudo rm *
    sudo apt-get update
    Code
    update läuft leider immer noch auf einen Fehler (failed to fecht ... /buster/inRelease). Some index files failed to download. They have been ignored, or old ones used inste

    Ich habe dann nochmal sudo apt-upgrade ausgeführt und er hat sehr lange und erfolgreich gearbeitet. Sudo apt-get update ergibt aber den gleichen Fehler. Danach nochmal sudo apt-get upgrade, wieder zwei Packete aktualisiert. Trotzdem läuft apt-get update mit obigen Fehler.


    Das "gute" ist sudo dpkg --configure -a bringt keinen Fehler mehr. sudo apt-upgrade meldet nichts mehr zu machen (0 new, 0 update). Aber ich habe immer noch den Fehler bei apt-get update.


    ... ein sudo apt-get install habe ich auch noch nachgeschoben. Hat aber das Problem nicht behoben. :-(


    Update Final: Puh... geschafft. Ich musste im Router den pihole als DNS rausnehmen (da der raspberry aktuell nicht läuft). Danach ging auch sudo apt-get update wieder. sudo apt-get upgrade lässt sich danach ebenfalls ausführen, aktuell gibt es aber keine neuen Pakete. Puh... war jetzt eine spannende Geschichte.


    Nun kann ich mich dem anderen Problem der Homebridge widmen, das diese nicht startet da das Hue plugin (Conbee / phoscon) hängt. Ich mache dazu aber im entsprechenden Thread weiter.


    Falls mein Selbstgespräch hier stört, bitte Bescheid geben. Dann lösche ich das. Sonst würde ich nochmal aufräumen und die Punkte aufschreiben die zum Erfolg geführt haben. Hoffentlich hilft es dann nochmal einen Newbie wie mir, wobei ich das keinen Wünsche das die Kiste beim apt-get upgrade abstürzt :-(

    • Hilfreich

    Ok, um dem Selbstgespräch etwas mehr Struktur zu geben und falls jemand ebenfalls mal in das Problem laufen sollte, das apt-get upgrade unterbrochen wurde.


    1. SD Karte am Rechner mounten. Daten von boot.bak auf die boot Partition kopiert. Danach wieder in den Raspberry einsetzen und neu starten.

    Code
    sudo rm /var/lib/apt/lists/lock
    sudo rm /var/cache/apt/archives/lock
    cd /var/lib/dpkg/updates
    sudo rm *

    3. sudo apt-get upgrade (mehrmals) bis keine Änderungen mehr passieren.

    4. sudo apt-get install (ob das eine Rolle gespielt hat, kann ich nicht einschätzen)

    5. sudo dpkg --configure -a (darf keine Fehler bringen)

    6. sudo reboot


    P.S.: Damit mein Windows 10 Rechner die ext4 Partion der SD Karte verwenden kann habe ich Ext2Fsd verwendet. Es geht jeder beliebiger Reader. Ich habe den Link eingefügt, damit im Falle eines Falles dieser nicht lange gesucht werden muss.


    P.P.S.: Wenn die SD Karte dann sowie so schon am Rechner angeschlossen ist, direkt noch ein Backup machen! Gerne nach der Reparatur.

  • schlug aber fehl ("temporary failure resolving...").

    Das war der Hinweis. Der Raspi kann einen Domainnamen auflösen und das heißt: der DNS geht nicht. Bei dir ist das pihole.

  • Moin, I need help,


    ich weiss nicht ob ich hier richtig bin, aber ich habe nach Langem, mal wieder ein großes Problem: es funktioniert nichts mehr.

    Ich wollte die Raspi4 mal wieder updaten und habe:


    sudo apt-get update

    sudo apt-get upgrade


    eingegeben. Ich habe nicht richtig aufgepasst was dann passiert ist, habe neu gestartet und jetzt geht nichts mehr. Der Raspi startet nicht mehr.