Beiträge von Michael Mrak

    Dann pausiert er aber immer 30 Sekunden nachdem das Fenster geöffnet wurde, egal ob es dann noch offen ist oder nicht …

    Scheint aber die gleiche Auswirkung zu haben (Heizkörper schaltet sich aus). Und wenn ich schließe läuft eine andere Automation an und aktiviert den Heizkörper wieder.


    Ach so, dann bleibt der Heizkörper eigentlich dann so lange aus bis man wieder zumacht. Naja, das ist eh das gewünschte Ergebnis.

    Ich habs mit Deinem Scriptvorschlag leider nicht hingekriegt, der Heizkörper (EVE Thermo) hat sich nicht pausiert. Jetzt hab ichs mal komplett einfach versucht - so scheint es eigentlich zu klappen.


    Was spricht gegen dieses Setup? Hab ich da jetzt was in der Logik übersehen?


    Hallo zusammen,


    mittlerweile hab ich ein recht umfangreiches HomeKit und HomeBridge Environment. Soweit läuft alles prima und ich habe alle meine Heizkörper mit EVE Thermostaten und alle Fenster und Türen mit EVE Door & Window Sensoren ausgestattet.


    In der EVE App kann man ja sehr komfortabel Automationen anlegen - wenn man ein Fenster in einem Raum öffnet pausiert dann auch der entsprechende Heizkörper. Das funktioniert soweit alles perfekt.


    Jetzt meine Frage: Ich habe auch mein Haustüre mit einem EVE Door & Window Sensor ausgestattet. Da wir zwei Hunde haben muss ich immer wieder die Türe kurz öffnen, die Hunde in den Garten lassen und sie nach einigen Minuten wieder reinlassen ins Haus. Richtigerweise triggert des öffnen der Türe jedes Mal das Thermostat von meinem Heizkörper im Vorzimmer. Da die Türe aber jeweils nur kurz (dafür aber alle 2 Stunden) geöffnet und geschlossen wird führt die dazugehörige Automation zu bis zu 20 oder 30 Thermostat Pause / Wiederanlauf Aktionen d.h. der Motor des Thermostats hat sehr viel zu tun.


    Gibt es eine Möglichkeit den Trigger für die Automation so zu ergänzen, dass beispielsweise erst nach 30 Sekunden die Automation losläuft. Alles binnen 30 Sekunden sollte NICHT zum Start der Automation führen. Falls es länger als 30 Sekunden dauert wäre es natürlich wünschenswert - in diesem Fall würde die Türe ja bewusst länger offen gelassen z.B. um zu lüften.


    Kann man diese Anforderung mit HomeKit & HomeBridge Bordmitteln hinkriegen?


    Liebe Grüße

    Michael

    Homebridge läuft jetzt sehr rund auf meinem Mac mini, so belasse ich es jetzt einmal:


    Aktueller Softwarestand:


    ├── [email protected]

    ├── [email protected]

    ├── [email protected]

    ├── [email protected]

    ├── [email protected]

    ├── [email protected]

    ├── [email protected]

    ├── [email protected]

    ├── [email protected]

    ├── [email protected]

    ├── [email protected]

    ├── [email protected]

    ├── [email protected]

    ├── [email protected]

    ├── [email protected]

    ├── [email protected]

    ├── [email protected]

    ├── [email protected]

    ├── [email protected]

    ├── [email protected]

    └── [email protected]


    Auf dem Raspi 4 hab ich mir jetzt PI-Hole installiert, tolle Sache!

    Guten Morgen allerseits,


    nun ist mir aufgefallen, dass es ja augenscheinlich drei Versionspfade gibt die man verwenden kann. v1.0.17 ist laut der offiziellen Quelle die aktuelle Version. Die finde ich interessanterweise gar nicht im Homebridge Config Auswahlmenü. Kann es daran liegen, dass ich alles auf meinem Mac laufen lassen? Ich finde leider nirgendwo Infos inwieweit sich die Versionen unterscheiden. v.1.2.5 läuft jedenfalls problemlos bei mir.


    Hier steht leider auch nicht näher erklärt wo die Unterschiede sind.


    Ich hab die letzten Tage verwendet um erneut einen Versuch zu starten das bestehende HomeBridge Setup auf meinem Rapi 4 zu reaktivieren. Leider keine Chance, trotz neuem Code und neuem User, downgrade von HomeBridge will ich mir aber nicht antun.


    Für mich jetzt kein Drama. Ich konnte jetzt auch Node-red problemlos auch auf meinen alten Mac Mini übersiedeln welcher ohnedies läuft. Dann bleib ich halt auch mit HomeBridge auf MacOS und der Rapi 4 kann zukünftig andere Aufgaben übernehmen.

    Da es bei uns in letzter Zeit zu mehreren Stromausfällen gekommen ist, hatte ich endlich einen Grund für die Aufrüstung einer USV ^^


    Jetzt wird erstmal umgebaut ;)


    Gute Entscheidung, ich hab seit mittlerweile einem Jahr auch alle meine Netzwerkkomponenten mit einer USV abgesichert.

    Also, ich konnte gerade eben auch noch problemlos die Node-RED HomeKit Instanz in der Home App wieder hinzufügen. Es liegt also scheinbar wirklich am HomeBridge Setup. Config habe ich nicht geändert, der einzige Unterschied war, dass seit vorgestern glaube ich die Final Version von iOS bzw. tvOS 14.2 auf die Geräte installiert wurde.


    Die Homebridge läuft nach wie vor im gleichen Lan, da hat sich überhaupt nichts geändert. Sie hängt am Ethernet. Ich denke aber auch, dass es eigentlich kein Netzwerkproblem handelt, ich erreiche die HomeBridge ja offensichtlich von Homekit, nur wird sie als "nicht kompatibles Gerät" abgewiesen. Und zwar auch von einer komplett "jungfräulichen" Homekit Installation.

    Also, ich hab jetzt mein HomeKit komplett zurückgesetzt. Konnte in mühsamer Detailarbeit jetzt wieder alle meine Hue Geräte, meine Tradifi Lampen und meine Eve Thermostate wieder problemlos einfügen.


    Nur wenn ich HomeBridge einfügen will erhalten ich nach wie vor diese mir bisher noch nie vorgekommene Fehlermeldung "Gerät ist nicht kompatibel". Die Homebridge läuft problemlos, keinerlei Fehlermeldungen im Log. Alle Plugins laden und ich kann alle Homebridge Geräte (sofern dies möglich ist) auch über das Webinterface von Homebridge steuern. Der Fehler muss vermutlich trotzdem bei meinem Homebridge Setup liegen.


    Ich bin mit meinem Latein am Ende, habt Ihr noch einen Tipp? Ich will ungern meine komplette Homebridge wieder von Grund auf einrichten.

    Neuer User ist schonmal gut. Ich würd es aber auch mal mit einem neuen PIN versuchen, wenn nicht bereits geschehen.

    Ändert nichts, sowohl mit neuem User als auch mit neuem PIN (beides gleichzeitig geändert) wird das hinzufügen verweigert mit dem Hinweis "Gerät ist nicht kompatibel".


    Wenn ich dann übrigens nocheinmal mit dem gleichen user und der gleichen Pin versuche erhalte ich in der Home App die Fehlermeldung "Gerät bereits hinzugefügt -... zuerst zurücksetzen". Das ist interessant, scheinbar merkt sich die Home App trotzdem die Einstellungen der HomeBridge Konfiguration die ich hinzufügen wollte.


    Auch manuell eingegebene Pin funktioniert nicht. "Gerät ist nicht kompatibel".

    Vermutlich durch das Update auf iOS 14.2 und tvOS 14.2 lässt sich HomeBridge derzeit nicht mehr in meiner HomeKit Umgebung betreiben. Nachdem zuerst in der Home App bei allen HomeKit Devices die Fehlermeldung "Keine Antwort" (in roter Schrift) gestanden ist habe ich mich auf Grund einiger Recherchen HomeKit aus Home zu entfernen und neu hinzuzufügen. Entfernen hat gelappt, alle meine HomeKit Gerätschaften sind jetzt nicht mehr in der Home App sichtbar.


    Wenn ich jedoch HomeKit (auch unter Verwendung eines neuen Users "CC:22:3D:E3:CE:32" wieder hinzufügen will wird mir dies mit dem Hinweis "Gerät kann nicht hinzugefügt werden" Gerät ist nicht kompatibel verweigert. Kennt wer dieses Problem? Oder haben wir mit iOS 14.2 und tvOS 14.2 jetzt einen HomeBridge Killer?

    Hallo allerseits,


    das Update 1.2.1 von HomeBridge lässt mein UPS Signalisierungsmodule homebridge-nut abstürzen. d.h. HomeBridge kann bei Verwendung dieses Moduls nicht mehr starten mit folgenden Fehlermeldungen:

    Ich hab das Modul jetzt einfach mal aus der config.json ausgetragen, HomeBridge läuft jetzt wieder rund.


    Reparieren wird das vermutlich nur der Entwickler von homebridge-nut können, oder?

    Steht doch in der Beschreibung, dass einige zusätzliche Abhängigkeiten installiert werden müssen, wenn man kein Docker Image verwendet:


    IMPORTANT If you encounter any issue while installing, you might have to install additionnal packages on your environment since the main dependency of it depends on canvas library which is not available for all configurations. See there for more details : canvas compiling.


    https://www.npmjs.com/package/homebridge-deebotecovacs

    Das sieht für mich so aus als würde das Plugin auf einem Raspi nicht zum laufen zu bringen sein. Oder irre ich da?