Homebridge mit Harmony Hub Plugin funktioniert nur kurz :\

  • Versuch mal ein


    sudo chown -R marco:marco /home/marco/.homebridge


    Stefan

  • Danke Stefan,


    scheint nun zu funktionieren.

    Nun habe ich noch ein anderes Problem und zwar:

    Meine Homebridge funktioniert nur solange ich per Putty verbunden bin :) Ich fahre die Homebridge natürlich NICHT mit Strg+C herunter, sondern schließe nur Putty!?


    Geholfen habe ich mir nun, in dem ich an meinem ESXi die Konsole der VM geöffnet und offen gelassen habe.


    Was mache ich falsch:/


    Grüße

  • Du machst nichts falsch. Du willst es so :-D


    Wenn du dich mit PuTTY mit dem Raspi verbindest und dich einloggst, dann wird eine sogenannte Shell gestartet. Die Shell führt Kommandos aus, die du eingibst. Auch wenn es so aussieht, dass du die Homebridge startest, indem du das Kommando homebridge eingibst, ist es die Shell, die das Kommando ausführt und es ist auch die Shell, die die Homebridge startest. Du dagegen bist nur einer, der tippen kann, mit hoher Befriedigung die Entertaste drückt und danach zusieht, wie die Dinge ihren Laufen nehmen.


    Der Prozess homebridge ist ein Tochterprozess der Shell und er läuft so lange, wie diese Shell läuft. Beendest du die Shell, dann killst du den Prozess homebridge. Schließt du das PuTTY-Fenster, dann beendest du die Shell.


    Das gleiche gilt für die VMware-Konsole (falls man die überhaupt schließen kann). Es gilt auch für jedes andere Terminalprogramm und für jedes andere Betriebssystem. So ist der Lauf der Dinge und so sollen sie sein.


    Du kennst eine andere Shell: Windows. Alle Windows-Programme brauchen Windows. Killst du Windows, werden alle Programme, die Windows gestartet hat, indem du es mit Doppelklick dazu angeleitet hast, beendet.


    Da es den Administratoren in großen Rechenzentren zu doof ist, für jeden Prozess ein eigenes Fenster offen zu halten und morgens die offenen Fenster zu zählen, ob noch alle da sind, starten sie Prozesse im Hintergrund. Und da es ihnen gleichzeitig zu mühsam ist, nach dem Reboot einer Maschine ein Fenster zu öffnen und dort nohup homebridge & einzugeben, verwenden sie ein sogenanntes Startskript, um einen Prozess zu starten und das vor allem automatisch bei Systemstart. Heutzutage wird das mit einem Dienstprogramm namens systemd gemacht.


    Ich kann nur empfehlen, das ebenfalls so zu machen. Auf die Schnelle:


    Öffne die Datei /etc/systemd/system/homebridge.service mit dem Editor nano.


    sudo nano /etc/systemd/system/homebridge.service


    Da die Datei aller Wahrscheinlichkeit noch nicht existiert, ist der Editor leer. Dort schreibst du jetzt rein:


    Dann speicherst du die Datei, indem du strg-x und dann y und dann die Entertaste drückst.


    Damit ist dein Startskript erstellt. Dann bringst du es dem System bei:


    sudo systemctl daemon-reload 

    sudo systemctl enable homebridge


    Dann startest du deine Homebridge mit

    sudo systemctl start homebridge


    Und siehst dir das Logfile an mit

    sudo journalctl -fau homebridge (Abbruch mit strg-c)


    Alle Angaben hier ohne Gewähr, da mein Setup ein völlig anderes ist. Ich habs jetzt hier mal so runtergeschrieben in der Hoffnung, dass das gleich bei dir funktioniert. Wie immer würd's mich wundern :-D Falls es funktioniert, wird die Homebridge auch gleich automatisch beim Booten deiner VM mitgestartet.


    Wenn's nicht klappt, bitte hier beschweren und Fehlermeldungen dazu posten.


    Gruß,

    Stefan

  • Wow! Danke Stefan für deinen Beitrag.

    Richtig, ich will es so ;)

    Die Shell und ich haben so eine Hassliebe:love::cursing::love: Nun ist es, Dank deiner Erklärung aber auch logisch.


    Ich bin halt ein virtualisierungs Kind. Ich virtualisiere alles was keine Antwort gibt 8o

    Es ist einfach MEGA praktisch! Hätte ich keine Virtualisierung, würden hier 9 Geräte im Dauerbetrieb laufen....


    Ich werde deinen Tip mal umsetzen und hier dann das Ergebnis mitteilen.


    Danke und viele Grüße

    Marco


    Edit:


    Nope. Nun bekomme ich folgenden Fehler



  • det sagt's ja schon. Also, wo isse denn, die Homebridge?


    Ergibt

    which homebridge


    eine brauchbare Aussage wie

    Code
    1. [email protected]:~ $ which homebridge
    2. /usr/local/bin/homebridge

    oder wie

    Code
    1. [email protected]:~ $ which homebridge
    2. /usr/bin/homebridge

    oder noch was anderes? Jeden falls muss das, was da raus kommt, eingetragen werden in /etc/systemd/system/homebridge.service hinter ExecStart= und vor $HOMEBRIDGE_OPTS. Falls da was Brauchbares herauskommt.


    Bitte mal testen.

    Stefan

  • Ok,


    ein "which homebridge" ergibt

    Code
    1. /usr/bin/homebridge

    das habe ich dann in der "homebridge.service" angepasst.


    Direkt die Homebridge gestartet und Fehler....


    Reboot


    -> Trommelwirbel :thumbdown::thumbup::thumbdown::thumbup::thumbdown::thumbup::thumbdown::thumbup::thumbdown::thumbup::thumbdown::thumbup:


    Homebridge erfolgreich unter ESXi als VM in Ubuntu Server 18.04 LTS laufen ;)


    P.s.

    Ich bin mindestens ein Bier schuldig!


    Vielen Dank.

  • :thumbup: