Homebridge App insecure Modus dauerhaft starten

  • Hallo ich versuche das Alexa Still zu installieren und nutze die Homebridge app für meinen Raspberry Pi. Alles andere Funktioniert wunderbar aber ich bin einfach nicht in der lage herauszufinden wie ich in den Insecure Modus dauerhaft starten könnte.

    Habe auch schon mit dem Entwickler des Plug ins geredet aber bisher kamen wir noch nicht zum richtigem Ergebnis.

    https://github.com/NorthernMan54/homebridge-alexa/issues/167

    Ich bin schon ziemlicher Anfänger was Linux und Terminal Nutzung per SSH angeht.

    Würde mich über jegliche Hilfe sehr freuen!

    Viele Grüße

  • Ah, ich habe gelesen, du hast Homebridge mittels dieser komischen App installiert. Hol dir von Apple das Geld wieder, solange die 14 Tage noch nicht rum sind. Dann installierst du dir Homebridge mit den hier vorhanden Scripts kostenlos und sicher schnell selbst oder von mir aus auch manuell. Was die App genau macht und wo die ihre Dateien speichert, keine Ahnung. Ich installiere grundsätzlich alles manuell, ohne Scripts, ohne alles. Da weiß ich zumindest, was genau passiert. Sicher dir vorher die config.json.


    Das einzige, was mir noch einfällt, den Schalter in der App "Systemd Service" auf aktiviert stellen, neustarten und nochmal schauen, ob die Datei /etc/default/homebridge nun mit Parametern existiert.

  • Naja hab die App jetzt schon seit paar Monaten und bin eigentlich recht zufrieden. Hatte es davor Manuell versucht und bin krachend gescheitert.

    Würde jetzt wirklich sehr ungern alles verwerfen.

    Müsste es denn nicht funktionieren wenn ich es hinkriegen würde die Datei zu bearbeiten?

  • Die Datei scheint aber nicht zu existieren. Daher sollst du mal versuchen, den entsprechend Schalter umzulegen, wie oben beschrieben. Vielleicht gibt es sie dann. Ansonsten magst du zufrieden sein, aber verstehen tust du die ganze Sache nicht, was aber hilfreich ist, wenn später mal Fehler auftreten. Also wie gesagt, Schalter "Systemd Service" aktivieren in den Einstellungen der App und schauen, ob es die Datei "homebridge" in /etc/default/ gibt.

  • Ah okay hatte dich missverstanden sorry. Also hab jetzt den Switch umgelegt aber das führt zum selben Ergebnis wenn ich

    sudo nano /etc/default/homebridge eingebe.


    Heißt es also alles neu installieren und dafür Alexa Funktionalität gewinnen oder es sein lassen und eben auf Alexa verzichten

    oder gäbe es da vielleicht eine Alternative.


    Dass ich das ganze nicht verstehe sehe ich Genauso weshalb ich ein wenig vor dem Manuellem Weg zurückschrecke.

  • Genau so ist es, es sei denn, jemand anderes im Forum weiß, wo diese komische App die entsprechenden Dateien anlegt.


    Ansonsten wirst du hier bei manueller Installation genug Hilfe bekommen, bei Verwendung der App eher nicht, weil diese hier niemand benutzt.


    Ich bin immer für manuelle Installation als Benutzer root. Falls du es eher nicht verstehen willst und auf eine Automatik verlassen willst, gibt es hier det´s Tool, das macht genau das, wie die Homebridge-App, nur ist dort klar, was genau passiert und fast jeder hier kann dir helfen. Beide Varianten stehen dir offen.


    Homebridge-Tool's zum aktualisieren, sichern, neu aufsetzen.....

  • Okay also wie du so schön gesagt hast:

    "Da weiß ich zumindest, was genau passiert."

    Auf einmal erkennt Alexa alle meine Homebridge Geräte.

    Ich weiß nicht ob es an dem Systemd Service switch lag weil ich ja sonst nix gemacht hab aber irgendwie klappt es jetzt.

  • Passt das so mit den Bildern? Kann es auch abschreiben aber hab angst da was zu vergessen.

    Aha, die App. Dein Startscript befindet sich in /etc/init.d/homebridge und dort musst du das dann einsetzen.


    sudo nano /etc/init.d/homebridge


    Mach mal einen Screenshot davon.


    Stefan

  • Ich bin immer für manuelle Installation als Benutzer root.

    Ich bin immer für die manuelle Installation als User != root.


    Stefan

  • Ich würde jetzt erstmal aber nichts ändern da eigentlich alles sauber läuft seit ungefähr 20 Stunden. Hab mir dann auch noch das hier geladen:

    https://github.com/nfarina/homebridge-dummy

    und kann mein komplettes HomeKit zeug mit dem Echo dot steuern.

    Eine Frage hätte ich noch: wieviel cpu Belastung ist denn "zu viel" nach eurer Erfahrung wo man anfängt an Stabilität einzubüßen?

    Habe nämlich auch dieses hier drauf:

    https://www.npmjs.com/package/homebridge-samsung-tizen

    Hätte die Option den Status deutlich öfter aktualisieren zu lassen damit es immer richtig da steht ob der TV an ist oder nicht, rutsche aber mit der Option auf 60% Cpu last. In der App wird die anzeige dann rot weshalb ich mich frage ob das denn gravierend ist? an den 100% kratze ich ja noch lange nicht aber wie gesagt ich war ohne das Tizen mit der refresh option bei 10-20% und kann es nicht wirklich beurteilen...


    Auf jeden Fall nochmal großen dank für eure Hilfe!

  • Eine Frage hätte ich noch: wieviel cpu Belastung ist denn "zu viel" nach eurer Erfahrung wo man anfängt an Stabilität einzubüßen?

    In meinen Augen 101%. Man büßt zwar keine Stabilität dadurch ein, aber ab da werden Dinge langsamer. Ich würde auch immer einen Blick auf die CPU-Temperatur werfen, vor allem dann, wenn man seinen Raspi in einer schlecht belüfteten oder warmen Umgebung betreibt, beispielsweise zwischen Router, Hue-Bridge, AppleTV, Time Capsule und Modem wie bei mir.


    Mein Raspi läuft laut homebridge-config-ui-x bei 0,7% Auslastung und einer Temperatur von knappen 50°. Das Plugin empfehle ich übrigens, denn es vereinfacht die Konfiguration der Homebridge ganz erheblich.


    Stefan