TasmoAdmin - Tasmota verwalten für Faule

  • Moin,


    ich habe mal wieder was Nettes entdeckt und dachte mir, das probierst du mal aus. Bei über 15 Tasmota-Geräten kann man ja schnell den Überblick verlieren, ganz zu schweigen vom Aufwand, die Dinger zu updaten. Die Lösung: TasmoAdmin. Mit diesem kann man nicht nur einfach die Geräte verwalten oder Einstellungen vornehmen. Besser noch, das Webinterface hat eine Update-Funktion. Man lädt die Minimal und die passende volle Firmware hoch und das Webinterface, updatet automatisch ALLE Geräte ohne weiteres händisches Zutun. Einfach installiert ist es aus.


    https://github.com/reloxx13/TasmoAdmin


    Code
    apt-get install apache2 php php7.0-curl php7.0-zip git libapache2-mod-php7.0


    Passt das bitte an, die meisten haben apache2 und git sicher schon installiert. Dann kanns ja losgehen.


    Code
    git clone https://github.com/reloxx13/TasmoAdmin.git /var/www/tasmoadmin
    chown -R www-data:www-data /var/www/tasmoadmin
    chmod 777 /var/www/tasmoadmin/tasmoadmin/tmp && sudo chmod 777 /var/www/tasmoadmin/tasmoadmin/data
    rm /etc/php/7.0/apache2/conf.d/opcache.ini

    Wurde php neu installiert, wirds die .ini nicht geben. Dann brauch sie nicht gelöscht werden. Jetzt noch die Config anlegen, Port (hier 9999) kann entsprechend angepasst werden:


    nano /etc/apache2/sites-available/tasmoadmin.conf


    nano /etc/apache2/ports.conf


    Hier Port 9999 oder welchen man gewählt hat hinzufügen:


    Listen 9999


    So, jetzt noch alles aktivieren und apache neustarten, fertig ist TasmoAdmin:


    Code
    a2ensite tasmoadmin
    a2enmod rewrite
    systemctl restart apache2



  • Hi, habe alles ohne Fehlermeldungen installiert.

    Leider komme ich nicht auf die tasmoadmin-Oberfläche.


    Habe Debian Buster mit Homebridge, iobroker und pihole auf dem Host laufen.

    Wenn ich die IP des Host im Browser eingebe lande ich auf der "Standard Apache2 Website" mit Info, dass alles läuft. -> siehe Anhang



    Den Port 9999 habe ich auch gesetzt, wenn ich diesen mit eingebe bekommen ich eine Config ausgespuckt:



    Anscheinend läuft ja Apache, aber irgendwas passt nicht ganz..


    Kann mir jemand helfen?

  • Anscheinend läuft ja Apache, aber irgendwas passt nicht ganz..

    Du benötigst einen Apache mit PHP. Installiere PHP einfach nach mit sudp apt-get install php und starte den Apache neu.

  • önnte das in meiner pihole-Installation begründet sein?

    Glaube ich nicht. Möglicherweise ist php nicht "enabled".

  • Ich weiß es nicht auswendig. Frag mal Google.