Homebridge GUI nicht mehr erreichbar via Browser

  • Nachdem mein Raspberry 3 als Homebridge-Server seit über 6 Monaten sauber und brav lief, habe ich nun eine ZigBee Steckdose in die config.json integrieren wollen. Konkret das entsprechende ZigBee Plugin wie bei GitHub verfügbar. Leider hat das so gar nicht funktioniert. Aktuell kann ich meine Raspberry nur über Shell/SSH erreichen. Habe es nun wieder geschafft, mein config.json Backup zurückzuspielen. Via SSH und dem Editor. Soweit so gut. Leider kommt es nach dem Neustart zu einer Fehlermeldung. Siehe Anhang. Wer kann die Fehlermeldung deuten, dass klar wird was ich falsch gemacht habe?

    Wie immer – vielen Dank für Eure Unterstützung! :thumbup:

  • Wer kann die Fehlermeldung deuten, dass klar wird was ich falsch gemacht habe?

    Niemand. Poste bitte mal den Inhalt deiner config.json. Kein Screenshot, bitte.


    Stefan

  • Danke für Deine schnelle Reaktion: Also ... hatte ja meine gesicherte (Backup) config.json zurückgespielt, weil meine Anpassungen wegen der geplanten ZigBee Erweiterung eben einen Fehler ausgegeben hat.


    D.h. meine gesicherte config.json war so 6 Monate im Einsatz. Habe trotzdem gerade jsonlint.com zur Verifizierung des Codes verwendet und das Ergebnis lautet „Valid Json“?!


    Dank Deines Hinweises sehe ich aber in der Fehlermeldung nun einen Pfad Aufruf, den ich so nicht verstehe. Ich habe drei Ordern auf dem Raspberry. 1. PI 2. Homebridge 3.Config. Was bedeutet nur der Pfad in der Fehlermeldung:

    usr/local/lib/node_modules/homebridge/lib/server.js:218?!

    Aktuell hänge ich total fest. Wie ärgerlich. Der Raspi hat die letzten 6 Monate so schön funktioniert, bis ich dieses ZigBee Plugin installiert habe. Darum auch meine Änderung an der config.json, die ich aber nun wieder rückgängig gemacht habe, durchs zurückspielen des BackUp. :-(


  • Hier wie gewünscht die Config.json:


    {

    "bridge": {

    "name": "Homebridge",

    "username": "CC:22:3D:E3:CE:30",

    "port": 51826,

    "pin": "031-45-154"

    },

    "description": "Home Smart Home",

    "platforms": [

    {

    "platform": "config",

    "name": "Config",

    "port": 8080,

    "auth": "form",

    "theme": "red",

    "restart": "sudo -n systemctl restart homebridge",

    "temp": "/sys/class/thermal/thermal_zone0/temp",

    "sudo": true,

    "log": {

    "method": "systemd",

    "service": "homebridge"

    }

    },

    {

    "platform": "Fritz!Box",

    "name": "My FritzBox",

    "username": "XXX",

    "password": "XXX",

    "url": "http://fritz.box",

    "interval": 60,

    "hide": [

    "wifi",

    "<ain>"

    ],

    "concurrent": false,

    "wifiName": "Guest WLAN",

    "options": {

    "strictSSL": false

    }

    }

    ],

    "accessories": []

    }

  • Und wenn ich schon dabei bin. Hier die Verzeichnisstruktur:


    drwxr-xr-x 5 pi pi 4096 Jun 10 09:30 .

    drwxr-xr-x 4 root root 4096 Nov 25 2018 ..

    -rw------- 1 pi pi 1610 Jun 10 12:11 .bash_history

    -rw-r--r-- 1 pi pi 220 Nov 13 2018 .bash_logout

    -rw-r--r-- 1 pi pi 3523 Nov 13 2018 .bashrc

    drwx------ 3 pi pi 4096 Jun 9 19:30 .config

    drwxr-xr-x 4 pi pi 4096 Jun 10 10:01 .homebridge

    drwxr-xr-x 6 pi pi 4096 Nov 15 2018 node-v11.2.0-linux-armv7l

    -rw-r--r-- 1 pi pi 17669881 Nov 15 2018 node-v11.2.0-linux-armv7l.tar.gz

    -rw-r--r-- 1 pi pi 675 Nov 13 2018 .profile

  • Stimmt, deine config.json sieht ok aus. Kann ich mal die ganze Fehlermeldung sehen? Oben steht ja nur ein Ausschnitt.

  • Hey vgnsxe,


    der Gedanke ist mir auch gekommen. Aber nachdem meine SSH/Linux/RaspiOS (was auch immer) Befehle-Skills gegen Null gehen, weiß ich aktuell nicht, wie ich nach der „config.json“ suchen kann. Aber ich mach mich jetzt via G schlau und werde berichten.

  • So, jetzt bin ich mit den gefundenen Kommandozeilen-Befehlen etwas tiefer eingedrungen. Sieht so aus, dass ich mittlerweile an drei Stellen eine „config.json“ liegen habe?!


    [email protected]:/# find -name "config.json"

    ./var/homebridge/config.json

    ./home/pi/.homebridge/config.json

    ./usr/local/lib/node_modules/homebridge-fritz/config.json

    [email protected]:/#


    Komme ich dem Problem näher? Einmal „config.json“ sollte doch genügen?!

  • Hey Sebbo, auch Dir danke fürs mithelfen. Über die Anleitung hier. Lief ja auch 6 Monaten einwandfrei. Problem wurde verursacht, weil ich die config.json erweitert habe, um eine ZigBee Steckdose via ZigBee Plugin zu integrieren (via Homebridge GUI)

  • Ich glaube, dass es ein verstecktes Zeichen ist. Das hatten wir schon einige Male. Mache dies:


    Kopiere die config.json, die du hier im Thread gepostet hast und die da oben irgendwo zu sehen ist, und ersetze damit die config.json auf deinem Raspi. Ich schätze, dann geht es wieder.


    Stefan

  • Guten Morgen,


    bin leider erst jetzt dazu gekommen, den Tip von schuste umzusetzen. Und das war die finale Lösung. Warum jetzt die config.json nicht dort lag, wo sie sein sollte ... keine Ahnung. Jetzt ist mein Homebridge GUI unter OSX-Safari wieder aufrufbar und ... ich versuch nochmal die ZigBee-Steckdose von Osram zu integrieren. :/

    Auf alle Fälle möchte ich allen danken, die sich meinem DAU Problem angenommen haben. Super Forum-Community hier. Aber das habe ich vor 7 Monaten schon mitbekommen, vor allen Dingen das Engagement und Wissen von schuste hat mir schon sehr geholfen.

    :thumbup::thumbup::thumbup: