Node update Problem

  • Hallo liebes smartapfel forum,


    ich betreibe bei mir zu hause eine Homebridge über den Raspberry, darüber steuere ich Thermostate und verschiedene Lampen. Jetzt möchte ich für diverse Plugin updates zuerst meine node updaten.

    Jedoch scheint es ein Problem mit dem Passwort oder dem user zu geben.

    Da ich komplett neu auf dem Gebiet bin, bräuchte ich mal eure Hilfe.


    Hier ein Screenshot der "Fehlermeldung"



    Ich hoffe mein Problem ist einigermaßen verständlich formuliert :)


    Beste Grüße

  • Ich hoffe mein Problem ist einigermaßen verständlich formuliert

    Nicht wirklich, könntest du bitte mal beschreiben was du vorher machst, damit diese Fehlermeldung erscheint? Die wird wohl nicht aus heiterem Himmel auftauchen.


    Wie greifst du auf das Pi zu? Über das Terminal am Mac und ssh? Oder über die Weboberfläche der Config-UI-X in der Konsole?

    Nach welcher Anleitung hast du die Homebridge installiert?

  • Ich greife über die Weboberfläche, sowie über SSH (Programm Putty) zu. Bei beiden gleiches Problem. Installiert habe ich die HB nach der Anleitung hier von Smartapfel.de


    Der Fehler oder die Aufforderung zur Eingabe des Passwortes erscheint sobald ich die HB versuche mittels "sudo systemctl stop homebridge" zu stoppen. Ich versuche das Update nach der Anleitung aus diesem Forum (Node.js Update auf Raspberry Pi mit Homebridge (so klappt´s auf alle Fälle))" durchzuführen.

    Einmal editiert, zuletzt von biggi () aus folgendem Grund: Passwort ist übrigens bekannt und wird anscheinend nicht angenommen?

    • Hilfreich

    Log dich über putty mit dem User pi ein und nicht mit homebridge. Der wird keine Sudo rechte haben.

  • Richtig, wie Lucifer sagt solltest du es über den User Pi probieren, nicht über den User Homebridge. Der User Homebridge hat nur eingeschränkte Rechte auf Sudo, wenn du es dennoch über Homebridge machen willst (Gibt eig. keinen Grund dazu), dann folge dieser Anleitung um dem User Rechte zu geben und ein Passwort zu vergeben:

    https://www.reddit.com/r/homeb…ssword_password_does_not/

  • Über ssh hat alles problemlos funktioniert. Ich hätte schwören können, das habe ich gestern genauso probiert über den user Pi...

    Aber gut

    Vielen Dank euch beiden :-)

  • Vielen Dank euch beiden

    Dir danke ich auch, und zwar für deine Frage. Gar nicht mehr aufhören zu danken würde ich, wenn du dich zukünftig noch entschließen könntest, Screenshots von allem anzufertigen außer von Logfiles oder Terminalausgaben. Ich weiß, wie furchtbar einfach das ist und welche Freude es bereitet, aber es ist halt nur furchtbar einfach für dich und bereitet auch nur dir Freude. Für andere ist es eher nur furchtbar und unerfreulich, weil die müssen jetzt alles von deinem Screenshot abschreiben, wenn sie es bei Google eingeben wollen.


    Das ist, um es mit freundlichen Worten zu sagen, sehr, sehr lästig. Vielleicht kannst du dich demnächst dazu entscheiden, hier einfach mit copy&paste den Text einzusetzen. Danke, again.