homebridge-ring

  • Hallo zusammen,


    hat jemand von euch homebridge-ring am laufen? Ich habe das Plugin installiert, bekomme aber beim ausführen von Homebridge folgenden Fehler:


    Bin mir nicht sicher ob es wirklich mit dem Plugin zusammen hängt.

  • Hallo zusammen,


    ich habe ein Problem, bei dem ich in der Forensuche und Websuche keine Lösung fand.


    Zusammenfassend zu mir:

    Vor Ewigkeiten hatte ich mich mich mit Linux beschäftigt und ausrangierte Windows-Desktops als Linux-Server eingerichtet und laufen lassen. Auch der Zugriff auf iOS via SSH kenne ich vor vor Jahren. Also will ich damit sagen, dass ich zur Laie bin, mir die Vorgehensweisen aber nicht völlig fremd sind.

    Ich habe seit gestern einen Pi laufen, denn ich mit dieser Anleitung ausgesetzt habe: https://www.matthias-petrat.co…t-auf-einem-raspberry-pi/.


    Fritzbox, Harmony Hub, Synolgy habe ich problemlos integrieren können.


    Ich greife auf den Pi entweder per iOS App oder SSH via Mac zu. Den Pi kann ich mit einem Fernseher via HDMI verbinden und per USB-Maus und Tastatur steuern


    Nun war meine Absicht unsere Ring Doorbell zu integrieren.


    Dazu habe ich dieses Plugin installiert: https://www.npmjs.com/package/homebridge-ring


    Dann bin ich dieser Anleitung gefolgt: http://pysselilivet.blogspot.c…kit-bridge-with-ring.html


    Dabei habe ich auch dieses hier zumindest als Plugin installiert: https://www.npmjs.com/package/homebridge-config-ui-x


    In diesem Zuge versuchte ich auch auf die config.json zuzugreifen mit sudo nano /var/homebridge/config.json um hier fortzufahren: https://github.com/dgreif/ring…ridge#basic-configuration.


    Ich bekomme allerdings die Fehlermeldung, dass dieses Verzeichnis nicht existiert. Wenn ich mir mit Cyberduck die Verzeichnisse des Pi anschaue, finde ich einen Ordner config.json unter /home/pi/node_modules. Auf dem Pi finde ich einen Ordner Homebridge unter root.


    So, nun habe ich im Terminal mal den nächsten Schritt eingegeben:

    Run the command with Your credentials for the Ring account

    $ npx -p ring-client-api ring-auth-cli

    npx: installed 168 in 29.448s

    This CLI will provide you with a refresh token which you can use to configure ring-client-api and homebridge-ring.

    Email: [email protected]

    Password: 123456



    Successfully logged in to Ring. Please remove your email/password from your config and add the following instead:



    "refreshToken": "eyJhbGcxxxxxxxxxxxxxxxxxxxuFWByT8A"


    Damit loggt sich der Pi auch korrekt bei Ring ein. Ich bekam eine Bestätigungsmail.


    Um dies alles aber korrekt zu integrieren, müsste ich doch auf die config.json zugreifen können und diese mit den entsprechenden Einträgen anzupassen.


    Mein Problem ist also, dass ich an diese Datei nicht ran komme.


    Ich fand auch ein Plugin Homebridge-config.json. Das habe ich auch mal installiert.


    Was mach eich denn falsch?


    Sorry, wenn ich so laienhaft frage. Aber ich komme an der Stelle nicht weiter.


    Und wenn ch schon dabei bin. Ich habe zwei Smartthings Geräte in meinem Netzwerk. Dafür habe ich diese Plugin gefunden: https://www.npmjs.com/package/homebridge-smartthings-v2-


    Auch der komme ich nicht weiter.


    Wäre super, wenn mir jemand helfen könnte.

  • Zitat von eltio

    Mein Problem ist also, dass ich an diese Datei nicht ran komme.

    Weil sie sich wehrt oder warum?


    Installationen, die per Homebridge-App vorgenommen worden sind, lassen sich nur schwer supporten. Die App macht nämlich folgendes: [keine Ahnung] und bei Änderungen passiert dann das: [keine Ahnung]. Fehler treten meist aus diesem Grund auf: [keine Ahnung]. Glasklar kann man feststellen: die App macht irgendwas und das irgendwie irgendwo. Du musst also nur irgendwas irgendwie irgendwo beheben.


    Hört sich blöd an und hilft dir kein Stück weiter, aber was soll ich machen? Es ist ja nicht so, dass ich diese App nicht auch gekauft hätte und ja, ich habe damit ebenfalls meine Erstinstallation gemacht und nein, es hat nicht so funktioniert, wie ich mir das vorgestellt habe. Hier im Forum gibt es einige (wenige), die ihre Homebridge mit der App betreiben können - ich gehöre leider nicht dazu. Die meisten hier behelfen sich mit dieser Anleitung.


    Man kann versuchen, seine Homebridge ohne config.json zu betreiben, aber das machen eigentlich nur diejenigen, die auch versuchen, ohne Herz zu leben. Letzteres ist nur schwer vorstellbar, ersteres überhaupt nicht. Die config.json liegt, je nachdem wie die Homebridge installiert wurde und wie sie betrieben wird, an unterschiedlicher Stelle, und bei dir ist es ganz sicher nicht /var/homebridge/config.json, sondern [keine Ahnung]. Ich weiß es einfach nicht.


    Dass ich jetzt auf eine andere Anleitung verweise, hört sich bestimmt ein bisschen komisch an, so als müsse man je nach Forum jedes mal seinen Raspi neu installieren, aber ich schlage es dir trotzdem vor. Ich behaupte mal ganz frech, dass es dein Leben mit Homebridge vereinfachen wird.


    Stefan

  • Vielen Dank für die schnelle Antwort.


    Und Joa, ich habe das so oder so ähnlich bereits vermutet/befürchtet... ;)


    Dann werde ich bei Gelegenheit mal der verlinkten Anleitung folgen.

  • Plugin läuft jetzt bei mir. Habe im Ordner "/lib/" alle Dateien mit denen von Github ersetzt nun läuft das Plugin. Seit kurzem gibt es sogar Unterstützung für Live Video.

    Funktioniert das Live Video bei Dir immer noch?

    Ich habe gestern homebridge-ring eingerichtet. Snapshot wird in HomeKit angezeigt und aktualisiert. Beim Live Video kommt immer der Fehler "Keine Antwort. Diese Kamera antwortet nicht".

  • FFmpeg hast du installiert?

    Ich nutze die letzte Version von Hoobs. Da sollte, lt. Hoobs FFMPEG bereits installiert sein.

    Ich werde aber trotzdem FFMPEG gleich installieren. Musstest Du die Einstellungen von FFMPEG nach der Installation anpassen? Wenn ja, kannst Du sie hier posten?

  • Ich nutze die letzte Version von Hoobs. Da sollte, lt. Hoobs FFMPEG bereits installiert sein.

    Ich werde aber trotzdem FFMPEG gleich installieren. Musstest Du die Einstellungen von FFMPEG nach der Installation anpassen? Wenn ja, kannst Du sie hier posten?

    Nein musste keine Einstellungen anpassen. Bei mir läuft das ganze unter macOS. Kann es sein das es ein spezifisches Problem mit Hobbs ist? Frag bei deren Support vielleicht mal nach.

  • Gude,

    kann mir jemand sagen ob das Ring-Plugin auch nur mir zwei Ring Chimes ( also keine Doorbell oder andere Ring-Produkte im Einsatz ) funktionieren würde ?

    Also, die Chimes per Trigger ( z.B. einen per homebridge in homekit eingebundenen Aqara Minischalter ) ansprechbar wären (= klingeln) ?


    Bin wie viele andere hier auf einer rein-Audio Klingel Suche, da wäre diese Kombination, falls es denn funktioniert, perfekt.

    ( btw., die Reaktion des Homepods als Klingel dauert mir zu lange, manchmal 5 Sekunden bis er anspricht, das scheidet also aus )

  • Hallöle,


    da ich im Moment alles umstelle auf HomeKit, aber die Kameras nicht eingebunden werden können, überlege ich Sie zu ersetzen.


    Rapsberry ist bestellt. Kann man die Ring Cam Outdoor und Indoor normal über Homebridge/Homekit dann über den RB4 integrieren und hat die gleichen Funktionen? Oder wäre es sinnvoller, die Cams zu verkaufen und neue Arlo oder Eve zu kaufen?

  • Tach zusammen,


    Ich habe meine ring doorbell 3 eingebunden.

    Allerdings kommt die Push nachricht in Homekit sehr spät (ca 10 sekunden)

    Bei den hibbeligen Postbosten heutzutage kann es hier schon zu spät sein :-)

    die ring app selbst funktioniert fast just in time.


    was genau kann ich da noch einstellen?


    mein config ist aktuelle noch sehr schmal.


    {
                "refreshToken": "xxx",
                "platform": "Ring",
                "hideCameraMotionSensor": true
            }



    danke euch

  • Hallo pillemats,


    wir haben die Doorbell 2 und ich nutze ebenfalls das PlugIn. Mir ist keine Einstellung / kein Parameter bekannt die/der Einfluss auf die Pushbenachrichtungen der Homeapp haben. Wir nutzen die App Rapid Ring (https://support.ring.com/hc/de…tionen-zur-Rapid-Ring-App) und NICHT Home für die Benachrichtigungen am Handy. Das funktioniert "just in time" und der "hibbelige Postboote" hat keine Chance zu entkommen, wenn wir das sind und er klingelt ;-)

  • Moin Zusammen,


    im Bereich Smarthome und auch Homebridge sehe ich mich aktuell noch als "Neuling" und so kommen mir auch schon die ersten Frage. In diesem Fall geht es um das folgende Plugin "homebridge-ring v9.12.8", welches ich gestern frisch auf meinem neu erhaltenem und anschließend mit Homebridge ausgestattetem Raspberry PI 4 installiert habe.


    Soweit funktioniert das Plugin eigentlich ganz gut, doch seitdem ich das Plugin installiert habe, sind mir zwei folgende Punkte aufgefallen:


    1) Meine Ring Video Doorbell 3 ist am Haus fest verdrahtet und somit wurde diese bis dato dauerhaft geladen. Seitdem ich jedoch gestern das Plugin installiert habe, zeigt mir die RING-App zwar als Stromquelle immer noch den Status "Festverdrahtet" an, doch beim Akku-Ladestand habe ich jetzt z.B. nur noch 92% und seit gestern auf heute konnte man feststellen, dass der Akkustand sich mindert. Kennt jemand dieses Problem?


    2) Ich weiß nicht, ob es am dem Plugin oder allgemein an der Homebridgeeinrichtung und dem Hinzufügen dieser als Bridge in das HomeKit zusammen hängt, doch in unregelmäßigen Abständen erhalte ich von meinem iPhone als Push-Benachrichtung erst eine Meldung "Keine der Steuerzentralen antwortet" und wenig später dann die Meldung "Eine Steuerzentrale antwortet". Diese Meldung kommt unabhängig von einem Geschehen... und ich kann mir diese Meldung nicht erklären. Vor dem Einsatz der Homebridge kam diese Meldung noch nie. Zur Info: Ich nutze zu Hause eine Apple TV, welche dauerhaft am Strom ist - aber natürlich nicht immer im direkten Betrieb, also so, wie es sich für ne Apple TV gehört, auch Mal im Standby Modus.


    Gibt es ansonsten Besonderheiten, welche ich eventuell im Zusammenspiel "HomeKit - Homebridge - homebridge-ring v9.12.8-Plugin" beachten sollte? Aktuell funktioniert das Ganze wie gesagt ganz gut - nur werde ich wohl, wenn ich 100% zufrieden bin, die Benachrichtigung via der RING-App abschalten, da ich aktuell einmal via App und einmal via HomeKit eine Mitteilung erhalte.


    Über Tipps und Tricks freue ich mich.


    Danke euch und beste Grüße

  • Hallo Zusammen,


    die oben genannten zwei Punkte (auch wenn es leider Keine Antwort gab) haben sich mehr oder weniger von alleine gelöst, doch aktuell kämpfe ich mit folgenden zwei neuen Problemen:


    [28/12/2020, 13:17:22] [Ring] Preparing Live Stream for Haustür

    [28/12/2020, 13:17:22] [Ring] Ding 6911280223942331746 is expired (480). Fetching a new ding and trying video stream again

    [28/12/2020, 13:17:24] [Ring] Stream Prepared for Haustür (1.808s)

    [28/12/2020, 13:17:26] [Ring] Streaming active for Haustür

    [28/12/2020, 13:17:42] [Ring] Live stream for Haustür appears to be inactive. (20.104s)

    [28/12/2020, 13:17:45] [Ring] Stopped Live Stream for Haustür

    [28/12/2020, 13:17:46] [Ring] Snapshot for Haustür failed to refresh after 70 attempts. This is normal behavior since this camera is unable to capture snapshots while streaming

    [28/12/2020, 13:17:46] [Ring] Failed to cache snapshot for Haustür (43.99s), The camera currently reports that it is online

    [28/12/2020, 13:17:46] [Ring] Failed to cache snapshot for Haustür (24.921s), The camera currently reports that it is online

    [28/12/2020, 13:17:46] [Ring] Failed to cache snapshot for Haustür (1.52s), The camera currently reports that it is online



    Ich verstehe es nicht... mal öffne ich die Cam via HomeKit und es läuft alles perfekt und dann aber, erhalte ich die oben genannte erste Fehlermeldung. Durchgehend jedoch erhalte ich dann die Fehlermeldung mit dem Snapshot. Ich habe es jedoch in der RING-App so eingestellt, dass er zwischenzeitlich gar keine Snapshot machen machen soll. Ich möchte lediglich, dass die Cam mich benachrichtigt, wenn der Bewegungsmelder eine Bewegung erkennt oder jemand klingelt.


    Weiß jemand, wieso die oben genannten Fehler auftauchen oder wie man diese beheben kann?


    Danke euch.

  • Ps: Jetzt .B. ging es perfekt...


    [28/12/2020, 13:32:40] [Ring] Preparing Live Stream for Haustür

    [28/12/2020, 13:32:41] [Ring] Stream Prepared for Haustür (1.527s)

    [28/12/2020, 13:32:41] [Ring] Streaming active for Haustür

    [28/12/2020, 13:32:42] [Ring] Received stream data from Haustür (1.717s)

    [28/12/2020, 13:32:50] [Ring] Stopped Live Stream for Haustür



    Sprich evtl. liegt oder lag es doch daran, dass man in kurzer Zeit versucht hat, die Kamera mehrmals aufzurufen? Falls es daran liegt, dann ok :-) ... dann bleibt aber noch der Punkt offen, wieso die Fehlermeldung mit den Snapshot auftaucht.