IP-Camera ffmpeg

  • Hey Ihr,


    habt ihr auch schon Irgendwelche IP-Cameras in eure HomeKit Umgebung mit Homebridge eingebunden?

    Ich würde Gerne Meinen Hikvision NVR dazu benutzen. Habe dazu die Anleitung versucht Homebridge IP-Camera.


    Leider Bekomme ich kein Bild Angezeigt. Weder Ein Livebild (Video) noch ein Standbild.

    Hat einer von euch schon Erfahrung in die Richtung?


    MfG

  • Code
    1. "name": "D-Link test Kamera",
    2. "videoConfig": {
    3. "source": "-re -f mjpeg -i http://admin:[email protected]/mjpeg.cgi -i http://admin:[email protected]/audio.cgi",
    4. "stillImageSource": "-f mjpeg -i http://admin:[email protected]/mjpeg.cgi",
    5. "maxStreams": 2,
    6. "maxWidth": 640,
    7. "maxHeight": 480,
    8. "maxFPS": 30
    9. }},

    Habe es mal so probiert mit meiner Test Kamera aber kein Ergebniss bzw. nur wieder das Schwarze Bild über den Link http://admin:[email protected]/mjpeg.cgi bekomme ich aber normal ein Bild aber keines in Home App.

    Ist der RasPi da vielleicht wenig zu schwach dafür?

  • Ich habe vorhin meine INSTAR 6014HD IP Kamera auf Anhieb mit Homebridge und dem "homebridge-camera-ffmpeg" Plugin in meine Homekit Umgebung intergriert. In der Apple Homekit App wird das Standbild alle 10 Sek. aktualisiert und auf das Livebild (Videostream) wird auch zugegriffen. Ich betreibe Homebridge auf meinem Ubuntu (16.04.2) Server.

  • Hallo,


    direkt zum Einstieg habe ich eine Frage zur Einbindung einer Hikvision Ip Kamera in Homekit.

    In der Home App von Apple funktioniert die Einbindung und nach einer kurzen Zeit ist sowohl das Standbild als auch der Livestream sichtbar.


    In der Elgato Eve App habe ich allerdings nur einen "Ein/Aus" Schalter für die Kamera. Hat jemand eine Idee wie ich das Kamerabild in die Eveapp bekommen.

    Wie bin ich bisher vorgegangen?


    Ich habe entsprechend diesem Tutorial ffmpeg installiert. Danach habe ich homebridge-ip-camera https://www.npmjs.com/package/homebridge-ip-camera installiert.

  • Kann ich bestätigen. Nutze die Logitech Circle2 mit offizieller HomeKit Unterstützung. Zeigt in der EVe App auch nur ein an/aus Schalter an, beziehungsweise ein Bewegungssensor an.


  • Ich habe die OMNA HD 180. Da wird mir in Eve auch ein Bild angezeigt.

    Habt ihr die Kamera bei „Auf einen Blick“ hinzugefügt? Nur dort hat man Zugriff auf das Bild.

  • Tatsächlich! Bei „auf einen Blick“ (komische Bezeichnung, Übersetzung-Fehler?) wird mir ein Live Bild angezeigt.


  • Kann sich diesen Fehler jemand anschauen?


    Mar 8 21:58:22 raspberrypi homebridge[1781]: events.js:160

    Mar 8 21:58:22 raspberrypi homebridge[1781]: throw er; // Unhandled 'error' event

    Mar 8 21:58:22 raspberrypi homebridge[1781]: ^

    Mar 8 21:58:22 raspberrypi homebridge[1781]: Error: spawn ffmpeg ENOENT

    Mar 8 21:58:22 raspberrypi homebridge[1781]: at exports._errnoException (util.js:1022:11)

    Mar 8 21:58:22 raspberrypi homebridge[1781]: at Process.ChildProcess._handle.onexit (internal/child_process.js:193:32)

    Mar 8 21:58:22 raspberrypi homebridge[1781]: at onErrorNT (internal/child_process.js:359:16)

    Mar 8 21:58:22 raspberrypi homebridge[1781]: at _combinedTickCallback (internal/process/next_tick.js:74:11)

    Mar 8 21:58:22 raspberrypi homebridge[1781]: at process._tickCallback (internal/process/next_tick.js:98:9)

    Mar 8 21:58:22 raspberrypi systemd[1]: homebridge-camera.service: main process exited, code=exited, status=1/FAILURE

    Mar 8 21:58:22 raspberrypi systemd[1]: Unit homebridge-camera.service entered failed state.

    Mar 8 21:58:32 raspberrypi systemd[1]: homebridge-camera.service holdoff time over, scheduling restart.

  • Lese mal mit, meine MotionEyeOs Cam wird in der Homebridge irgendwie nicht mehr gefunden, dabei hatte ich sie schon mal drin, nur wurde kein Bild angezeigt