Beiträge von Bankaifan

    Geht leider nicht. Weder öffnen, noch löschen noch Moven geht. Es kommt immer die Meldung das die Struktur bereinigt werden muss..

    Hm... ich glaube das einspielen des HB-Backup hat mir das System zerstört. Fang ich halt nochmal neu an.

    Dein filesystem ist inkonsistent,

    Solange das nicht repariert ist, kommt die Meldung immer wieder.

    So sollte es komplett sein:

    Code
    1. sudo su -c 'echo "FSCKFIX=yes" >> /etc/default/rcS'
    2. sudo touch /forcefsck
    3. sudo reboot & exit

    Hab ich gemacht. Bekomme jetzt ne Fehlermeldung beim Booten.




    Der vorgeschlagene Befehl gibt folgendes aus



    Das habe ich jetzt versucht, hat an dem Zustand nichts geändert außer dass jetzt wieder das ursprüngliche Problem besteht - über init.d startet die HB nicht mehr

    Der Aufruf ist unverändert.

    Ich habe jetzt ein Backup-Image eingespielt. Damit läuft es jetzt wieder. Dafür bekomme ich beim Boot diese Meldung (Siehe Anhang) - die den Bootvorgang blockiert und keinen SSH-Zugriff gestattet, bis ich CTRL+D drücke.


    Ich glaube, das hängt mit dem Backup (raspiBackup.sh) und dem Mount zusammen.
    Ich habe den USB-Stick nicht explizit über die fstab gemountet



    Code: /etc/fstab
    1. [email protected]:~ $ cat /etc/fstab
    2. proc /proc proc defaults 0 0
    3. /dev/mmcblk0p6 /boot vfat defaults 0 2
    4. /dev/mmcblk0p7 / ext4 defaults,noatime 0 1
    5. # a swapfile is not a swap partition, no line here
    6. # use dphys-swapfile swap[on|off] for that

    Hallo zusammen,


    habe mal wieder ein Problem. Und zwar, startet meine HB über init.d nicht mehr.
    Startcommand ist /etc/init.d/homebridge start (restart)

    Er legt dann auch sein PID-File an, aber die HB startet nicht. Es gibt nicht mal einen Log-Eintrag (keines der Files unter /var/log/ bis auf auth.log wird geändert)

    Hat jemand spontan ne Idee, woran das liegen könnte? War von einem Tag auf den Anderen (nächtlicher Reboot)

    Mit welchen Infos kann ich euch unterstützen?

    Das beschriebene Problem von dir hatte ich auch mit einem Lichtschlauch. Nach kurzem Kontakt mit dem Support wurde mir die Eve energy ausgetauscht und das Problem war behoben.



    Sent from my iPhone using Community


    Danke für den Tipp. Das probiere ich sofort

    Moin,


    ich hab in meiner Eve Energy im Schlafzimmer 3 LED-Vorhänge (fürs Himmelbett ;-)) stecken.
    Leider schaltet die Energy nicht ganz tot und es kommt noch minimal Strom durch. Dadurch glimmen und flackern die LEDs wie blöd - da kann kein Mensch schlafen.
    Das Phänomen kannte ich bisher nur von Stromleisten mit Kippschalter, der eine Statuslampe verbaut hat. Da glimmen LEDs auch, wenn man sie einsteckt.


    Hat jemand eine Idee, wie man das beheben könnte? Muss da noch ein zusätzlicher Verbraucher mit auf die Energy oder so?


    Besten Dank schonmal

    Ich finde es Quatsch, die App zu benutzen. Händisch geht es schneller, ist sicherer und man lernt und kann dann mal Fehler beheben.


    Ich nutze die App eigentlich nur für die Installation der HB aus Faulheit, um unterwegs am Handy ne Console und n Log zu haben und um meine Config-Backups zu verwalten.
    Heute wollt ich einfach mal sehen, was die Updatefunktion so treibt.


    Ich arbeite täglich mit Linux - allerdings RHEL und das verhält sich nunmal komplett anders als das Debian. Das hat nichtmal nen Vim nativ installiert. Nur den vi und den komischen nano...

    Ich hab das Update nochmal angeschossen über die App. Die ist mir zwischendurch mal abgeschmiert.

    Das Update hat dann statt dem aktuellen Node 8.9 installiert

    Danach ging kein sudo npm mehr - nur noch ohne sudo.
    also /usr/local/bin/npm i [email protected] aufgerufen und danach das update auf die neuste Node version angestoßen.
    Das ging nur auf 9.5 - also update auf 9.10.1 und npm nochmal sauber installiert.
    Dann npm rebuild und es lief wieder sauber.
    Hab den App-Entwicklern ne Mail geschrieben... da müssen sie nochmal ran.

    Ich brauche mal Hilfe.
    Habe die Update-Funktion aus der Homebridge-App genutzt. Jetzt kann ich NPM nicht mehr nutzen.


    npm WARN npm npm does not support Node.js v9.10.0

    npm WARN npm You should probably upgrade to a newer version of node as we

    npm WARN npm can't make any promises that npm will work with this version.

    npm WARN npm Supported releases of Node.js are the latest release of 4, 6, 7, 8.

    npm WARN npm You can find the latest version at https://nodejs.org/

    WARNING: You are likely using a version of node-tar or npm that is incompatible with this version of Node.js.

    Please use either the version of npm that is bundled with Node.js, or a version of npm (> 5.5.1 or < 5.4.0) or node-tar (> 4.0.1) that is compatible with Node.js 9 and above.

    npm[1093]: ../src/node_zlib.cc:436:static void node::{anonymous}::ZCtx::Init(const v8::FunctionCallbackInfo<v8::Value>&): Assertion `args.Length() == 7 && "init(windowBits, level, memLevel, strategy, writeResult, writeCallback," " dictionary)"' failed.

    Abgebrochen



    Node 9.10.0 hatte ich vor dem update schon.

    npm list -g --depth=0 gibt folgendes aus


    [email protected]:~ $ list-versions

    ###############################################

    Plugin Versionen:

    npm WARN npm npm does not support Node.js v9.10.0

    npm WARN npm You should probably upgrade to a newer version of node as we

    npm WARN npm can't make any promises that npm will work with this version.

    npm WARN npm Supported releases of Node.js are the latest release of 4, 6, 7, 8.

    npm WARN npm You can find the latest version at https://nodejs.org/

    /usr/local/lib

    ├── [email protected]

    ├── [email protected]

    ├── [email protected]

    ├── [email protected]

    ├── [email protected]

    ├── [email protected]

    ├── [email protected]

    ├── [email protected]

    ├── [email protected]

    ├── [email protected]

    ├── [email protected]

    └── [email protected]

    npm ERR! invalid: [email protected] /usr/local/lib/node_modules/npm/node_modules/tar/node_modules/minizlib

    NPM-Version

    5.6.0

    Node-Version

    v9.10.0



    Sieht so aus, als hätte die Update-Funktion ein Downgrade durchgeführt... von npm 5.8.0 auf 5.6.0 aber wie komme jetzt wieder auf 5.8.0 wenn npm nicht mehr geht?