Beiträge von Hunter

    Moin zusammen,


    den Bug bzgl. der Probleme mit Rattern und Co in Twitter, Instagramm ist mir ja bekannt, grad auch aus einigen YouTube Videos.


    Was ich festgestellt habe ist aber auch, dass die Kamera vom 14 Pro auch keine Auto Fokussierung macht scheinbar in Apps wie WhatsApp oder im Facebook Messenger.


    Hat jemand ein IPhone 14 Pro und kann dies verifizieren? Da das Problem sich anders äußert als bei den anderen 3. Anbieter Apps wollte ich gern mal horchen, ob das auch ein generelles Problem ist. Wenn man nach Autofokus sucht im Google findet man natürlich herrlich viele Ergebnisse zum Menüpunkt "Fokus" zur Zeit. :)

    Gibt es denn derzeit ein Zigbee Gerät was sauber an Deinem Raspbee arbeitet?

    Hast Du sonst mal geschaut, ob der Raspbee noch sauber aufgesteckt ist?

    Sonst vielleicht mal den Raspbee neu installieren und ein altes Backup der Leuchten einspielen.

    Moinsen,


    Ich hab mir einen Aquara Vibrationssensor an meinen Türgong gebastelt.

    Dieser löst auch sauber aus wenn es an der Tür klingelt und ich bekomme auch eine Push Nachricht aufs iPhone.


    Wie bekommt man eine Automation gebastelt, dass beim Auslösen des Sensors oder Dummy Switch, dass auf dem iPhone nicht nur eine Push Nachricht ankommt, sonern auch ein MP3 oder Klingelton etc abgespielt wird.


    Alternativ: gibt es schicke smarte Türgongs im Austausch des herkömmlichen Türgongs. Eine Doorbell mit Cam kann ich bei mir leider nicht wirtlich verbauen, da die Türklingel in einem Lichtschalter verbaut ist.

    Ich werd es mal probieren und berichte! :)


    Code
    [09/08/2022, 09:28:00] [Homebridge UI] Could not create a backup of the config.json file to /var/lib/homebridge/backups/config-backups EXDEV: cross-device link not permitted, rename '/var/lib/homebridge/config.json' -> '/var/lib/homebridge/backups/config-backups/config.json.1660030080738'

    Ausgeführt und Neustart des Servers durchgeführt. Leider noch nicht erfolgreich gewesen.

    Danke Dir trotzdem für Deine Bemühungen! sschuste


    Ich hatte bzgl des Fehlers in github Issues gelesen, dass wohl npm der Verursacher sein könnte? Ich hatte vorhin versucht mein npm v8.11 auf v8.16 zu erneuern aber irgendwie will sich das nicht sauber updaten. Und wer weiß, ob das überhaupt der Auslöser ist..

    det - hast Du denn mal probiert, die Schalter auf ein Licht anzulernen, ob Sie dann funktionieren? Ich nutze inzwischen die Hue Dimmer Switches für meine Rollos, da ich bei den Ikea Schaltern im Halbdunkel nie erkannt habe, welche Seite für "Auf" und welche für "Zu" war.


    Vielleicht war das Rollo oder der Schalter schon mal irgendwo eingebunden?

    Sonst den Schalter nochmal resetten und neu einbinden? Auf jeden Fall hatten die Schalter auch sauber bei mir funktioniert, wenn ich diese über den Conbee II in Homekit reingebracht hatte und dort konfiguriert hatte. Ich hatte das damals nur geändert, weil man unter Phoscon meine ich auch "Start -> "Stop" festlegen konnte.

    Moin sschuste,


    alles gut, ich bin doch nahezu für jede Schandtat zu haben und ich hab ja ein Backup aller Daten. :)

    Spannend ist aber, dass trotz SD Card Wechsel und neuen Aufsetzen der Homebridge, die Configs weiterhin nicht gesichert werden bei Änderung an der config.json. Die Ausgabe poste ich Dir gleich wenn ich mir den Zugang von der Arbeit zur Homebridge freigebaut habe. :)


    Spannend ist, dass gestern um 12:00:59 Uhr noch eine ganze Reihe an config.json Änderungen gespeichert wurde, vermutlich der Vorgang, wo ich gestern nochmal alles zurückgesetzt hatte an Plugins und dann das Backup eingespielt habe. Ist denn das Plugin config-ui-x für die Sicherungen verantwortlich oder schreibt die Homebridge selbst diese Sicherung?


    Und grad gesehen:

    Release Notes

    4.50.1 (2022-08-09)

    Bug Fixes

    • Dashboard: Fix an issue displaying the log viewer and termial widgets on Chrome > 104 (#1400)
    • Backups: Fixed an issue restoring backups when the Homebridge storage directory is a symbolic link
    • Backups: All symbolic links are dereferenced when performing a backup (the raw symlink is backed up, not what it pointed to)


    Ok .. auch weiterhin nach dem Update die Meldung:


    Code
    Could not create a backup of the config.json file to /var/lib/homebridge/backups/config-backups EXDEV: cross-device link not permitted, rename '/var/lib/homebridge/config.json' -> '/var/lib/homebridge/backups/config-backups/config.json.1660027318712'
    Code
    [email protected]:/var/lib/homebridge $ ps aux | grep home
    avahi 358 0.5 0.1 7312 3280 ? Ss Aug08 6:53 avahi-daemon: running [homebridge.local]
    pi 9411 0.0 3.5 179344 67108 ? Ssl Aug08 0:20 /opt/homebridge/bin/node server.js
    pi 10127 0.0 0.0 7452 600 pts/0 S+ 08:29 0:00 grep --color=auto home
    pi 22025 4.0 13.8 372132 266120 ? Sl Aug08 34:48 homebridge

    Wir haben hier 2 von den Meross Nachtischlampen im Einsatz. Diese sind über Wlan direkt in Homekit drin. Wochenlang hatte ich immer wieder den Ausfall einer Lampe. Bis ich irgendwann gemerkt hab, dass sich die Lampen nicht nur mit dem Repeater ums Eck verbunden hatten, sondern auch mal direkt mit dem weit entfernten Router. Seitdem ich den Lampen zugeflüstert hab, wie ihr Routing laufen soll, hatte ich keine Ausfälle mehr.

    sschuste Ohje das hat die Situation nicht verbessert.

    Jetzt bekomme ich jede Menge rote Zeilen... :)


    Kann man das wieder rückgängig machen? Die Homebridge stürzt jetzt dauerhaft ab. :/

    Ok - Nach einem Neustart hat sich die Homebridge wieder gefangen .. puh. Aber der Fehler für die Config Backups kommt weiterhin. Schade. Spannenderweise sind aber config.json Sicherungen im Ordner. Na, ich werde das mal weiter beobachten.


    Schon mal vielen Dank sschuste

    Moin zusammen,


    nachdem ewig meine NFS Freigabe vom NAS für die Backups vom Pi nicht funktionieren wollte, hatte ich vorhin mal die Dropbox Variante ausprobiert von sschuste. Das hatte soweit auch schon funktioniert aber lustigerweise hatte dann auch auf einmal meine NFS Freigabe vom NAS direkt funktioniert.


    Nur leider habe ich mir jetzt die beiden Backup Ordner für die automatischen config.json Backups zerschossen und vermutlich auch für die Instance-backups.

    Beide Ordner unter /var/lib/homebridge/backups waren auf einmal nicht mehr vorhanden.

    Ich habe diese dann wieder händisch angelegt aber vermutlich stört sich config-ui-x nun an den Berechtigungen.

    Mache ich nun eine Änderung im config.json File so bekomme ich folgende Fehlermeldung:


    Could not create a backup of the config.json file to /var/lib/homebridge/backups/config-backups EXDEV: cross-device link not permitted, rename '/var/lib/homebridge/config.json' -> '/var/lib/homebridge/backups/config-backups/config.json.1659912671509'


    Wenn ich die Datei wie vorgeschlagen einfach nur benenne ist mir damit ja am Ende nicht wirklich geholfen oder sehe ich das falsch.

    Gibt es eine Chance, die Backup Ordner wieder sauber einzurichten, dass mir beide Backups wieder angelegt werden?


    Danke für Eure Hilfe!


    EDIT: Ok, die instance-backups funktionieren! Hier habe ich auch nochmal den Pfad hinterlegt in der config.json. Aber Änderungen an der config.json werden nicht mehr zwischengespeichert im config-backups Ordner.