Versionsupdates: iOS, macOS, Homebridge, npm, Node.js, Plugins, Apps, Firmware und sonstiges ...

  • Moin Moin,


    ich dachte ich mach mal einen Thread auf in dem Versionsupdates gepostet werden können.


    Also wenn jemanden auffält das irgendwas ein Update oder ähnliches bekommen hat bitte hier posten.


    Macht es ab und zu vieleicht einfacher es mitzubekommen wenn es was neues gibt ;)


    Ich mach mal den Anfang:


    Node.js ist in Version 7.10.0 am 03.05.2017

    Homebridge in Version 0.4.20 am 02.05.2017


    Gruß Nastra

  • Danke det homebridge-hue Version 0.4.1 war die Lösung zum Fehler hue API 1.18???



  • homebridge-platform-wemo Version 1.1.9 am 04.05.2017

    npm 4.6.1 am 04.05.2017

    The only way to do great work is to love what you do !

    Einmal editiert, zuletzt von Nastra ()

  • Ich hätte mal eine Verständnisfrage.

    Nach was richtet sich die Node.js Version?

    Ich habe die 7.6.0 und mir wird auch nix neueres angeboten.

  • Node.js z.B. wird dir bei den normalen Updates nicht angezeigt deswegen ja auch der Thread hier .-)


    Schau mal hier:

    https://nodejs.org/en/


    Wie du es Updates findest du in der Befehlssammlung unter Anleitungen.

    The only way to do great work is to love what you do !

  • Hey det , was meinst du mit da holt es sich auch mein Tool? Und wenn ich sudo npm i [email protected] -g mache, komme ich nur auf die npm-version 4.5.0. Es gibt doch aber schon 4.6.1 bzw davor 4.6.0? Hat jemand eine Idee warum das so ist?



    Einmal editiert, zuletzt von xMAIKx ()

  • homebridge-broadlink-rm 2.3.7

    homebridge-hue 0.4.2

    The only way to do great work is to love what you do !

  • Hey det , was meinst du mit da holt es sich auch mein Tool? Und wenn ich sudo npm i [email protected] -g mache, komme ich nur auf die npm-version 4.5.0. Es gibt doch aber schon 4.6.1 bzw davor 4.6.0? Hat jemand eine Idee warum das so ist?

    Geb mal sudo npm i [email protected] -g ein dann zieht er die current version

    The only way to do great work is to love what you do !

    Einmal editiert, zuletzt von Nastra ()

  • Geb mal sudo npm i [email protected] ein dann zieht er die current version

    Das hat bei mir leider nicht geklappt ...


    [email protected]:~ $ sudo npm i [email protected]


    /home/pi

    ??? [email protected]

    npm WARN enoent ENOENT: no such file or directory, open '/home/pi/package.json'

    npm WARN pi No description

    npm WARN pi No repository field.

    npm WARN pi No README data

    npm WARN pi No license field.

    [email protected]:~ $


    Das Update auf node.js 7.10.0 hat erfolgreich geklappt.

    3 Mal editiert, zuletzt von No.Trace () aus folgendem Grund: kleine Nachträge

  • No.Trace welche Variante hast du für das Node Update genommen??



  • xMAIKx


    Ich habe mir spontan für die Variante II entschieden ;)

    Und für meinen "Raspberry Pi Model B Rev" diesen Link zu node.js genommen - https://nodejs.org/dist/v7.10.….10.0-linux-armv6l.tar.xz


    Habe es genau wie in de Anleitung gemacht ... aber vorher mein pilight und homebridge gestopt.


    Gruß Kai

    Einmal editiert, zuletzt von No.Trace ()

  • Danke, werde es mal am Wochenende ausprobieren. NPM macht bei mir dieselbe Fehlermeldung wie bei dir.?



  • Kein Problem ... ich werde mal sehen ob ich mit "sudo npm i [email protected] -g" wieder auf die npm 4.5.0 komme,

    irgendwie bin ich wieder bei 4.2.0 gelandet ... so ganz habe ich das noch nicht verstanden ;)


    ... bin nun wieder auf 4.5.0 hoch ... hat gelappt.


    Viel Erfolg ...

    Einmal editiert, zuletzt von No.Trace ()

  • Nastra Wo kann ich eigentlich sehen, was von node und npm eigentlich die gerade aktuelle version verfügbar ist, bevor ich die installiere?

    Und gibt es für npm einen unterschied welcher Raspberry es ist? Irgendwie hat nämlich npm auf 4.6.1 bei mir nicht funktioniert. Zumindest aber wieder auf 4.5.0 und alles läuft.

    Danke vorab.

    Hilfreich?

  • Moin ...


    mit diesem Befehl kannst Du prüfen ob Updates verfügbar sind: "sudo npm outdated -g" (steht zum Glück alles in der SSH Befehlssammlung).

    Welche Version Du hast, kannst Du mit "npm -v" oder "node -v" herausfinden.

    Ich glaube die npm ist nicht von der Hardware abhängig, aber bei der node.js gibt es verschiedene CPU-Versionen, da habe ich auf der node Homepage

    - https://nodejs.org/en/download/current/ - nachgesehen und das Update über die Variante II aus der SSH Befehlssammlung genommen.


    Auch bei mir hat das Update auf npm 4.6.1 nicht geklappt ... steht ja weiter oben schon, aber die 4.5.0 geht ;)

    Frag mich aber nicht was das für Änderungen oder Verbesserungen gibt ... das frage ich mich auch ...


    CU Kai

  • Zitat

    Nastra Wo kann ich eigentlich sehen, was von node und npm eigentlich die gerade aktuelle version verfügbar ist, bevor ich die installiere?

    npm entweder als Befehl wie oben schon beschrieben (sudo npm outdated -g) oder hier auf der github Seite https://github.com/npm/npm/releases


    node.js siehe einen Beitrag höher.


    Zitat

    Und gibt es für npm einen unterschied welcher Raspberry es ist?

    Nicht das ich wüsste, ich glaube das ist nur bei Node.js der fall.


    Zitat

    Irgendwie hat nämlich npm auf 4.6.1 bei mir nicht funktioniert. Zumindest aber wieder auf 4.5.0 und alles läuft.


    Bei mir hat es ohne Probleme funktioniert:



    Ich kann mich erinnern das bei früheren Updates manchmal die Aktualisierung bei mir auch nicht auf anhieb geklappt hat. Probier einfach mehrmals nacheinander npm zu aktualisieren ich meine bei mir hat es dann meistens geklappt.

    The only way to do great work is to love what you do !

  • Zitat

    Frag mich aber nicht was das für Änderungen oder Verbesserungen gibt ... das frage ich mich auch ...

    Das geht uns allen so 8o

    The only way to do great work is to love what you do !

  • Ich kann mich erinnern das bei früheren Updates manchmal die Aktualisierung bei mir auch nicht auf anhieb geklappt hat. Probier einfach mehrmals nacheinander npm zu aktualisieren ich meine bei mir hat es dann meistens geklappt.

    Na dann werde ich es zwischendurch mal wieder versuchen, vielleicht klappt es ja dann ;) Danke für den Tip ...


    Wie sieht denn Eure '/home/pi/package.json' Datei aus ... ggf. könnte es daran liegen, ich hatte erst keine und habe dann eine mit

    sudo npm init eine erstellt, aber die war wohl nicht ganz richtig ... weiss auch nicht genau was da rein muss ...


    Habe eine package.json gefunden, aber auch in dem Odner lässt sich 4.6.1 nicht installieren

    Naja ... mal weiter testen ...

    2 Mal editiert, zuletzt von No.Trace ()