Verbindung Homebridge zu HomeKit

  • Hallo,


    ich habe das Problem, wenn ich das App "Home" öffne, werden Philipps Hue Lampen, Tado usw. sofort angezeigt. Diese wurde direkt mit HomeKit verbunden.

    Bei Homebridge Geräten steht am Anfang "aktualisieren" und dann "keine Antwort"


    Erst wenn ich in das jeweilige Geräte direkt reingehe, dauert es kurz und dann aktualisiert sich der Status bei allen Homebridge Geräten.

    An was kann das liegen?


    Vielen Dank.

  • An was kann das liegen


    klassische Netzwerk Laufzeiten. Die Anfrage geht von HomeKit an Homebridge und die muss den Status mitteilen


    das dauert lang.


    Aber Gründe hier gibt es viele.
    lahmes Netz wifi etc

    Lahmer Raspi

    Viele Geräte

    ...

    //.ichael

    -----------------------------------


  • Ich habe jetzt Apple TV und Homebridge mit dem Netzwerk verbunden.

    Leider keine Verbesserung.


    Wenn das Home App offen ist und offen bleibt gibt es keine Probleme.

    Sobald ich aber das Iphone sperre und dann wieder ins Home App reingehe, dauert es ca. 6-8 Sekunden, bis die Geräte der Homebridge sich aktualisieren.

    Die Geräte die direkt mit Homekit verbunden sind, sind sofort da.


    Ich bin der Meinung ist liegt an einer Einstellungssache an der Homebridge. Kommt mir so vor, wie die in einen Standby Modus geht.

  • Ich bin der Meinung ist liegt an einer Einstellungssache an der Homebridge. Kommt mir so vor, wie die in einen Standby Modus geht.

    ehrlich gesagt wäre mich das neu. Ich habe derzeit noch die 0.4.53 weil die 1.04 bei mir nicht läuft. und ich habe auch gelegentlich eine Verzögerung drin. Mich hat die nie gestört. Ich habe 12 Räume und 127 Geräte im Homekit.

    Wobei mir die 8 Sekunden schon lange vorkommen.

    Seit ich eine PI 4 habe ist es auch besser geworden. Davor musst ich mit Wischgesten den Raum wechseln um aktuellen Status zu bekommen.


    Also wenn du die Latenz Zeiten mit Kabel Anschluss verringert hat, dann mach mal einen einfachen Test und Dinge mal mit einem terminal Programm deine HB vom iPhone aus an und sieh dir die einzelnen ping Zeiten mal an.


    Vielleicht sieht man hier stark unterschiedliche Laufzeiten.


    Wenn ja - da habe ich auch bei Mutter Erfolg gehabt, hab ich die QS Einstellungen des Routers eingestellt.


    Jedenfalls müsste ich nicht, wie du die Reaktionszeit der HB beschleunigen kannst.

    //.ichael

    -----------------------------------


  • Das ist wohl eher ein Problem der Home-App. Mit Controller, Home+ etc. sind Homebridge-Geräte bei mir sofort da.

  • NAbend.


    Ich würde gerne nochmal kurz in die Runde fragen, ob das Thema Noch aktuell ist. Auf GitHub gibt es ja auch zahlreiche User, die den plötzlichen Verbindungsverlust erwähnen.

    Ich habe nun auch schon hin und her gebastelt, Node Versionen getauscht, Plugins deaktiviert, aber immer wieder kommt es zum Verbindungsabbruch ( nach mehreren Stunden von HomeKit zur Homebridge. Ein Neustart löst das Problem immer sofort.

    Da ich hier nicht so viel davon lese, scheint es sich um Einzelfälle zu handeln.

    Es gibt hier also genug User, die unter 1.1.0 keine Probleme mit der HomeKit App haben?

    Gibt es sonst noch Ideen, die Abhilfe schaffen könnten?

  • Also die Verbindungsgeschwindigkeit dauert immer noch lange. Aber ist besser geworden.

    Mich hat ein Nutzer vor kurzem angeschrieben und er meint es liegt auch am Homematic App und er ist von Hoobs deswegen wieder weggegangen, weil die Verbindung nicht stabil läuft.


    Was setzt du ein?

  • Moin,


    bei mir hat es sich ein wenig verändert. Die Zeitspanne bis zu einem Abbruch ist auf ein paar Tage angewachsen, ich setze folgende Plugins ein:


    automation-switches

    config-ui-x

    fritz-platform

    hue

    ifttt

    people

    telegram

    weather-plus

    shelly

    zp

    delay-switch

    http-webhooks

    Blinkcameras

    alexa

    delayswitch

    notification

    dummy

  • Nachdem ich mir nun einen CronJob angelegt habe und die Homebridge täglich neu starte, läuft alles reibungslos. Auch wenn ich den Fehler eher ignoriere, der im GitHub immer noch offen ist.

    Spricht irgendetwas gegen einen täglichen Reboot der Homebridge?

  • alexa

    kannst du mal testweise - wenn es keinen immensen Aufwand bedeutet - Alexa und diese Telegram deaktivieren. Ich kann mich vage daran erinnern in der Kombi mal was gelesen zu haben. Bei Alexa fließt recht viel Netzwerkkram herum und die HB wartet mal schon etwas auf die anderen. Daher könnte ich ir vorstellen, dass es daran liegen könnte.

    Mit Telegram und Alexa zusammen hatte ich auf einer Probier HB mal stress. Keine Abstürzte eher Fehler beim hochlaufen und es brauchte zwei Neustarts.


    Und ZP hab ich bei mir auch laufen und das erzeugt jede menge Meldungen im Log. geht zwar alles, aber viel Heart Beats und ähnliches.


    Sind auf jedenfalll ne menge Plugins.


    Spricht irgendetwas gegen einen täglichen Reboot der Homebridge?

    Mein IT Herz verkrampft sich ... sonst nix. Ist einfach ein mieser Workarount.

    //.ichael

    -----------------------------------


  • Hey, ich versuchs mal mit dem Deaktivieren des Alexa Plugins, brauche das eigentlich nur für einen Badschalter und das auch nur, wenn ich vergessen habe den Lichtschalter zu drücken :) Vielleicht hilft es ja. Ich bin nur überrascht dass sehr viele User diesen Fehler haben, aber hier scheinbar nicht so das Thema ist. Wir werden sehen... Danke schon mal.

  • Spricht irgendetwas gegen einen täglichen Reboot der Homebridge?

    Nichts. Ich starte meine Homebridge mehrmals wöchentlich, meist dann wenn ein Plugin-Update gelaufen ist, meinen Raspi dagegen starte ich sehr selten neu.


  • Also ich habe jetzt die Erfahrung auch gemacht, dass ein täglich Neustart extrem viel hilft.

    Hoobs bzw. Homebridge läuft stabil und schnell.


    Kann ich jeden nur empfehlen.