Raspberry Pi an neuen Router anlernen

  • Hallo Community,


    folgende Netzwerkkonfiguration Zuhause:


    Ich habe an meinem Kabelmodem (192.168.0.1) noch ein Airport Extreme (192.168.0.2) hängen, der sich um das WLAN kümmert. Bisher habe ich über den DHCP des Kabelmodems und dem Airport im Bridge-Modus die IP-Adresse einfach durchgereicht, so hatte das Raspberry Pi die IP 192.168.0.8.


    Jetzt habe ich den Airport rausgeschmissen und durch ne Fritzbox 4040 ersetzt. Die Fritzbox so konfiguriert, dass die ein eignes Subnetz/IP-Adressbereich aufspannt (192.168.10.1). Ich dachte eigentlich, dass ich den raspbi mit homebridge einfach an den neuen Router anschließen kann und sich eine neue IP Adresse holt. Dem scheint nicht so.


    Zuvor hat das RaspPi über die MAC-Adresse in den Einstellungen des Kabelmodems eine statische IP bekommen. Da habe ich nun die MAC-Adresse vom Pi rausgeschmissen, somit hat er keine statische IP mehr.


    Am Pi selber habe ich niemals eine Netzwerk-Konfiguration vorgenommen, da direkt per LAN am Airport/Fritzbox angeschlossen. Daher wundert es mich, dass es hier Probleme gibt.


    Wo muss ich ansetzen? in der /etc/dhcpcd.conf bzw. interface eth0?


    Neustart vom Pi hat nichts gebracht, damit er sich vom neuen IP-Adressbereich eine neue Adresse holt.


    Danke!

  • Hallo,

    Es ist sehr komisch das er keine neue IP Adresse bekommen hat. (war bei mir auch das Problem) ich habe die IP Adresse einfach Manuell eingestellt. Also mein alter Router hatte z.B 192.168.10.X und mein neuer 192.168.0.X (habe jetzt einfach mal deine Zahlen genommen) und dann habe ich den Raspberry angeschlossen und ich hatte noch die alte IP Adresse (also z.B die hier 192.168.10.100) dann habe ich einfach die neue IP Adresse vom Router genommen (Im Beispiel jetzt die 192.168.0.X) und habe einfach statt dem X eine Zahl hingeschrieben die noch nicht vergeben war

    LG

  • Der Raspi verwendet normalerweise keine statische IP-Adresse. Er sollte ganz normal einen DHCP-Server fragen, wenn er nach einem Neustart eine IP-Adresse benötigt. Normalerweise fragt der Raspi alle 24 Stunden nach der Adresse (zumindest wenn es der Kabelmodem-DHCPd so vorgegeben hat). Aber nach einem Neustart?


    Es gibt viele Möglichkeiten, dem Raspi eine statische IP-Adresse zu verschaffen. Ich habe meinem eine verpasst, und ich habe das in /etc/dhcpcd.conf gemacht. Dazu musste ich extra ein paar Zeilen anfügen:


    # A sample configuration for dhcpcd.

    # See dhcpcd.conf(5) for details.


    # Allow users of this group to interact with dhcpcd via the control socket.

    #controlgroup wheel


    # Inform the DHCP server of our hostname for DDNS.

    hostname


    # Use the hardware address of the interface for the Client ID.

    clientid

    # or

    # Use the same DUID + IAID as set in DHCPv6 for DHCPv4 ClientID as per RFC4361.

    # Some non-RFC compliant DHCP servers do not reply with this set.

    # In this case, comment out duid and enable clientid above.

    #duid


    # Persist interface configuration when dhcpcd exits.

    persistent


    # Rapid commit support.

    # Safe to enable by default because it requires the equivalent option set

    # on the server to actually work.

    option rapid_commit


    # A list of options to request from the DHCP server.

    option domain_name_servers, domain_name, domain_search, host_name

    option classless_static_routes

    # Respect the network MTU. This is applied to DHCP routes.

    option interface_mtu


    # Most distributions have NTP support.

    #option ntp_servers


    # A ServerID is required by RFC2131.

    require dhcp_server_identifier


    # Generate SLAAC address using the Hardware Address of the interface

    #slaac hwaddr

    # OR generate Stable Private IPv6 Addresses based from the DUID

    slaac private


    # Example static IP configuration:

    #interface eth0

    #static ip_address=192.168.0.10/24

    #static ip6_address=fd51:42f8:caae:d92e::ff/64

    #static routers=192.168.0.1

    #static domain_name_servers=192.168.0.1 8.8.8.8 fd51:42f8:caae:d92e::1


    # It is possible to fall back to a static IP if DHCP fails:

    # define static profile

    #profile static_eth0

    #static ip_address=192.168.1.23/24

    #static routers=192.168.1.1

    #static domain_name_servers=192.168.1.1


    # fallback to static profile on eth0

    #interface eth0

    #fallback static_eth0

    interface wlan0

    static ip_address=192.168.1.22/24

    static routers=192.168.1.1

    static domain_name_servers=192.168.1.22


    Die letzten vier Zeilen sollten in deiner dhcpcd.conf fehlen.


    https://www.elektronik-kompend…/raspberry-pi/1912151.htm beschreibt, wie man auf welche Arten eine statische Adresse setzen kann. Möglicherweise kannst du diese Anleitung gebrachen, wenn du eine statische Adresse entfernen willst.


    Und wichtig: du solltest nur einen einzigen DHCP-Server in deinem Netzwerk betreiben. Schalt den auf dem Kabelmodem zur Not aus.

  • Danke euch für die Antworten!

    Und wichtig: du solltest nur einen einzigen DHCP-Server in deinem Netzwerk betreiben. Schalt den auf dem Kabelmodem zur Not aus.


    Das könnte das Problem sein, nur leider lässt sich DHCP in meinem Kabelmodem (Vodafone Box, Compal CH7466CE) nicht deaktivieren, auch der DNS nicht ändern (u.a. deswegen der zweite Router mit angeschlossenen Pi-Hole)


    Ich möchte aber ungern das Kabelmodem in den Bridge-Mode versetzen, da dann alles zur Fritzbox durchgeschleift wird und die direkt im Internet steht. Ich hätte das Kabelmodem gerne weiterhin als erste Barriere. Aktuell ist es eine Router-Kaskade wo zwar Geräte von Router 2 auch ins Internet kommen, Aber Router 1 nicht ins Subnetz und nur der Router 2 angezeigt bekommt, aber nicht welche Geräte dahinter noch dranhängen.


    Hier meine DHCPCD.conf:


    # generated by deCONZ

    # A sample configuration for dhcpcd.

    # See dhcpcd.conf(5) for details.


    # Allow users of this group to interact with dhcpcd via the control socket.

    #controlgroup wheel


    # Inform the DHCP server of our hostname for DDNS.

    hostname


    # Use the hardware address of the interface for the Client ID.

    clientid

    # or

    # Use the same DUID + IAID as set in DHCPv6 for DHCPv4 ClientID as per RFC4361.

    # Some non-RFC compliant DHCP servers do not reply with this set.

    # In this case, comment out duid and enable clientid above.

    #duid


    # Persist interface configuration when dhcpcd exits.

    persistent


    # Rapid commit support.

    # Safe to enable by default because it requires the equivalent option set

    # on the server to actually work.

    option rapid_commit


    # A list of options to request from the DHCP server.

    option domain_name_servers, domain_name, domain_search, host_name

    option classless_static_routes

    # Most distributions have NTP support.

    option ntp_servers

    # Respect the network MTU. This is applied to DHCP routes.

    option interface_mtu


    # A ServerID is required by RFC2131.

    require dhcp_server_identifier


    # Generate Stable Private IPv6 Addresses instead of hardware based ones

    slaac private


    interface wlan0

    static ip_address=192.168.8.1/24

    interface eth0

    static ip_address=192.168.0.8/24

    static routers=192.168.0.1

    static domain_name_servers=46.182.19.48 80.241.218.68


    Komisch, dass die letzten vier Zeilen überhaupt definiert sind. Hab die DHCPCD.conf nie angerührt.


    EDIT: so, nach Löschen der letzten vier Zeilen habe ich tatsächlich das Pi in den neuen IP-Adressbereich bekommen. Nun ist wie gewohnt über die IP-Adresse die deCONZ/Phoscon App aufrufbar, sowie über Port :8080 Homebridg-Config-UI und über Port :8081 das Pi-Hole Admin-Panel.


    Danke!

    3 Mal editiert, zuletzt von Patrick_ ()

  • Noch eine Ergänzung: Der Übeltäter des Ganzen war tatsächlich das Pi-Hole! Ich hatte das erst vor einigen Tagen zusätzlich neben Homebridge installiert und der bei der Installation sich öffnende Konfigurator hat bei den Fragen


    "Do you want to use your current network settings as a static address?"


    IP adress: 192.168.0.8/24

    Gateway: 192.168.0.1


    und bei


    "select your Upstream DNS Provider: Custom"


    46.182.19.48 80.241.218.68 (DNS von DigitalCourage)


    dann wohl die vier Zeilen in die dhcpcd.conf geschrieben. Das hatte ich nicht bedacht.


    Jetzt habe ich die vier Zeilen nicht gelöscht, sondern lediglich die IP Adresse und Gateway angepasst, da ich das für die Pi-Hole Konfiguration weiterhin benötige.

    Einmal editiert, zuletzt von Patrick_ ()

  • Ich hätte das Kabelmodem gerne weiterhin als erste Barriere. Aktuell ist es eine Router-Kaskade wo zwar Geräte von Router 2 auch ins Internet kommen, Aber Router 1 nicht ins Subnetz und nur der Router 2 angezeigt bekommt, aber nicht welche Geräte dahinter noch dranhängen.

    Wenn das nur ein Kabelmodem ist, dann gibt es keine Barriere. Vorsicht mit den Begriffen: ein Modem ist etwas anderes als ein Router. Also hat das Kabelmodem auch Routerfunktionen, oder? Muss ja eigentlich, wenn dein Airport im Bridge-Modus dranhing.

  • Ne ne, schon ein "vollwertiger" Router. Habe mich falsch ausgedrückt. Er ist nur enorm abgespeckt von den Funktionen her, weil Vodafone natürlich nicht will, dass damit rumgebastelt wird. Er könnte theoretisch auch WLAN, aber das hätte ich für 2,99 EUR zum Vertrag zubuchen müssen, Frechheit.

  • Ich würde mich hier einmal anhängen. Da ich aktuell den Router und damit WLAN wechsle... reicht es, wenn ich im Part 1 der Anleitung für einrichten von Homebridge die Datei mit neuer ssid etc überarbeite? Oder braucht es mehr?

  • Wenn dein Pi über WLAN am Router hängt, sollte es ausreichen, wenn du die SSID und Passwort in der wpa_supplicant.conf änderst.


    IP-Adresse holt er sich vom neuen Router über DHCP dann selber wieder, außer du hast wie ich Pi-Hole installiert, dann wurde auch bei dir eine statisches IP-Adresse auf dem Pi in die dhcpcd.conf geschrieben.

  • Ich würde mich hier einmal anhängen. Da ich aktuell den Router und damit WLAN wechsle... reicht es, wenn ich im Part 1 der Anleitung für einrichten von Homebridge die Datei mit neuer ssid etc überarbeite? Oder braucht es mehr?

    In der Anleitung steht nicht, wie du das machst. Da ist die Ersteinrichtung beschrieben . Wie Patrick_ schon schreibt, musst du deine WLAN-Daten neu setzen mit:


    sudo nano /etc/wpa_supplicant/wpa_supplicant.conf


    Was dir natürlich außerordentlich schwerfallen wird, wenn du dich nicht mehr auf den Raspi einloggen kannst :huh:. Daher schließ ihn erstmal per LAN-Kabel an.

  • Schmeiß halt die Infos von deinem WLAN wieder aus der wpa_supplicant.conf raus.


    sudo nano /etc/wpa_supplicant/wpa_supplicant.conf