Homebridge startet (scheinbar) nicht mehr

  • Ich komme seit eben nicht mehr auf. Ich komme nicht mehr aufs Webinterface - per SSH komme ich aber aufs Gerät. Ab und zu geht auch irgendwie mal ne Lampe, aber eher im AUsnahmefall. Leider habe ich keine Ahnung von Linux - jemand eine Tipp, was ich tun kann.



    Dann dachte ich, ich update mal die UI über SSH -> Siehe da: Error, die ich nicht verstehe

    Einmal editiert, zuletzt von DJay () aus folgendem Grund: Ein Beitrag von Bizzy mit diesem Beitrag zusammengefügt.

  • sudo npm install -g --unsafe-perm homebridge homebridge-config-ui-x

    Damit installierst oder updatest du homebridge und homebridge-config-ui-x.


    npm WARN deprecated [email protected]

    Ignorieren.


    npm ERR! rofs EROFS: read-only file system,

    Ich würde erst mal den Raspi neu booten und es dann noch mal versuchen. Könnte ein kaputtes Dateisystem sein, dass dann bei Reboot repariert wird.


    Wenn das nicht klappt, würde ich so vorgehen:

    sudo su -

    npm uninstall -g --unsafe-perm homebridge-config-ui-x

    npm install -g --unsafe-perm homebridge-config-ui-x

  • Neu gestartet hatte ich das Ding gezwungenermaßen schon mehrmals :-D Aber der 2. Befehl schmeißt schon folgendes:

  • Na, das sieht ja richtig kaputt aus. Der Installer npm hat's hinter sich.

  • Na, das sieht ja richtig kaputt aus. Der Installer npm hat's hinter sich.

    Was kann ich da nun machen? Neu aufsetzen wäre der Horror, das bekomme ich nie wieder so ans laufen 🤣
    Kriegt man das irgendwie repariert?

    Und du hast mir jetzt schon 2 oder 3 mal so geholfen, dass es danach wieder ging - kann man sich iwie revanchieren? Gibt es ein Spendenkonto oder sowas? 😁🙌

  • Gibt es ein Spendenkonto oder sowas?

    Ja, das gibt es, aber es gibt nicht genug Geld ;(.


    Neu aufsetzen wäre der Horror, das bekomme ich nie wieder so ans laufen 🤣

    Die Frage ist: warum ist npm kaputt? Das passiert normalerweise dann, wenn das Dateisystem des Raspi beschädigt wird, aber warum ist das beschädigt? Du hast möglicherweise eine kaputte SD-Card, und dann kommst du um eine Neuinstallation eh nicht herum.


    Wenn es nur um die Homebridge geht, dann ist die Sache nicht so schwer. Befindet sich auf dem Raspi noch andere Software, dann wird es schon schwieriger. Ich weiß natürlich nicht, was bei dir so los ist.


    Auf jeden Fall solltest du von deiner config.json ein Backup machen. Ich weiß, Backups sind für Heulsusen, und wozu auch: funktioniert doch alles, aber manchmal muss man einfach mal aufhören, ein richtiger Kerl zu sein und statt dessen eine defensive Haltung einnehmen.


    Deine config.json befindet sich an einem bestimmten Ort, der dadurch festgelegt ist, wie du deine Homebridge konfiguriert hast. Die wahrscheinlichsten Orte sind entweder /var/homebridge/config.json oder /var/lib/homebridge/config.json. Du kannst sie dir im Terminal anzeigen lassen mit:


    cat /var/homebridge/config.json oder cat /var/lib/homebridge/config.json. Einer der beiden Befehle zeigt die Konfiguration an, der andere ergibt eine Fehlermeldung. Merke dir den Pfad, der was Brauchbares anzeigt.


    Dann kopierst du die Datei auf deinen Mac. Dazu öffnest du ein Terminalfenster und gibst dort ein:

    scp [email protected]:/var/homebridge/config.json .

    Das kopiert deine Homebridge-Konfiguration vom Raspi zum Mac. Natürlich verwendest du die IP-Adresse deines Raspi und den Pfad, den du dir oben gemerkt hast. Möglicherweise musst du das Passwort des Users pi eingeben.


    Damit ist der wichtigste Teil deiner Homebridge gesichert und liegt nun in deinem Userverzeichnis auf deinem Mac - du kannst sie im Finder sehen.


    Jetzt kannst du versuchen, node neu zu installieren. Folgend die Anweisungen für einen Raspi 3 oder 4. Lies sie komplett durch, bevor du startest.


    Herunterladen:

    https://nodejs.org/dist/latest-v14.x/node-v14.17.6-linux-armv7l.tar.gz


    Auspacken:

    tar xf node-v14.17.6-linux-armv7l.tar.gz


    Node an die richtige Stelle kopieren. Das ist der wirklich hässliche Teil der Aktion und ich persönlich würde mich etwas davor fürchten. Aber da deine Installation eh schrottig ist, sind deine Aktionsmöglichkeiten eher klein. Also:

    sudo cp -R node-v14.17.6-linux-armv7l/* /usr/local/


    Das überschreibt deine existierende node-Version. Das dauert einen Augenblick und jetzt ist ein guter Zeitpunkt, die Hände zu falten und "bitte, bitte, bitte" zu murmeln. Nicht überschrieben oder verändert wird dabei deine Homebridge-Konfiguration. Aber theoretisch kann dieser Vorgang deine Lage auch verschlimmern (wenn das noch möglich ist). Es fällt mir eigentlich sehr schwer, solche Tipps zu veröffentlichen - immerhin bin ich nachher der Depp, der deinem Raspi den Rest gegeben hat.


    Jetzt kannst du testen, ob das funktioniert hat:

    node -v zeigt dir die Versionsnummer des installierten node an

    npm -v zeigt dir die Versionsnummer des installierten npm an


    Wenn dabei keine Fehlermeldungen auftauchen, startest du deine Homebridge neu und wirfst einen Blick ins Log. Vielleicht tut sich ja was Gutes. Lass sehen.

  • Keine Sorge, jemand der hilft kann am Ende in meinen Augen nicht der Depp sein.

    Ich habe glücklicherweise im Juli oder August noch ein vollständiges Backup über das Webinterface gemacht. So wie ich da sehe, ist da ja dann auch die Config schon mit drin. Andere Software läuft auf dem Rasp nicht. Ich weiß auch ehrlichgesagt nicht mal, was das für ein Raspberry ist - der ist schon seit 2 Jahren oder so irgendwo in meinem Schreibtisch versteckt 🤣

    Was ich schon länger überlege ist, dass ich mir einen Synology Nas kaufe und das da drauf laufen lasse, weil ich eh gerne wieder einen Nas hätte. Das ist aber immer daran gescheitert, dass ich so Angst vor dem Umzug der Homebridge hatte und davon ausgehe, dass hier im Haus danach nix mehr funktioniert.

    Also: Befehle habe ich ausgeführt. Fehlermeldung bekomme ich keine. Versionen werden mir auch angezeigt. Neustart:

    Was mich wundert - config wurde nicht gefunden steht da oben. Trotzdem sind die Geräte teilweise in HOME zu finden. Bis auf HUE -> was die zweite Fehlermeldung erklärt. Das Webinterface geht aber nach wie vor nicht.


    Achso und das ging alles nicht mehr, seitdem ich das HUE Update gemacht habe. Da stand dann bei, dass er auch NODE updatet... danach war es so, wie es jetzt ist. Zumindest glaube ich das :-D

    Einmal editiert, zuletzt von Bizzy () aus folgendem Grund: Ein Beitrag von Bizzy mit diesem Beitrag zusammengefügt.

  • Wenn ich versuche die UI händig zu installieren (hattest du mir mal in einem anderen Thread gezeigt) ->


    npm ERR! Invalid response body while trying to fetch https://registry.npmjs.org/chalk: Integrity verification failed for sha512-4RCwoBXeSNOKZSbcoj8cSO1LA9yvqPQu7HVkQUgBV++mR3zG1n4A+CMHBw4PcvMPd4m+kK8DJi+sTLhVztOWgw== (/root/.npm/_cacache/content-v2/sha512/e1/10/b0a015de48d38a6526dca23f1c48ed4b03dcafa8f42eec756441480157efa6477cc6d67e00f82307070e0f72f30f7789be90af03262fac4cb855ced39683)


    npm ERR! A complete log of this run can be found in:

    npm ERR! /root/.npm/_logs/2021-09-19T09_38_06_542Z-debug.log

  • npm ERR! Invalid response body while trying to fetch https://registry.npmjs.org/chalk: Integrity verification failed for sha512-

    Du hast aber auch lustige Fehlermeldungen - das liegt jetzt wohl an npmjs. Naja, vielleicht.


    Einfach mal die npm-Caches löschen. Auf den Raspi einloggen und dann:

    rm -rf .npm

    sudo su -

    rm -rf .npm

    exit


    Vielleicht klappt's ja dann.


    Installiere das Hue-Plugin neu:

    sudo npm install -g --unsafe-perm homebridge-hue


    und homebridge-config-ui-x

    sudo npm install -g --unsafe-perm homebridge-config-ui-x

  • Freut mich, dass dich die Fehler belustigen, ich weine schon die ganze Zeit 🤣

    Kein plan, was das nun wieder bedeutet ->

    Code
    [email protected]:~ $ sudo npm install -g --unsafe-perm homebridge-hue
    added 3 packages, changed 99 packages, and audited 103 packages in 1m
    44 packages are looking for funding
    run `npm fund` for details
    found 0 vulnerabilities

    Und der zweite Befehl:


    Einmal editiert, zuletzt von Bizzy () aus folgendem Grund: Ein Beitrag von Bizzy mit diesem Beitrag zusammengefügt.

  • Jetzt:


    Keine Fehler, aber WebIF geht nach wie vor nicht.


    das irritiert mich nach wie vor

    Code
    [19/09/2021, 19:05:33] config.json (/root/.homebridge/config.json) not found.

    Oh jetzt geht das WebIF doch wieder. Wie finde ich jetzt am Besten raus, ob alles wieder ordnungsgemäß läuft?


    Alles scheint aktuell zu sein, außer das LANDROID PLUGIN. Das wirft folgenden Fehler:


    2 Mal editiert, zuletzt von Bizzy () aus folgendem Grund: Ein Beitrag von Bizzy mit diesem Beitrag zusammengefügt.

  • added 3 packages, changed 99 packages, and audited 103 packages in 1m

    3 Pakete hinzugefügt, 99 Pakete geändert und 103 Pakete geprüft, und das einer Minute

    44 packages are looking for funding
    run `npm fund` for details

    44 Pakete sind auf der Suche nach Finanzierung

    Führe `npm fund` für Details aus

    found 0 vulnerabilities

    Keine Schwachstellen gefunden

    [email protected]:~ $ sudo npm install -g --unsafe-perm homebridge-config-ui-x
    npm WARN deprecated [email protected]: This release contains a breaking change from 0.3.1 but otherwise functions properly. Please read the changelog on Github to learn more.

    Ein Hinweis für den Programmierer: "npm WARN veraltet [email protected]: Diese Version enthält eine bahnbrechende Änderung gegenüber 0.3.1, funktioniert aber ansonsten einwandfrei. Bitte lies das Changelog auf Github, um mehr zu erfahren."


    sudo homebridge

    Nein! So nicht!!! Das erzeugt sofort:

    config.json (/root/.homebridge/config.json) not found.

    Man sticht nicht anderen Leuten mit einer Stricknadel ins Auge. Man prüft Strom auf der Steckdose nicht mit der Zunge. Man startet die Homebridge nicht mit sudo homebridge.


    Je nachdem, wie deine Homebridge installiert wurde, lautet der Startbefehl entweder:

    sudo systemctl start homebridge oder hb-service start

  • Liebe Homebridgeprofis,


    leider startet meine Homebridge nicht mehr und ich finde in der config.json den Fehler nicht. Könnt ihr euch sie mal ansehen und mir weiterhelfen? Der Fehler müsste bei einer Klammer im unteren Bereich liegen, oder?

    Ich freue mich über eine Antwort.

    Vielen Dank im Voraus.


    Liebe Grüße


    René

  • Jede Klammer die geöffnet wird, muss auch irgendwo wieder geschlossen werden.

    Bei dir beginnt es mit einer geschweiften Klammer und endet mit einer eckigen. Auch spuckt der Test deiner config.json auf jsonlint.com aus, dass es mittendrin auch mal Probleme mit einer Klammer gibt.

  • Eher so (die geschweifte Klammer, die am Ende fehlte, stand mitten im Code - siehe in deinem Post in Zeile 78):



    Achtung: bei deiner Alarmanlage sind die Einträge doppelt (beispielsweise tripped-sensor und andere). Die dürfen da nur einmal stehen. Deshalb musst du dort zuerst aufräumen, sonst bleibt's bei deiner Fehlermeldung.

  • Lieber Patrick, lieber schubste,

    vielen Dank für eure freundliche Hilfe.

    Ich habe eure Tipps angewandt. Leider führte es nicht zum Erfolg.

    Ich wollte mich via ssh am pi anmelden und folgende Meldung kommt:"

    ssh: connect to host 192.168.178.40 port 22: Connection refused".

    Wenn ich den Pi an den Monitor schließe, dann erscheint der Desktop ganz normal. Hab ihr eine Idee, an was da liegen könnte? Ich hab ja nur die json config verändert.


    Liebe Grüße


    René

  • ssh: connect to host 192.168.178.40 port 22: Connection refused".

    Das bedeutet, das auf einem Computer mit der IP-Adresse 192.168.178.40 kein SSH-Server (sshd) läuft, der normalerweise den Login-Request beantworten würde. Entweder wurde der sshd nicht gestartet, oder er wurde gestoppt, oder die IP-Adresse ist nicht die richtige.


    Das Ändern der config.json hat in keinem Fall einen Einfluss auf den sshd. Versuche ein sudo systemctl restart sshd auf dem Computer mit der IP-Adresse 192.168.178.40.

  • Das Ändern der config.json hat in keinem Fall einen Einfluss auf den sshd. Versuche ein sudo systemctl restart sshd auf dem Computer mit der IP-Adresse 192.168.178.40.

    Wie genau meinst du das? Am Mac, von dem ich normalerweise zugreife, komme ich ja nicht drauf. Soll ich mal am Pi das eingeben? Welches "Programm" zur Eingabe nutze ich dafür?

    Vielen Dank für deine Mühe :-)

  • Soll ich mal am Pi das eingeben?

    Ja. Ich nehme jetzt einfach mal an, das der Computer mit der IP-Adresse 192.168.178.40 dein Raspi ist. Der Befehl startet den sshd.

  • Hallo sschuste,


    vielen Dank nochmal für deine Hilfe. Leider führte sie nicht zum Erfolg. Ich würde dir den Fehler gerne rauskopieren aber ich arbeite nur mit Tastatur, meine alte Maus ist nicht auffindbar 😂

    Ich hab daher mal Bilder der Fehlercodes gemacht. Hast du noch eine Idee?

    Liebe Grüße

    LG René