Homebridge Installationsanleitungen

  • Bei ersterem verstehst du was du tust, da du nachvollziehen kannst wo evtl. du später bei einem Problem ansetzen musst. Beim anderen installierst du blind ein fertiges Image das dir all die Arbeit abnimmt aber du dir am Ende vermutlich nicht selber helfen kannst wenn Fehler auftreten.

  • Deidara

    Inzwischen empfehle wir auch das aktuelle Image und die offizielle "Getting Started" Anleitung von Homebridge. Damit bist Du dann auf dem aktuellen Stand von hb-service, Node, Config UI und hast eine gute Grundlage.


    Später kann im Bedarfsfall zu Fragen auch dazu Unterstützung hier im Forum von der überwiegenden Anzahl der Nutzer gegeben werden.


    Viel Erfolg weiterhin, einen angenehmen Austausch und alles Gute.

    Hilfreich?

  • Ich zitiere den "Godfather" of Homebridge Installationsanleitung:

    Verwende diese Anleitung: https://github.com/homebridge/…mage/wiki/Getting-Started

    Und nimm dieses Image: https://github.com/homebridge/…mage/releases/tag/v1.0.15


    Geht schneller als mit der Smartapfelanleitung.

    Da war DJay schneller;(

  • Hier gibts kein fertiges Image.

    Beide Anleitungen setzen auf der gleichen Basis auf.

    Ein Image ist der Container in den in diesem Fall das Betriebssystem gepackt ist.

  • Okay und weiß jemand ob man die Temperatursensoren die man an den Raspberry Pei anstecken kann auch dazu verwendet werden können um seine Smart Home zu steuern besser gesagt um bei HomeKit als temperatursensoren erkannt werden ?

  • Hier gibts kein fertiges Image.

    Beide Anleitungen setzen auf der gleichen Basis auf.

    Ein Image ist der Container in den in diesem Fall das Betriebssystem gepackt ist.

    Äh, doch. Was ihr da verlinkt habt ist das Homebridge-Rasbian-Image?!? :/ Oder meinst du das hier auf Smartapfel ist kein Image?


    Ich sollte nicht vor dem ersten Kaffee in Foren schreiben ...

    Raspberry Pei

    Sorry aber das triggert mich extrem. Es ist ein "Pi" englisch ausgesprochen. Nicht "Pei". :whistling:

  • Verwende diese Anleitung: https://github.com/homebridge/…mage/wiki/Getting-Started

    Und nimm dieses Image: https://github.com/homebridge/…mage/releases/tag/v1.0.15


    Geht schneller als mit der Smartapfelanleitung.




    Hallo zusammen, habe mich hier mal angemeldet da ich einfach nicht mehr weiterkomme und im Prinzip blutiger Anfänger bin aber auch nachdem ich seit Montag oder Sonntag dran bin und mich jeden Tag ein paar Stunden damit beschäftige und alles möglich gegoogelt habe nicht klar komme.

    Ich bin lernwillig, werde aber mit Sicherheit falsche Begriffe verwenden deshalb nicht haten. Hoffe man versteht was ich vor habe.


    Ich zitiere einfach mal die Anleitung die ich genutzt habe bzw. nutzen wollte.


    Vielleicht zunächst zu meinem Vorhaben:

    Habe einen Pi3 A+ mit RaspBee 1 "Aufsteck-Platine" welches ich gerne als ZigBee Gateway nutzen möchte.


    Damit möchte ich im ersten Schritt einfach nur meine Aqara Tür Sensoren verbinden und hätte gerne eine Benachrichtung aufs IPhone wenn sich der Status des Sensors ändert.


    Mein 1. Versuch:

    Raspbee Image von Dresden Elektronik installiert (Raspbian Buster Desktop)

    mit Deconz und Phoscon die Verbindung hinbekommen und in Phoscon auch sehen können wenn der Sensor offen oder geschlossen ist.


    Dann habe ich über eine Anleitung im Internet das Homebridge installiert und konnte es auch mit mit meinem IPhone koppeln, kam dann aber nicht mehr weiter weil ich nicht wusste wie ich die Sensoren nun in die App bekomme.


    Also habe ich hier eine Anleitung gefunden die mir jedoch auch nicht weiterhalf da ein Schritt nicht machbar war.


    Mein 2. Versuch:

    Somit bin ich dann umgesprungen und wollte die von mir zitierte Anleitung von Github durchführen.


    Also SD Karte in den PC, alle Daten auf einem Order gesichert und das Image von Github auf die frische SD Karte geflasht.


    Bin mittlerweile so "weit" dass ich der Github Anleitung nach als nächstes die Home App verbinden muss, jedoch kommt nun immer die Meldung "Gerät bereits hinzugefügt" "Um dieses Gerät zu deinem Zuhause hinzuzufügen, musst du es zuerst zurücksetzen."


    Zwischendrin habe ich über den Desktop PC auch noch ein Zigbee Plugin auf der Homebridge installiert (der Fehler mit dem hinzufügen war vorher und nachher da)


    Leider habe ich in der App jedoch bereits alles mit zurücksetzen probiert es tut sich jedoch nichts. Habe auch über den Windows PC schon den Nutzernamen geändert und die Bridge neu gestartet.


    Bring leider auch nichts, dann habe ich eine Anleitung hier gefunden wie man einen gewissen Ordner aus der Config löschen oder verschieben kann was bei meinem Fehler zusammen mit einem Neustart helfen kann.


    Auf dem Raspberry komme ich jedoch nicht ins Befehlterminal sondern nur auf diese Homebridge "Seite" auf der ich mich einloggen kann. Leider klappen da meine Daten jedoch nicht und die sind zu 100% richtig eingegeben und ich habe die Bridge über den Windows PC bereits neugestartet nach der Passwort und Benutzernamens Änderung.



    Alles in Allem verzweifle ich nun, ich habe gefühlt 200 Tabs auf dem Handy und dem PC offen aber finde nirgends die richtige Lösung. Bin ich vielleicht generell auf dem Holzweg?


    Ich sehe nun auch noch, dass der Raspbee 1 laut Dresden Elektronik nicht mal für den Pi 3 A+ geeignet ist. Fällt mir erst jetzt auf.... somit kann ich wahrscheinlich eh alles vergessen und muss mindestens auf den 3 B umsteigen?



    Sorry für die ganzen Fragen und den langen Text, ich hoffe jedoch dass mir jemand helfen kann.


    Vielen Dank im Voraus für Eure Unterstützung.

  • Raspbee Image von Dresden Elektronik installiert (Raspbian Buster Desktop)

    mit Deconz und Phoscon die Verbindung hinbekommen und in Phoscon auch sehen können wenn der Sensor offen oder geschlossen ist.


    Dann habe ich über eine Anleitung im Internet das Homebridge installiert und konnte es auch mit mit meinem IPhone koppeln, kam dann aber nicht mehr weiter weil ich nicht wusste wie ich die Sensoren nun in die App bekomme.

    Eigentlich hättest du an diesem Punkt nur noch das "Homebridge-hue" Plugin installieren müssen um die beiden zu verbinden und es hätte klappen müssen. Hast du auch Homebridge-config-ui-x installiert? Das schließe ich aus deiner Aussage das du "auf diese Homebridge Seite" kommst.

  • Bin mittlerweile so "weit" dass ich der Github Anleitung nach als nächstes die Home App verbinden muss, jedoch kommt nun immer die Meldung "Gerät bereits hinzugefügt" "Um dieses Gerät zu deinem Zuhause hinzuzufügen, musst du es zuerst zurücksetzen."

    Du hattest ja schon eine Homebridge verbunden. Um das noch mal zu machen musst du erst in der Konfiguration von Homebridge diese Zeile ändern:


    {
    "bridge": {
    "name": "Homebridge",
            
    "username": "CC:22:3D:E3:CE:30",
    "port": 51826,
    "manufacturer": "homebridge.io",
    "model": "homebridge",
    "pin": "031-45-128"
    },


    in etwas anderes, beispielsweise in

    "username": "CC:22:3D:E3:CE:31",


    Alle anderen Zeilen in deiner Konfiguration lässt du so, wie sie sind, auch wenn sie vom obigen Beispiel abweichen. Speichern, Homebridge neu starten, dann klappt's.

  • Eigentlich hättest du an diesem Punkt nur noch das "Homebridge-hue" Plugin installieren müssen um die beiden zu verbinden und es hätte klappen müssen. Hast du auch Homebridge-config-ui-x installiert? Das schließe ich aus deiner Aussage das du "auf diese Homebridge Seite" kommst.


    Hi, danke für die Antwort, das hatte ich glaube ich auch gemacht. Ich weiß es nicht mehr genau... :-(

    Auf jeden Fall war der Pi dann plötzlich ganz unheimlich langsam und deshalb habe ich es nicht weiter probiert mit der Anleitung und wollte es von vorne auf die Art hier bzw.




    Hi, auch Dir natürlich vielen Dank, es hat nun so funktioniert, habe den letzten Buchstaben der bei mir "E" war in "F" geändert.


    Ich kann das IPhone nun verbinden, die nächsten Schritte wäre die Deconz / Phoscon Installation und dann das Ganze versuchen über die "Drittanbieter App" Funktion bei Phoscon hinzuzufügen oder?


    Deconz und Phoscon würde ich jetzt eigentlich nach dieser Anleitung installieren und dann versuchen die Homebridge "in das Phoscon" zu bekommen.


    Wäre die Vorgehensweise korrekt?

    Wie komme ich denn am Pi nun in die Config um Deconz zu installieren? Am Pi bin ich mommentan nur in dieser Homebridge Ansicht :/ Oder kann ich da über die Homebridge Config weiterarbeiten? Macht eher wenig Sinn oder :-D


    Oder sollte ich lieber über das Homebridge Plugin "homebridge-zigbee-nt v2.0.2" arbeiten wenn das geht? Was würdet ihr empfehlen :-)?

  • Oder sollte ich lieber über das Homebridge Plugin "homebridge-zigbee-nt v2.0.2" arbeiten wenn das geht?

    Das geht nicht, du hast nen Conbee, kein CC253X Stick.


    Wie komme ich denn am Pi nun in die Config um Deconz zu installieren? Am Pi bin ich mommentan nur in dieser Homebridge Ansicht :/ Oder kann ich da über die Homebridge Config weiterarbeiten? Macht eher wenig Sinn oder

    steht in deiner selbst verlinkten Anleitung: sudo hb-config im Terminal am Mac eingeben. Zuvor natürlich über SSH mit dem Pi verbinden.

  • Das geht nicht, du hast nen Conbee, kein CC253X Stick.


    steht in deiner selbst verlinkten Anleitung: sudo hb-config im Terminal am Mac eingeben. Zuvor natürlich über SSH mit dem Pi verbinden.

    Schade und Danke :-) das wollte auch irgendwie nicht und da das Teil echt unheimlich langsam wurde habe ich es nochmal von vorne probiert.... echt anstrengend irgendwie ich glaube ich stehe irgendwo vollkommen auf dem Schlauch. Aber ich würde mich echt gern reinfuchsen :-).


    Also nun habe ich es wieder auf meine zuerst geplante Art probieren wollen


    Image von Dresdenelektronik auf die SD Card geflasht, dann mit Phoscon den ersten Sensor verbunden und das WLAN eingerichtet damit ich das Kabel los geworden bin.


    Als nächstes wollte ich npm installiert und auf die aktuelle Version gebracht (6.14.11).


    Nun habe ich bei sudo npm i -g npm diese Meldungen erhalten:


    npm WARN npm npm does not support Node.js v10.23.1

    npm WARN npm You should probably upgrade to a newer version of node as we

    npm WARN npm can't make any promises that npm will work with this version.

    npm WARN npm Supported releases of Node.js are the latest release of 4, 6, 7, 8, 9.

    npm WARN npm You can find the latest version at https://nodejs.org/


    heißt ich müsste erst das Node Update erledigen, richtig? Nach dieser Anleitung? Wobei die ja erst will dass ich Homebridge stoppe, dabei habe ich ja bisher außer dem Dresden Elektronik Image (Raspbian Buster Desktop) und o.g. npm noch nichts gemacht.


    Wenn ich sudo npm i -g homebridge-hue ausführe kommt auch wieder Chaos, also muss Node geupdatet werden, sollte das mit oben verlinkter Anleitung funktionieren?



    Riesen Chaos im System, sorry. Würde es nur endlich gerne zum Laufen bekommen. Ist langsam frustrierend :-(

  • Wobei die ja erst will dass ich Homebridge stoppe, dabei habe ich ja bisher außer dem Dresden Elektronik Image (Raspbian Buster Desktop) und o.g. npm noch nichts gemacht.

    Deswegen heißt die Anleitung ja auch "Node.js Update auf Raspberry Pi mit Homebridge" ;) Du kannst auch einfach die ersten beiden Schritte überspringen.


    Vermutlich reicht aber auch folgendes:


    Hol dir erstmal den Node-Versionmanager mit:

    sudo npm install -g n


    und dann update Node mit

    sudo n lts


    das sollte reichen.

  • Nach dieser Anleitung?

    Ja, aber ohne reboot. Der ist nicht notwendig. Es kann dir passieren, dass du alle Plugins nachinstallierten musst.

  • Nabend,


    habe gerade den zweiten Versuch unternommen Homebridge zu installieren (Smartapfel Homebridge Anleitung). Bin an dem Punkt, wo ich Homebridge starten und mir das Logfile anzeigen lassen soll.


    Das klappt aber nicht... :-/

    Hab schon zwei Tippfehler in der config.json behoben.


    Irgendwo muss noch ein Fehler sein, könnt ihr mir da auf die Sprünge helfen?


  • Irgendwo muss noch ein Fehler sein

    Wäre hilfreich, wenn man auch die dazugehörige config.json postet, in der der Fehler vermutlich steckt.


    Vermutlich nicht ohne Grund sagt dein Log in der allerersten Zeile : There was a problem reading your config.json file.

  • Feb 03 22:53:48 raspberrypi homebridge[3321]: SyntaxError: Unexpected token h in JSON at position 85

    Scheint relativ weit unten zu sein der Fehler, habs auch mal markiert. Am besten jsonlint.com nutzen. Dort reinkopieren und pruefen lassen und erst wenn das passt homebridge starten lassen.

  • habe gerade den zweiten Versuch unternommen Homebridge zu installieren

    Gibt es einen Grund, wenn Du Homebridge doch eh ganz neu aufsetzt und es mit der Anleitung hier nicht klappt, warum Du nicht der offiziellen Homebridge Pi Image Anleitung folgst? Da ist dann hb-service, Wifi, Config UI, aktuelle Node, alles schon automatisch mit drin.

    Unsere Anleitung wird auch gerade überarbeitet, die dann ebenfalls der aktuellen, offiziellen Anleitung folgt.

    Hilfreich?