Abrufgeschwindigkeit optimieren

  • Hej,


    ich habe einige Zigbee Geräte, einige Xiaomi Geräte etc - alle per Homebridge eingebunden (pi 4, 5Ghz).


    Wenn ich meine Home per Eve App öffne, fängt die HB ja an die stati erst abzurufen, das dauert dann in Summe 5-10 Sek bis alle Geräte rückgemeldet haben.


    Meine Bosch Geräte dagegen sind quasi sofort ersichtlich.


    Ist das bei euch auch so? Kann HB zb regelmäßig den Status abrufen und cachen um das zu beschleunigen?


    Oder ist das Bottleneck am Ende meine mit iPad derzeit ungünstig gewählte zentrale? (HomePod incoming)


    Achja, die normale Kommunikation, zb Fenster auf (Aquara) und Heizkörper aus (Bosch) geht super schnell!


    Es scheint mit eher dann aufzutreten wenn alle Geräte abgerufen werden. (40 Stück: 30 Zigbee, 10 Restliche)

  • Meine Erfahrungen sind ähnlich. Ich nutzte zwei HomePods als Steuerzentralen und habe viele (Philipps) Hue-Geräte, Eve-Geräte (inkl. eve extend) und per WLAN eingebundene Geräte. Bei allen ist der Status quasi ad-hoc verfügbar sobald ich die Home-App öffne. Man kann noch kurz den Status "Aktualisierung" (oÄ) lesen uns dann ist der jeweilige Status (bspw. "offen", etc.) erkennbar. Bei allen via Homebridge eingebundenen Geräte dauert das deutlich länger. Man kann sich via Config-UI-X-PlugIn ja im Protokoll-Fenster anschauen, was "live" auf der Homebridge passiert. Dort kann mann bspw. erkennen, wenn ein PlugIn sich "verschluckt" und/oder lange Ladezeiten produziert. Bei meinen Nachforschungen in meinem Setup habe ich damit dann herausgefunden, dass es bei mir an einem PlugIn liegt, welches die "Ladezeit" signifikant erhöht. Dabei handelt es sich um ein PlugIn zur Integration meines Gardena-Rasenmäher in Homekit. Ich konnte erkennen, dass sich das PlugIn manchmal beim aushandeln der Token für die REST-API von Gardena "verschluckt". Das geht auch einher mit der dann langen initialen Ladezeit in der Home-App. Danach sind dann - wie bei dir - Statusänderungen quasi ad-hoc zu sehen. Passiert das (also der Fehler beim Aushandeln des Token) nicht oder habe ich das besagte PlugIn deinstalliert, dauert das initiale Laden zwar auch ein klein wenig länger aber nicht so gravierend.


    Mich würde daher auch interessieren, ob man an der HB etwas optimieren kann.

    Aber ich fürchte eher nicht, da zumindest in meinem Fall die HB an sich ziemlich flott reagiert. Evtl. kannst du auch mal checken, ob es mglw. an einem bestimmten PlugIn liegt. Vielleicht kannst du dann über den Entwickler dieses PlugIns gehen.

    Ein cachen des Status halte ich eher nicht für zielführend, da du ja mehr oder weniger den aktuellen Status sehen möchtest. Was nützt dir der gecachte Status bspw. deiner Fenster von vor fünf Minute, wenn vor zwei Minuten eines aufgemacht wurde und du jetzt schauen möchtest, ob alle Fenster geschlossen sind.

  • Bei allen via Homebridge eingebundenen Geräte dauert das deutlich länger.

    Bei mir zeigt sich ein derartiges Verhalten nicht. Ich habe eine Homebridge auf einem Raspi 3 mit 21 Geräten und eine zweite auf einem Raspi 4 mit weiteren 57. Dazu kommen 9 Geräte über Node Red und 25 über die Hue-Bridge. Plus ein paar Koogeek-, Parce- und EVE-Steckdosen. Alle aktualisieren innerhalb einer Sekunde und alle gleichzeitig.

  • Könnte es daher kommen, dass mein pi an einem Repeater hängt?


    Ich könnte ihn natürlich näher an die FB bringen, damit die Verbindung besser wird, damit einhergehend wäre nur blöderweise Zigbee nicht so Zentral platziert wie bisher.


    Man kann sich via Config-UI-X-PlugIn ja im Protokoll-Fenster anschauen, was "live" auf der Homebridge passiert. Dort kann mann bspw. erkennen, wenn ein PlugIn sich "verschluckt" und/oder lange Ladezeiten produziert. Bei meinen Nachforschungen in meinem Setup habe ich damit dann herausgefunden, dass es bei mir an einem PlugIn liegt, welches die "Ladezeit" signifikant erhöht. Dabei handelt es sich um ein PlugIn zur Integration meines Gardena-Rasenmäher in Homekit. Ich konnte erkennen, dass sich das PlugIn manchmal beim aushandeln der Token für die REST-API von Gardena "verschluckt". Das geht auch einher mit der dann langen initialen Ladezeit in der Home-App. Danach sind dann - wie bei dir - Statusänderungen quasi ad-hoc zu sehen. Passiert das (also der Fehler beim Aushandeln des Token) nicht oder habe ich das besagte PlugIn deinstalliert, dauert das initiale Laden zwar auch ein klein wenig länger aber nicht so gravierend.

    das dachte ich mir auch schon, werde mal nachsehen ob mein Landroid Plugin hier das Problem hervorruft.

    Einmal editiert, zuletzt von DJay () aus folgendem Grund: Ein Beitrag von Dane03 mit diesem Beitrag zusammengefügt.

  • Bei mir zeigt sich ein derartiges Verhalten nicht. Ich habe eine Homebridge auf einem Raspi 3 mit 21 Geräten und eine zweite auf einem Raspi 4 mit weiteren 57. Dazu kommen 9 Geräte über Node Red und 25 über die Hue-Bridge. Plus ein paar Koogeek-, Parce- und EVE-Steckdosen. Alle aktualisieren innerhalb einer Sekunde und alle gleichzeitig.

    Hmm ... interessant. Ich habe mich immer gefragt, ob es eine Grenze hinsichtlich der Anzahl der Geräte gibt bzw. ob eine hohe Anzahl an Geräten die Performance irgendwann beeinträchtigt. Aber das zeigt: wohl eher nicht.


    Seit ich alles im Docker auf meinem NAS habe reagiert alles viel flotter, als vorher am Pi3. FHEM, Homebridge, Pihole, Deconz...

    Bei mir läuft die HB auf einem PI 3B+. Der sollte eigentlich genug "Power" bieten. Aber ein NAS hat natürlich noch mehr Leistung.


    Könnte es daher kommen, dass mein pi an einem Repeater hängt?

    Meiner hängt an einem Switch, der direkt an der FB hängt.

  • Meiner hängt an einem Switch, der direkt an der FB hängt.

    Dann häng ihn mal direkt an den Router und check mal, ob das Verhalten sich ändert.

  • Völlig unabhängig von einer Homebridge kann ich euch mitteilen, dass die Aktualisierung bei mir insbesondere mit den Geräten von Eve bestimmt 20-30 Sekunden dauern. Die Aktualisierung erfolgt auch nur in der Eve – App. In der Home App passiert leider viel zu oft gar nichts. Ich habe als Steuerzentralen drei HomePods und ein iPad Pro in meiner Wohnung verteilt.

  • Aber liegt das wirklich an dem Hersteller oder ist das Problem woanders zu suchen?

    Das Problem ist vermutlich eher, dass ich einen Extend als montagsgerät hatte (Reichweite 1m) und Bluetooth halt je nach Gegebenheiten funktioniert - oder auch nicht.. bei uns ein klares nicht.


    Erst reichte die Reichweite nicht, brauchte extends.

    Die extends haben dann dauernd die Verbindung zum WLAN verloren und ohnehin schlechte Verbindungen zu Teils 2m entfernten (durch wand) Geräten.


    Also Osram Steckdose vornedran um den Extend zum neu verbinden zu zwingen.


    Wenn ich die Kosten von allen ‚Krücken‘ zusammenrechne, die trotz allem kein zufriedenstellendes Ergebnis hatten, bin ich weit über den Kosten bei Bosch.


    Aber so ist’s halt hier - da macht jeder seine Erfahrungen.


    Jetzt aber BTT 8o

  • So, heute Regentag und viel Zeit gehabt meine Home-App zu verstrubeln. Ich habe meine HB dupliziert und damit ist Home nicht zurecht gekommen. Nach vielem Ausprobieren ist mir auch mal aufgefallen, dass bei meiner Frau noch einige Regeln in Home waren, welche gar nicht mehr aktuell waren.

    Das war für mich der Auslöser, mein Zuhause komplett zu löschen und das Ganze neu aufzusetzen. Das Ergebnis war für mich den Aufwand wert. Wo ich vorher wie du manchmal sogar länger als 10sek auf die Verfügbarkeit meiner HB Geräte warten musste, sind diese jetzt sofort angezeigt...also genau so schnell wie die nativen Geräte.

    Zusammengefasst: An HB wurde nichts verändert. mein Zuhause in Home komplett gelöscht, alle 135 HB Geräte wieder hinzugefügt und ein top Ergebnis erhalten.

    Als kleiner Anhang, ich habe vor ca. 2Jahre mit Home angefangen und in dieser Zeit viel experimentiert und fast täglich Geräte oder Szenen hinzugefügt oder verändert, also viel zu tun für mein Home.

    HomeKit Geräte / Homebridge Geräte:

    Raspberry 4 4GB | 4x Raspberrypi 3 Model B+ | Raspberry Zero | FritzBox 7490| HarmonyHub | Sonoff/Wemos/Tasmota | Danalock | Koogeek | Z-Way | Raspi-Cam | SwitchBot | Shelly| Logitech Circle2 | RavenSystem | DeCONZ



    Homebridge Plugins:

    Homebridge| Fritzbox | People | Callmonitor | Automation-Switches | Magichome-platform | Harmony | OpenHAB | ioBroker | Z-Way | Camera-FFMPEG | Website-to-Camera | video-doorbell-button |

  • So, heute Regentag und viel Zeit gehabt meine Home-App zu verstrubeln. Ich habe meine HB dupliziert und damit ist Home nicht zurecht gekommen. Nach vielem Ausprobieren ist mir auch mal aufgefallen, dass bei meiner Frau noch einige Regeln in Home waren, welche gar nicht mehr aktuell waren.

    Das war für mich der Auslöser, mein Zuhause komplett zu löschen und das Ganze neu aufzusetzen. Das Ergebnis war für mich den Aufwand wert. Wo ich vorher wie du manchmal sogar länger als 10sek auf die Verfügbarkeit meiner HB Geräte warten musste, sind diese jetzt sofort angezeigt...also genau so schnell wie die nativen Geräte.

    Zusammengefasst: An HB wurde nichts verändert. mein Zuhause in Home komplett gelöscht, alle 135 HB Geräte wieder hinzugefügt und ein top Ergebnis erhalten.

    Als kleiner Anhang, ich habe vor ca. 2Jahre mit Home angefangen und in dieser Zeit viel experimentiert und fast täglich Geräte oder Szenen hinzugefügt oder verändert, also viel zu tun für mein Home.

    Wow, das klingt nach viel Arbeit. Gerade bei so vielen Geräten. Hattest du deine Automationen irgendwie gesichert, also ein Backup gemacht? Ich selbst suche immer noch eine Möglichkeit das alles mal zu sichern. Die Controller App hatte ich mal getestet. Sie speichert allerdings keine Kurzbefehle in Home-Automationen. Da ich diese aber recht häufig verwende, viel die App schonmal raus. Aber vielleicht gibt es ja eine Alternative.





  • Ich habe zum Glück fast keine Automationen. Aber selbst das Geräte einrichten (Räume, Benachrichtigungen etc.) hat ewig gedauert. War aber auch mal wie Frühjahrsputz und habe einiges unnötiges gleich entrümpelt.

    HomeKit Geräte / Homebridge Geräte:

    Raspberry 4 4GB | 4x Raspberrypi 3 Model B+ | Raspberry Zero | FritzBox 7490| HarmonyHub | Sonoff/Wemos/Tasmota | Danalock | Koogeek | Z-Way | Raspi-Cam | SwitchBot | Shelly| Logitech Circle2 | RavenSystem | DeCONZ



    Homebridge Plugins:

    Homebridge| Fritzbox | People | Callmonitor | Automation-Switches | Magichome-platform | Harmony | OpenHAB | ioBroker | Z-Way | Camera-FFMPEG | Website-to-Camera | video-doorbell-button |

  • Dann häng ihn mal direkt an den Router und check mal, ob das Verhalten sich ändert.

    Danke für den Tipp sschuste (da hätte ich ja selbst mal drauf kommen das auszuprobieren ;)). Ich habe das vor ein paar Tagen mal "umgestöpselt" und die letzten Tage mal laufen lassen. Ich kann keine Änderung feststellen. Grundsätzlich läuft die Homebridge auch schnell. Ich glaube - wie gesagt -, dass es an dem ein oder andere PlugIn liegt, welches sich "verschluckt". Aktuell macht Netatmo Wetter bei mir Probleme. Irgendwas schraubt netatmo wohl gerade an der API und das PlugIn kann sich die Stationsdaten nicht mehr holen. Das führt dann dazu, dass meine Geräte in der HomeApp erstmal lange brauchen bevor sie ihren aktuellen Status anzeigen. Deaktiviere ich dieses (und das oben beschriebene PlugIn für meinen Rasenmäher) läuft die Homebridge 1a. Es scheint so zu sein, dass wenn ein PlugIn Probleme hat, dass die "danach" zu ladenden Geräte warten müssen und bei denen dann das Statusupdate in der HomeAPP mehr Zeit benötigt. Ich frage mich, ob eine zweite Instant der Homebridge, in die man dann die "problematischen" Plugins auslagert, Abhilfe schaffen könnte?

  • So, heute Regentag und viel Zeit gehabt meine Home-App zu verstrubeln. Ich habe meine HB dupliziert und damit ist Home nicht zurecht gekommen. Nach vielem Ausprobieren ist mir auch mal aufgefallen, dass bei meiner Frau noch einige Regeln in Home waren, welche gar nicht mehr aktuell waren.

    Das war für mich der Auslöser, mein Zuhause komplett zu löschen und das Ganze neu aufzusetzen. Das Ergebnis war für mich den Aufwand wert. Wo ich vorher wie du manchmal sogar länger als 10sek auf die Verfügbarkeit meiner HB Geräte warten musste, sind diese jetzt sofort angezeigt...also genau so schnell wie die nativen Geräte.

    Zusammengefasst: An HB wurde nichts verändert. mein Zuhause in Home komplett gelöscht, alle 135 HB Geräte wieder hinzugefügt und ein top Ergebnis erhalten.

    Als kleiner Anhang, ich habe vor ca. 2Jahre mit Home angefangen und in dieser Zeit viel experimentiert und fast täglich Geräte oder Szenen hinzugefügt oder verändert, also viel zu tun für mein Home.

    Hmmm ... davor scheue ich mich noch. Ich bin auch eigentlich von "Anfang an" (hinsichtlich HomeKit) dabei und habe zu Beginn auch viel ausprobiert. Da würde "einmal zurück auf Los" sicher was bringen. Aber mir geht auch ähnlich wie SkyLeader. Ich habe viel Automationen mit Kurzbefehlen. Das alles neu machen müssen, wäre mega langwierig ... aber, dass das bei dir soviel "Performancegewinn" gebracht hat, macht mich nachdenlich ;)