Danalock V3 HK Automation wird nicht ausgeführt

  • Hi,


    ich nehme beim Danalock aktuell wahr, dass zeitbasierte Automationen anfangs unregelmäßig ausgeführt wurden.
    Dann ist mir aufgefallen, immer nachdem ich den ATV neu gestartet hatte wurde um 21 Uhr die Automation „Türe schließen“ an diesem Tag nicht ausgeführt. Wenn ich am ATV dann nichts gemacht habe wurden die Tage darauf diese Automation ausgeführt. Wenn ich ATV wieder neu gestartet habe ging am Abend die Automation nicht.....



    Gesendet von iPhone mit Community

  • Ich habe übers Wochenende meine Auslöser erweitert und stelle seither meine ich fest, dass ich bei der Automation zum Danalock nun immer 2 Meldungen erhalte.


    Und zwar, wenn die seit Monaten bestehende Automation um 21 Uhr das Danalock verriegeln lässt, kommt zuerst „Aufgeschlossen“ und dann zeitgleich die Meldung „Abgeschlossen“.


    Das Schloss schließt auch ab, wie es sein soll.


    Aber woher kommt die erste Meldung, dass aufgeschlossen wurde?


    Die einzige Veränderung ist am Danalock, dass ich einen Aqara DoubleSwitch mit integriert habe, um auf einer Taste die Haustüre zu öffnen (ist eine Szene „Haustüre öffnen).


    Auch heute morgen, als beide iphones dann außer Haus waren und das people-plugin dann Abwesenheit meldet, wurde das Danalock abgeschlossen, aber zuerst wieder die Meldung „aufgeschlossen“ und dann abgeschlossen.


    Hat jemand so ein Phänomen auch mal gehabt oder jemand eine Idee dazu?


    Mir scheint, als ob hier der aktuelle Zustand mit gemeldet wird.....



    Gesendet von iPhone mit Community

  • Auch ich habe mit einer Automation ein Problem, ich kriege die Automation "Wenn die letzte Person Zuhause verlässt" in der Home-App nicht zum Laufen. Eingetragen sind sowohl meine Partnerin als auch ich (wir sind die einzigen beiden Bewohner), Ort steht auf "Zuhause", Zeit steht auf "beliebig". In beiden iPhones ist die iCloud-"Standort teilen"-Option korrekt mit "von diesem Gerät" aktiviert - aber das Schloss verriegelt einfach nicht bzw. es kommt auch keine Meldung, ob die Automation ausgeführt werden soll. Habe gewartet, bis ich mehrere Kilometer entfernt war und dann das Schloss manuell verriegeln müssen.

    Übersehe ich da evtl. noch eine notwendige Einstellung.....?

  • Ich konnte mein obiges Problem am Wochenende tatsächlich erfolgreich lösen. Ich hatte grundsätzlich das Problem, dass das Danalock meine "Verriegeln bei Verlassen"-Automation nie ausgeführt hatte. egal, ob ich "wenn irgendwer verlässt" oder "wenn der letzte verlässt" eingestellt hatte. Mit meiner "Ankunft"-Automation gab es jedoch von Anfang an keinerlei Probleme. Schonmal seltsam.

    Ich habe dann aber per Test mit einer einfachen HomeKit-Lampe festgestellt, dass die "Verlassen"-Geofencing-Funktion an sich korrekt funktioniert, nur eben offenbar nicht, wenn das Danalock direkt angesteuert werden soll. Ebenfalls seltsam.

    Daher habe ich (wie auch beim vollautomatischen Öffnen) einen Fake Switch gesetzt, der statt des Danalocks geschaltet wird, sobald das Haus verlassen wird. Auf diesen Fake Switch reagiert das Danalock dann per zweiter Automation und verriegelt.


    M.E. handelt es sich hierbei um einen Bug (entweder in HomeKit selbst oder in der Danalock-Firmware), denn eine "Verriegeln bei Verlassen"-Automation sollte auch ohne Fake Switch grundsätzlich mit dem Danalock funktionieren, wenn auch nur mit zusätzlicher Bestätigung auf Watch oder iPhone. Das hat aber in meinem Fall wie gesagt NIE funktioniert, kein einziges Mal, trotz vieler Tests, Resets, neu anlegen von Automationen etc. pp. Erst, seitdem ich den Umweg über den Fake Switch eingebunden habe, funktioniert es auf Anhieb sehr zuverlässig.


    Hat denn jemand von euch es hinbekommen, eine "Beim Verlassen verriegeln"-HomeKit-Automation (Geofencing) zum Laufen zu kriegen, die das Danalock direkt und ohne Umwege ansteuert? Falls ja, verratet mir mal, wie...

  • Bei mir läuft es über die verlassen Funktion bis auf wenige Ausnahmen eigentlich problemlos. Wie weit ist bei dir die Steuerzentrale vom Danalock entfernt?

    Das war nämlich einer der Punkte, die ich in der Vergangenheit festgestellt habe, Entfernung zur nächsten Zentrale zu groß, wurde die Ansteuerung des Danalock unzuverlässig und auch der Status wurde nicht richtig angezeigt.

    Homebridge 0.4.49 | homebridge-config-ui-x v4.4.4 | homebridge-eveatmo v0.4.5 | homebridge-harmony v0.7.0 | homebridge-hue v0.11.25 | homebridge-nello v0.4.5 | homebridge-raspberrypi-temperature v0.0.7 | homebridge-automation-switches v3.2.1

  • Meine Steuerzentrale (HomePod) ist nur wenige Meter von der Haustür entfernt, daran kann es nicht liegen - sonst hätte ich ja beim Öffnen/Ankunft auch dieselben Probleme gehabt. Da kam aber die Meldung immer zuverlässig an der selben Stelle ca. 100 m von der Haustür entfernt. Beim Verlassen kam NIE, kein einziges Mal, eine Meldung, auch nicht, nachdem ich schon kilometerweit weg war.


    Steuert denn deine "Verlassen"-Automation dein Danalock tatsächlich DIREKT an? Oder schaltet sie etwas anderes, worauf das Danalock dann reagiert?

  • Das Danalock wird direkt angesteuert und für die Alarmanlage gibt es 2 Fake Switches die zusätzlich beim Verlassen gesetzt werden um die Überwachung der Fenster und Wohnungstür zu aktivieren. Beides funktioniert zuverlässig.

    Homebridge 0.4.49 | homebridge-config-ui-x v4.4.4 | homebridge-eveatmo v0.4.5 | homebridge-harmony v0.7.0 | homebridge-hue v0.11.25 | homebridge-nello v0.4.5 | homebridge-raspberrypi-temperature v0.0.7 | homebridge-automation-switches v3.2.1

  • ...und warum hast du das so gelöst? Ist doch eigentlich wesentlich komfortabler, wenn das System automatisch abschließt, sobald der letzte das Haus verlässt. Und sollte das mal aus irgendwelchen Gründen nicht funktionieren, kann man ja auch jederzeit aus der Ferne manuell abschließen....


    Oder hat deine Methode irgendeinen Vorteil, den ich gerade nicht sehe?