homebridge-camera-ffmpeg | RTSP Real Time Streaming Protocol

  • Moin!


    Ich habe hier eine IP-Kamera, die per "onvif" ansprechbar ist. Mit VLC bekomme ich ein wunderschönes Video über die URL: rtsp://192.168.178.61:554/onvif1

    Dazu zeigt mir VLC folgendes an:



    In Homebride auf einem Raspberry Pi 3B+ habe ich die Kamera über homebridge-camera-ffmpeg eingebunden (ffmpeg ist installiert):



    Mit dem maxFPS und auch mit anderen Parametern habe ich jetzt ziemlich oft herumgespielt, aber nichts wirklich lauffähiges hinbekommen.

    Vorher hatte ich das Ganze auf einem Raspberry Pi Zero WH und dort gab es immerhin ein ruckelndes Video mit vielen Artefakten.


    Hier sind die Debug-Meldungen von ffmpeg:

    Ganz am Schluß holt er sich auch ein Standbild ohne Probleme. Das wird auch öfter einmal upgedatet.


    Eine andere Kamera, die über die URL: http://192.168.178.57/media/?user=admin&pwd=&action=stream angesprochen wird, läuft hingegen auf demselben Pi ohne Probleme.

    Dort sieht es im Log dann so aus:



    Weiß hier vielleicht jemand einen Rat?

    So komme ich irgendwie nicht weiter.


    Danke!

  • Ich habe bei mir die Auflösung optimiert auf 640 X 360 und FPS auf 20. Hast doch sicher mehrer streams bei deiner Cam. Ich kann zwischen neben, Haupt & mobile wählen. Habe den Nebenstrecken geäugt und die Auflösung angepasst und nun läuft alles ohne ruckeln und Max 0,5 sec Verzögerung zu der realtime



    Sent from my iPhone using Community

  • Den ersten Satz habe ich ja noch verstanden, dann aber leider verläßt es mich.


    Ich habe jetzt einmal diese Konfiguration ausprobiert:

    Code
    "videoConfig": {
    "source": "-re -i rtsp://192.168.178.61:554/onvif1",
    "maxWidth": 640,
    "maxHeight": 360,
    "maxFPS": 20,
    "maxStreams": 2,
    "maxBitrate": 150,
    "packetSize": 188,
    "debug": true
    }


    Aber es kommt auch nur das hier zustande:


  • Servus Zusammen,


    ich habe jetzt hier nach Anleitung die C2 in der HomeApp. Das Foto wechselt alle 10 sek. klappt wunderbar nur nicht von ausserhalb. Da kommt das Bild eher sporadisch an.

    Mein Problem ist auch wie bei einigen anderen hier. Das wenn ich auf das Foto klicke um den Stream zu sehen nichts kommt.


    Immer der Fehler:

    [1/7/2019, 5:02:23 PM] [Camera-ffmpeg] ERROR: FFmpeg exited with code 1


    bei VLC klappt alles! Hat vielleicht jemand noch ne Idee wie ich an eine Lösung komme.


    Danke Grüße

    Bernie

  • Hallo Bernie68,


    Sah uns mal welches Modell und Hersteller du verwendest. Dann zeige uns gerne noch deine Config die du eingebaut hast.

  • Ok Dennis.


    logisch braucht man natürlich:)


    Raspberry ZeroW und Foscam C2 und hier die Config Einstellung.

  • Mittels Firefox (glaube ich) kannst du dir den rtsp:Stream link anzeigen. Error bedeutet das die Daten zum abrufen nicht stimmen. Wenn du den Raum in dem die Kamera ist öffnest, versucht HomeKit immer zu erst einen Screenshot zu machen und dieses dann darzustellen. Also wann kommt der error code? Eventuell kommt der erst sobald du versuchst dir ein Live Bild anzeigen zu lassen. So kannst du erstmal Schaun was den error auslösen könnte.


    P.s. In dem link zum Image musst du auch deine Daten eintragen wie in etwa:

    http://Benutzer:[email protected]:Port/auto.jpg

  • HI hier ist mal meine config habe es so eingefügt


    "platform": "Camera-ffmpeg",

    "cameras": [{

    "name": "Kamera",

    "videoConfig": {

    "source": "-re -i rtsp://admin:[email protected]/Streaming/channels/1/picture",

    "stillImageSource": "",

    "maxStreams": 2,

    "maxWidth": 1280,

    "maxHeight": 720,

    "maxFPS": 30


    ihn Vlc kriege ich ein Bild also müsste es doch stimmen benutze ein Hikvision DS-2CD2052-I

    laut dem link müssten es andere links sein aber die gehen nicht

    mjpeg api/mjpegvideo.cgi?InputNumber=1&StreamNumber=[CHANNEL]

    ffmpeg /Streaming/Channels/101

  • Ok habe es nun endlich geschaft hin zu bekommen :)

    Nur was mir auf fällt das ich keine live ansicht habe sondern immer nur ein Bild bekomme wenn ich auf die Kamera gehe.

    Und sie muss dann immer neu laden des dauert auch weiß einer an was des liegen könnte?

    Habe jetzt 2 mal den gleichen link genommen bei meiner config

    "source": "-re -i rtsp://admin:[email protected]/Streaming/channels/1/picture",

    "stillImageSource": "-i http://admin:[email protected]/Streaming/channels/1/picture",

    Muss ich da vielciht was ändern und er aktualiest die cam auch nciht von alleine nur wenn ich auf sie drauf klicke

  • ok stimmt damit war nur ein bild zu sehen habe nun denn richtigen link damit wird live video abgespielt

    rtsp://admin:[email protected]/Streaming/channels/101

    wenn ich aber nur den link eingebe und beim 2 nix dann findet er meine kamera nicht.

    wenn ich beide ein gebe so

    "source": "-re -i rtsp://admin:[email protected]/Streaming/channels/101",

    "stillImageSource": "-i http://admin:[email protected]/Streaming/channels/1/picture",

    dann ist wieder nur stand bild und keine live ansicht

  • [2/2/2019, 5:54:38 PM] Loaded config.json with 28 accessories and 0 platforms.

    [2/2/2019, 5:54:38 PM] ---

    [2/2/2019, 5:54:40 PM] Loaded plugin: homebridge-camera-ffmpeg

    [2/2/2019, 5:54:40 PM] Registering platform 'homebridge-camera-ffmpeg.Camera-ffmpeg'

    [2/2/2019, 5:54:40 PM] ---

    [2/2/2019, 5:54:40 PM] Loaded plugin: homebridge-config-ui-x

    [2/2/2019, 5:54:40 PM] Registering platform 'homebridge-config-ui-x.config'

    [2/2/2019, 5:54:40 PM] ---

    [2/2/2019, 5:54:40 PM] Loaded plugin: homebridge-harmony

    [2/2/2019, 5:54:40 PM] Registering platform 'homebridge-harmonyHub.HarmonyHubWebSocket'

    [2/2/2019, 5:54:40 PM] ---

    [2/2/2019, 5:54:41 PM] Loaded plugin: homebridge-http

    [2/2/2019, 5:54:41 PM] Registering accessory 'homebridge-http.Http'

    [2/2/2019, 5:54:41 PM] ---

    [2/2/2019, 5:54:42 PM] Loaded plugin: homebridge-http-switch

    [2/2/2019, 5:54:42 PM] Registering accessory 'homebridge-http-switch.HTTP-SWITCH'

    [2/2/2019, 5:54:42 PM] ---

    [2/2/2019, 5:54:42 PM] Loading 0 platforms...

    [2/2/2019, 5:54:42 PM] Loading 28 accessories...

    [2/2/2019, 5:54:42 PM] [Lava Lampe] Initializing Http accessory...

    [2/2/2019, 5:54:42 PM] [Weihnachtsbaum] Initializing Http accessory...

    [2/2/2019, 5:54:42 PM] [Bluetooth] Initializing Http accessory...

    [2/2/2019, 5:54:42 PM] [Wohnzimmer Lampe] Initializing Http accessory...

    [2/2/2019, 5:54:42 PM] [Wohnzimeer Lampe Wechsel] Initializing HTTP-SWITCH accessory...

    [2/2/2019, 5:54:42 PM] [Wohnzimeer Lampe Wechsel] Switch successfully configured...

    [2/2/2019, 5:54:42 PM] [Wohnzimmer Lampe Wechsel 3mal] Initializing HTTP-SWITCH accessory...

    [2/2/2019, 5:54:42 PM] [Wohnzimmer Lampe Wechsel 3mal] Switch successfully configured...

    [2/2/2019, 5:54:42 PM] [Wohnzimmer Lampe Wechsel 2mal] Initializing HTTP-SWITCH accessory...

    [2/2/2019, 5:54:42 PM] [Wohnzimmer Lampe Wechsel 2mal] Switch successfully configured...

    [2/2/2019, 5:54:42 PM] [Wohnzimmer Led] Initializing HTTP-SWITCH accessory...

    [2/2/2019, 5:54:42 PM] [Wohnzimmer Led] Switch successfully configured...

    [2/2/2019, 5:54:42 PM] [Led Leiste] Initializing Http accessory...

    [2/2/2019, 5:54:42 PM] [Led Leiste Rot] Initializing HTTP-SWITCH accessory...

    [2/2/2019, 5:54:42 PM] [Led Leiste Rot] Switch successfully configured...

    [2/2/2019, 5:54:42 PM] [Led Leiste Grün] Initializing HTTP-SWITCH accessory...

    [2/2/2019, 5:54:42 PM] [Led Leiste Grün] Switch successfully configured...

    [2/2/2019, 5:54:42 PM] [Led Leiste Chroma] Initializing HTTP-SWITCH accessory...

    [2/2/2019, 5:54:42 PM] [Led Leiste Chroma] Switch successfully configured...

    [2/2/2019, 5:54:42 PM] [Led Leiste Flash] Initializing HTTP-SWITCH accessory...

    [2/2/2019, 5:54:42 PM] [Led Leiste Flash] Switch successfully configured...

    [2/2/2019, 5:54:42 PM] [Küche Rollo Runter] Initializing HTTP-SWITCH accessory...

    [2/2/2019, 5:54:42 PM] [Küche Rollo Runter] Switch successfully configured...

    [2/2/2019, 5:54:42 PM] [Küchen Rollo Rauf] Initializing HTTP-SWITCH accessory...

    [2/2/2019, 5:54:42 PM] [Küchen Rollo Rauf] Switch successfully configured...

    [2/2/2019, 5:54:42 PM] [Küchen Rollo Stop] Initializing HTTP-SWITCH accessory...

    [2/2/2019, 5:54:42 PM] [Küchen Rollo Stop] Switch successfully configured...

    [2/2/2019, 5:54:42 PM] [Terrasse Rollo Stop] Initializing HTTP-SWITCH accessory...

    [2/2/2019, 5:54:42 PM] [Terrasse Rollo Stop] Switch successfully configured...

    [2/2/2019, 5:54:42 PM] [Terrasse Rollo Runter] Initializing HTTP-SWITCH accessory...

    [2/2/2019, 5:54:42 PM] [Terrasse Rollo Runter] Switch successfully configured...

    [2/2/2019, 5:54:42 PM] [Terrasse Rollo Rauf] Initializing HTTP-SWITCH accessory...

    [2/2/2019, 5:54:42 PM] [Terrasse Rollo Rauf] Switch successfully configured...

    [2/2/2019, 5:54:42 PM] [Terrasse 2 Rollo Stop] Initializing HTTP-SWITCH accessory...

    [2/2/2019, 5:54:42 PM] [Terrasse 2 Rollo Stop] Switch successfully configured...

    [2/2/2019, 5:54:42 PM] [Terrasse 2 Rollo Runter] Initializing HTTP-SWITCH accessory...

    [2/2/2019, 5:54:42 PM] [Terrasse 2 Rollo Runter] Switch successfully configured...

    [2/2/2019, 5:54:42 PM] [Terrasse 2 Rollo Rauf] Initializing HTTP-SWITCH accessory...

    [2/2/2019, 5:54:42 PM] [Terrasse 2 Rollo Rauf] Switch successfully configured...

    [2/2/2019, 5:54:42 PM] [Terrasse beide Stop] Initializing HTTP-SWITCH accessory...

    [2/2/2019, 5:54:42 PM] [Terrasse beide Stop] Switch successfully configured...

    [2/2/2019, 5:54:42 PM] [Terrasse beide Runter] Initializing HTTP-SWITCH accessory...

    [2/2/2019, 5:54:42 PM] [Terrasse beide Runter] Switch successfully configured...

    [2/2/2019, 5:54:42 PM] [Terrasse beide Rauf] Initializing HTTP-SWITCH accessory...

    [2/2/2019, 5:54:42 PM] [Terrasse beide Rauf] Switch successfully configured...

    [2/2/2019, 5:54:42 PM] [Rollo Alle Stop] Initializing HTTP-SWITCH accessory...

    [2/2/2019, 5:54:42 PM] [Rollo Alle Stop] Switch successfully configured...

    [2/2/2019, 5:54:42 PM] [Rollo Alle Runter] Initializing HTTP-SWITCH accessory...

    [2/2/2019, 5:54:42 PM] [Rollo Alle Runter] Switch successfully configured...

    [2/2/2019, 5:54:42 PM] [Rollo Alle Rauf] Initializing HTTP-SWITCH accessory...

    [2/2/2019, 5:54:42 PM] [Rollo Alle Rauf] Switch successfully configured...

    Load homebridge-camera-ffmpeg.Camera-ffmpeg

    Setup Payload:

    X-HM://0023ISYWYD668

    Scan this code with your HomeKit app on your iOS device to pair with Homebridge:



    aber kein fehler