(gelöst) Shelly Errors - Fehlersuche

  • Hallo zusammen,


    Der Titel sagt es bereits - meine Shellys lassen sich nicht mehr per Homekit/Homebridge bedienen und das Log ist voll mit Error-Meldungen:


    [30.11.2021, 16:16:35] [Shelly] Failed to load device settings

    [30.11.2021, 16:16:35] [Shelly] Error: Timeout of 10000ms exceeded (device SHSW-1 F4CFA2E50472, at 192.168.188.18)

    [30.11.2021, 16:16:41] [Shelly] Failed to load device settings

    [30.11.2021, 16:16:41] [Shelly] Error: Timeout of 10000ms exceeded (device SHSW-25 F4CFA2E0B845, at 192.168.188.54)

    superagent: double callback bug

    [30.11.2021, 16:16:46] [Shelly] Failed to load device settings

    [30.11.2021, 16:16:46] [Shelly] Error: connect EHOSTUNREACH 192.168.188.16:80 (device SHSW-1 E098069535C0, at 192.168.188.16)

    [30.11.2021, 16:16:50] [Shelly] Failed to load device settings

    [30.11.2021, 16:16:50] [Shelly] Error: Timeout of 10000ms exceeded (device SHSW-1 F4CFA2E50472, at 192.168.188.18)

    [30.11.2021, 16:17:07] [Shelly] Failed to load device settings

    [30.11.2021, 16:17:07] [Shelly] Error: connect EHOSTUNREACH 192.168.188.5:80 (device SHSW-1 2CF43268EB4D, at 192.168.188.5)

    [30.11.2021, 16:17:15] [Shelly] Failed to load device settings

    [30.11.2021, 16:17:15] [Shelly] Error: Timeout of 10000ms exceeded (device SHSW-1 483FDA82B196, at 192.168.188.9)

    [30.11.2021, 16:17:29] [Shelly] Failed to load device settings

    [30.11.2021, 16:17:29] [Shelly] Error: Timeout of 10000ms exceeded (device SHSW-1 2CF43268EB4D, at 192.168.188.5)

    superagent: double callback bug


    Hat jemand eine Idee was das ist und wie ich das beheben kann?

  • Bisschen Eigeninitiative bei der Fehlersuche wäre hilfreich, damit man das eingrenzen kann:

    - Gab es ein Update vom Hombridge-Shelly Plugin?

    - Hast du Änderungen an der Config.json vorgenommen?

    - Irgendwelche anderen Updates in Homebridge vorgenommen?

    - Gab es ein Firmware-Update der Shellys?

    - Sind die Shellys noch über ihre eigene Weboberfläche erreichbar?

    - Sind die Shellys noch im Router zu sehen?

    - Haben die Shellys vom Router eine neue IP Adresse bekommen (weil keine fixen vorher vergeben)?

  • Kein Update des Shelly Plugins

    Keine Änderungen an der config.json

    Keine anderen Updates

    Kein Shelly Update

    Shellys sind über ihre eigene Oberfläche erreichbar

    Shellys sind im Router vorhanden

    Alle Shellys haben fixe Adressen


    Hab jetzt mal den Neustart erzwungen. Die Fehlermeldungen sind weg, sie kommen jetzt nur noch wenn ich eine Aktion versuche auszulösen, was nicht geht:


    [30.11.2021, 16:53:08] [Shelly] Failed to set light

    [30.11.2021, 16:53:08] [Shelly] Error: Timeout of 10000ms exceeded (device SHDM-2 E8DB84D4840F, at 192.168.2.187)


    Was mich wundert - die IP-Adresse stimmt so nicht. Die IP sollte sein 192.168.188.27. Irgendwas ist hier verdreht…

    Einmal editiert, zuletzt von Spy () aus folgendem Grund: Ein Beitrag von Guitardoc mit diesem Beitrag zusammengefügt.

  • Klar, dass da Fehlermeldungen kommen. Sie sind offensichtlich ja nicht im selben Netz/IP-Raum. Entweder, Du setzt die Shellies zurück und weist sie dem korrekten Netz zu oder schaust mal nach, ob sie gerade eine eigenständiges WLAN aufgesetzt haben, auf dass Du Dich mit dem Laptop/was-auch-immer connectest und das Netz korrigierst, ohne sie zurückzusetzen.


    Warum das nun passiert ist? Von allein bestimmt nicht. Und dass sie ausgerechnet diese IP-Adresse nun haben, sieht für mich nicht nach einer zufälligen aus.

  • Spy

    Hat das Thema geschlossen
  • Spy

    Hat den Titel des Themas von „Homebridge Log voll mit Shelly Errors - Shellys lassen sich nicht mehr bedienen“ zu „Shelly Errors - Fehlersuche“ geändert.
  • Ja toll. Und was mache ich nun? Mit den Infos kann ich nichts anfangen. Und ich habe nichts bewusst irgendwo verändert und hier gepostet um euch zu ärgern.


    Und so ”offensichtlich” ist das nicht für jeden, zumindest nicht für mich. Vielleicht findet sich aber noch jemand der mir hier helfen möchte. Ich bin am Verzweifeln.

  • Entweder, (1) Du setzt die Shellies zurück und weist sie dem korrekten Netz zu oder (2) schaust mal nach, ob sie gerade eine eigenständiges WLAN aufgesetzt haben, auf dass Du Dich mit dem Laptop/was-auch-immer connectest und das Netz korrigierst, ohne sie zurückzusetzen.

    Hast Du die Shellies selbst installiert oder hast Du sie von jemandem installieren lassen? Welche IP-Adresse hat Dein Router? Mit welchem Gerät kannst Du Dich auf die Weboberfläche der Shellies connecten? Welche IP-Adresse hat dieses Gerät?


    Ich bin ehrlich gesagt davon ausgegangen, dass Du sie selbst installiert hast. Dabei hast Du ja sicherlich eine Installationsanleitung befolgt (2). An der selben Stelle ist bestimmt auch eine Anleitung, wie man einen Shelly zurücksetzt(1). Sonst hilft auch die Suchmaschine Deines Vertrauens.


    Sobald sie wieder im Netz und erreichbar sind, solltest Du im Router die IP-Adressen fest reservieren.

  • So, ich denke, ich konnte das Problem eingrenzen. Bei den IP-Adressen stimmt was nicht.


    Im Router sind die Adressen richtig eingetragen (fixe Adressen für alle Shellys). Schicke ich einen ping dorthin, dann funktioniert dieser.


    Wenn ich über Homekit ein Licht anschalten will, dann kommt ein Fehler, und zwar dass das Gerät nicht erreichbar ist, gefolgt von einer völlig anderen IP-Adresse. Dorthin geht auch kein ping, denn diese IP-Adresse gibt es ja gar nicht.

    Ich habe jetzt einen Shelly neu gestartet (Strom komplett weg und wieder dran), den Router neu gestartet, die Homebridge neu gestartet. Router überprüft - IP ist richtig eingetragen. Wenn ich jetzt versuche den Shelly per Homekit zu schalten kommt im Protokoll exakt der gleiche oben beschriebene Fehler gefolgt von der gleichen falschen IP-Adresse.


    Die Homebridge läuft auf einem Raspi. Gibt es dort irgendwo eine Tabelle, wo die IP-Adressen noch mal gespeichert sind, welche aus welchen Gründen auch immer eine fehlerhafte Zuweisung bekommen hat?

  • Ein richtiger Reset eines Shellys 1 funktioniert folgendermaßen:


    1. Strom weg

    2. Strom wieder dran

    3. Glaub innerhalb einer Minute fünf mal nacheinander schalten. Bis du ein mehrmaliges klicken hörst.


    Erst dann sind die Shellys zurück gesetzt.


    Achtung. Danach musst du dich erstmal wieder ins das WLAN vom Shelly einwählen und mit der Standard IP einloggen.

  • Beide IP sind identisch.


    Ich habe aber etwas anderes entdeckt. Ich habe mir mal mit arp -av alle Geräte anzeigen lassen, die der Raspi kennt. Witzigerweise kennt er nicht alle Geräte, welche aber in der FRITZ!Box angemeldet und aktiv sind und auch eine feste IP haben. Und genau die fehlenden Geräte geben den Fehler aus und werden mit der „falschen“ IP angesprochen.


    Mit anderen Worten - die FRITZ!Box stellt Geräte mit IP und MAC-Adressen zur Verfügung, der Raspi erkennt davon aber nicht alle. Hmm. Wie kann denn das nun wieder sein?

  • Die Homebridge läuft auf einem Raspi. Gibt es dort irgendwo eine Tabelle, wo die IP-Adressen noch mal gespeichert sind, welche aus welchen Gründen auch immer eine fehlerhafte Zuweisung bekommen hat?

    Jein. Es gibt in Homebridge einen Cache, der möglicherweise falsche Adressen enthält. Siehe in homebridge-config-ui-x, oben rechts: 3-Punkte-Menü, dann Homebridge-Einstellungen, dann ganz unten Verwalten von Geräten im Cache.


    Die Adressen, die dem Raspi selbst bekannt sind, listet der Befehl arp -n auf.

    Mit anderen Worten - die FRITZ!Box stellt Geräte mit IP und MAC-Adressen zur Verfügung, der Raspi erkennt davon aber nicht alle. Hmm. Wie kann denn das nun wieder sein?

    Wenn die Shellys die Fritzbox nicht kontaktieren, dann passiert das. Es könnte glatt sein, dass sie sich ihre Adressen von einem anderen DHCP-Server holen - das fällt mir dazu als erstes ein, auch wenn ich für unwahrscheinlich halte.

  • Hmm. Ich habe jetzt mal Router und Raspi mehrmals neu gestartet. Einige Geräte erkennt er jetzt richtig, die meisten nicht. Manche, die schon mal wieder funktioniert hatten, funktionieren wieder nicht mehr. Seltsam. Allerdings kommt jetzt nicht mehr der seltsame Fehler mit einer falschen IP-Adresse. Dafür kommen jetzt Timeouts und EHOSTUNREACHED.


    Ich habe ein Gerät mal aus dem Cache genommen und neu eingebunden. Das funktioniert jetzt.


    Interessanterweise läuft der ioBroker auch nicht rund.


    Arp -n liefert auf den ersten Blick alle IP Adressen richtig zurück.


    PS. Was mir noch einfällt - ich habe vor ein paar Tagen allen fest verdrahteten Shellys gesagt, dass sie ab -70dB nach einer besseren Verbindung suchen sollen. Aber das dürfte doch damit nichts zu tun haben?


    Irgendwie scheint sich das Problem gelöst zu haben. Ich habe Router und Raspi mehrmals neu gestartet und nach und nach sind die Geräte wieder richtig angemeldet.

    Was für ein seltsames Verhalten. Keine Ahnung was da los war. Es hat mehrere Stunden und einige Reboots gebraucht aber jetzt scheint es einigermaßen wieder zu funktionieren.


    Ich hab jetzt was entdeckt. In meinen Access-Points gibt es die Option DHCP-Fallback. Die hab ich jetzt mal ausgeschaltet. Jetzt stimmen die IPs zumindest wieder. Allerdings ist jetzt alles voll mit Shelly EHOSTUNREACH errors und dem superagent: double callback bug. Ich vermute, dass das normal ist, solange bis das Gerät sich gemeldet und seine IP bezogen hat?

    2 Mal editiert, zuletzt von Spy () aus folgendem Grund: Ein Beitrag von Guitardoc mit diesem Beitrag zusammengefügt.

  • Das nehme ich an. Die Dauer wird wahrscheinlich 24 Stunden betragen, es sei denn, die betroffenen Geräte werden neu gestartet. Das ist bei den Shelleys natürlich nicht so einfach.


    Die Dauer, wie lange ein DHCP lease gültig ist, wird im DHCP-Server eingestellt, ist aber nicht rückwirkend machbar.

  • Die beste Lösung für mich ist die feste Zuweisung der IP direkt im Shelly und nicht über DHCP oder Router. Das mache ich bei allen SmartHome-Geräten, soweit die das ermöglichen.

    1. Raspberry Pi4 - Homebridge, TVHeadend, Fileserver (SMB, AFP)

    2. Elgato, Koogeek, Shelly, Trådfri, Broadlink, Logitech, EZcontrol, SiliconDust, FRITZ!Box

    .


  • Die festen IP-Adressen müssen natürlich außerhalb des DHCP-Bereiches liegen. Der DHCP in der Fritte liegt out of the box zwischen 20-199. Damit hast du ab 200 zur Verfügung. Du kannst den DHCP-Bereich aber auch verkleinern.