Verschiedene Homebridge Probleme

  • Naja, ich leg dir hier gern eine Konfiguration hin, die feinstes JSON enthält trotzdem läuft damit keine Homebridge. Beispielsweise:


    Code
    1. {
    2. "bullshit": {
    3. "blafasel": "wasnquatsch hier"
    4. }
    5. }

    Schmeiß das mal nach jsonlint rein und du bekommst ein thumbs up zurück.


    Deine Fehlermeldung besagt, dass du ein anderes Logformat für homebridge-config-ui-x einstellen sollst. Das kannst du auch tun, indem du in homebridge-config-ui-x den Menüpunkt Plugins aufrufst und dann bei homebridge-config-ui-x den Punkt Einstellungen.


    Wenn du deine Homebridge mit sudo systemctl start homebridge startest, dann kannst das Log sehen mit sudo journlctl -fau homebridge.


    Stefan

  • @all


    Seit ich auf node 11.0 und npm 6.4.1 bin und sonst eigentlich nichts verändert habe ist meine Hauptinstanz des öfteren nicht erreichbar in HomeKit. Andere Instanzen machen keine Probleme.


    Ist dies noch bei jemandem ähnlich?


    Start-Log bringt keinerlei Fehlermeldung.


    Komisch ist, wenn die eine Instanz nicht erreichbar ist und ich den live-log über


    sudo journalctl -f -u homebridge aufrufe gibt es auch keinen versuch eines neustarts. Es werden einfach die letzen logs angezeigt ohne jegliche Fehlermeldung. Es scheint dann, als ob es nur die Verbindung Instanz Homebridge zu HomeKit betrifft.....



    Gesendet von iPhone mit Community

  • Ergänzend noch eine Frage zu meinem Problem gestern, welches sich eher noch verschlimmert hat...


    Kann es sein, dass sich die Instanz einfach aufhängt? Im log stehen keine Fehlermeldungen, jedoch wird das log auch nicht weitergeführt. Es bleibt einfach z.B. bei 10.21 Uhr stehen und es folgen auch keine weiteren logs mehr wie zum Beispiel Status-Aktualisierungen des Fritz-callmonitors oder des rademachers-homepilot........


    Ich werde wohl die plugins wo ein hub dahinter hängt wohl verteilen müssen in weitere Instanzen, sodass ich zum einen weniger Ausfälle habe und ich evtl. lokalisieren kann, an was es liegt.


    Ich habe in einem issue auf github bei der homebridge gelesen, dass dies evtl. an einem "unsauberen geschriebenen" plugin liegen könne. Wobei ich mit dem node und npm update eigentlich nur das hue-plugin und das mi-aqara-plugin aktualisiert habe und das hue-plugin heute vormittag nochmals neu installiert habe, aber es wurde eher schlimmer als besser.


    Da die anderen Instanzen diese Probleme nicht aufweisen schließe ich mal node und npm in Zusammenhang mit [email protected] aus und werde versuchen, das plugin ausfindig zu machen.


    das tado-plugin habe ich mal aus der config entfernt, die homebridge schmiert aber weiterhin ab, an dem ist es dann auch nicht gelegen.


    Falls hier noch jemand eine weitere Idee hat, bin ich froh um jeden Tipp.....


    Oder falls es noch andere Möglichkeiten gibt, eventuelle Fehler anzeigen zu lassen außer mit sudo journalctl -f -u homebridge oder dann sudo cat /var/log/syslog, dann gerne schreiben.

  • Ich habe nun ein backup aufgespielt und bin erst mal wieder zurück auf node 9.5.0 und npm 5.6.0.....


    Mir ist aber erst im nachgang eingefallen, was ich eventuell falsch gemacht habe.


    Ich habe mit det seinem tool node und npm aktualisiert, danach musste ein rebuild her.


    Dann habe ich nicht die plugins neu installiert......


    Könnte dies dazu geführt haben, dass irgendwo was nicht richtig rund gelaufen ist?


    Oder wie macht ihr eure updates? ( ich weiß, es ist schon einige mal besprochen worden, aber immer noch nicht für mich 100# ig gelöst für den best way)....



    Gesendet von iPhone mit Community

  • Oder wie macht ihr eure updates?

    Selten. Plugins update ich, sobald ein Update da ist, aber node fasse ich ungern an. Und wenn, dann mache ich das mit n. Aktuell läuft bei mir die 10.13.0 LTS-Version, und die werde ich solange nutzen, bis sie ein Update bekommt oder ein Plugin den Einsatz von node > 10 nötig macht.


    Stefan

  • sschuste


    Danke für deine Rückmeldung. Eigentlich fasse ich node auch immer ungern an. Irgendwie war ich gerade gut gelaunt und wollte vermutlich diesen Zustand schnellstens verändern..... was gelungen ist.


    Deine Variante „n“, ist die wie folgt?


    sudo systemctl stop homebridge
    sudo npm cache clean -f
    sudo npm install -g n
    sudo n latest
    sudo npm install -g --unsafe-perm [email protected]


    sudo npm i [email protected] -g


    cd /usr/local/lib/node_modules/
    sudo npm rebuild --unsafe-perm


    sudo reboot



    Gesendet von iPhone mit Community

  • Irgendwie war ich gerade gut gelaunt und wollte vermutlich diesen Zustand schnellstens verändern..... was gelungen ist.

    :D


    Ja, so ähnlich. Ich mach's halt nicht so häufig. Beim letzten node-Update brauch ich kein rebuild zu machen, wie schön. beim letzten Mal habe ich das mit node-gyp rebuild gemacht und rebooten tu ich auch nix.


    Stefan

  • Wenn ich dich nun schon exklusiv zum fragen am „Wickel“ habe.


    Es es denn für npm wichtig, dass diese auf dem neuesten Stand ist?


    Ich mache die Erfahrung aktuell mit meinen älteren Versionen, dass alles bestens läuft, hauptsache die homebridge ist auf der aktuellsten version....



    Gesendet von iPhone mit Community

  • Es es denn für npm wichtig, dass diese auf dem neuesten Stand ist?


    Ich mache die Erfahrung aktuell mit meinen älteren Versionen, dass alles bestens läuft, hauptsache die homebridge ist auf der aktuellsten version....

    So sieht's aus. Und ich glaube nicht, das npm immer auf dem neuesten Stand sein muss. ich meine, was machen wir denn damit? Über ein npm install -g --unsafe-perm sind doch die meisten von uns nie hinausgekommen, und das funktioniert schon immer. Ich weiß auch nicht, was es da ständig zu verbessern gibt.


    Ich sitz grad im ICE und hab daher keine Möglichkeit, meine Homebridge zu erreichen, und daher kann ich dir nicht sagen, welche npm-Version ich einsetze. Vielleicht hat das letzte node-Update ja auch npm auf eine höhere Version gebracht. Wie du siehst, habe ich keinen Plan. Da hilft dir der exklusive Wickel ma rein gar nix :-D


    Gruß

  • [quote='det','https://forum.smartapfel.de/forum/thread/487-verschiedene-homebridge-probleme/?postID=43917#post43917']

    im node 11.x.x ist npm 6.4.1 enthalten

    :)

    [/quote]

    Ok, das heißt, wenn man node 11.xxxx installiert wird automatisch npm 6.4.1 mit installiert?


    Ich habe nach node noch manuell npm installiert. War das evtl. der Fehler?



    Gesendet von iPhone mit Community