homebridge-config-ui-x (Webinterface für Homebridge)

  • Ist der "Bug" eigentlich bekannt, dass die ui bei der Ramauslastung immer anzeigt, das der ganze Ram quasi in Benutzung ist obwohl er das eigentlich nicht ist?

    Wieso ist er das nicht? Woher weißt du das?

  • Ist der "Bug" eigentlich bekannt, dass die ui bei der Ramauslastung immer anzeigt, das der ganze Ram quasi in Benutzung ist obwohl er das eigentlich nicht ist?

    Homebridge läuft im Docker auf ner Synology falls das noch wichtig ist.

    ist bei mir genau so, auch im Docker auf einer Diskstation

  • @

    Ist der "Bug" eigentlich bekannt, dass die ui bei der Ramauslastung immer anzeigt, das der ganze Ram quasi in Benutzung ist obwohl er das eigentlich nicht ist?

    Homebridge läuft im Docker auf ner Synology falls das noch wichtig ist.

    Je nach Art des Containers hat Homebridge keinen Zugriff auf den Host. Deshalb funktioniert auch das Synology Plugin in diesen Fällen nicht.

  • Moin,

    leider ist es bei mir "mal wieder" so weit...

    Habe alles nach der Anleitung hier installiert (Vielen lieben dank für den Autor dieser Anleitung), es lief auch schon einmal alles nur nachdem ich ein neues Plugin installiert habe, homebridge-mi-flower-care, es #ausGründen nicht lief, danach deinstalliert habe, bekomme ich diesen Fehler.

    Lustigerweise funktioniert der befehl "homebridge" als user Pi 1a mit der Config, nur wenn ich es als dienst starte wie in der Anleitung beschrieben, bekomme ich diesen Fehler.



    Ich bin leider wirklich Ratlos und hoffe auf ein wenig Hilfe von den Experten.

    Beste Grüße und schon einmal vielen Dank!

  • was steht bei dir in

    /etc/systemd/system/homebridge.service bei

    User=

    da sollte pi stehen

    und das Daten Verzeichnis in /etc/default/homebridge

    HOMEBRIDGE_OPTS=-I -Q -C -U /var/homebridge


    dahin die config.json von /Home/pi/.hombridge kopieren

    (Sicherung nicht vergessen)

    :)

  • Hi,


    ich habe aktuell die Version 3.9.1 am laufen, bis dato alles perfekt, nur seid heute Morgen sucht das Plugin nach neuen Updates.


    Dadurch ist die Hb gestoppt und keine Geräte funktionieren mehr.


    Wie kann ich das Problem lösen bzw. habt ihr das selbe Problem?

  • Zumindest heute Morgen ging bei mir alles völlig problemfrei. Das Problem tritt auf, wenn das Plugin npmjs.com nicht erreichen kann, um nach Updates für die Plugins zu suchen. Allerdings hat das bei mir noch nie die Homebridge gestoppt.


    Übrigens, die aktuelle Version von homebridge-config-ui-x ist 4.4.5. Mit dieser Version kann man das Plugin auch so einrichten, dass es losgelöst von der Homebridge läuft. Damit erreicht man, dass die beiden sich gegenseitig nicht mehr blockieren können.


    Stefan

  • Ich bekomme gerade die nNachricht im Log das nicht smehr angezeigt werden kann, da über 500 Zeilen offen sind. Habe bei NPM in den Instruktionen des Plugins nachgelesen wie ich den Log purgen kann, bin aber nicht ganz schlau geworden. Könnte mir da jemand auf die Sprünge helfen?


    Besten Dank


  • Ich bekomme gerade die nNachricht im Log das nicht smehr angezeigt werden kann, da über 500 Zeilen offen sind.

    Nein, die Meldung hast du nicht bekommen. Da steht, dass journalctl 500 Zeilen des Logfiles anzeigen wollte und das nicht tun konnte, weil bereits zu viele Dateien offen sind. Journalctl konnte also die eine, die es braucht, nicht mehr zusätzlich öffnen (um die 500 Zeilen daraus anzuzeigen).


    Kein schöner Fehler. Er sagt aus, dass dein Raspi überlastet ist durch zu viele Prozesse, die viele Dateien öffnen. Da muss jetzt ein Linux-Profi ran, der herausfindet, welche Dateien und Prozesse das sein könnten. Ich würde mit dem berühmten Befehl ps aux anfangen, falls man sich überhaupt noch auf der Büchse einloggen kann, aber um das Ding wieder zum Laufen zu bekommen, startest du den Raspi einfach neu.


    Die Frage ist, ob und wann das wieder auftritt.


    Stefan


    PS: Ich sehe gerade, dass ich exakt das gleiche Problem habe.

    Einmal editiert, zuletzt von sschuste ()

  • PS: Ich sehe gerade, dass ich exakt das gleiche Problem habe.

    So, das ps aux zeigte die Prozessliste, also eine Liste aller Prozesse, die auf dem Raspi laufen an. Ein Prozess war direkt auffällig, weil er mehr als 120 Mal lief:

    Code
    1. root 32379 0.0 0.3 8840 3268 pts/72 Ss+ Jun10 0:00 sudo -n journalctl -o cat -n 500 -f -u homebridge
    2. root 32384 0.0 1.0 57560 10200 pts/72 S+ Jun10 0:00 journalctl -o cat -n 500 -f -u homebridge

    Alle Prozesse wurden am 10. Juni gestartet und keiner der Prozesse verbrauchen keine CPU-Zeit. Ich habe keinen blassen Schimmer, warum das passiert. Ich bin den Spuk dann wieder los geworden durch ein:


    sudo killall journalctl


    Ich werde das weiter beobachten. Mal sehen, ob das erneut passiert.


    Stefan

  • Ich werde das weiter beobachten. Mal sehen, ob das erneut passiert.

    Es passiert. Immer, wenn das Log über homebridge-config-ui-x aufgerufen wird, wird der Prozess gestartet, der das Log liest (journalctl -o cat -n 500 -f -u homebridge) und nicht wieder beendet. Irgendwann laufen dann soviel Prozesse, dass sie die obige Fehlermeldung auslösen.


    Der Neustart von homebridge-config-ui-x beendet die Prozesse wieder.


    Ich werd mal den Entwickler fragen.


    Stefan

  • Danke, weil ich hatte nämlich auch den starken Verdacht dass das mit Config-ui-x zusammenhängt, habe aber die Fehlermeldung falsch interpretiert. Hatte halt während meines Testens mit Scripten ständig das Log offen...


    Nach Neustart ist "ps aux" hier unauffällig.