Xiaomi Mi Flora / Flower Care - Smarter Pflanzensensor homebridge-mi-hygrothermograph

  • Xiaomi Sachen in einer 2. Instanz l

    naja ich hab genug raspis und setz immer einen nach der Anleitung auf. Wobei ich ehrlicherweise ein Image hab inzwischen .... zum testen ist das ganz okay. Ich hab mir nie die Mühe einer 2. Instanz gemacht.


    wie auch immer: wie logge ich das Plugin korrekt - würde schon wissen woranes liegt

    //.ichael

    -----------------------------------


  • Guten Abend,


    hat schonmal jemand versucht das Plugin auf einer Homebridge am Mac zum Laufen zu bekommen?


    Ich scheitere schon beim Auslesen der GeräteID. Gibt es hierfür einen passenden Befehl? Bluetooth-hci-socket kann am Mac nicht installiert werden.


    Vielen Dank im Voraus.

  • Du brauchst nur ein Bluetooth Gerät welches deine Umgebung absucht. Kann auch eine App auf deinem Handy sein. Der Zeigt dir dann alle in der Umgebung befindlichen Geräten mit der Adresse an. (heißt das bei Bluetooth auch MAC Adresse? hat zumindest das gleiche Format)

    HomeKit Geräte / Homebridge Geräte:

    Raspberry 4 4GB | 4x Raspberrypi 3 Model B+ | Raspberry Zero | FritzBox 7490| HarmonyHub | Sonoff | Danalock | Koogeek | Z-Way | Raspi-Cam | SwitchBot | Shelly 2.5| Logitech Circle2 | RavenSystem



    Homebridge Plugins:

    Homebridge| Fritzbox | People | Callmonitor | Automation-Switches | Magichome-platform | Harmony | ewelink | OpenHAB | ioBroker | Z-Way | Camera-FFMPEG | Website-to-Camera | video-doorbell-button |

  • Ich bekomme mit den Apps zwar alle möglichen Bluetoothgeräte in meiner Umgebung angezeigt. Auch den gewünschten Pflanzensensor. In den Details sehe ich allerdings nur eine ellenlange UUID und nichts was auch nur ansatzweise nach der Mac Adresse aussieht...

  • also ich habe mit einen der 1000000 BT App geladen, die frei sind und das BLE bringt die MAC ID raus. wenn man sie zu lesen weiss.


    Siehe Bilder

    Bilder

    //.ichael

    -----------------------------------


  • Perfekt vielen Dank! Ich habe unzählige Apps getestet und bei allen kam nur die UUID raus.


    Blöde Frage, wie genau lese ich die MAC ID jetzt richtig? Bei welchem Block fange ich an und bei welchem höre ich auf? Im Screenshot sind 7 Blöcke markiert, kann die ID auch so lang sein oder sollten das nur 6 sein? Sehe ich das richtig, dass man die ID von rechts nach links lesen muss?

  • Also, ich lass mir die Adressen mit sudo hcitool lescan anzeigen. Hab ich was übersehen, dass ihr das alle nicht benutzt? Das hakelt manchmal ein bisschen, dann mit control-c (ctrl-c, strg-c) abbrechen und erneut starten.


    [email protected]:~ $ sudo hcitool lescan

    LE Scan ...

    37:BF:D4:92:31:07 (unknown)

    C8:69:CD:5B:6B:30 (unknown)

    C8:69:CD:5B:6B:30 (unknown)

    DD:BA:5D:2B:91:F9 (unknown)

    DD:BA:5D:2B:91:F9 Hue Lamp

    E4:FC:66:1E:5E:3E (unknown)

    B8:09:8A:D3:5F:B2 (unknown)

    B8:09:8A:D3:5F:B2 (unknown)

    D3:9C:6A:AB:1B:27 Eve

    D3:9C:6A:AB:1B:27 Eve Energy 1698

    E4:FC:66:1E:5E:3E (unknown)

    C4:7C:8D:67:3E:5B (unknown)

    C4:7C:8D:67:3E:5B Flower care

  • sudo hcitool lescan funktioniert am pi. macOS kann mit diesem Befehl allerdings nichts anfangen (Meine Homebridge läuft auf einem iMac).


    Da sich meine Kenntnisse im Terminal auf Copy&Paste beschränken habe ich natürlich sofort verloren, sobald es eine Abweichung zwischen Pi und macOS gibt^^

  • Also, ich lass mir die Adressen mit sudo hcitool lescan anzeigen.

    ja ich auch - aber ich habe so viele der Sensoren und das tool zeigen so zu sagen die Entfernung an und da kann man sich gut vor den Sensor setzten scannen, verbinden und eis sicher, dass es der ist der in der Pflanzen xyz steckt.

    Le Scan zeigt nur den Typ an .. ist halt etwas nervig,


    Ich hab inzwischen 20 Stück :-D

    //.ichael

    -----------------------------------


  • mmh ich hab mich jetzt schon tierisch gefreut das es endlich ein Plugin für die Dinger gibt, leider kommt bei mir bei der Installations allerdings folgender Fehler:


    Hat zufällig jemand ähnliche Probleme? Die Sensoren werden aber im HomeKit hinzugefügt.


    Merci

  • Hat zufällig jemand ähnliche Probleme? Die Sensoren werden aber im HomeKit hinzugefügt.

    ja hab ich auch ...


    bislang hab ich das ignoriert. Aber vermutlich ist es am ende der Grund warum es beim mir inzwischen unter 1.1 auch nicht geht

    //.ichael

    -----------------------------------


  • heute ist mir folgendes im Log aufgefallen


    (node:2919) MaxListenersExceededWarning: Possible EventEmitter memory leak detected. 11 stateChange listeners added to [Noble]. Use emitter.setMaxListeners() to increase limit


    Noble habe ich glaub wegen dem Flora-Plugin installiert ?!?

    HomeKit Geräte / Homebridge Geräte:

    Raspberry 4 4GB | 4x Raspberrypi 3 Model B+ | Raspberry Zero | FritzBox 7490| HarmonyHub | Sonoff | Danalock | Koogeek | Z-Way | Raspi-Cam | SwitchBot | Shelly 2.5| Logitech Circle2 | RavenSystem



    Homebridge Plugins:

    Homebridge| Fritzbox | People | Callmonitor | Automation-Switches | Magichome-platform | Harmony | ewelink | OpenHAB | ioBroker | Z-Way | Camera-FFMPEG | Website-to-Camera | video-doorbell-button |

  • heute ist mir folgendes im Log aufgefallen


    (node:2919) MaxListenersExceededWarning: Possible EventEmitter memory leak detected. 11 stateChange listeners added to [Noble]. Use emitter.setMaxListeners() to increase limit


    Noble habe ich glaub wegen dem Flora-Plugin installiert ?!?

    Diese Meldung kannst ignorieren, hab hier im Forum schon öfters was darüber.

  • dein Link scheint nicht zu funktionieren.


    Manche haben es geschafft, das Plugin mit der aktuellen Node zu betreiben. Ich gehöre leider nicht dazu, obwohl ich auch schon eine neue HB aufgesetzt hab und mehreres ausprobiert habe es ans laufen zu bekommen.

    HomeKit Geräte / Homebridge Geräte:

    Raspberry 4 4GB | 4x Raspberrypi 3 Model B+ | Raspberry Zero | FritzBox 7490| HarmonyHub | Sonoff | Danalock | Koogeek | Z-Way | Raspi-Cam | SwitchBot | Shelly 2.5| Logitech Circle2 | RavenSystem



    Homebridge Plugins:

    Homebridge| Fritzbox | People | Callmonitor | Automation-Switches | Magichome-platform | Harmony | ewelink | OpenHAB | ioBroker | Z-Way | Camera-FFMPEG | Website-to-Camera | video-doorbell-button |

  • dein Link scheint nicht zu funktionieren.


    Manche haben es geschafft, das Plugin mit der aktuellen Node zu betreiben. Ich gehöre leider nicht dazu, obwohl ich auch schon eine neue HB aufgesetzt hab und mehreres ausprobiert habe es ans laufen zu bekommen.

    lescan findet die Sensoren? Einbinden konntest Du diese, aber es kommen keine Daten an (auch nach gut 10 Minuten nicht)? Oder was ist genau das Problem.


    Ich habe jetzt mir nochmal die NPM Beschreibung vom plug-in angesehen. Es steht ganz deutlich das es mit node 10+ kompatibel ist.


    Zitat

    System dependencies

    This plugin is using node-mi-flora / @abandonware/noble in the background with the same package dependencies. @abandonware/noble is a version of noble that has support for Node 10+. To be able to use this version of Noble, I had to create a fork of the node-mi-flora with support for this version of Noble.

    You can install the following dependencies using apt-get, if not already done.

    Code
    (sudo) apt-get install bluetooth bluez libbluetooth-dev libudev-dev

    It is recommended to install @abandonware/noble, node-gyp and bluetooth-hci-socket manually with the following commands:

    Code
    sudo npm install --unsafe-perm -g bluetooth-hci-socket
    sudo npm install -g --unsafe-perm @abandonware/noble
    sudo npm install -g --unsafe-perm node-gyp

    Aktuell bin ich auf node 12.17.0 wobei das Update für 12.18.0 schon da ist. Da meine Homebridge aber aktuell gut läuft, mag ich nicht updaten ;-)


    Ich warte lieber, bis Probleme auftreten, dann kann ich alles in einem Abwasch machen.


    Also, das verlinkte plug-in ist mit den Xiaomi Plant Sensoren (die wie Lutscher ausehen) kompatibel mit der aktuellen node Version. Es muss also an etwas anderem liegen...


    Gruß


    sschuste Du hattest doch auch die Xiaomi Sensoren. Wie hast Du Deine inzwischen ans laufen bekommen? Auch mit dem plug-in oder bist Du einen anderen Weg gegangen?

  • Auch mit dem plug-in oder bist Du einen anderen Weg gegangen?

    Ich hab die Sensoren sogar mit dem alten Plugin unter Node 10 zum Laufen bekommen, indem ich den armen Raspi softwaremäßig ordentlich verbogen habe. Das hätte natürlich nicht ein einziges Update überlebt, so dass es eine Fingerübung war, aber nix, was ich als Lösung hätte anbieten können.


    Also hab ich mir was gesucht, dass kein noble braucht und keinen darauf basierenden hci-socket und kein wiederum darauf basierendes Plugin. Und bin fündig geworden. Die Lösung ist viel aufwändiger als ein die Installation eines Plugins, aber sie funktioniert.


    Ich habe hier äußerst kurz beschrieben, wie das geht.