Neu bei Homekit ... und genervt! (Home App)

  • Hallo zusammen,


    ich verwende Tado und Hue, beide nativ Homekit fähig. Zudem habe ich über Homebridge auf meiner Synology einige zusätzliche Geräte angebunden.


    Da mir Erfahrungswerte fehlen, eine kurze Frage in die Runde:


    Ist es normal, dass die Home App sich beim Starten nur sehr unzuverlässig mit dem Service verbindet?

    Oft wird lange aktualisiert und in der "zuhause" Ansicht dann "keine Antwort" ausgegeben. Erst wenn ich in einen konkreten Raum gehe, wird der Kontakt zu den Geräten

    hergestellt und auch die "zuhause" Ansicht stimmt wieder.


    Ist das so üblich, oder gibt es einen Fehler in meiner Konfiguration?


    Über Antworten freue ich mich.


    VG


    Hendrik

  • Wenn ich in der Küche bin und mein Router steht in der Stube ist es auch arg verzögert. WLAN Signal muss sehr gut sein dann ist alles perfekt. Ein Ab und Anmelden bei Icloud brachte auch Erfolg und alles wurde schneller. Seid iOS12 auch alles viel besser.


    Gruß Norman

  • Also ich habe die gleichen Probleme - da die meisten Geräte über Bluetooth kommunizieren gibt es systembedingt Probleme mit der Reichweite. Ich habe z.B. einen Türsensor bei meiner Haustüre der die meiste Zeit in der Home-App mit "keine Antwort" angezeigt wird - dieser ist aber gerade mal ca 15m vom AppleTV entfernt (also auch für eine BT Verbindung nahe genug)

    Auch ein auf der Terrasse montierter Temperatursensor (EVE) wird sehr oft nicht erreicht (ebenfalls kurze Entfernung mit einer Glastüre dazwischen)


    Einzig Geräte welche im WLAN sind funktionieren perfekt (habe im Keller einen Netzadapter der immer erreichbar ist (und dass mit Stahlbetonwänden dazwischen) - Auch ein Heizungsthermostat welches über WLAN gesteuert wird funktioniert perfekt.


    Ich habe auch schon mit verschiedenen Aufstellungsorten meines Apple TV experimentiert - manchmal wird's ein wenig besser, aber das Apple TV sollte halt doch beim TV im Wohnzimmer bleiben. Auch ein Upgrade des Apple TV (vom 3er auf ein 4K) hat keine Besserung gebracht.


    Habe auch schon einige Male meine Konfiguration erneuert und so gut wie alle Tipps die man dazu finden kann durchprobiert (es wird einfach nicht besser)


    Alles in allem muss ich sagen dass HomeKit für mich momentan nicht wirklich geeignet ist und ich es für noch sehr unausgereift empfinde.


    Größtes Problem ist dabei der verwendete BT Übertragungsstandard (meiner Meinung nach)



    Grüße

    r.

  • Mit 15m Reichweite bist du aber sehr optimistisch. Die mittlere Reichweite bei Bluetooth beträgt 8 bis 10m. Dies ist aber auch hinlänglich bekannt und eine für Bluetooth typische Reichweite. Es wird dir auch niemand bestätigen, dass du mit nur einer Steuerzentrale eine reibungslose Zusammenarbeit aller Komponenten gewährleistet bekommst. Je nach Wohnungsgröße bedarf es hier drei bis fünf Zentralen wie bei uns z.B. im EG: 1 ATV, 1 Homepod und 1 IPad am Dauerstrom an der Wand. OG: 1ATV und ein IPad mit Dauerstrom an der Wand und siehe da, alles läuft sowas von völlig einwandfrei und vor allem zuverlässig, erst Recht seit IOS 12.

    Mit Smart Home können Sie Ihre Anwesenheit Zuhause simulieren, prima dann hätte noch gerne die Office Version dazu 8o

    -------------------------------------------------------------------------------------------------------------------------------------------------

    Wer den Hafen nicht kennt in den er segeln möchte, für den ist kein Wind der richtige - Lucius Seneca.

  • Das Problem ist auch die Routeranbindung von HomePod und AppleTV. Dabei habe ich festgestellt, dass der HomePod als verbundene Steuerzentrale gut funktioniert. Mein AppleTV 4K -eine Etage höher zickt schonmal.

    Insgesamt finde ich es schwierig, dieses "Home" zu konfigurieren. Vieles ist nicht sichtbar, oder wie die Steuerzentralenauswahl, nicht zu steuern. Stecker raus und warten ist eigentlich nicht die Lösung, aber klappt schonmal.

    Ich habe bisher auf alle Firmen verzichtet, die mit einer Bridge arbeiten und meine einzelnen HomeKit-Geräte über die HomeApp angemeldet.

    Wenn es eine gewisse Zeit problemlos läuft, überrascht es immer wieder mit nicht verbundenen Geräten.

    Mein iPad min 2 hat zwar das aktuelle iOS, scheint aber für HomeKit zu alt...

  • Die Lösung für das Bluetooth Problem ist einfach:

    Eine Zigbee bridge, wie z.B. die Hue und dann nur noch Zigbee Sensoren und Aktoren einsetzen. Einzigster Nachteil, die Kompatibilitäten findet man oft erst hinter her raus. (geht/geht nicht)


    Kostet auch viel weniger als 500 AppleTV in der Wohnung zu verteilen.

  • Ich hab nur ein AppleTv4k als Homezentrale im Schlafzimmer, aber sonst kein einziges natives Gerät bis auf Trädfri (ist aber natürlich per LAN am Router).

    Alles andere (Homematic, Milight, WLAN-Steckdosen, FunkSteckdosen, TV usw.) ist per HB zugeordnet.


    Es ist sehr, sehr selten, dass mal ein längeres "keine Antwort" erscheint.

    Egal ob ich vor Ort (Home-Wifi) bin, als auch von unterwegs - und auch dieser Zugriff von außerhalb läuft sehr stabil. Und es laufen bei mir zwangsweise einige Programme am RPi, wegen diesen "zusammengewürfelten" Komponenten. (ioBroker, HomeBridge, HA.Bridge, PiControl, webmin usw.)


    Ach ja - mein Wohnraum ist über 140qm und das Schlafzimmer mit dem ATV4k liegt am äußersten Ende.

    Daher verwundert es mich, dass bei euch - mit nativen Geräten - solche Probleme bestehen.

    Naja, wenn man natürlich 800 qm hat wird's wohl doch schwierig ;-)

  • Ich habe ein Apple TV4 als Steuerzentrale in der einen Ecke einer 85m2 Wohnung und decke damit alles Problemlos ab. Lediglich eine Eve Energy genau am anderen Ende der Wohnung, also am entferntesten Punkt, findet manchmal keinen Kontakt. Aber da sind drei Wände und ein Kamin zwischen der Steckdose und dem ATV4.
    Die Ladezeit in der Apple HomeApp ist seit iOS 12 sehr schnell geworden, es sei denn das iPhone hat eine schlechte Internetverbindung. Bei guter Verbindung dauert das 1-2 Sekunden.



    Gesendet von iPhone mit Community

  • Hallo zusammen,


    herzlichen Dank für die zahlreichen Erfahrungsberichte.


    Bei mir wurde es etwas besser, nachdem ich iCloud de- und wieder reaktiviert habe. Allerdings Immer noch weit entfernt von einem flüssigen Erlebnis.


    Aber immerhin scheint das ja nach euren Rückmeldungen aktuell leider eher die Regel zu sein. Erspart mir viel weiteres Tüfteln. Danke dafür.

  • Liest sich im ersten Satz wie ein Wunder,

    dann löst der 2 Satz es auf -wenn also "alles andere" über WLAN angedockt ist - kein Wunder !

    Das würde wohl auch bei 800 qm klappen...

  • Scheint bei mir auch was mit Homebridge zu tun zu haben.

    Die nativ unterstützen Geräte sind zuverlässiger verfügbar. Die per Homebridge angebundenen bekommen meist erst Kontakt, wenn ich ich den entsprechenden Raum wechsle.

  • Dieses ganze HomeKit System ist einfach eine Todgeburt! Es funktioniert nichts wie es sein sollte - das bin ich von Apple nicht gewohnt (schade eigentlich)


    Habe nun einen Zustand, wo 3 Geräte noch in der Home-App aufscheinen, diese aber permanent mit der Meldung "Aktualisieren" - werden aber nicht gefunden, ein Löschen der Geräte ist auch nicht möglich, wenn ich auf Gerät entfernen tippe - passiert rein gar nix, nach einigen Minuten kommt dann die Meldung "Vorgang konnte nicht abgeschlossen werden" und das Dialogfeld mit dem Gerät kann nicht geschlossen werden - also HomeApp komplett schließen (über Task-Manager) und wieder neu aufmachen - Geräte sind noch da und werden nicht gefunden. Wenn ich das ganze Haus aus HomeKit entfernen möchte tut sich ebenfalls nichts - keine Meldung, nix.

    Hab schon bei allen Geräten HomeKit aus den icloudSettings raus und wieder rein gegeben - es funktioniert einfach gar nichts mehr .....

    Zusätzlich zeigt die HomeKit App auf jedem Gerät ein anderes Bild an (am iPhone sind andere Geräte die nicht funktionieren im Vergleich zum iPad)

    Eine andere Möglichkeit HomeKit Zurückzusetzen gibt es anscheinend auch nicht ....

  • Habt Ihr denn alle Geräte in den Favoriten, sprich direkt auf der Startseite von Home?

    Seit dem ich mich hier auf die wirklich wesentlichen Geräte beschränke (aktuell gerade einmal 14 Geräte) öffnet die App schnell und mit zuverlässigem Gerätestatus.

  • Hmm kann einige nicht verstehen. Das funktioniert alles so reibungslos und schnell. Geräte Aktualisieren in nicht mehr als einer Sekunde. Nichts stürzt ab oder bleibt hängen. Die Geräte die übern Raspi eingebunden sind hängen etwas hinterher aber seit IOS 12 alles richtig angenehmund flüssig.

    Auch im Kontrollzentrum der Home Button läuft perfekt mit den Geräten und Szenen.

  • Ich muss inzwischen auch Entwarnung geben! Nach ewigem Hin und Her hat sich das Netatmo Plugin als Ursache herausgestellt. Es bremst die gesamte Homebridge aus und führt zu der von mir beobachteten Problematik.


    Homebridge lauft nun flüssig und die Daten stehen instantan in der Home App zur Verfügung.


    Als Alternative zum Netatmo Plugin nutze ich nun homebridge-eveatmo v0.4.0.

    Es stellt zwar keine Kamera Daten zur Verfügung, was jedoch zu verscherzen ist, da nativer HomeKit Support für die Netatmo Kameras gerade ausgerollt wird.

  • henkb hab gerade selbige Baustelle. Vorwerk-Plugin war es schon mal nicht. Wäre nur noch my weather plus oder dad einfach langsame Raspberry 1 + deConz GUI.


    Aber statt Plugins komplett zu streichen solltest du überlegen einen zweiten Homebridge-Process laufen zu lassen, nur für das langsame Plugin...

  • henkb


    Hi,


    kurze Frage: Warst du das aktuell auch mit dem Issue auf github bei der homebridge? 😜



    Gesendet von iPhone mit Community

  • Aber statt Plugins komplett zu streichen solltest du überlegen einen zweiten Homebridge-Process laufen zu lassen, nur für das langsame Plugin...

    Ja, das wäre auch nochmal eine Alternative. Allerdings konnte ich das Plugin ja erfolgreich durch ein anderes ersetzen.


    Hi,


    kurze Frage: Warst du das aktuell auch mit dem Issue auf github bei der homebridge? 😜

    Genau. Das war ich ebenfalls. :)