Homebridge starte nicht

  • Hallo zusammen,


    meine Homebridge lief bisher ohne Probleme.


    Heute habe ich ein Plugin deinstalliert und die Homebridge neu gestartet, seit dem erreiche ich sie nicht mehr unter "http://192.168.178.100:8080"


    Wenn ich die Homebridge Manuel starte "sudo Homebridge" (ob das so richtig ist keine Ahnung) dann startet sie immer in einem anderen Port und nicht wie in der Konfiguration 51826.


    Was kann ich tun?

  • Was kann ich tun?

    Als allererstes verzichtest du mal auf sudo homebridge. Und dann erzählst du mal, nach welcher Anleitung du die Homebridge installiert hast.

  • ich habe nach Anleitung smartapfel installiert.

    Allerdings parallel zu Biobroker auf einem pi4.

    Wir haben im Dezember schon mal geschrieben, das bei mir die Verzeichnisse dadurch etwas anders sind

  • ich habe nach Anleitung smartapfel installiert.

    Ok. Die Anleitung sagt, dass man die Homebridge mit sudo systemctl start homebridge startet oder mit sudo systemctl restart homebridge neustartet. Sie sagt darüber hinaus, dass man das Logfile ansehen kann mit sudo journalctl -fau homebridge und dass man sogar einen Start der Homebridge mit der Anzeige des Logs verbinden kann mit sudo systemctl restart homebridge; sudo journalctl -fau homebridge.

    Was kann ich tun?

    Das Log lesen. Also das tun, was Server-Administratoren so machen. Du bist zufälligerweise Server-Administrator. Im Log steht drin, warum die Homebridge nicht startet. Log lesen ist nicht einfach, daher kannst es hier auch posten und wir schauen gemeinsam rein.

  • -- Logs begin at Tue 2021-01-05 09:38:01 CET. --

    Jan 05 10:12:28 pi4-iobroker homebridge[3530]: at Object.<anonymous> (/usr/lib/node_modules/homebridge/bin/homebridge:17:22)

    Jan 05 10:12:28 pi4-iobroker homebridge[3530]: at Module._compile (internal/modules/cjs/loader.js:999:30)

    Jan 05 10:12:28 pi4-iobroker homebridge[3530]: at Object.Module._extensions..js (internal/modules/cjs/loader.js:1027:10)

    Jan 05 10:12:28 pi4-iobroker homebridge[3530]: at Module.load (internal/modules/cjs/loader.js:863:32)

    Jan 05 10:12:28 pi4-iobroker homebridge[3530]: [2021-1-5 10:12:28] Got SIGTERM, shutting down Homebridge...

    Jan 05 10:12:28 pi4-iobroker homebridge[3530]: [2021-1-5 10:12:28] [HomeMatic CCU] [RPC] Removing Event Server for Interface BidCos-RF.

    Jan 05 10:12:28 pi4-iobroker homebridge[3530]: [2021-1-5 10:12:28] [HomeMatic CCU] [RPC] Removing Event Server for Interface BidCos-Wired.

    Jan 05 10:12:28 pi4-iobroker homebridge[3530]: [2021-1-5 10:12:28] [HomeMatic CCU] [RPC] Removing Event Server for Interface HmIP-RF.

    Jan 05 10:12:28 pi4-iobroker systemd[1]: homebridge.service: Succeeded.

    Jan 05 11:23:11 pi4-iobroker systemd[1]: Started Node.js HomeKit Server.

    Jan 05 11:23:11 pi4-iobroker homebridge[7358]: [2021-1-5 11:23:11] Loaded config.json with 1 accessories and 2 platforms.

    Jan 05 11:23:11 pi4-iobroker homebridge[7358]: [2021-1-5 11:23:11] ---

    Jan 05 11:23:12 pi4-iobroker homebridge[7358]: [2021-1-5 11:23:12] Loaded plugin: [email protected]

    Jan 05 11:23:12 pi4-iobroker homebridge[7358]: [2021-1-5 11:23:12] Registering platform 'homebridge-config-ui-x.config'

    Jan 05 11:23:12 pi4-iobroker homebridge[7358]: [2021-1-5 11:23:12] ---

    Jan 05 11:23:12 pi4-iobroker homebridge[7358]: [2021-1-5 11:23:12] Loaded plugin: homebridge-home[email protected]

    Jan 05 11:23:12 pi4-iobroker homebridge[7358]: [2021-1-5 11:23:12] Registering platform 'homebridge-homematic.HomeMatic'

    Jan 05 11:23:12 pi4-iobroker homebridge[7358]: [2021-1-5 11:23:12] ---

    Jan 05 11:23:12 pi4-iobroker homebridge[7358]: [2021-1-5 11:23:12] Loading 2 platforms...

    Jan 05 11:23:12 pi4-iobroker homebridge[7358]: [2021-1-5 11:23:12] [Config] Initializing config platform...

    Jan 05 11:23:12 pi4-iobroker homebridge[7358]: [2021-1-5 11:23:12] [Config] Spawning homebridge-config-ui-x with PID 7380

    Jan 05 11:23:12 pi4-iobroker homebridge[7358]: [2021-1-5 11:23:12] [HomeMatic CCU] Initializing HomeMatic platform...

    Jan 05 11:23:12 pi4-iobroker homebridge[7358]: [2021-1-5 11:23:12] [HomeMatic CCU] [Core] merging configurations

    Jan 05 11:23:12 pi4-iobroker homebridge[7358]: [2021-1-5 11:23:12] [HomeMatic CCU] Homematic Plugin Version 0.1.231

    Jan 05 11:23:12 pi4-iobroker homebridge[7358]: [2021-1-5 11:23:12] [HomeMatic CCU] Plugin by thkl https://github.com/thkl

    Jan 05 11:23:12 pi4-iobroker homebridge[7358]: [2021-1-5 11:23:12] [HomeMatic CCU] Homematic is a registered trademark of the EQ-3 AG

    Jan 05 11:23:12 pi4-iobroker homebridge[7358]: [2021-1-5 11:23:12] [HomeMatic CCU] Please report any issues to https://github.com/thkl/homebridge-homematic/issues

    Jan 05 11:23:12 pi4-iobroker homebridge[7358]: [2021-1-5 11:23:12] [HomeMatic CCU] running in production mode

    Jan 05 11:23:12 pi4-iobroker homebridge[7358]: [2021-1-5 11:23:12] [HomeMatic CCU] will connect to your ccu at 192.168.178.101

    Jan 05 11:23:12 pi4-iobroker homebridge[7358]: [2021-1-5 11:23:12] [HomeMatic CCU] IMPORTANT !! Starting this version, your homematic custom configuration is located in /var/homebridge/homematic_config.json

    Jan 05 11:23:12 pi4-iobroker homebridge[7358]: [2021-1-5 11:23:12] [HomeMatic CCU] [RPC] using xmprpc for communication with BidCos-RF

    Jan 05 11:23:12 pi4-iobroker homebridge[7358]: [2021-1-5 11:23:12] [HomeMatic CCU] init RPC for BidCos-RF.

    Jan 05 11:23:12 pi4-iobroker homebridge[7358]: [2021-1-5 11:23:12] [HomeMatic CCU] [RPC] local ip used : 192.168.178.100. you may change that with local_ip parameter in config

    Jan 05 11:23:12 pi4-iobroker homebridge[7358]: [2021-1-5 11:23:12] [HomeMatic CCU] init RPC for VirtualDevices.

    Jan 05 11:23:12 pi4-iobroker homebridge[7358]: [2021-1-5 11:23:12] [HomeMatic CCU] [RPC] local ip used : 192.168.178.100. you may change that with local_ip parameter in config

    Jan 05 11:23:12 pi4-iobroker homebridge[7358]: [2021-1-5 11:23:12] [HomeMatic CCU] [RPC] using xmprpc for communication with BidCos-Wired

    Jan 05 11:23:12 pi4-iobroker homebridge[7358]: [2021-1-5 11:23:12] [HomeMatic CCU] init RPC for BidCos-Wired.

    Jan 05 11:23:12 pi4-iobroker homebridge[7358]: [2021-1-5 11:23:12] [HomeMatic CCU] [RPC] local ip used : 192.168.178.100. you may change that with local_ip parameter in config

    Jan 05 11:23:12 pi4-iobroker homebridge[7358]: [2021-1-5 11:23:12] [HomeMatic CCU] init RPC for HmIP-RF.

    Jan 05 11:23:12 pi4-iobroker homebridge[7358]: [2021-1-5 11:23:12] [HomeMatic CCU] [RPC] local ip used : 192.168.178.100. you may change that with local_ip parameter in config

    Jan 05 11:23:12 pi4-iobroker homebridge[7358]: [2021-1-5 11:23:12] Loading 1 accessories...

    Jan 05 11:23:12 pi4-iobroker homebridge[7358]: [2021-1-5 11:23:12] Error loading accessory requested in your config.json at position 1

    Jan 05 11:23:12 pi4-iobroker homebridge[7358]: [2021-1-5 11:23:12] [HomeMatic CCU] [RPC] server for interface BidCos-RF. is listening on port 9090.

    Jan 05 11:23:12 pi4-iobroker homebridge[7358]: [2021-1-5 11:23:12] [HomeMatic CCU] [RPC] Creating Local HTTP Client for CCU RPC Events

    Jan 05 11:23:12 pi4-iobroker homebridge[7358]: [2021-1-5 11:23:12] [HomeMatic CCU] [RPC] server for interface VirtualDevices. is listening on port 9093.

    Jan 05 11:23:12 pi4-iobroker homebridge[7358]: [2021-1-5 11:23:12] [HomeMatic CCU] [RPC] Creating Local HTTP Client for CCU RPC Events

    Jan 05 11:23:12 pi4-iobroker homebridge[7358]: [2021-1-5 11:23:12] [HomeMatic CCU] [RPC] server for interface BidCos-Wired. is listening on port 9091.

    Jan 05 11:23:12 pi4-iobroker homebridge[7358]: [2021-1-5 11:23:12] [HomeMatic CCU] [RPC] Creating Local HTTP Client for CCU RPC Events

    Jan 05 11:23:12 pi4-iobroker homebridge[7358]: [2021-1-5 11:23:12] [HomeMatic CCU] [RPC] server for interface HmIP-RF. is listening on port 9092.

    Jan 05 11:23:12 pi4-iobroker homebridge[7358]: [2021-1-5 11:23:12] [HomeMatic CCU] [RPC] Creating Local HTTP Client for CCU RPC Events

    Jan 05 11:23:13 pi4-iobroker homebridge[7358]: [2021-1-5 11:23:13] Error: The requested accessory 'XiaomiRoborockVacuum' was not registered by any plugin.

    Jan 05 11:23:13 pi4-iobroker homebridge[7358]: at PluginManager.getPluginForAccessory (/usr/lib/node_modules/homebridge/src/pluginManager.ts:198:15)

    Jan 05 11:23:13 pi4-iobroker homebridge[7358]: at /usr/lib/node_modules/homebridge/src/server.ts:347:37

    Jan 05 11:23:13 pi4-iobroker homebridge[7358]: at Array.forEach (<anonymous>)

    Jan 05 11:23:13 pi4-iobroker homebridge[7358]: at Server._loadAccessories (/usr/lib/node_modules/homebridge/src/server.ts:330:29)

    Jan 05 11:23:13 pi4-iobroker homebridge[7358]: at Server.start (/usr/lib/node_modules/homebridge/src/server.ts:156:12)

    Jan 05 11:23:13 pi4-iobroker homebridge[7358]: at cli (/usr/lib/node_modules/homebridge/src/cli.ts:80:10)

    Jan 05 11:23:13 pi4-iobroker homebridge[7358]: at Object.<anonymous> (/usr/lib/node_modules/homebridge/bin/homebridge:17:22)

    Jan 05 11:23:13 pi4-iobroker homebridge[7358]: at Module._compile (internal/modules/cjs/loader.js:999:30)

    Jan 05 11:23:13 pi4-iobroker homebridge[7358]: at Object.Module._extensions..js (internal/modules/cjs/loader.js:1027:10)

    Jan 05 11:23:13 pi4-iobroker homebridge[7358]: at Module.load (internal/modules/cjs/loader.js:863:32)

    Jan 05 11:23:13 pi4-iobroker homebridge[7358]: [2021-1-5 11:23:13] Got SIGTERM, shutting down Homebridge...

    Jan 05 11:23:13 pi4-iobroker homebridge[7358]: [2021-1-5 11:23:13] [HomeMatic CCU] [RPC] Removing Event Server for Interface BidCos-RF.

    Jan 05 11:23:13 pi4-iobroker homebridge[7358]: [2021-1-5 11:23:13] [HomeMatic CCU] [RPC] Removing Event Server for Interface BidCos-Wired.

    Jan 05 11:23:13 pi4-iobroker homebridge[7358]: [2021-1-5 11:23:13] [HomeMatic CCU] [RPC] Removing Event Server for Interface HmIP-RF.

    Jan 05 11:23:13 pi4-iobroker systemd[1]: homebridge.service: Succeeded.

  • Du hast kein Plugin für den Xiaomi Staubsauger installiert. Entweder lädst dir das Plugin runter oder du schmeißt den Xiaomi Eintrag aus deiner config.

  • Genau, Lling hat recht. Vielleicht reicht ja ein:

    npm install -g --unsafe-perm homebridge-xiaomi-roborock-vacuum

  • Ich fürchte das ist genau das Plugin das er deinstalliert hat. Wird er ja nicht ohne Grund gemacht haben.


    Aber entweder das Plugin installieren oder es aus der Config schmeißen.

  • Das hat leider nicht funktioniert


    [email protected]:~ $ npm install -g --unsafe-perm homebridge-xiaomi-roborock-vacuum

    npm WARN checkPermissions Missing write access to /usr/lib/node_modules

    npm ERR! code EACCES

    npm ERR! syscall access

    npm ERR! path /usr/lib/node_modules

    npm ERR! errno -13

    npm ERR! Error: EACCES: permission denied, access '/usr/lib/node_modules'

    npm ERR! [Error: EACCES: permission denied, access '/usr/lib/node_modules'] {

    npm ERR! errno: -13,

    npm ERR! code: 'EACCES',

    npm ERR! syscall: 'access',

    npm ERR! path: '/usr/lib/node_modules'

    npm ERR! }

    npm ERR!

    npm ERR! The operation was rejected by your operating system.

    npm ERR! It is likely you do not have the permissions to access this file as the current user

    npm ERR!

    npm ERR! If you believe this might be a permissions issue, please double-check the

    npm ERR! permissions of the file and its containing directories, or try running

    npm ERR! the command again as root/Administrator.


    npm ERR! A complete log of this run can be found in:

    npm ERR! /home/pi/.npm/_logs/2021-01-05T12_20_49_280Z-debug.log

  • Sudo npm install -g --unsafe-perm homebridge-xiaomi-roborock-vacuum

  • Jetzt habe ich ein neue Problem.

    die Bridge ist in Apple Home Kit verschwunden.

    Wenn ich neu anlerne kommt die Meldung, dass die Bridge bereits verbunden ist.


    Wo kann ich die Bridge ändern das diese wie eine neue für Apple wie eine neue Erscheint.

  • Wo kann ich die Bridge ändern das diese wie eine neue für Apple wie eine neue Erscheint.

    Ändere in config.json den Usernamen, beispielsweise von CC:22:3D:E3:CE:30 in CC:22:3D:E3:CE:31 und starte die Homebridge neu.

  • Hab vorhin das Eufy Security Plugin zum Testen installiert, nach dem es nicht richtig lief habe ich es deinstalliert.


    Seit dem startet die Homebridge nicht mehr.


    Anbei mein Log, wäre um jede Hilfe dankbar.


    Feb 18 20:18:43 raspberrypi homebridge[6111]: [18/02/2021, 20:18:43] Homebridge is running on port 51826.

    Feb 18 20:18:44 raspberrypi homebridge[6111]: [18/02/2021, 20:18:44] [EufySecurityHomebridgePlugin] failed to register push token Error: Request failed: https://security-app-eu.eufylife.com/v1/passport/login -> 100028 - Failed to request.

    Feb 18 20:18:44 raspberrypi homebridge[6111]: at /usr/local/lib/node_modules/homebridge-plugin-eufy-security/node_modules/eufy-node-client/build/http/http.utils.js:24:15

    Feb 18 20:18:44 raspberrypi homebridge[6111]: at Generator.next (<anonymous>)

    Feb 18 20:18:44 raspberrypi homebridge[6111]: at fulfilled (/usr/local/lib/node_modules/homebridge-plugin-eufy-security/node_modules/eufy-node-client/build/http/http.utils.js:5:58)

    Feb 18 20:18:44 raspberrypi homebridge[6111]: at processTicksAndRejections (internal/process/task_queues.js:93:5)

    Feb 18 20:18:44 raspberrypi homebridge[6111]: (node:6111) UnhandledPromiseRejectionWarning: Error: Request failed: https://security-app-eu.eufylife.com/v1/passport/login -> 100028 - Failed to request.

    Feb 18 20:18:44 raspberrypi homebridge[6111]: at /usr/local/lib/node_modules/homebridge-plugin-eufy-security/node_modules/eufy-node-client/build/http/http.utils.js:24:15

    Feb 18 20:18:44 raspberrypi homebridge[6111]: at Generator.next (<anonymous>)

    Feb 18 20:18:44 raspberrypi homebridge[6111]: at fulfilled (/usr/local/lib/node_modules/homebridge-plugin-eufy-security/node_modules/eufy-node-client/build/http/http.utils.js:5:58)

    Feb 18 20:18:44 raspberrypi homebridge[6111]: at processTicksAndRejections (internal/process/task_queues.js:93:5)

    Feb 18 20:18:44 raspberrypi homebridge[6111]: (Use `node --trace-warnings ...` to show where the warning was created)

    Feb 18 20:18:44 raspberrypi homebridge[6111]: (node:6111) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). To terminate the node process on unhandled promise rejection, use the CLI flag `--unhandled-rejections=strict` (see https://nodejs.org/api/cli.htm…unhandled_rejections_mode). (rejection id: 1)

    Feb 18 20:18:44 raspberrypi homebridge[6111]: (node:6111) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code.

    Feb 18 20:18:44 raspberrypi homebridge[6111]: [18/02/2021, 20:18:44] TypeError [ERR_INVALID_ARG_TYPE]: The "data" argument must be of type string or an instance of Buffer, TypedArray, or DataView. Received undefined

    Feb 18 20:18:44 raspberrypi homebridge[6111]: at Hash.update (internal/crypto/hash.js:84:11)

    Feb 18 20:18:44 raspberrypi homebridge[6111]: at Object.generate (/usr/local/lib/node_modules/homebridge/node_modules/hap-nodejs/src/lib/util/uuid.ts:9:11)

    Feb 18 20:18:44 raspberrypi homebridge[6111]: at PushClient.callback (/usr/local/lib/node_modules/homebridge-plugin-eufy-security/src/platform.ts:134:46)

    Feb 18 20:18:44 raspberrypi homebridge[6111]: at PushClient.handleParsedMessage (/usr/local/lib/node_modules/homebridge-plugin-eufy-security/node_modules/eufy-node-client/build/push/push-client.service.js:206:26)

    Feb 18 20:18:44 raspberrypi homebridge[6111]: at PushClientParser.<anonymous> (/usr/local/lib/node_modules/homebridge-plugin-eufy-security/node_modules/eufy-node-client/build/push/push-client.service.js:103:63)

    Feb 18 20:18:44 raspberrypi homebridge[6111]: at PushClientParser.emit (events.js:315:20)

    Feb 18 20:18:44 raspberrypi homebridge[6111]: at PushClientParser.onGotMessageBytes (/usr/local/lib/node_modules/homebridge-plugin-eufy-security/node_modules/eufy-node-client/build/push/push-client-parser.service.js:150:14)

    Feb 18 20:18:44 raspberrypi homebridge[6111]: at PushClientParser.handleFullMessage (/usr/local/lib/node_modules/homebridge-plugin-eufy-security/node_modules/eufy-node-client/build/push/push-client-parser.service.js:79:22)

    Feb 18 20:18:44 raspberrypi homebridge[6111]: at PushClientParser.waitForData (/usr/local/lib/node_modules/homebridge-plugin-eufy-security/node_modules/eufy-node-client/build/push/push-client-parser.service.js:64:18)

    Feb 18 20:18:44 raspberrypi homebridge[6111]: at PushClientParser.onGotMessageSize (/usr/local/lib/node_modules/homebridge-plugin-eufy-security/node_modules/eufy-node-client/build/push/push-client-parser.service.js:124:18)

    Feb 18 20:18:44 raspberrypi homebridge[6111]: [18/02/2021, 20:18:44] Got SIGTERM, shutting down Homebridge...

    Feb 18 20:18:45 raspberrypi homebridge[6111]: [18/02/2021, 20:18:45] [MagicHome-Platform] [ 'Polling Light', 'ACCF239F2950' ]

    Feb 18 20:18:45 raspberrypi homebridge[6111]: [18/02/2021, 20:18:45] [MagicHome-Platform] /usr/local/lib/node_modules/homebridge-magichome-platform/src/flux_led.py 192.168.178.48 -i

    Feb 18 20:18:45 raspberrypi homebridge[6111]: [18/02/2021, 20:18:45] [MagicHome-Platform] Unknown ID [192.168.178.48] OFF [Color: (26, 5, 0)]

    Feb 18 20:18:45 raspberrypi homebridge[6111]: [18/02/2021, 20:18:45] [MagicHome-Platform] [ 'Updating Device', 'ACCF239F2950', { H: 12, S: 100, L: 10 }, false ]

    Feb 18 20:18:45 raspberrypi homebridge[6111]: [18/02/2021, 20:18:45] [Homebridge UI] Homebridge Config UI X v4.39.0 is listening on :: port 8080

    Feb 18 20:18:46 raspberrypi homebridge[6111]: [18/02/2021, 20:18:46] [MagicHome-Platform] 1 bulbs found

    Feb 18 20:18:46 raspberrypi homebridge[6111]: ACCF239F2950=192.168.178.48

    Feb 18 20:18:46 raspberrypi homebridge[6111]: [18/02/2021, 20:18:46] [MagicHome-Platform] Saving Lights

    Feb 18 20:18:46 raspberrypi homebridge[6111]: [18/02/2021, 20:18:46] [MagicHome-Platform] {"ACCF239F2950":"192.168.178.48","192.168.178.48":"192.168.178.48"}

    Feb 18 20:18:46 raspberrypi homebridge[6111]: [18/02/2021, 20:18:46] [MagicHome-Platform] Lights Saved.

    Feb 18 20:18:46 raspberrypi homebridge[6111]: [18/02/2021, 20:18:46] [MagicHome-Platform] Discovery Finished

    Feb 18 20:18:46 raspberrypi homebridge[6111]: [18/02/2021, 20:18:46] [MagicHome-Platform] { ACCF239F2950: '192.168.178.48', '192.168.178.48': '192.168.178.48' }

    Feb 18 20:18:49 raspberrypi homebridge[6111]: [18/02/2021, 20:18:49] [Hue] goodbye

    Feb 18 20:18:49 raspberrypi systemd[1]: homebridge.service: Main process exited, code=exited, status=143/n/a

    Feb 18 20:18:49 raspberrypi systemd[1]: homebridge.service: Failed with result 'exit-code'.

    Feb 18 20:18:59 raspberrypi systemd[1]: homebridge.service: Service RestartSec=10s expired, scheduling restart.

    Feb 18 20:18:59 raspberrypi systemd[1]: homebridge.service: Scheduled restart job, restart counter is at 4.

    Feb 18 20:18:59 raspberrypi systemd[1]: Stopped Node.js HomeKit Server.

    Feb 18 20:18:59 raspberrypi systemd[1]: Starting Node.js HomeKit Server...

  • Du hast das eufy Plugin Konfiguration noch in deiner confit stehen. Musst du rauslöschen.

    Ja das hatte ich vorhin schon probiert, konnte die Config.json nicht aufrufen.


    Hatte es dann mit installieren / deinstallieren ebenfalls übers Terminal versucht. Konnte die Konfig. trotzdem nicht aufrufen


    Irgendwie hat sie sich jetzt gefangen, konnte es dann aus der Konfig. löschen.


    Danke dir.


    Wie gehe ich den generell vor wenn ich auf die config.JSON im Terminal zugreifen möchte?

    Habe sudo nano/var/homebridge/config.json eingegeben.

    Kam aber die Meldung das er sie nicht finden kann.

  • Wie gehe ich den generell vor wenn ich auf die config.JSON im Terminal zugreifen möchte?

    Habe sudo nano/var/homebridge/config.json eingegeben.

    Kam aber die Meldung das er sie nicht finden kann.

    Es kommt drauf an, wie du homebridge installiert hast, weil da kann die Datei an unterschiedlichen Stellen liegen. Generell, sollte mittlerweile bei so gut wie allen serioesen Installationsanleitungen es so aufgebaut sein, dass config-ui-x mit dabei ist und dieses Plugin unabhaengig von homebridge laeuft und du dort auf die Benutzeroberflaeche kommst um deine config. im browser anzupassen.


    Ansonsten, sollte die config.json bei dir an der Stelle liegen die du oben eingegeben hast, dann beachte, dass du zumindest hier in deinem Beitrag ein Leerzeichen vergessen hast, es heißt:


    sudo nano /var/homebridge/config.json.


    Solltest du homebridge mit der offiziellen Anleitung von github selbst installiert haben, dann helfen dir hier diese Pfade weiter:


    Homebridge Pfade und Befehle

  • Es kommt drauf an, wie du homebridge installiert hast, weil da kann die Datei an unterschiedlichen Stellen liegen. Generell, sollte mittlerweile bei so gut wie allen serioesen Installationsanleitungen es so aufgebaut sein, dass config-ui-x mit dabei ist und dieses Plugin unabhaengig von homebridge laeuft und du dort auf die Benutzeroberflaeche kommst um deine config. im browser anzupassen.

    Habe es installiert wie hier beschrieben, nur hatte die Oberfläche auch Probleme. Teilweise kurz aufgetaucht und dann aber wieder abgestürzt oder Ladeanzeige.

    Irgendwann nach mehreren versuchen konnte ich über die Oberfläche die Config anpassen.


    Habe aber auch alles, wie in den Beiträgen beschrieben, ausprobiert. Über Terminal installieren / deinstallieren des fehlerhaften Plugins. Vielleicht hat das auch dazu beigetragen dass ich die Oberfläche im Browser wieder erreichen konnte.


    Ansonsten, sollte die config.json bei dir an der Stelle liegen die du oben eingegeben hast, dann beachte, dass du zumindest hier in deinem Beitrag ein Leerzeichen vergessen hast, es heißt:


    sudo nano /var/homebridge/config.json.

    Wahrscheinlich habe ich tatsächlich in der „Panik“ das Leerzeichen vergessen.

  • Guten morgen zusammen


    Ich habe seit ein paar Tagen folgendes Problem:

    Ich wollte auf meine über homebridge eingebundenen Geräte zugreifen, dabei habe ich festgestellt das die Geräte nicht erreichbar sind. Ich kann auch über den pc nicht auf homebridge zugreifen, nur übers iPhone. Laut log stimmt was mit homeconnect nicht also Plugin deaktiviert und plötzlich stimmt was mit dem FRITZ!Box Plugin nicht mehr also auch deaktiviert. Aber das Spiel geht so weiter Plugin für Plug in.

    Das Problem hatte ich vor ein paar Tagen schon einmal, ich habe den raspi von Strom getrennt und danach lief es wieder. Eben das gleiche. Das kann ja nicht normal sein?!

    Ich habe leider nur Bildschirmaufnahmen, kann mir hier bitte jemand helfen.