Verzögerter Homebridge Start nach Reboot (Empfehlenswert bei der Nutzung vom RaspBee Gateway mit deConz)

  • Auf Grund der Übersichtlichkeit und der Größe des Threads Installation RaspBee von Dresden habe ich hier damit uns das errungene Wissen nicht verloren geht kurz zusammengefasst wie ein verzögerter Start der Homebridge beim Reboot eingerichtet wird.


    Wieso dieser benötigt wird kann im hier nachgelesen werden Installation RaspBee von Dresden


    An dieser Stelle nochmal vielen Dank für die Unterstützung von @Krocko und SeydX :thumbup:


    1.) Datei anlegen:

    Code
    /etc/systemd/system/homebridge.timer



    2.) Inhalt einfügen:

    Code
    [Unit]
    Description=Homebridge verzögert starten
    [Timer]
    OnBootSec=5min
    Unit=homebridge.service
    [Install]
    WantedBy=multi-user.target

    Hinweis:

    OnBootSec=5min kann variabel verändert werden nach belieben.


    3.) Aktivieren mit:

    Code
    sudo systemctl daemon-reload
    sudo systemctl enable homebridge.timer
    sudo systemctl start homebridge.timer


    4.) Prüfen ob Timer angelegt wurde:

    Code
    systemctl list-timers --all
    Code
    [email protected]:~ $ systemctl list-timers
    NEXT LEFT LAST PASSED UNIT ACTIVATES
    Mon 2017-12-25 19:59:39 CET 1min 29s left n/a n/a homebridge.timer homebridge.service
    Mon 2017-12-25 20:09:39 CET 11min left n/a n/a systemd-tmpfiles-clean.timer systemd-tmpfiles-clean.service
    Tue 2017-12-26 06:06:44 CET 10h left Mon 2017-12-25 06:04:35 CET 13h ago apt-daily-upgrade.timer apt-daily-upgrade.service
    Tue 2017-12-26 08:25:05 CET 12h left Mon 2017-12-25 18:09:20 CET 1h 48min ago apt-daily.timer apt-daily.service

    5.) Datei homebridge.service im Autostart deaktivieren

    Code
    sudo systemctl disable homebridge.service
  • Hier noch eine zweite Variante wie man eine Verzögerung einbauen kann. Diese unterscheidet sich zum Timer dahin das hier auch beim Restart verzögert wird und nicht nur beim Boot.


    Kann hilfreich sein wenn man viele Instanzen von Homebridge laufen lassen möchte diese aber versetzt starten sollen.

    .

    Pfad öffnen:

    /etc/systemd/system


    Service Datei öffnen von der Homebridge oder der Instanz:

    homebridge.service


    Zeile 13 einfügen: ExecStartPre=/bin/sleep 20

    The only way to do great work is to love what you do !

  • Und wie verhält sich das ganze bei mehreren instanzen? Gilt das für alle laufenden die Verzögerung?

    Wer nicht mit der Zeit geht, muss mit der Zeit gehen 8o

  • Das bezieht sich immer auf eine Instanz. Erste Instanz 10 sek die zweite fängt nach 20 sek an usw.

    The only way to do great work is to love what you do !

  • det

    Log kommt morgen im Laufe des Tages...

    Ich habe DeConz exakt so installiert wie im Thead „Installation RaspBee von Dresden“ beschrieben. Dementsprechend startet DeConz als Service...

    Ich denke es stimmt etwas mit der Ausführung des Autostart Scripts nicht, wobei das Script selber ja zu funktionieren scheint denn die Befehle Start/stop/Status/ funktionieren ja...

    Ich denke ich werde es morgen gegen das Autostart Script von Dir hier im Forum tauschen.


    Nastra

    Mit Deinem Script wird Homebridge nach dem Boot des Pi als Service gestartet, genau wie beim bisherigen Script, nur zeitverzögert? Dann könnte ich das ja ebenfalls nehmen um die bisherige Autostart zu löschen?

  • Wenn das startscript generell funktioniert,

    1 sudo update-rc.d homebridge defaults

    Nochmal ausführen.


    Um es als Dienst zu starten, reicht nicht nur das Script, es müssen 2 Skripte sein

    Und ein paar Befehle.

    Gibt hier einen Thread hombridge als Dienst einrichten.

  • Ich habe versucht gerade die Start Verzögerung ein zu bauen habe aber nun folgende Probleme:


    Option 1:

    Ich kann die Datei leider Aufgrund der fehlenden „permission“ nicht anlegen. Fehlen mir rechte über VNC?


    Option 2:

    Die Homebridge.service finde ich nicht, Homebridge ist per iOS „Homebridge“ App installiert worden da ich manuell leider nur Probleme hatte auf dem Beta Image von Dresden (ich wollte den Phoscon Support).


    Bei mir sieht der Ordner wie folgt angehangen aus.


    Nastra

    Hast du vielleicht eine Idee?


    Ich freu mich auf euer Feedback!

  • Deine Homebridge scheint nicht als systemd eingerichtet zusein daher ist auch kein Service vorhanden. Diese App wird vermutlich die HB als init.d installiert haben. Da ich die App nicht nutze kann ich dir da auch nichts genaueres sagen.


    Dir bringt da auch nichts einfach die Datei anzulegen die HB umzustellen auf systemd da gehört ein bissien mehr zu. Im Bereich Anleitungen gibt es einen Thread von det der beschreibt wie man die init.d HB umstellt auf systemd. Kann aber gut sein das die App dann nicht mehr mit deiner HB funktioniert.


    Anlegen kannst du keine Datei weil du nicht als root angemeldet bist vermutlich.


    Auch wenn ich es gefühlt schon 1000 mal geschrieben habe nehm statt diese App die Schrott ist doch lieber ein fertiges Image auch im Bereich Anleitung verfügbar was nur auf die SD Karte gespielt werden muss, Plugins installieren fertig.


    Ich glaube ich werde mal die Tage einen Thread erstellen und anpinnen für alle App geschädigten mit diesem Hinweis ^^


    Oder der Entwickler der App schmeißt eine Runde hier im Forum für die übernommende Supportleistung seiner Gewerblichen App.


    ThePersident Nicht persönlich nehmen ist nichts gegen dich nur gegen diesen App die von der Idee gut ist aber irgendwie schlecht umgesetzt sein muss ;)


    Kleiner Tipp noch am Rande schau dir mal die Homebridge Tools von det an damit kannst du auf dein fertiges Image hier aus dem Forum deCONZ automatisch installieren lassen

    The only way to do great work is to love what you do !

  • Nastra keine Sorge ich nehme das nicht persönlich. Ich bin leider ein DAU im Bereich Linux/Raspberry Pi ? - daher aber auch total dankbar für jeden Tip! Nur dieses Forum hat mich das Teil noch nicht aus dem Fenster werfen lassen. Tatsächlich bin ich nur bis jetzt dank der App soweit gekommen.


    Ich werd mich dann wohl mal an der von dir beschriebenen Option versuchen ?

  • Hi,

    habe ein raspbi 4 mit homebridge nach forenanleitung installiert und deconz. Nach jedem Restart des raspbies werden wir die hue lampen nicht mehr in EVE/Home angezeigt. So ald ich homebridge einmalig neu starte funktioniert alles wieder... Hängt das auch damit zusammen, dass homebridge vor Deconz startet? Frage deshalb nach, weil der Thread schon über 2 Jahre alt ist und sich in der Zeit ja einiges getan hat... :)


    LG

    Hombride: v1.3.1

    Node.js: v14.16.0

    NPN: v6.14.11

    Conbee2 firmware: 26660700

    Conbee2 version: 2.10.01 / 23.12.2020

  • Habe dieses Problem auch nach einem Neustart (aber dort wusste scheinbar niemand dieses Verhalten). Reichen denn im Normalfall nicht 60 Sekunden bis Deconz oben ist?

  • Bei mir das gleiche, nach Neustart der Homebridge muss ich immer erst in der Phoscon app den "App verbinden" Knopf drücken. Nur dann verbindet sich die Homebridge wieder mit Deconz. Wenn ich das nicht tue versucht der Pi sich alle 15 sekunden zu verbinden und Homebridge läuft nicht.....

    wenn man das ändern könnte wärte schon praktisch

  • Bei mir das gleiche, nach Neustart der Homebridge muss ich immer erst in der Phoscon app den "App verbinden" Knopf drücken. Nur dann verbindet sich die Homebridge wieder mit Deconz. Wenn ich das nicht tue versucht der Pi sich alle 15 sekunden zu verbinden und Homebridge läuft nicht.....

    wenn man das ändern könnte wärte schon praktisch

    Du kannst in der Homebridge Config (Homebridge-Hue) einen Benutzer und Kennwort für die Phoscon Anmeldung hinterlegen. Diese Daten werden im Log angezeigt, wenn du App verbinden in Phoscon wählst

  • Du kannst in der Homebridge Config (Homebridge-Hue) einen Benutzer und Kennwort für die Phoscon Anmeldung hinterlegen. Diese Daten werden im Log angezeigt, wenn du App verbinden in Phoscon wählst



    Supertip das probier ich gleich aus....

    👌

  • So ich bins nochmal.

    Also es geht mit den Angaben soweit, dass nach Start von Homebridge auch das Raspbee Modul weiterläuft OHNE erneute Anmeldung... 👍

    Aber nach Stromausfall (Unwetter) und bei Neustart des Pi muss ich das von Hand anschubsen, Deconz startet nicht selbständig. Da war dicke Luft weil nix mehr gin beim letzten Gewitter und ich war 3 Tage unterwegs. :)

    Ich will jetzt alle Jalousien mit shellys anhängen, da muss der Pi zuverlässig von selbst wieder starten.

    Die Jalousieen werden dann auch über Zigbee Taster gesteuert.



    VG

  • Ich ba das mit der Startverzögerung nach Anleitung von Nastra probiert mit VNC auf dem Pi, aber wenn ich was speichern möchte sagt er keine Berechtigung