iOS 16 -zeitgesteuerte Automation funktionieren nicht

  • Hallo zusammen. Ich habe das Problem das seit IOS16 meine zeitgesteuerten Automationen nicht mehr ausgelöst werden. Sowohl meine bosch unterputz rolladensteuerrung als auch diverse lampen werden nicht mehr automatisch zu einer bestimmten uhrzeit gesteuert. Gibt es dazu schon infos oder könnt ihr mir eventuell weiterhelfen?


    Lg

  • Die zeitgesteuerten Automationen laufen hier unter iOS16 einwandfrei. Lediglich An- und Abwesenheitsautomationen zicken im Moment.

  • Schade bei mir leider nicht mehr. Bis vor dem update funktionierte alles reibungslos doch jetzt tut sich nichts mehr. Wenn ich die Automation aber teste funktioniert alles wie gewohnt, nur eben nicht mehr von alleine

  • Hier auch keine Probleme unter iOS 16. Was nutzt du denn als Steuerzentrale Beaglezina? Wenn es ein HomePod sein sollte schau mal nach, ob da das Update auf HomePodOS evtl. auf seine Installation wartet.


    EDIT: Bin gerade mal durch meine Automationen gegangen und musste feststellen, dass ich nur noch eine einzige HomeKit Automation aktiv habe, die die Uhrzeit als Trigger nimmt. Und die läuft nur bei Abwesenheit und nachts. Von daher kann ich zu dem Problem gar keine eigenen Erfahrungen beitragen. Steuerzentrale checken als Tipp lasse ich aber mal so stehen.

    Einmal editiert, zuletzt von HolgerKR ()

  • Schade bei mir leider nicht mehr. Bis vor dem update funktionierte alles reibungslos doch jetzt tut sich nichts mehr. Wenn ich die Automation aber teste funktioniert alles wie gewohnt, nur eben nicht mehr von alleine

    Bei mir ist es leider genauso. Trigger ist bei mir ein Dummy-Switch. Der selbe Switch funktioniert in einer anderen Automation problemlos. Ich fürchte wir können wieder einmal nur auf ein Update warten ...





  • Bei mir läuft auch die ein oder andere Regel nicht mehr, ein System hab ich noch nicht erkannt. Sämtliche Zentralen sind auf 16.

    Bei Macrumors gibt es auch einen Thread zu dem Thema (den Namen der bisher 3 Poster nach könnten aber alle aus dem deutschsprachigen Raum sein; wäre ja nicht das erste Mal, dass HomeKit nur außerhalb der USA kaputt ist. ;-) )


    Bei reddit ist einer der Meinung, dass vor allem Thread Geräte betroffen seien. Könnte das auch bei dir hinkommen HSV-Steph ?

  • Bei mir funktionieren auch einige Automationen nicht mehr. Ich meine auch ein Muster erkannt zu haben:


    - alle Automationen die in Kurzbefehle konvertiert sind und Werte abrufen (z.B. die aktuelle Helligkeit im Carport). Ich meine irgendwo gelesen zu haben dass die Kurzbefehle Probleme mit den Werten haben und somit nicht laufen

    - An- und Abwesenheit funktioniert nicht


    Hat jemand ähnliche Erfahrungen gemacht? Alle Automationen die normal durch Zeit oder Geräte getriggert werden laufen ohne Probleme.

  • Selbes Problem auch bei mir.


    Die Morgenautomation die über einen Kurzbefehl gestartet wird und bei der von einem Lichtsensor die Luxwerte abgerufen werden sollen, funktioniert nicht mehr.

    Ob es jetzt an der abfrage des Luxwertea oder an dem Warten 59 Sekunden 2x liegt weiss Ich nicht.


    Ebenso funktioniert eine Automation bei der um 22:15 diverse Lichter ausgeschaltet werden sollen nicht mehr

  • Kann es ggf. damit zusammenhaengen, dass teilweise Geraete die nach HomeKit gebracht werden nicht alle Namen von den "Unterfunktionen" korrekt uebernommen haben und alles den selben Namen hatte und deshalb ggf. ne Automation die einen bestimmten Schalter schalten soll nicht durchlaufen konnte?


    Ich musste bspw. einige homebridge devices wie Air Fryer, Kettle, roborock, etc. die Namen neu vergeben, da es ansonsten gar nicht (mehr) lief. Siehe https://github.com/homebridge/homebridge/issues/3210

  • Ich hab mal eine nicht mehr funktionierende Regel gelöscht und neu angelegt, jetzt geht sie wieder. 😉

    Danke für den Hinweis.

    Hab das jetzt bei den Automationen auch gemacht die merklich nicht mwhr funktioniert hatten und jetzt gehen sie wieder.

  • Danke für den Hinweis.

    Hab das jetzt bei den Automationen auch gemacht die merklich nicht mwhr funktioniert hatten und jetzt gehen sie wieder.

    Aber das kann doch nicht ernsthaft eine Lösung sein, Apple. Ich habe das Update auf iOS 16 noch nicht gemacht, aber wenn möchte ich nicht meine Automationen (sehr viele und teilweise sehr komplex per Kurzbefehl erweitert) neu programmieren müssen.


    Also lieber noch warten mit dem Update? Wann und wo wird bekannt wenn ein Update Verbesserungen für HomeKit mit sich bringt?

  • Das sehe ich genau so. Ich habe auch mehrere teils sehr komplex aufeinander abgestimmte Automationen die ich über laufe der jahre aufeinander abgestimmt habe. Das kann nicht die lösung sein alles nochmal neu aufzusetzen. Da heißt es wohl wieder einmal hoffen auf Nachbesserung🤷🏻‍♂️ das geht einem langsam echt auf den Kecks. Mal funktioniert die Rolladensteuerrung von Bosch nicht, dann antworten bestimmt Geräte aus heiterem Himmel nicht mehr mit der steuerzentrale und Siri als sprachassistent versteht an manchen tagen nur das was sie möchte. Also wenn das die zukunft sein soll, dann steht uns noch ein haufen arbeit bevor🙈


    Marktreif ist das aus meiner Sicht noch lange nicht. 🤷🏻‍♂️

    Einmal editiert, zuletzt von Spy ()

  • Nach etwas probieren gestern konnte Ich das ganze soweit eingrenzen das bei dem Kurzbefehl der die gute Nacht Szene aktiviert, die abfrage des Netzwerks nicht funktioniert.

    Diesen Teil rausgenommen und die Automation klappt.

    Das gabs zumindest bei mir in der Vergangenheit auch schon😤.

  • Ich hatte gestern auch nochmal probiert.


    Automation 1 ohne Kurzbefehle funktioniert wunderbar

    Trigger: Wenn die Helligkeit unter 1000lux fällt

    Aktion: schließe Rolläden


    Automation 2 mit Kurzbefehl funktioniert nicht

    Trigger: Wenn Bewegung erkannt wird im Carport

    Bedingung: Wenn Helligkeit kleiner als 80lux

    Aktion: Schalte Carport Licht ein


    Automation 3 wieder ohne Kurzbefehl

    Trigger: Wenn Bewegung erkannt wird im Carport

    Bedingung: Nachts

    Aktion: Schalte Carport Licht ein

    Funktioniert einwandfrei.


    Ich meine es auf folgendes begrenzt zu haben:

    - An-/Abwesenheits Steuerung geht nicht

    - Kurzbefehle die Werte von Geräten abrufen gehen nicht (z.B. Lux Werte oder Aktuelle Wetterbedingungen)


    Keine Ahnung, nervt ein wenig wenn man sich nicht auf die Kurzbefehle verlassen kann.


    BTW: Hier der Beitrag aus dem Internet:

    https://homekitautomationtips.…ut-bug-in-ios-15-tvos-15/

    https://homekitautomationtips.…15-tvos-15-with-examples/


    Ich hab meinen Kurzbefehl mal angepasst und berichte dann ob es heute Abend Funktioniert (siehe Bilder im Anhang)

  • Bei mir waren ettliche Namen Hue-Geräten auf den Philipps Standartnamen zurückgesetzt. Nach der Korrektur auf den von mir verwendeten Namen in Home funktioniert es wieder. Interessant war, dass nach aktivieren des Editmodes Apple direkt den ursprünglichen von mir vergebenen Namen vorgeschlagen hat.

  • tommey

    Automationen mit Kurzbefehlen machen regelmäßig Probleme.

    Das kannst du umgehen indem du Automationen mit Bedingungen in einer alternativen HomeKit-App anlegst (Eve, Home+, Controller, … ).